タスク一覧の使用

[ タスク一覧 ] を使って、 TODOHACKなどのトークンやカスタム トークンを使用するコード コメントを追跡し、コード内の事前に定義された場所に直接アクセスできるショートカットを管理できます。 ソース コード内のその場所に移動するには、一覧の項目をクリックします。

このトピックの内容

[タスク一覧] ウィンドウ

[タスク一覧] が開き、アプリケーション ウィンドウの下部に表示されます。

[タスク一覧] を開くには

  • [表示] メニューで、[タスク一覧] をクリックします (キーボード: Ctrl + \、T)。

    [タスク一覧] ウィンドウ

一覧の並べ替え順序を変更するには

  • 任意の列のヘッダーをクリックします。 検索結果をさらに絞り込むには、Shift キーを押しながら 2 番目の列ヘッダーをクリックします。

    または、ショートカット メニューで、 [並べ替え]をクリックして、ヘッダーを選択します。 検索結果をさらに絞り込むには、Shift キーを押しながら 2 番目のヘッダーをクリックします。

列の表示/非表示を切り替えるには

  • ショートカット メニューで、 [列の表示]をクリックします。 表示または非表示にする列をクリックします。

列の順序を変更するには

  • 任意の列ヘッダーを目的の場所にドラッグします。

ユーザー タスク

Visual Studio 2015 ではユーザー タスク機能が削除されました。 Visual Studio 2013 以前のバージョンからのユーザー タスク データを含むソリューションを Visual Studio 2015 で開くと、.suo ファイル内のユーザー タスク データは影響を受けませんが、ユーザー タスクはタスク一覧に表示されません。

ユーザー タスク データに引き続きアクセスして更新する場合は、プロジェクトを Visual Studio 2013 で開き、好きなプロジェクト管理ツール (Team Foundation Server など) にユーザー タスクの内容をコピーする必要があります。

トークンとコメント

[タスク一覧] ウィンドウには、コメント マーカーが手前にあるコードのコメント、および定義済みのトークンも表示されます。 たとえば、次の C# コメントには 3 つの個別の部分があります。

  • コメント マーカー (//)

  • トークン、たとえば (TODO)

  • コメント (残りのテキスト)

// TODO: Load state from previously suspended application  

TODO が事前に定義されたトークンであるため、このコメントは TODO タスクとして一覧に表示されます。

カスタム トークン

既定で、Visual Studio には、HACK、TODO、UNDONE、NOTE のトークンが含まれます。 大文字と小文字は区別されません。

カスタム トークンを独自に作成することもできます。

カスタム トークンを作成するには
  1. [ツール] メニューの [オプション]をクリックします。

  2. [環境] フォルダーを開き、 [タスク一覧]をクリックします。

    [タスク一覧] ([オプション] ダイアログ ボックス - [環境]) が表示されます。

    Visual Studio タスク一覧

  3. [トークン] カテゴリの [名前] テキスト ボックスに、トークン名を入力します (例: バグ)。

  4. [優先順位] ドロップダウン リストで、新しいトークンの既定の優先順位を選択します。 [追加] ボタンをクリックします。

C++ TODO コメント

既定で、C++ TODO コメントは [タスク一覧] ウィンドウに表示されます。 この動作を変更できます。

C++ TODO コメントをオフにするには
  1. [ツール] メニューで、[オプション | テキストエディター | C/C++ | 表示 | コメント タスクの列挙] に移動し、値を False に設定します。

  2. [オプション] ダイアログ ボックスで、 [テキスト エディター]を開きます。

  3. [C/C++][表示]を選択し、 [コメント タスクの列挙][False]に設定します。

ショートカット

ショートカット は、 [タスク一覧]で追跡されるコード内のブックマークで、標準のブックマークとはアイコンが異なります。 コード内の対応する位置に移動するには、 [タスク一覧] にあるショートカットをダブルクリックします。

Visual Studio タスク一覧へのショートカット アイコン

ショートカットを作成するには

  • ショートカットを配置するコードにポインターを挿入します。 [編集 | ブックマーク | タスク一覧へのショートカットの追加] を選択するか、キーボードで Ctrl + K、Ctrl + H を押します。

    コード内のショートカットをナビゲートしていくには、一覧でショートカットを選択し、ショートカット メニューから [次のタスク][前のタスク] をクリックします。

関連項目

[タスク一覧] ([オプション] ダイアログ ボックス - [環境])