チュートリアル: アプリケーションをビルドするWalkthrough: Build an application

このチュートリアルを完了すると、Visual Studio を使用してアプリケーションをビルドする際に構成できるオプションの使用方法を習得できます。By completing this walkthrough, you'll become more familiar with several options that you can configure when you build applications with Visual Studio. サンプル アプリケーション用に、カスタムのビルド構成の作成、特定の警告メッセージの非表示設定、ビルド出力情報の拡張を行います。You'll create a custom build configuration, hide certain warning messages, and increase build output information for a sample application.

サンプル アプリケーションをインストールするInstall the sample application

WPF アプリケーションのビルドの概要サンプルをダウンロードします。Download the Introduction to building WPF applications sample. C# か Visual Basic を選択します。Choose either C# or Visual Basic. ダウンロードした .zip ファイルを解凍し、Visual Studio で ExpenseItIntro.sln ファイルを開きます。After the .zip file has downloaded, extract it and open the ExpenseItIntro.sln file using Visual Studio.

カスタム ビルド構成を作成するCreate a custom build configuration

ソリューションを作成すると、デバッグ ビルド構成およびリリース ビルド構成と、これらの既定のプラットフォーム ターゲットがソリューションに対して自動的に定義されます。When you create a solution, debug and release build configurations and their default platform targets are defined for the solution automatically. これらの構成をカスタマイズすることも、独自に作成することもできます。You can then customize these configurations or create your own. ビルド構成では、ビルドの種類を指定します。Build configurations specify the build type. ビルド プラットフォームでは、その構成でアプリケーションが対象とするオペレーティング システムを指定します。Build platforms specify the operating system that an application targets for that configuration. 詳細については、「ビルド構成について」、「ビルド プラットフォームについて」、「方法 : デバッグ構成とリリース構成を設定する」を参照してください。For more information, see Understand build configurations, Understand build platforms, and How to: Set debug and release configurations.

[構成マネージャー] ダイアログ ボックスを使用すると、構成とプラットフォームの設定を変更または作成できます。You can change or create configurations and platform settings by using the Configuration Manager dialog box. この手順では、テスト用のビルド構成を作成します。In this procedure, you'll create a build configuration for testing.

ビルド構成を作成するCreate a build configuration

  1. [構成マネージャー] ダイアログ ボックスを開きます。Open the Configuration Manager dialog box.

    [ビルド] メニュー、[構成マネージャー] コマンド

  2. [アクティブ ソリューション構成] 一覧の <[新規作成...]> をクリックします。In the Active solution configuration list, choose <New...>.

  3. [新しいソリューション構成] ダイアログ ボックスで、新しい構成の名前として「Test」と入力し、既存のデバッグ構成から設定をコピーして、[OK] を選びます。In the New Solution Configuration dialog box, name the new configuration Test, copy settings from the existing Debug configuration, and then choose the OK button.

    [新しいソリューション構成] ダイアログ ボックス

  4. [アクティブ ソリューション プラットフォーム] 一覧の <[新規作成...]> をクリックします。In the Active solution platform list, choose <New...>.

  5. [新しいソリューション プラットフォーム] ダイアログ ボックスで、[x64] を選択します。x86 プラットフォームの設定はコピーしません。In the New Solution Platform dialog box, choose x64, and don't copy settings from the x86 platform.

    [新しいソリューション プラットフォーム] ダイアログ ボックス

  6. [OK] を選択します。Choose the OK button.

    アクティブなソリューション構成がテストに変更され、アクティブなソリューション プラットフォームが x64 に設定されました。The active solution configuration has been changed to Test with the active solution platform set to x64.

    テスト構成を使用した構成マネージャー

  7. [閉じる] を選択します。Choose Close.

[標準] ツール バーの [ソリューション構成] ボックスの一覧を使用すると、アクティブなソリューション構成を簡単に確認または変更することができます。You can quickly verify or change the active solution configuration by using the Solution Configurations list on the Standard toolbar.

[ソリューション構成] オプション (標準ツール バー)

アプリケーションのビルドBuild the application

次に、カスタム ビルド構成を使用してソリューションをビルドします。Next, you'll build the solution with the custom build configuration.

ソリューションをビルドするBuild the solution

  • メニュー バーで、[ビルド] > [ソリューションのビルド] の順にクリックします。On the menu bar, choose Build > Build Solution.

    [出力] ウィンドウに、ビルドの結果が表示されます。The Output window displays the results of the build. ビルドに成功しました。The build succeeded.

コンパイラの警告を非表示にするHide compiler warnings

次に、コンパイラに警告を生成させるコードを紹介します。Next we'll introduce some code that causes a warning to be generated by the compiler.

  1. C# プロジェクトで、ExpenseReportPage.xaml.cs ファイルを開きます。In the C# project, open the ExpenseReportPage.xaml.cs file. ExpenseReportPage メソッドにコード int i; を追加します。In the ExpenseReportPage method, add the following code: int i;.

    OROR

    Visual Basic プロジェクトで、ExpenseReportPage.xaml.vb ファイルを開きます。In the Visual Basic project, open the ExpenseReportPage.xaml.vb file. カスタム コンストラクターの Public Sub New... にコード Dim i を追加します。In the custom constructor Public Sub New..., add the following code: Dim i.

  2. ソリューションをビルドします。Build the solution.

[出力] ウィンドウに、ビルドの結果が表示されます。The Output window displays the results of the build. ビルドに成功しましたが、次の警告が生成されました。The build succeeded, but warnings were generated:

出力ウィンドウ、Visual Basic

出力ウィンドウ、Visual C#

ビルド出力が見やすくなるように、ビルド時に特定の警告メッセージを一時的に非表示にすることができます。You can temporarily hide certain warning messages during a build rather than have them clutter up the build output.

C# の特定の警告を非表示にするHide a specific C# warning

  1. ソリューション エクスプローラーで、最上位のプロジェクト ノードを選択します。In Solution Explorer, choose the top-level project node.

  2. メニュー バーで [表示] > [プロパティ ページ] の順に選びます。On the menu bar, choose View > Property Pages.

    プロジェクト デザイナーが開きます。The Project Designer opens.

  3. [ビルド] ページを選択し、[警告の表示なし] ボックスで、警告番号 0168 を指定します。Choose the Build page and then, in the Suppress warnings box, specify the warning number 0168.

    [ビルド] ページ、[プロジェクト デザイナー]

    詳細については、「Build Page, Project Designer (C#)」([ビルド] ページ (プロジェクト デザイナー) (C#)) を参照してください。For more information, see Build Page, Project Designer (C#).

  4. ソリューションをビルドします。Build the solution.

    [出力] ウィンドウには、ビルドの概要情報のみが表示されます。The Output window displays only summary information for the build.

    出力ウィンドウ、Visual C# ビルド警告

Visual Basic のすべてのビルド警告を非表示にするSuppress all Visual Basic build warnings

  1. ソリューション エクスプローラーで、最上位のプロジェクト ノードを選択します。In Solution Explorer, choose the top-level project node.

  2. メニュー バーで [表示] > [プロパティ ページ] の順に選びます。On the menu bar, choose View > Property Pages.

    プロジェクト デザイナーが開きます。The Project Designer opens.

  3. [コンパイル] ページで、[すべての警告を表示しない] チェック ボックスをオンにします。On the Compile page, select the Disable all warnings check box.

    [コンパイル] ページ、[プロジェクト デザイナー]

    詳細については、「Visual Basic での警告の構成」を参照してください。For more information, see Configure warnings in Visual Basic.

  4. ソリューションをビルドします。Build the solution.

    [出力] ウィンドウには、ビルドの概要情報のみが表示されます。The Output window displays only summary information for the build.

    出力ウィンドウ、Visual Basic ビルド警告

    詳細については、「方法: コンパイラ警告を非表示にする」を参照してください。For more information, see How to: Suppress compiler warnings.

出力ウィンドウに追加のビルド詳細を表示するDisplay additional build details in the Output window

[出力] ウィンドウに表示されるビルド プロセスに関する情報量を変更できます。You can change how much information about the build process appears in the Output window. ビルドの詳細度は、通常、最小に設定されています。これは、優先度の高い警告またはエラーと共にビルド プロセスの概要のみが [出力] ウィンドウに表示されることを意味します。Build verbosity is usually set to Minimal, which means that the Output window displays only a summary of the build process along with any high priority warnings or errors. ビルドに関する詳細情報を表示するには、「[オプション] ダイアログ ボックス、[プロジェクトおよびソリューション]、[ビルド/実行]」を参照してください。You can display more information about the build by using the Options dialog box, Projects and Solutions, Build and Run.

重要

詳細情報を表示する場合は、ビルドの完了までにかかる時間が長くなります。If you display more information, the build will take longer to complete.

[出力] ウィンドウの情報量を変更するChange the amount of information in the Output window

  1. [オプション] ダイアログ ボックスを開きます。Open the Options dialog box.

    [ツール] メニューの [オプション] コマンド

  2. [プロジェクトおよびソリューション] カテゴリを選択し、[ビルド/実行] ページを選択します。Choose the Projects and Solutions category, and then choose the Build and Run page.

  3. [MSBuild プロジェクト ビルドの出力の詳細] ボックスの一覧の [標準] を選択し、[OK] をクリックします。In the MSBuild project build output verbosity list, choose Normal, and then choose the OK button.

  4. メニュー バーで、[ビルド] > [ソリューションのクリーン] を選びます。On the menu bar, choose Build > Clean Solution.

  5. ソリューションをビルドし、[出力] のウィンドウの情報をレビューします。Build the solution, and then review the information in the Output window.

    ビルド情報には、ビルドの開始時刻 (出力の先頭にあります) とファイルが処理された順序が含まれています。The build information includes the time that the build started (located at the beginning) and the order in which files were processed. この情報には、ビルド時に Visual Studio で実行される実際のコンパイラ構文も含まれています。This information also includes the actual compiler syntax that Visual Studio runs during the build.

    たとえば、C# のビルドの場合、/nowarn オプションには、このトピックで指定した警告コード 1762 が、他の 3 つの警告と共に示されます。For example, in the C# build, the /nowarn option lists the warning code, 1762, that you specified earlier in this topic, along with three other warnings.

    Visual Basic のビルドの場合、/nowarn には除外する特定の警告が含まれていないため、警告は表示されません。In the Visual Basic build, /nowarn doesn't include specific warnings to exclude, so no warnings appear.

    ヒント

    Ctrl+F キーを押して [検索] ダイアログ ボックスを表示すると、[出力] ウィンドウの内容を検索できます。You can search the contents of the Output window if you display the Find dialog box by choosing the Ctrl+F keys.

詳細については、「方法: ビルド ログ ファイルを表示、保存、および構成する」を参照してください。For more information, see How to: View, save, and configure build log files.

リリース ビルドを作成するCreate a Release Build

出荷用に最適化されたバージョンとしてサンプル アプリケーションをビルドすることができます。You can build a version of the sample application that's optimized for shipping it. リリース ビルドでは、ビルドの開始前に実行可能ファイルをネットワーク共有にコピーすることを指定します。For the release build, you'll specify that the executable is copied to a network share before the build is kicked off.

詳細については、「方法 : ビルド出力ディレクトリを変更する」とVisual Studio でのプロジェクトとソリューションのビルドおよびクリーンに関するページを参照してください。For more information, see How to: Change the build output directory and Build and clean projects and solutions in Visual Studio.

Visual Basic 用にリリース ビルドを指定するSpecify a release build for Visual Basic

  1. プロジェクト デザイナーを開きます。Open the Project Designer.

    [表示] メニュー、[プロパティ ページ] コマンド

  2. [コンパイル] ページをクリックします。Choose the Compile page.

  3. [構成] ボックスの一覧の [リリース] をクリックします。In the Configuration list, choose Release.

  4. [プラットフォーム] ボックスの一覧の [x86] をクリックします。In the Platform list, choose x86.

  5. [ビルド出力パス] ボックスに、ネットワーク パスを指定します。In the Build output path box, specify a network path.

    たとえば、\\myserver\builds を指定できます。For example, you can specify \\myserver\builds.

    重要

    メッセージ ボックスが表示され、指定したネットワーク共有が信頼できる場所ではない可能性があるという警告が示されることがあります。A message box might appear, warning you that the network share that you've specified might not be a trusted location. 指定した場所を信頼できる場合は、メッセージ ボックスの [OK] をクリックします。If you trust the location that you've specified, choose the OK button in the message box.

  6. アプリケーションをビルドします。Build the application.

    [ビルド] メニューの [ソリューションのビルド] コマンド

C# 用にリリース ビルドを指定するSpecify a release build for C#

  1. プロジェクト デザイナーを開きます。Open the Project Designer.

    [表示] メニュー、[プロパティ ページ] コマンド

  2. [ビルド] ページを選びます。Choose the Build page.

  3. [構成] ボックスの一覧の [リリース] をクリックします。In the Configuration list, choose Release.

  4. [プラットフォーム] ボックスの一覧の [x86] をクリックします。In the Platform list, choose x86.

  5. [出力パス] ボックスに、ネットワーク パスを指定します。In the Output path box, specify a network path.

    たとえば、\\myserver\builds を指定できます。For example, you could specify \\myserver\builds.

    重要

    メッセージ ボックスが表示され、指定したネットワーク共有が信頼できる場所ではない可能性があるという警告が示されることがあります。A message box might appear, warning you that the network share that you've specified might not be a trusted location. 指定した場所を信頼できる場合は、メッセージ ボックスの [OK] をクリックします。If you trust the location that you've specified, choose the OK button in the message box.

  6. 標準ツール バーで、ソリューション構成を [リリース] に、ソリューション プラットフォームを [x86] に設定します。On the Standard toolbar, set the Solution Configurations to Release and the Solution Platforms to x86.

  7. アプリケーションをビルドします。Build the application.

    [ビルド] メニューの [ソリューションのビルド] コマンド

    指定したネットワーク パスに、実行可能ファイルがコピーされます。The executable file is copied to the network path that you specified. そのパスは \\myserver\builds\\FileName.exe になります。Its path would be \\myserver\builds\\FileName.exe.

これで、このチュートリアルを完了できました。Congratulations: you've successfully completed this walkthrough.

関連項目See also