コード エディターでのコードの作成Write code in the code editor

Visual Studio エディターには、コードとテキストの記述と管理を容易にする多数の機能が用意されています。The Visual Studio editor provides many features that make it easier for you to write and manage your code and text. アウトラインを使用すると、個々のコード ブロックを展開したり折りたたんだりできます。You can expand and collapse different blocks of code by using outlining. コードの詳細は、IntelliSense、オブジェクト ブラウザー、および呼び出し階層を使用して調べることができます。You can learn more about the code by using IntelliSense, the Object Browser, and the Call Hierarchy. コードを探すには、[移動][定義へ移動][すべての参照の検索] などの機能を使用します。You can find code by using features such as Go To, Go To Definition, and Find All References. コード スニペットを使用してコード ブロックを挿入し、 [使用法から生成]などの機能を使用してコードを生成することもできます。You can insert blocks of code with code snippets, and you can generate code by using features such as Generate From Usage. 初めて Visual Studio エディターを使用する場合は、簡単な概要について「コードの編集」をご覧ください。If you have never used the Visual Studio editor before, see Editing Your Code for a quick overview.

コードは、いくつかの方法で表示できます。You can view your code in a number of different ways. 既定では、ソリューション エクスプローラーにファイルごとに整理されたコードが表示されます。By default, Solution Explorer shows your code organized by files. ウィンドウの下部にある [クラス ビュー] タブをクリックすれば、クラスごとに整理されたコードを表示することができます。You can click on the Class View tab at the bottom of the window to view your code organized by classes.

1 つまたは複数のファイルでテキストを検索および置換することができます。You can search and replace text in single or multiple files. 詳細については、「テキストの検索と置換」を参照してください。For more information, see Finding and Replacing Text. テキストの検索と置換をするときに正規表現を使用できます。You can use regular expressions to find and replace text. 詳細については、「Visual Studio での正規表現の使用」を参照してください。For more information, see Using Regular Expressions in Visual Studio.

Visual Studio では、言語によって異なる機能がサポートされています。同じ機能の動作が、言語によって異なる場合もあります。The different Visual Studio languages offer different sets of features, and in some cases the features behave differently in different languages. これらの相違点の多くは機能の説明に示されていますが、詳細については、各 Visual Studio 言語のセクションを参照してください。Many of these differences are specified in the descriptions of the features, but for more information you can see the sections on specific Visual Studio languages.

重要

使用する Visual Studio のエディションと設定が、IDE の機能に影響することもあります。The Visual Studio edition and the settings you are using may affect the features in the IDE. このため実際の機能は、このトピックに記載されている内容と異なる場合があります。They might differ from those described in this topic.

エディターの機能Editor Features

構文の色分け表示Syntax Coloring コード ファイルやマークアップ ファイルでは、他と区別するために一部の構成要素が色分け表示されます。Some syntax elements of code and markup files are colored differently to distinguish them. たとえば、キーワード (C# の using 、Visual Basic の Imports など) に使用される色と、型 ConsoleUriなど) に使用される色は異なります。For example, keywords (such as using in C# and Imports in Visual Basic) are one color, but types (such as Console and Uri) are another color. 文字列リテラルやコメントなど、他の構文要素も色分け表示されます。Other syntax elements are also colorized, such as string literals and comments. C++ では、型、列挙、マクロ、およびその他のトークンの中で区別するための色が使用されています。C++ uses color to differentiate among types, enumerations, and macros, among other tokens.

[ツール] メニューから開くことができる [フォントおよび色]、[環境]、[オプション] ダイアログ ボックスでは、各型の既定の色を確認し、特定の構成要素の色を変更することができます。You can see the default color for each type, and you can change the color for any specific syntax element in the Fonts and Colors, Environment, Options Dialog Box, which you can open from the Tools menu.
エラー マークと警告マークError and Warning Marks コードを追加してソリューションを作成する際、コードに (a) さまざまな色の波線または (b) 電球アイコンが表示されることがあります。As you add code and build your solution, you may see (a) different-colored wavy underlines (known as squiggles) or (b) light bulbs appearing in your code. 赤の波線は構文エラー、青はコンパイラ エラー、緑は警告、紫はその他の種類のエラーを表します。Red squiggles denote syntax errors, blue denotes compiler errors, green denotes warnings, and purple denotes other types of errors. 電球は、問題の修正方法を提案し、その修正を簡単に適用できます。Light bulbs suggest fixes for problems and make it easy to apply the fix.

各エラーおよび警告の波線については、既定の色を [ツール]、[オプション]、[環境]、[フォントおよび色] の順にクリックして開くダイアログ ボックスで確認できます。You can see the default color for each error and warning squiggle in the Tools/Options/Environment/Fonts and Colors dialog box. [構文エラー][コンパイル エラー][警告]、および [その他のエラー]を探してください。Look for Syntax Error, Compiler Error, Warning, and Other Error.
中かっこの一致Brace Matching コード ファイル内の開いている始め中かっこ内に挿入ポイントがある場合、始め中かっこと終わり中かっこの両方が強調表示されます。When the insertion point is placed on an open brace in a code file, both it and the closing brace are highlighted. この機能により、中かっこの配置ミスや不足を直ちに知ることができます。This feature gives you immediate feedback on misplaced or missing braces. かっこの一致のオンとオフを切り替えるには、 [区切り記号を自動強調表示する] ([ツール]、[オプション]、[テキスト エディター]) の設定を使用します。You can turn brace matching on or off with the Automatic Delimiter Highlighting setting (Tools/Options/Text Editor). 強調表示色を変更するには、 [フォントおよび色] ([ツール]、[オプション]、[環境]) を使用します。You can change the highlight color in the Fonts and Colors setting (Tools/Options/Environment). [かっこの一致 (強調表示)] または [かっこの一致 (四角形)]を探してください。Look for Brace Matching (Highlight) or Brace Matching (Rectangle).
構造ビジュアライザーStructure Visualizer コード ファイル内の対になった中かっこを点線でつなぎ、始めかっこと終わりかっこのペアを識別しやすくします。Dotted lines connect matching braces in code files, making it easier to see opening and closing brace pairs. このためコードベースでコードをより簡単に見つけることができます。This can help you find code in your codebase more quickly. 点線は、[ツール]、[オプション]、[テキスト エディター]、[全般] ページの順に移動して [表示] セクションにある [Show structure guidelines (構造のガイド線を表示する)] を使用してオンとオフを切り替えることができます。You can turn these lines on or off with the Show structure guidelines in the Display section of the Tools/Options/Text Editor/General page.
行番号Line Numbers 行番号はコード ウィンドウの左余白に表示できます。Line numbers can be displayed in the left margin of the code window. これらは、既定では表示されません。They are not displayed by default. このオプションを有効にするには、テキスト エディターの [すべての言語] ([ツール]、[オプション]、[テキスト エディター]、[すべての言語]) の設定を使用します。You can turn this option on in the Text Editor All Languages settings (Tools/Options/Text Editor/All Languages). 各言語 ([ツール]、[オプション]、[テキスト エディター]、[<言語>]) の設定を変更することで、個々のプログラミング言語で行番号を表示できます。You can display line numbers for individual programming languages by changing the settings for those languages (Tools/Options/Text Editor/<language>). 行番号を印刷する場合は、[印刷] ダイアログ ボックスで [行番号を入れる] を選択する必要があります。For line numbers to print, you must select Include line numbers in the Print dialog box.
変更追跡Change Tracking 左余白の色を使用すると、ファイルに対する変更を追跡することができます。The color of the left margin allows you to keep track of the changes you have made in a file. ファイルを開いてから保存していない変更は、左余白 (選択余白と呼ばれます) に黄色バーで示されます。Changes you have made since the file was opened but not saved are denoted by a yellow bar on the left margin (known as the selection margin). 変更を保存した後 (ファイルを閉じる前) は、バーが緑色に切り替わります。After you have saved the changes (but before closing the file), the bar turns green. ファイルを保存した後で変更を元に戻すと、バーはオレンジ色に切り替わります。If you undo a change after you have saved the file, the bar turns orange. この機能のオンとオフを切り替えるには、 [テキスト エディター] ( [ツール]、[オプション]、[テキスト エディター] ) の設定の[変更履歴を記録する]オプションを変更します。To turn this feature off and on, change the Track changes option in the Text Editor settings (Tools/Options/Text Editor).
コードおよびテキストの選択Selecting Code and Text テキストは、標準の連続ストリーム モードか、ボックス モード (行単位ではなく、テキストを四角形で部分的に選択する) で選択できます。You can select text either in the standard continuous stream mode or in box mode, in which you select a rectangular portion of text instead of a set of lines. ボックス モードで選択を行うには、Alt キーを押しながらマウスをドラッグします (または、Alt キーと Shift キーを押しながら <方向キー> を押します)。To make a selection in box mode, press ALT as you drag the mouse over the selection (or press ALT + SHIFT + <arrow key>). 選択範囲の先頭の文字から最後の文字までの四角形で囲まれた範囲に入っているすべての文字が選択されます。The selection includes all of the characters within the rectangle defined by the first character and the last character in the selection. 選択した領域に入力した、または貼り付けた内容が、各行の同じ位置に挿入されます。Anything typed or pasted into the selected area is inserted at the same point on each line.
ズームZoom どのコード編集ウィンドウでも、Ctrl キーを押しながらマウスのスクロール ホイールを回転すると、簡単に表示を拡大縮小することができます (または、Ctrl + Shift + .You can zoom in or out in any code window by pressing and holding the CTRL key and moving the scroll wheel on the mouse (or CTRL + SHIFT + . で拡大、Ctrl + Shift + , で縮小)。to increase and CTRL + SHIFT + , to decrease). また、コード ウィンドウの左下隅にあるズーム ボックスを使用すると、特定のズーム倍率を設定できます。You can also use the Zoom box in the lower left corner of the code window to set a specific zoom percentage. ズーム機能は、ツール ウィンドウでは使用できません。The zoom feature does not work in tool windows.
仮想空白文字Virtual Space 既定では、Visual Studio エディター内の行末は、最後の文字の直後になります。このため、行末で右方向キーが押されると、カーソルが次の行の先頭に移動します。By default, lines in Visual Studio editors end after the last character, so that the RIGHT ARROW key at the end of a line moves the cursor to the beginning of the next line. 他のエディターには、行末が最後の文字の直後ではないものもあります。この場合は、カーソルを行内の任意の位置に置くことができます。In some other editors a line does not end after the last character, and you can place your cursor anywhere on the line. エディターの仮想空白文字を有効にするには、 [ツール]、[オプション]、[テキスト エディター]、[すべての言語] の設定を使用します。You can enable virtual space in the editor in the Tools/Options/Text Editor/All Languages settings. [仮想空白を使用][右端で折り返す]のうち、いずれかのみを有効にすることができます。Note that you can enable either Virtual Space or Word Wrap, but not both.
印刷Printing ファイルの印刷時に行番号を含める場合や、コードの折りたたまれた領域を非表示にするには、 [印刷] ダイアログ ボックスのオプションを使用します。You can use the options in the Print dialog box to include line numbers or hide collapsed regions of code when you print a file. [ページ設定] ダイアログ ボックスで [ページ ヘッダー]を選択すると、ファイルの完全パスと名前を印刷できます。In the Page Setup dialog box, you can also choose to print the full path and the name of the file by choosing Page header.

カラー印刷オプションを設定するには、 [ツール]、[オプション]、[環境]、[フォントおよび色] の順にクリックして開くダイアログ ボックスを使用します。You can set color printing options in the Tools/Options/Environment/Fonts and Colors dialog box. [設定の表示] ボックスの一覧の [プリンター] をクリックしてカラー印刷をカスタマイズします。Choose Printer in the Show settings for list to customize color printing. ファイルの印刷用には、ファイルの編集用とは異なる色を指定できます。You can specify different colors for printing a file than for editing a file.
全体的な操作を元に戻す/やり直すGlobal Undo and Redo 複数ファイルに影響する全体的な操作を元に戻すかやり直すには、 [編集] メニューの [直前の全体的な操作を元に戻す] または [直前の全体的な操作をやり直す] を使用します。The Undo Last Global Action and Redo Last Global Action commands on the Edit menu undo or redo global actions that affect multiple files. 全体的な操作には、クラスや名前空間の名前の変更、ソリューション間での検索置換操作、データベースのリファクタリング、複数のファイルを変更するなどの操作があります。Global actions include renaming a class or namespace, performing a find-and-replace operation across a solution, refactoring a database, or any other action that changes multiple files. 現在の Visual Studio セッション中に、全体的に元に戻すコマンドと全体的にやり直すコマンドを操作に適用できます。これは、元の操作を適用したソリューションを閉じた後でも実行できます。You can apply the global undo and redo commands to actions in the current Visual Studio session, even after you close the solution in which an action was applied.

詳細な編集機能Advanced Editing Features

[編集]、[詳細設定] サブメニューには、多数の詳細機能があります。You can find a number of advanced features on the Edit/Advanced submenu. これらの機能のうち、コード ファイル種類によっては、使用できないものもあります。Not all these features are available for all types of code files.

ドキュメントのフォーマットFormat Document ドキュメント内で、コード行に適切なインデントを設定し、中かっこを移動して行を区切ります。Sets the proper indentation of lines of code and moves curly braces to separate lines in the document.
選択範囲のフォーマットFormat Selection 選択範囲内で、コード行に適切なインデントを設定し、中かっこを移動して行を区切ります。Sets the proper indentation of lines of code and moves curly braces to separate lines in the selection.
選択した行でのタブ化Tabify Selected Lines 適切な箇所で、先頭の空白をタブに変換します。Changes leading spaces to tabs where appropriate.
選択した行でのタブ化解除Untabify Selected Lines 先頭のタブを空白に変換します。Changes leading tabs to spaces. ファイル内のすべての空白をタブに変換 (または、すべてのタブを空白に変換) する場合は、 Edit.ConvertSpacesToTabsEdit.ConvertTabsToSpaces comm、s.If you want to convert all the spaces in your file to tabs (or all the tabs to spaces), you can use the Edit.ConvertSpacesToTabs and Edit.ConvertTabsToSpaces commands. これらのコマンドは、Visual Studio のメニューには表示されませんが、クイック アクセス ウィンドウまたはコマンド ウィンドウから呼び出すことができます。These commands do not appear in Visual Studio menus, but you can call them from the Quick Access window or the command window.
[大文字に変換]Make Uppercase 選択範囲内のすべての文字を大文字に変更します。範囲が選択されていない場合は、カーソル位置の文字をまたは大文字に変更します。Changes all characters in the selection to uppercase, or if there is no selection, changes the character at the insertion point to uppercase.
小文字に変換Make Lowercase 選択範囲内のすべての文字を小文字に変更します。範囲が選択されていない場合は、カーソル位置の文字をまたは小文字に変更します。Changes all characters in the selection to lowercase, or if there is no selection, changes the character at the insertion point to lowercase.
選択した行を上へ移動Move selected Lines Up 選択した行を 1 行上に移動します。Moves the selected line up one line. ショートカット: Alt + ↑ キー。Shortcut: ALT + UP ARROW.
選択した行を下へ移動Move Selected Lines Down 選択した行を 1 行下に移動します。Moves the selected line down one line. ショートカット: Alt + ↓ キー。Shortcut: ALT + DOWN ARROW.
ドキュメントの検証Validate Document JScript コード ファイルを検証します。Validates JScript code files.
左右スペースの削除Delete Horizontal White Space 現在の行の末尾にあるタブまたは空白を削除します。Deletes tabs or spaces at the end of the current line.
スペースの表示View White Space 空白を中黒、タブを矢印として表示します。Displays spaces as raised dots, and tabs as arrows. ファイルの末尾は四角形の記号として表示されます。The end of a file is displayed as a rectangular glyph. [ツール]、[オプション]、[テキスト エディター]、[すべての言語]、[右端の折り返しの記号を表示する] が選択されている場合は、その記号も表示されます。If Tools/Options/Text Editor/All Languages/Word Wrap/Show visible glyphs for word wrap is selected, that glyph is also displayed.
[右端で折り返す]Word Wrap ドキュメント内のすべての行が見えるように、コード ウィンドウ内に収めます。Causes all the lines in a document to be visible in the code window. [右端で折り返す] を無効にするには、テキスト エディターの [すべての言語]([ツール]、[オプション]、[テキスト エディター]、[すべての言語]) の設定を使用します。You can turn word wrap off and on in the Text Editor All Languages settings (Tools/Options/ Text Editor/All Languages).
選択範囲のコメントComment Selection 選択項目または現在の行にコメント文字を追加します。Adds comment characters to the selection or the current line.
選択範囲のコメントを解除Uncomment Selection 選択項目または現在の行からコメント文字を削除します。Removes comment characters from the selection or the current line.
行インデントIncrease Line Indent 選択された行または現在の行にタブ (または同等の空白) を追加します。Adds a tab (or the equivalent spaces) to the selected lines or the current line.
行インデント解除Decrease Line Indent 選択された行または現在の行からタブ (または同等の空白) を削除します。Removes a tab (or the equivalent spaces) from the selected lines or the current line.
タグの選択Select Tag タグが含まれるドキュメント (XML、HTML など) で、タグを選択します。In a document that contains tags (for example, XML or HTML), selects the tag.
タグ内容の選択Select Tag Content タグが含まれるドキュメント (XML、HTML など) で、内容を選択します。In a document that contains tags (for example, XML or HTML), selects the content.

いくつかの異なる方法でコード エディター内を移動することができます。たとえば、カーソルを前の位置に戻したり、先に進めたり、型またはメンバーの定義を表示したり、ナビゲーション バーを使用して特定のメソッドにジャンプします。You can move around in the code editor in several different ways, including navigating backwards and forwards to previous insertion points, viewing the definition of a type or member, and jumping to a specific method using the navigation bar. 詳細については、「Navigating code」 (コードの移動) を参照してください。For more information see Navigating code.

コード ベース内の参照の検索Finding references in your code base

特定のコード要素が参照されている場所をコードベース全体で検索するには、[すべての参照の検索] コマンドを使用します。To find where particular code elements are referenced throughout your codebase, you can use the Find All References command. また、型またはメンバーをクリックすると、参照の強調表示機能により、その型またはメンバーへのすべての参照が自動的に強調表示されます。Also, when you click on a type or member, the reference highlighting feature automatically highlights all references to that type or member. 詳細については、「コード内の参照の検索」を参照してください。For more information, see Finding references in your code.

エディターのカスタマイズCustomize the Editor

[ツール] メニューの [設定のインポートとエクスポート ウィザード] コマンドを使用すると、Visual Studio の設定を他の開発者と共有することや、設定を標準に準拠させることができます。Visual Studio の既定の設定に戻すこともできます。You can share your Visual Studio settings with another developer, have your settings conform to a standard, or return to Visual Studio default settings by using the Import and Export Settings Wizard command on the Tools menu. [設定のインポートとエクスポート ウィザード] で、選択した全般設定または言語やプロジェクトに固有の設定を変更することができます。In the Import and Export Settings Wizard, you can change selected general settings or language and project-specific settings.

新しいホット キーを定義する、または既存のホット キーを再定義するには、[ツール][オプション][環境][キーボード] の順に移動します。To define new hotkeys or redefine existing hotkeys, go to Tools, Options, Environment, Keyboard. ホット キーの詳細については、「既定のキーボード ショートカット」を参照してください。For more information about hotkeys, see Default Keyboard Shortcuts.

エディターのカスタマイズの詳細については、「エディターのカスタマイズ」を参照してください。For more information about customizing the editor, see Customizing the Editor. 言語固有のエディター オプションについては、「Using the Visual Studio Development Environment for C#」(C# の Visual Studio 開発環境を使用する) と「[オプション]、[テキスト エディター]、[JavaScript]、[書式設定]」を参照してください。For information about language-specific editor options, see Using the Visual Studio Development Environment for C# and Options, Text Editor, JavaScript, Formatting.

関連項目See Also

Visual Studio IDEVisual Studio IDE