Visual Studio を最新リリースに更新する

常に最新の機能、修正、改善を利用できるように、Visual Studio 2017 の最新リリースに更新することをお勧めします。

また、最新バージョンを試す場合は、代わりに Visual Studio 2019 のダウンロードとインストールを検討してください。

重要

Visual Studio をインストール、更新、または変更するには、管理アクセス許可を持つアカウントでログオンする必要があります。 詳細については、「ユーザー アクセス許可と Visual Studio」を参照してください。

注意

このトピックは、Windows 上の Visual Studio に適用されます。 Visual Studio for Mac については、「Visual Studio for Mac を更新する」を参照してください。

Visual Studio 2017 バージョン 15.6 以降を更新する

IDE 内から直接使用しやすくするために、インストールと更新プログラムのエクスペリエンスが整理されました。 ここでは、バージョン 15.6 以降から新しいバージョンの Visual Studio に更新する方法について説明します。

通知ハブの使用

更新プログラムがある場合、Visual Studio には対応する通知フラグが表示されます。

  1. 作業内容を保存します。

  2. 通知フラグを選択して 通知 ハブを開き、インストールする更新プログラムを選択します。

    通知ハブを使用して Visual Studio 2017 を更新する

    ヒント

    Visual Studio 2017 のエディションに対する更新プログラムは累積になっているため、常に最新のバージョン番号のものをインストールしてください。

  3. [更新] ダイアログ ボックスが開いたら、 [今すぐ更新] を選択します。

    通知ハブの [更新] ダイアログボックスを使用して Visual Studio 2017 を更新する

    [ユーザー アクセス制御] ダイアログ ボックスが開いたら、 [はい] を選択します。 [お待ちください] ダイアログが表示されることがあります。処理が完了すると、Visual Studio インストーラーが開き、更新が開始されます。

    バージョン 15.6 の新しい Visual Studio インストーラー エクスペリエンス

    更新が続行されます。 処理が完了すると、Visual Studio が再起動されます。

    注意

    Visual Studio を管理者モードで実行する場合は、更新後に Visual Studio を手動で再起動する必要があります。

IDE の使用

更新プログラムを確認し、Visual Studio のメニュー バーから更新プログラムをインストールすることができます。

  1. 作業内容を保存します。

  2. [ヘルプ] > [更新プログラムの確認] を選択します。

    Visual Studio バージョン 15.6 の新しい [ヘルプ] メニュー

  3. [更新] ダイアログ ボックスが開いたら、 [今すぐ更新] を選択します。

    前のセクションと同様に更新が実行され、更新が正常に完了すると Visual Studio が再起動されます。

    注意

    Visual Studio を管理者モードで実行する場合は、更新後に Visual Studio を手動で再起動する必要があります。

Visual Studio インストーラーの使用

Visual Studio の以前のバージョンと同様に、Visual Studio インストーラーを使用して更新プログラムをインストールすることもできます。

  1. 作業内容を保存します。

  2. インストーラーを開きます。 必要に応じて、Visual Studio インストーラーを更新してから続行します。

    注意

    Windows 10 を実行しているコンピューターの場合、V という文字の下に Visual Studio インストーラー と表示されるか、M という文字の下に Microsoft Visual Studio インストーラー と表示されます。

  3. インストーラーの [製品] ページで、前にインストールした Visual Studio のエディションを探します。

  4. 更新プログラムが使用可能な場合は、 [更新] ボタンが表示されます (使用可能な更新プログラムがあるかどうかをインストーラーが判断するために数秒かかる場合があります)。

    [更新] ボタンを選択して更新プログラムをインストールします。

    Visual Studio インストーラーを使用して Visual Studio 2017 を更新する

Visual Studio 2017 バージョン 15.5 以前のバージョンを更新する

以前のバージョンを使用している場合、Visual Studio 2017 バージョン 15.0 からバージョン 15.5 の更新プログラムを適用するには、次の手順を実行します。

通知ハブを使用して更新する

  1. 更新プログラムがある場合、Visual Studio には対応する通知フラグが表示されます。

    Visual Studio 2017 の通知フラグを更新する

    通知フラグを選択して、通知 ハブを開きます。

    通知ハブの Visual Studio 2017 更新プログラム

    ヒント

    Visual Studio 2017 のエディションに対する更新プログラムは累積になっているため、常に最新のバージョン番号のものをインストールしてください。

  2. ["Visual Studio 更新プログラム" が使用可能です] を選択すると、 [拡張機能と更新プログラム] ダイアログ ボックスが開きます。

    Visual Studio の更新プログラムを選択する

  3. [拡張機能と更新プログラム] ダイアログ ボックスで、 [更新] ボタンを選択します。

    [拡張機能と更新プログラム] ダイアログで [更新] を選択する

Visual Studio の通知の詳細

Visual Studio は、Visual Studio 自体またはいずれかのコンポーネントの更新プログラムが入手可能な場合に通知します。また、Visual Studio 環境で特定のイベントが発生した場合も通知します。

  • 通知フラグが黄色の場合は、インストールできる Visual Studio 製品の更新プログラムが存在します。
  • 通知フラグが赤の場合は、ライセンスに問題があります。
  • 通知フラグが黒の場合は、確認のためのオプション メッセージまたは情報メッセージが存在します。

通知フラグを選択して 通知 ハブを開いてから、操作する通知を選択します。 または、通知を無視するか破棄するかを選択します。

通知ハブでオプション メッセージまたは情報メッセージを表示する

通知を無視することを選択した場合は、Visual Studio で表示されなくなります。 無視される通知のリストをリセットする場合は、通知ハブの [設定] ボタンを選択します。

通知ハブの設定ボタンを選択して通知オプションを表示する

Visual Studio インストーラーを使用して更新する

  1. インストーラーを開きます。 続行する前に、インストーラーの更新が必要な場合があります。 更新が必要な場合は、更新するよう求められます。

    注意

    Windows 10 を実行しているコンピューターの場合、V という文字の下に Visual Studio インストーラー と表示されるか、M という文字の下に Microsoft Visual Studio インストーラー と表示されます。

  2. インストーラーの [製品] ページで、前にインストールした Visual Studio のエディションを探します。

  3. 更新プログラムが使用可能な場合は、 [更新] ボタンが表示されます (使用可能な更新プログラムがあるかどうかをインストーラーが判断するために数秒かかる場合があります)。

    [更新] ボタンを選択して更新プログラムをインストールします。

    Visual Studio インストーラーを使用して Visual Studio 2017 を更新する

常に最新の機能、修正、改善を利用できるように、Visual Studio の最新リリースに更新することをお勧めします。

Visual Studio をまだインストールしていない場合は、Visual Studio のダウンロード ページに移動し、無料試用版をインストールしてください。 現在、別のバージョンの Visual Studio を使用している場合は、複数バージョンの Visual Studio をインストールするか、以前のバージョンの Visual Studio をアンインストールしてください。

重要

Visual Studio をインストール、更新、または変更するには、管理アクセス許可を持つアカウントでログオンする必要があります。 詳細については、「ユーザー アクセス許可と Visual Studio」を参照してください。

注意

このトピックは、Windows 上の Visual Studio に適用されます。 Visual Studio for Mac については、「Visual Studio for Mac を更新する」を参照してください。

Visual Studio 2019 を更新する方法を次に示します。

Visual Studio インストーラーを使用する

  1. コンピューター上の Visual Studio インストーラー を見つけます。

    Windows の [スタート] メニューで "installer" を検索できます。

    Visual Studio インストーラー

    続行する前に、インストーラーの更新が必要な場合があります。 その場合は、画面の指示に従います。

  2. インストーラーで、インストールした Visual Studio のエディションを探します。

    たとえば、以前にインストールした Visual Studio Community 2019 に対して更新プログラムが存在する場合は、"利用可能な更新プログラムがあります" というメッセージが表示されます。

    更新する Visual Studio 2019 のエディションを選択する

  3. [更新] を選択して更新プログラムをインストールします。

    [更新] ボタンを選択して更新プログラムをインストールする

  4. 更新が完了したら、コンピューターの再起動を求められる場合があります。 その場合は、その操作を行い、通常どおり Visual Studio を起動します。

    コンピューターの再起動を求められなかった場合は、[起動] を選択してインストーラーから Visual Studio を起動します。

    [起動] ボタンを選択して Visual Studio を起動する

IDE を使用する

更新プログラムを確認し、Visual Studio 2019 にあるメニュー バーまたは検索ボックスを使用してインストールできます。

Visual Studio を開きます

  1. Windows の [スタート] メニューから、[Visual Studio 2019] を選択します。

    Visual Studio 2019 を開く

  2. [作業の開始] で、任意のオプションを選択すると、IDE が開きます。

    Visual Studio インストーラーを開く

    Visual Studio が開きます。 IDE 内に、Visual Studio 2019 の更新プログラム に関するメッセージが表示されます。

    IDE 内の "Visual Studio 2019 の更新プログラム" に関するメッセージ

  3. Visual Studio 2019 の更新プログラム に関するメッセージで、[詳細の表示] を選択します。

    Visual Studio 2019 の更新プログラムに関するメッセージで [詳細の表示] を選択する

  4. [更新プログラムがダウンロードされてインストールの準備完了] ダイアログ ボックスで、[更新] を選択します。

    [更新プログラムがダウンロードされてインストールの準備完了] ダイアログ ボックスで [更新] ボタンを選択する

    Visual Studio が更新され、閉じられた後に、再起動されます。

Visual Studio 内

  1. メニュー バーから、[ヘルプ] を選択して、[更新プログラムの確認] を選択します。

    [ヘルプ] メニューから [更新プログラムの確認] を選択する

    注意

    更新プログラムを確認するには、IDE にある検索ボックスを使用することもできます。 Ctrl+Q キーを押し、「更新プログラムの確認」と入力して、一致した検索結果を選択します。

  2. [利用可能な更新プログラムがあります] ダイアログ ボックスで、[更新] を選択します。

    [利用可能な更新プログラムがあります] ダイアログ ボックスで [更新] ボタンを選択する

    Visual Studio が更新され、閉じられた後に、再起動されます。

通知ハブを使用する

  1. Visual Studio 内に、作業内容を保存します。

  2. Visual Studio IDE の右下隅にある通知アイコンを選択して、[通知] ハブを開きます。

    Visual Studio IDE の通知アイコン

  3. [通知] ハブ では、インストールする更新プログラムを選択して、[詳細表示] を選択します。

    Visual Studio 2019 の通知ハブ

    ヒント

    Visual Studio 2019 のエディションに対する更新プログラムは累積になっているため、常に最新のバージョン番号のものをインストールしてください。

  4. [利用可能な更新プログラムがあります] ダイアログ ボックスで、[更新] を選択します。

    Visual Studio が更新され、閉じられた後に、再起動されます。

更新設定のカスタマイズ

Visual Studio の更新設定は、いくつかの異なる方法でカスタマイズできます。たとえば、インストール モードの変更や、自動ダウンロードの選択などを行います。

2 つのインストール モードから選択することができます。

  • ダウンロード中にインストールする
  • 全部ダウンロードしてからインストールする

また、[Automatically download updates](更新プログラムを自動的にダウンロードする) 設定を選択することもできます。これを使うと、コンピューターがアイドル状態のときに更新プログラムがダウンロードされます。

その方法は次のとおりです。

  1. メニュー バーで [ツール] > [オプション] の順に選択します。

  2. [環境] を展開してから、[製品の更新プログラム] を選択します。

    Visual Studio での更新設定

  3. Visual Studio の更新プログラム用に使用したいインストール モードと自動ダウンロード オプションを選択します。

常に最新の機能、修正、改善を利用できるように、Visual Studio の最新リリースに更新することをお勧めします。

Visual Studio をまだインストールしていない場合は、Visual Studio のダウンロード ページに移動し、無料試用版をインストールしてください。 現在、別のバージョンの Visual Studio を使用している場合は、複数バージョンの Visual Studio をインストールするか、以前のバージョンの Visual Studio をアンインストールしてください。

重要

Visual Studio をインストール、更新、または変更するには、管理アクセス許可を持つアカウントでログオンする必要があります。 詳細については、「ユーザー アクセス許可と Visual Studio」を参照してください。

注意

このトピックは、Windows 上の Visual Studio に適用されます。 Visual Studio for Mac については、「Visual Studio for Mac を更新する」を参照してください。

Visual Studio 2022 を更新する方法を次に示します。

Visual Studio インストーラーを使用する

  1. コンピューター上の Visual Studio インストーラー を見つけます。

    Windows の [スタート] メニューで "installer" を検索できます。

    Visual Studio インストーラー

    続行する前に、インストーラーの更新が必要な場合があります。 その場合は、画面の指示に従います。

  2. インストーラーで、インストールした Visual Studio のエディションを探します。

    たとえば、以前にインストールした Visual Studio Community 2022 に対して更新プログラムが存在する場合は、"利用可能な更新プログラムがあります" というメッセージが表示されます。

    更新する Visual Studio 2019 のエディションを選択する

  3. [更新] を選択して更新プログラムをインストールします。

    [更新] ボタンを選択して更新プログラムをインストールする

  4. 更新が完了したら、コンピューターの再起動を求められる場合があります。 その場合は、その操作を行い、通常どおり Visual Studio を起動します。

    コンピューターの再起動を求められなかった場合は、[起動] を選択してインストーラーから Visual Studio を起動します。

    [起動] ボタンを選択して Visual Studio を起動する

IDE を使用する

更新プログラムを確認し、Visual Studio 2022 にあるメニュー バーまたは検索ボックスを使用してインストールできます。

Visual Studio を開きます

  1. Windows の [スタート] メニューから、 [Visual Studio 2022] を選択します。

    Visual Studio 2022 を開きます。

  2. [作業の開始] で、任意のオプションを選択すると、IDE が開きます。

    Visual Studio インストーラーを開く

    Visual Studio が開きます。 IDE 内に、Visual Studio 2022 の更新プログラム に関するメッセージが表示されます。

    IDE 内の "Visual Studio 2019 の更新プログラム" に関するメッセージ

  3. Visual Studio 2022 の更新プログラム に関するメッセージで、 [詳細の表示] を選択します。

    Visual Studio 2019 の更新プログラムに関するメッセージで [詳細の表示] を選択する

  4. [更新プログラムがダウンロードされてインストールの準備完了] ダイアログ ボックスで、[更新] を選択します。

    [更新プログラムがダウンロードされてインストールの準備完了] ダイアログ ボックスで [更新] ボタンを選択する

    Visual Studio が更新され、閉じられた後に、再起動されます。

Visual Studio 内

  1. メニュー バーから、[ヘルプ] を選択して、[更新プログラムの確認] を選択します。

    [ヘルプ] メニューから [更新プログラムの確認] を選択する

    注意

    更新プログラムを確認するには、IDE にある検索ボックスを使用することもできます。 Ctrl+Q キーを押し、「更新プログラムの確認」と入力して、一致した検索結果を選択します。

  2. [利用可能な更新プログラムがあります] ダイアログ ボックスで、[更新] を選択します。

    [利用可能な更新プログラムがあります] ダイアログ ボックスで [更新] ボタンを選択する

    Visual Studio が更新され、閉じられた後に、再起動されます。

通知ハブを使用する

  1. Visual Studio 内に、作業内容を保存します。

  2. Visual Studio IDE の右下隅にある通知アイコンを選択して、[通知] ハブを開きます。

    Visual Studio IDE の通知アイコン

  3. [通知] ハブ では、インストールする更新プログラムを選択して、[詳細表示] を選択します。

    Visual Studio 2019 の通知ハブ

    ヒント

    Visual Studio 2022 のエディションに対する更新プログラムは累積になっているため、常に最新のバージョン番号のものをインストールしてください。

  4. [利用可能な更新プログラムがあります] ダイアログ ボックスで、[更新] を選択します。

    Visual Studio が更新され、閉じられた後に、再起動されます。

更新設定のカスタマイズ

Visual Studio の更新設定は、いくつかの異なる方法でカスタマイズできます。たとえば、インストール モードの変更や、自動ダウンロードの選択などを行います。

2 つのインストール モードから選択することができます。

  • ダウンロード中にインストールする
  • 全部ダウンロードしてからインストールする

また、[Automatically download updates](更新プログラムを自動的にダウンロードする) 設定を選択することもできます。これを使うと、コンピューターがアイドル状態のときに更新プログラムがダウンロードされます。

その方法は次のとおりです。

  1. メニュー バーで [ツール] > [オプション] の順に選択します。

  2. [環境] を展開してから、[製品の更新プログラム] を選択します。

    Visual Studio での更新設定

  3. Visual Studio の更新プログラム用に使用したいインストール モードと自動ダウンロード オプションを選択します。

管理者の更新

ソフトウェア インストールの管理を一元化している組織に属している場合、お使いのコンピューターでの更新をエンタープライズ管理者が Visual Studio に指示できます。 お使いのコンピューターで受け取れる更新プログラムの種類を制御または構成する方法については、「Configuration Manager を使用して Visual Studio 更新プログラムを展開する」を参照してください。

サポートを受ける

ときには、問題が発生してしまうことがあります。 Visual Studio のインストールが失敗した場合は、「Visual Studio のインストールとアップグレードの問題のトラブルシューティング」に記載されているステップ バイ ステップ ガイドをご覧ください。

インストール関連の問題については、インストール チャット (英語のみ) のサポート オプションも用意されています。

他のいくつかのサポート オプションを次に示します。

関連項目