方法: Visual Studio を使用して共同作業するHow-to: Collaborate using Visual Studio

Visual Studio で Live Share を使用して共同作業する準備はできていますか。Ready to get collaborating with Live Share in Visual Studio? そうであれば、以下をご覧ください。If so, you're in the right spot! この記事では、Visual Studio 向け Visual Studio Live Share 拡張機能のいくつかの特定の機能を使用する方法を説明します。In this article we'll walk you through how to use some of the specific features in the Visual Studio Live Share extension for Visual Studio.

ここで説明するすべてのコラボレーション アクティビティは、1 人のコラボレーション セッション ホストと 1 人以上のゲストを伴うことに注意してください。Note that all collaboration activities in described here involve a single collaboration session host and one or more guests. ホストはコラボレーション セッションを開始した人であり、参加する人はすべてゲストです。The host is the person that started the collaboration session and anyone that joins is a guest.

"短い要約をお探しですか。代わりに、共有または参加のクイック スタートをご覧ください。 "Looking for an abridged summary? Check out the share or join quickstarts instead.

ヒント

"独自のコラボレーション セッションに参加" できることをご存知でしたか。Did you know you can join your own collaboration session? これを使うと、Live Share を独自に試したり、Visual Studio または VS Code のインスタンスを起動してリモートでそれに接続したりできます。This allows you to try Live Share on your own or to spin up an instance of Visual Studio or VS Code and connect to it remotely! 両方のインスタンスで同じ ID を使用することもできます。You can even use the same identity on both instances. ぜひお試しください。Check it out!

インストールInstallation

始める前に、Visual Studio 2019 または Visual Studio 2017 15.6 以降を Windows 7、8.1、または 10 にインストールする必要があります。Before you begin, you'll need to install Visual Studio 2019 or Visual Studio 2017 15.6 or higher on Windows 7, 8.1, or 10. ただし、ローカルな元に戻す/やり直しがサポートされているので、Visual Studio 15.7 以降をお勧めします。However, Visual Studio 15.7+ is recommended as this enables local undo/redo support.

始めるのは簡単です。Getting going is simple:

Visual Studio 2019 の場合For Visual Studio 2019

  1. 任意のエディションの Visual Studio 2019 をインストールします。Install the any edition of Visual Studio 2019.
  2. サポートされているワークロードをインストールします。Install a supported workload. (例: ASP.NET、.NET Core、C++、Python、Node.js)(e.g. ASP.NET, .NET Core, C++, Python, and/or Node.js)
  3. Visual Studio Live Share は、既定でこれらのワークロードと共にインストールされます。Visual Studio Live Share is installed by default with these workloads.

Visual Studio 2017 の場合For Visual Studio 2017

  1. 任意のエディションの Visual Studio 2017 15.6 以降をインストールします。Install the any edition of Visual Studio 2017 15.6+.
  2. サポートされているワークロードをインストールします。Install a supported workload. (例: ASP.NET、.NET Core、C++、Node.js)(e.g. ASP.NET, .NET Core, C++, and/or Node.js)
  3. マーケットプレースから Visual Studio Live Share 拡張機能をダウンロードしてインストールします。Download and install the Visual Studio Live Share extension from the marketplace.

Visual Studio Live Share をダウンロードして使用すると、ライセンス条項プライバシーに関する声明に同意したものと見なされます。By downloading and using Visual Studio Live Share, you agree to the license terms and privacy statement. 問題が発生した場合は、トラブルシューティングに関するページをご覧ください。See troubleshooting if you run into problems.

ダウンロードDownload

サインインSign in

共同作業するためには、他のすべてのユーザーに認識されるように、Visual Studio Live Share にサインインする必要があります。In order to collaborate, you'll need sign into Visual Studio Live Share so everyone knows who you are. これは純粋にセキュリティ対策であり、マーケティングや他の研究活動に参加することはありませんThis is purely a security measure and does not opt you into any marketing or other research activities. Microsoft の個人アカウント (例: @outlook.com)、Microsoft の職場または学校アカウント (AAD)、または GitHub アカウントを使用してサインインすることができます。You can sign in using a Microsoft personal account (e.g. @outlook.com), Microsoft-backed work or school account (AAD), or a GitHub account. サインインは簡単です。Signing in is easy.

既定では、Visual Studio では個人アカウントが使用されるため、既に Visual Studio にログインしている場合は、この手順をスキップできます。By default Visual Studio uses your personalization account so if you're already logged into Visual Studio, you may be able to skip this step. それ以外の場合、通常どおりにサインインします。Otherwise sign as you would normally.

VS のサインイン ボタン

Visual Studio の個人アカウント以外の別のサインインを使用したい場合は、 [ツール]>[オプション]>[Live Share]>[ユーザー アカウント] の順に移動し、資格情報を切り替えます。If you want to use a different sign-in than your Visual Studio personalization account, go to Tools > Options > Live Share > User account to switch credentials.

VS Tools オプションの Live Share

[外部アカウント] を選択すると、GitHub のような、Visual Studio のパーソナル化機能でサポートされていないアカウントを選択することができます。Selecting External Account allows you to select an account not supported by Visual Studio's personalization feature like GitHub. Live Share 機能を初めて使用するとブラウザーが自動的に表示されるので、サインインを完了できます。A browser will automatically appear the first time you use a Live Share feature so you may complete sign in.

ヒント

[ツール] > [オプション] > [Live Share] > [全般] に移動して、既定の Live Share 設定をすべて表示できることをご存知でしたか。Did you know can go to Tools > Options > Live Share > General to view all the default Live Share settings? ご自身のニーズに合わせてコラボレーションのエクスペリエンスをカスタマイズしましょう。Customize your collaboration experience to your needs! Live Share の [全般] 設定内から [詳細] > [機能] > [インサイダー] を選択すれば、Live Share のすべての新機能を試すこともできます。You can also try all the new Live Share features by choosing Advanced > Features > Insiders from inside the General Live Share settings!

問題がある場合は、詳細についてトラブルシューティングに関する記事をご覧ください。If you run into trouble, check out troubleshooting for more tips.

プロジェクトを共有するShare a project

Visual Studio Live Share をダウンロードしてインストールしたら、以下の手順のようにして、コラボレーション セッションを開始し、共同作業する同僚を招待します。After downloading and installing Visual Studio Live Share, follow these steps to start a collaboration session and invite a colleague to work with you.

  1. サインインSign in

    サインインできたので、独自のコラボレーション セッションを開始する準備が整いました。Now that you are signed in, you are ready to start your own collaboration session. サインインしていませんか。Not signed in? 詳しくは、「サインイン」をご確認ください。Check sign in for more details.

  2. ソリューション、プロジェクト、またはフォルダーを開くOpen a solution, project, or folder

    通常のワークフローを使用して、ゲストと共有するフォルダー、プロジェクト、またはソリューションを開きます。Use your normal workflow to open a folder, project, or solution you would like to share with your guests.

  3. [省略可能] 非表示または除外されているファイルを更新する[Optional] Update hidden or excluded files

    既定では、プロジェクト内の .gitignore ファイルで参照されているすべてのファイル/フォルダーは、Live Share によりゲストに対して非表示になります。By default, Live Share hides any files/folders referenced in .gitignore files in your project from guests. ファイルを非表示にするとファイル ツリーに表示されなくなるのに対し、除外するとデバッグなどの操作中でも送信されなくなります。Hiding a file prevents it from appearing in the file tree while excluding it stops it from being transmitted even during operations like debugging. 別のファイルを非表示/除外する場合は、これらの設定を使用して .vsls.json ファイルをプロジェクトに追加できます。If you want to hide/exclude different files, a .vsls.json file can be added to your project with these settings. 詳細については、ファイルのアクセスと可視性を制御するのセクションを参照してください。See controlling file access and visibility for details.

  4. コラボレーション セッションを開始するStart a collaboration session

    次に、右上隅の [Live Share] ボタンをクリックして、Live Share セッションを開始します。Now, click the "Live Share" button in the upper right hand corner to start a Live Share session. ご自分のコラボレーション セッションへの共有可能なリンクが、クリップボードに自動的にコピーされます。A shareable link to your collaboration session is automatically copied to your clipboard.

    VS の共有ボタン

    初めてコラボレーション セッションを開始すると、Live Share のツール ウィンドウが表示されます。Once you start your collaboration session for the first time you will see a Live Share tool window. 次回 Live Share セッションを開始したときにこのウィンドウが表示されるように、必ずこれをドッキングしておきます。Make sure you dock this window to ensure it shows up the next time you start a Live Share session.

    VS Live Share ツール ウィンドウ

    注意

    初めて共有するときに、Live Share エージェントがポートを開くのを許可するように、デスクトップのファイアウォール ソフトウェアから求められる場合があります。You may be asked by your desktop firewall software to allow the Live Share agent to open a port the first time you share. これを受け入れるかどうかは任意ですが、共同作業する人が自分と同じネットワーク上にいるときには、セキュリティで保護された "ダイレクト モード" を有効にしてパフォーマンスを向上させます。Accepting this is entirely optional but enables a secured "direct mode" to improve performance when the person you are working with is on the same network as you are. 詳細については、接続モードを変更するのセクションを参照してください。See changing the connection mode for details.

  5. [省略可能] 読み取り専用モードを有効にする[Optional] Enable read-only mode

    コラボレーション セッションを開始したら、セッションを読み取り専用に設定して、ゲストが共有中のコードを変更できないようにすることができます。Once you start your collaboration session, you can set the session to be read-only to prevent guests from making edits to the code being shared.

    共有後、招待リンクがクリップボードにコピーされたことを知らせる通知が表示されます。After sharing, you will get a notification that the invite link has been copied to your clipboard. オプションを選択して、セッションを読み取り専用にすることができます。You can then select the option to make the session read-only.

    VS の読み取り専用モード

  6. リンクを送信するSend someone the link

    電子メール、Slack、Skype などを使用して、招待したい人にリンクを送信します。Send the link over e-mail, Slack, Skype, etc. to those you want to invite. Live Share セッションがゲストに提供できるアクセス レベルを考慮すると、信頼できる人とだけ共有すべきであることに注意してください。また、共有するものの影響を十分に検討してください。Note that, given the level of access Live Share sessions can provide to guests, you should only share with people you trust and think through the implications of what you are sharing.

    セキュリティのヒント: Live Share の一部の機能のセキュリティの影響について理解したいですか。Security Tip: Want to understand the security implications of some of Live Share's features? セキュリティ記事を参照してください。Check out the security article.

    招待したゲストが質問がある場合は、「クイック スタート:最初のセッションに参加する」の記事で、ゲストとして開始および実行することについて、もう少し詳しい情報が得られます。If the guest you invited has questions, the "Quickstart: Join your first session" article provides some more information on getting up and running as a guest.

  7. [省略可能] ゲストを承認する[Optional] Approve the guest

    既定では、ゲストはコラボレーション セッションに自動的に参加し、ゲストが共同作業の準備ができると、通知されます。By default, guests will automatically join your collaboration session and you'll be notified when they've ready to work with you. この通知ではセッションからゲストを削除できますが、代わりに参加するすべてのユーザーに明示的な "承認" を要求することもできます。While this notification gives you the option to remove them from the session, you can also opt to instead require an explicit "approval" for anyone joining.

    機能を有効にするには、 [ツール] > [オプション] > [Live Share] > [ゲスト承認が必要] を True にするだけです。Simply change Tools > Options > Live Share > Require guest approval to True to enable the feature. この設定を有効にすると、ゲストが参加する前に、ゲストの承認を促す通知が表示されます。Once you have this setting turned on, a notification will prompt you to approve the guest before they can join.

    Visual Studio の参加承認要求

    招待のセキュリティに関する考慮事項の詳細については、「招待および参加アクセス」を参照してください。See invitations and join access for additional details on invitation security considerations.

  8. Live Share セッションを管理するManage your Live Share session

    あなたのゲストが VS Code または Visual Studio で共有セッションへのリンクを開くと、Live Share ツール ウィンドウの参加者の下にそのユーザーが表示されます。Once your guest has opened the link to your shared session in VS Code or Visual Studio you will see them listed under participants in the Live Share tool window. ここで、ゲストの名前の横を見れば、各自が現在どのファイル内にいるのかを確認できます。You are now able to see which file your guest is currently in next to their name.

    VS Live Share ツール ウィンドウ

    Live Share ツール ウィンドウを使うと、セッションを管理するための主要機能すべてに、1 つの場所からアクセスできます。The Live Share tool window allows you to access all key features to manage your session in one place.

    ヒント

    セッション中に Live Share ツール ウィンドウが表示されなくなりましたか。Can't see the Live Share tool window anymore during your sessions? [ビュー] > [その他のウィンドウ] > [Live Share] から、いつでもそれを見つけることができます。You can always go to View > Other Windows > Live Share and find it!

コラボレーション セッションの終了Ending the collaboration session

ホストは、共有/セッション状態ボタン (右上隅) をクリックして [End Collaboration Session](コラボレーション セッションの終了) を選択することで、完全に共有を停止し、コラボレーション セッションを終了できます。As a host, you can stop sharing completely and end the collaboration session by clicking the share / session state button (in the upper right hand corner) and selecting "End Collaboration Session".

共有を停止する

すべてのゲストに、セッションが終了したことが通知されます。All guests will be notified that the session has ended. セッションが終了すると、ゲストはコンテンツにアクセスできなくなり、一時ファイルは自動的にクリーンアップされます。Once the session has ended, guests will no longer be able to access the content and any temp files are automatically cleaned up.

共有で問題が発生しますか。Having issues with sharing? トラブルシューティングに関する記事を参照してください。Check out troubleshooting.

コラボレーション セッションに参加するJoin a collaboration session

Visual Studio Live Share をダウンロードしてインストールした後、ゲストはわずかな手順でホストされたコラボレーション セッションに参加できます。After downloading and installing Visual Studio Live Share, guests only need to take a couple steps to join a hosted collaboration session. 参加するには、ブラウザー経由手動の 2 つの方法があります。There are two ways to join: via the browser and manually.

セキュリティのヒント: コラボレーション セッションに参加するゲストとして、ホストが特定のファイルや機能に対してアクセスを制限する場合があることを理解しておく必要があります。Security Tip: As a guest joining a collaboration session, it's important to understand that hosts may restrict your access to certain files or features. Live Share の一部の機能と設定のセキュリティの影響について理解したいですか。Want to understand the security implications of some of Live Share's features and settings? セキュリティ記事を参照してください。Check out the security article.

ブラウザー経由で参加するJoin via the browser

コラボレーション セッションに参加する最も簡単な方法は、単純に Web ブラウザーで招待のリンクを開くことです。The easiest way to join a collaboration session is to simply open the invite link in a web browser. このフローに従うと次のようになります。Here's what you can expect when you follow this flow.

  1. サインインするSign in

    Live Share 拡張機能をインストールした後は、サインインして他の共同作業者に自分のことを知ってもらいます。After installing the Live Share extension, you'll want to sign in to let other collaborators know who you are. 既定では、Visual Studio では個人アカウントが使用されるため、このステップをそっくり省略できる場合があります。By default Visual Studio uses your personalization account, so you may be able to skip this step entirely.

    詳しくは、「サインイン」をご覧ください。See sign in for more details.

  2. 招待リンクをクリックする/ブラウザーで招待状を開くClick on the invite link / open the invite in your browser

    ブラウザーで招待リンクを開く (またはもう一度開く) だけです。Now, simply open (or re-open) the invite link in a browser.

    :Live Share の拡張機能をまだインストールしていない場合は、拡張機能のマーケットプレースへのリンクが表示されます。Note: If you have not yet installed the Live Share extension, you'll be presented with links to the extension marketplace. 拡張機能をインストールしてツールを再起動して再度試します。Install the extension and restart your tool and retry.

    ブラウザーで Live Share 対応のツールを起動するかどうかをたずねる通知が表示されます。You should be notified that the browser wants to launch a Live Share enabled tool. 選択したツールの起動を許可すると、起動したときにコラボレーション セッションに接続されます。If you let it launch your selected tool, you'll be connected to the collaboration session once it starts.

    参加ページ

    ホストがオフラインの場合は、代わりにこの時点で通知されます。If the host is offline, you'll be notified at this point instead. ホストに連絡して、もう一度共有するように依頼できます。You can then contact the host and ask them to share again.

    注意

    まだ問題がありますか?Still having trouble? 手動で参加する」を参照してください。See join manually.

  3. 共同作業をするCollaborate

    これで完了です。That's it!! しばらくすると、接続されて共同作業を開始できます。In a few moments you'll be connected and you can start collaborating.

    "セッション状態" を伝達するように "Live Share" ボタンが変化するのを確認できます。You will see the "Live Share" button transition to convey a "Session State". この表示については、後述する「セッション状態」を参照してください。See session state information below for what this looks like.

    参加が完了すると、ホストが現在編集しているファイルに自動的に移動します。You'll then be automatically taken to the file the host is currently editing once the join is complete.

手動で参加するJoin manually

Web ブラウザーを使用しないで手動で参加することもできます。使用するツールが既に実行されている場合、いつも使用しているものとは違うツールを使用したい場合、または何らかの理由で招待リンクに問題がある場合に役に立ちます。You can also manually join without using a web browser which can be useful in situations where the tool you want to use is already running, you want to use a different tool than you usually do, or if you are having trouble with getting invite links to work for some reason. 手順は簡単です。The process is easy:

  1. サインインするSign in

    Live Share 拡張機能をインストールした後は、サインインして他の共同作業者に自分のことを知ってもらいます。After installing the Live Share extension, you'll want to sign in to let other collaborators know who you are. 既定では、Visual Studio では個人アカウントが使用されるため、このステップをそっくり省略できる場合があります。By default Visual Studio uses your personalization account, so you may be able to skip this step entirely.

    詳しくは、「サインイン」をご覧ください。See sign in for more details.

  2. 参加コマンドを使用するUse the join command

    単に [ファイル] > [Join Live Share Session](Live Share セッションに参加) の順に移動するSimply go to File > Join Live Share Session

    VS 参加メニュー

  3. 招待リンクを貼り付けるPaste the invite link

    送信された招待 URL を貼り付けて確認します。Paste in the invite URL you were sent and confirm.

  4. 共同作業をするCollaborate!

    これで完了です。That's it! すぐにコラボレーション セッションに接続されるはずです。You should be connected to the collaboration session momentarily.

    "セッション状態" を伝達するように "Live Share" ボタンが変化するのを確認できます。You will see the "Live Share" button transition to convey a "Session State". この表示については、後述する「セッション状態」を参照してください。See session state information below for what this looks like.

    参加が完了すると、ホストが現在編集している場所に自動的に移動します。You'll then be automatically taken to where the host is currently editing once the join has completed.

コラボレーション セッションから退席するLeave the collaboration session

ゲストは、ツールを閉じるか、共有/セッション状態ボタンをクリックして [Leave Collaboration Session](コラボレーション セッションを退席) を選択するだけで、他のユーザーのセッションを終了させずに、コラボレーション セッションから退席できます。As a guest, you can leave the collaboration session without ending it for others by simply closing the tool or by clicking the share / session state button and selecting "Leave Collaboration Session".

VS 参加メニュー

一時ファイルは自動的にクリーンアップされるため、これ以上の操作は必要ありません。Any temp files are automatically cleaned up so no further action is needed.

参加で問題が発生しますか。Having issues with joining? トラブルシューティングに関する記事を参照してください。Check out troubleshooting.

共同編集Co-editing

ゲストがコラボレーション セッションに参加すると、すべてのコラボレーターがすぐに互いの編集と選択内容をリアルタイムで見られるようになります。Once a guest has joined a collaboration session, all collaborators will immediately be able to see each others edits and selections in real-time. 行う必要があることは、エクスプローラーでファイルを選択して、編集を始めることだけです。All you need to do is pick a file from the file explorer and start editing. ホストとゲストの両方が他のユーザーの編集を見ることができ、簡単に反復処理して迅速にソリューションを完了できます。Both hosts and guests will see edits as you make them and can contribute themselves making it easy iterate and rapidly nail to down solutions.

注意

読み取り専用でコラボレーション セッションに参加すると、ゲストはファイルを編集することができません。Joining a read-only collaboration session prevents guests from being able to make edits to files. ホストは、共有するときに読み取り専用モードを有効にすることができます。A host can enable read-only mode when they share. ゲストは、セッション状態を見ることで、読み取り専用セッションに参加しているかどうかを確認できます。As a guest, you can tell if you have joined a read-only session by looking at your session state.

共同編集を示すスクリーンショット

注意

特定の言語では共同編集にいくつかの制限があります。Co-editing has a few limitations for certain languages. 言語ごとの機能の状態については、プラットフォームのサポートに関するページをご覧ください。See platform support for the state of features by language.

カーソルと編集だけでなく、選択も同じファイル内にいるすべての参加者に見えます。Beyond cursors and edits, selections you make are also visible to all participants in that same file. これにより簡単に、問題の場所を示したり、アイデアを伝えたりできます。This makes it easy to highlight where problems might exist or convey ideas.

強調表示を示すスクリーンショット

さらに、すべての参加者は、共有プロジェクト内のファイルに移動できます。Better yet, you and other participants can navigate to any file in the shared project. 共同編集も個別編集も可能です。つまり、調査、微調整、完全な共同編集の間をシームレスに切り替えることができます。You can either edit together or independently meaning you can seamlessly switch between investigation, making small tweaks, and full collaborative editing.

注意

既定では、Live Share は共有ソリューションの外部で開かれているファイルも共有します。By default Live Share shares opened files external to the shared solution as well. この機能を無効にする場合は、[ツール] > [オプション] > [Live Share] で [外部ファイルの共有] を False にします。If you want to disable this feature, update Share External Files in Tools > Options > Live Share to False.

結果の編集内容は保存時にホストのコンピューターに保存されるので、編集が終わってもファイルを同期、プッシュ、送信する必要はありません。The resulting edits are persisted on the host's machine on save so there is no need to synchronize, push, or send files around once you're done editing. 編集内容は "そこにあります"。The edits are "just there."

セキュリティのヒント: すべての参加者が個別にファイルに移動して編集できるようにした場合、ホストは .vsls.json ファイルを使用してゲストがプロジェクト内でアクセスできるファイルを制限できます。Security Tip: Given all participants can independently navigate and edit files, as a host, you may want to restrict which files guests are able to access in your project via a .vsls.json file. ゲストとしては、これらの設定の結果、特定のファイルが表示されないことを認識していることが重要です。As a guest, it is also important to realize you may not see certain files as a result of these settings. 詳細については、ファイルのアクセスと可視性を制御するのセクションを参照してください。See controlling file access and visibility for details.

参加者フラグの動作の変更Changing participant flag behaviors

Visual Studio Live Share では、既定で、参加者のカーソルがある場所の横に、または参加者が編集、強調表示、カーソル移動するときに、自動的に "フラグ" が表示されます。By default, Visual Studio Live Share automatically displays a "flag" next to a participant's cursor on hover, or when they edit, highlight, or move their cursor. 場合によってはこの動作を変更することもできます。In some cases you may prefer to change this behavior. 次の手順に従います。To do so:

  1. [ツール] > [オプション] > [Live Share] に移動しますGo to Tools > Options > Live Share
  2. [フラグの表示] オプションを次のいずれかに変更します。Change the Flag visibility option to one of the following:
オプションOption 動作Behavior
OnHoverOnlyOnHoverOnly フラグは、カーソルでポイントしたときだけ表示されます。The flag is only visible when you hover over the cursor.
OnHoverOrActivityOnHoverOrActivity 既定値です。This is the default. フラグは、ポイントしたとき、または参加者が編集、強調表示、カーソル移動した場合に表示されます。The flag is visible on hover or if the participant edits, highlights, or moves their cursor.
AlwaysAlways フラグは常に表示されます。The flag is always visible.

フォローFollowing

コラボレーション セッション中は常に、エディターの右上のサインイン ボタンの横で各参加者のイニシャルを確認できます。Whenever you are in a collaboration session, you'll be able can see each participant's initials in the upper right of the editor next to the sign in button. イニシャルをポイントすると、参加者の完全な情報が表示されます。Hovering over the initials shows you the participant's full information.

ユーザーを示すスクリーンショット

複数のファイルやコード内の場所にまたがる問題や設計について説明する必要がある場合があります。Sometimes you may need to explain a problem or design that spans multiple files or locations in code. このような状況では、プロジェクト全体を移動する同僚を一時的にフォローすると便利な場合があります。In these situations, it can useful to temporarily follow a colleague as they move throughout the project. このため、ゲストは、コラボレーション セッションに参加するとホストを自動的に "フォロー" します。For this reason, as a guest, when you join a collaboration session you will automatically "follow" the host. 参加者をフォローすると、エディターは参加者が現在開いているファイル、カーソル、スクロール位置との同期を維持します。When following a participant, your editor will stay in sync with their currently open file, cursor, and scroll position.

注意

既定では、Live Share は共有ソリューションの外部で開かれているファイルも共有します。By default Live Share shares opened files external to the shared solution as well. この機能を無効にする場合は、[ツール] > [オプション] > [Live Share] で [外部ファイルの共有] を False にします。If you want to disable this feature, update Share External Files in Tools > Options > Live Share to False.

簡単に "フォロー モード" を終了して自分の編集を開始するには、次のいずれかが発生した場合、フォローは停止します。To make it easy to switch out of "follow mode" and start editing on your own, you'll stop following if any of the following happens:

  1. 編集、カーソル移動、または選択を行うYou edit, move your cursor, or make a selection
  2. 別のファイルを選択するYou select another file

また、右上隅でフォローしているユーザーのイニシャルをクリックして、いつでもフォローを停止できます。You can also stop following at any time by clicking the initials of the person you are following in the upper right hand corner. フォローしていることを示す参加者のイニシャルの周りの円が消えます。The circle around the participant's initials that indicates you are following them will then disappear.

フォローされている Visual Studio 参加者 フォローされていない Visual Studio 参加者

この同じ場所のイニシャルをクリックして、コラボレーション セッションのホストまたはゲストをフォローできます。You can click on any initials in this same location to follow any host or guest in the collaboration session. フォローするのではなく他のユーザーの場所に移動するだけの場合は、イニシャルをダブルクリックします。Note that if you just want to jump to someone's location rather than following them, simply double-click their initials.

フォーカス設定Focusing

場合によっては、自分が編集している場所を、コラボレーション セッションの全員に見てもらいたいことがあります。Occasionally you may want everyone in a collaboration session to come and take a look at something you are doing. Live Share では、フォローが返しやすくなる通知を使って、全員が自分に注意を "フォーカス" するよう要求することができます。Live Share lets you ask that everyone "focus" their attention on you with a notification that makes it easy for them to follow you back.

右上隅のセッション状態/共有ボタンをクリックして、[参加者へフォロー依頼] を選択するだけです。Just click on the session state / share button in the upper right hand corner and select "Focus Participants".

フォーカス メニュー オプション

コラボレーション セッションのすべてのユーザーに、注目を求める通知が送信されます。Everyone in the collaboration session will then get a notification that you've requested their attention

フォーカス トースト通知

参加者は、フォローする準備ができたら、通知の "フォローする" をクリックするだけで済みます。They can then just click "Follow" right from the notification when they're ready to put their focus on you.

共同デバッグCo-debugging

Visual Studio Live Share の共同デバッグ機能は、問題をデバッグするための強力で独自の方法です。Visual Studio Live Share's collaborative debugging feature is a powerful and unique way to debug an issue. コラボレーション エクスペリエンスを有効にして問題をトラブルシューティングする以外に、参加者はホストのマシンで共有デバッグ セッションを提供することで、環境固有の可能性がある問題を調査できます。Beyond enabling a collaborative experience to troubleshoot problems, it also you and other participants in your session the ability to investigate issues that may be environment specific by providing a shared debugging session on the host's machine.

セキュリティのヒント: すべての参加者が個別にファイルに移動して編集できるようにした場合、ホストは .vsls.json ファイルを使用してゲストがプロジェクト内でアクセスできるファイルを制限できます。Security Tip: Given all participants can independently navigate and edit files, as a host, you may want to restrict which files guests are able to access in your project via a .vsls.json file. また、コンソール/REPL アクセスは、参加者がホストのコンピューターでコマンドを実行できることを意味するので、信頼できるユーザーとのみ共同バッグする必要があります。You should also be aware that Console/REPL access means that participants can execute commands on your machine so you should only co-debug with those you trust. ゲストとしては、これらの設定の結果として、デバッガーが特定のファイル制限付きのファイルにステップインするとフォローできないことにも注意が必要です。As a guest, it is also important to realize you may not be able to follow the debugger as it step into certain files restricted files as a result of these settings. 詳細については、ファイルのアクセスと可視性を制御するのセクションを参照してください。See controlling file access and visibility for details.

簡単に使用できます。Using it simple. コラボレーション セッション ホストは単に、Visual Studio で通常の方法でデバッグを開始する必要があります。The collaboration session host simply needs to start debugging via the usual means in Visual Studio.

VS のデバッグ ボタン

デバッガーがホスト側でアタッチすると、すべてのゲストも自動的にアタッチされます。Once the debugger attaches on the host's side, all guests are also automatically attached as well. ホストのマシンで 1 つのデバッグ "セッション" が実行されている間、すべての参加者はそれに接続されて、それぞれに独自のビューがあります。While there is one debugging "session" running on the host's machine, all participants are connected to it and have their own view.

ヒント

共同デバッグを行うタイミングと方法を変更したい場合は、 [ツール] > [オプション] > [Live Share] の設定で、既定の動作を変更できます。If you want to change when and how co-debugging happens, you can change the default behaviors via settings in Tools > Options > Live Share.

アタッチされた VS デバッガー

だれでもデバッグ プロセスをステップ実行でき、制御をネゴシエートする必要なしに、コラボレーター間でシームレスに切り替えることができます。Anyone can step through the debugging process which enables seamless switching between collaborators without having to negotiate control.

注意

言語またはプラットフォームごとのデバッグ機能の状態については、プラットフォームのサポートに関するページをご覧ください。See platform support for the state of debugging features by language or platform.

各コラボレーターは、異なる変数を調査し、呼び出し履歴内の異なるファイルにジャンプし、変数を検査し、ブレークポイントを追加または削除できます。Each collaborator can investigate different variables, jump to different files in the call stack, inspect variables, and even add or remove breakpoints. 共同編集機能では、各参加者は、他のユーザーがいる場所を追跡でき、問題の異なる側面の同時調査と共同デバッグの間をシームレスに切り替える独自の機能が提供されます。Co-editing features then allow each participant orator to track where the others are located to provide the unique ability to seamlessly switch between concurrently investigating different aspects of the problem and collaboratively debugging.

注意

読み取り専用のコラボレーション セッション中は、ゲストはデバッグ プロセスをステップ実行できません。While in a read-only collaboration session, a guest will not be able to step through the debugging process. ただし、ブレークポイントを追加または削除したり、変数を検査したりすることはできます。They can however, still add or remove breakpoints, and inspect variables.

ヒント

また、Visual Studio から VS Code デバッグ セッションに、またはその逆に、参加することもできます。You can also participate in VS Code debugging sessions from Visual Studio and vice versa! 共同デバッグの詳細については、Visual Studio での説明をご覧ください。Check out the Visual Studio instructions on co-debugging for more information.

Web アプリの自動共有Automatic web app sharing

さらによいことに、ASP.NET Web アプリ プロジェクトでは、既定で、デバッグ時にホストのプロジェクトが自動的に Web ブラウザーを起動して実行中の Web アプリケーションに接続するように構成されている場合、Live Share は各ゲストのマシンで同じことを自動的に行います。Even better, for ASP.NET Web App projects, by default if the host's project is configured to automatically start a web browser to connect to the running web application when debugging, Live Share will automatically do the same on each guest's machine! これは安全な方法で行われ、既定ではゲストはデバッグ セッションの間だけリモート Web アプリケーションを使用できます。This is done in a secure way and the remote web application is only available to the guests during the debugging session by default.

他の種類のプロジェクトおよびセッションの期間についてサーバーへのアクセスを共有する方法については、「サーバーを共有する」をご覧ください。See share a server for information on how to share server access for other project types and/or for the duration of the session.

ヒント

自動ブラウザー共有の動作が好きではなく、変更したい場合は、 [ツール] > [オプション] > [Live Share] で設定を更新できます。If you don't like the automated browser sharing behavior and want to change it, you can update settings in Tools > Options > Live Share.

同時デバッグのアニメーション

Visual Studio がデバッグ セッションに参加するタイミングを変更するChange when Visual Studio joins debugging sessions

既定では、ゲストはホストによって共有されると自動的にデバッグ セッションにアタッチされます。By default, as a guest, you'll be automatically attached to debugging sessions when they are shared by the host. ただし、この動作が混乱を招く場合があります。However, in some cases you may find this behavior disruptive. さいわい、次のようにしてそれを変更できます。Fortunately, you can change it as follows:

  1. [ツール] > [オプション] > [Live Share] に移動しますGo to Tools > Options > Live Share
  2. [Join debug session](デバッグ セッション参加オプション) を次のいずれかに変更します。Change the Join debug session option to one of the following:
オプションOption 動作Behavior
自動Automatic これが既定値です。The default. ゲストは、ホストが開始するすべての共有デバッグ セッションに自動的に参加します。As a guest, you'll automatically join any shared debugging session the host starts.
Prompted (確認)Prompted ゲストは、ホストによって開始された共有デバッグ セッションに参加するかどうか確認するように求められます。As a guest, you are prompted as to whether you want to join a shared debugging session when it is started by the host.
手動Manual ゲストは、デバッグ セッションに手動で参加する必要があります。As a guest, you'll need to manually join any debugging sessions. デタッチと再アタッチ」をご覧ください。See detaching and reattaching.

デタッチと再アタッチDetaching and reattaching

ゲストは、一時的にデバッグを停止したいことがあります。As a guest, you may wish to stop debugging temporarily. さいわい、デバッグ ツールバーの "停止" アイコンをクリックするだけで、ホストまたは他のゲストに影響を与えずに、デバッガーをデタッチできます。Fortunately, you can simply click the "stop" icon in the debug toolbar to detach the debugger without affecting the host or other guests.

設定を更新したために自動的にアタッチしなくなった場合、または後で再アタッチしたい場合は、[スタートアップ アイテムの選択...] ドロップダウンから目的の実行中のデバッグ セッションを選択し...If you've updated settings so you no longer auto-attach or if you simply want to reattach later, you can simply select the desired running debugging session from the "Select Startup Item..." drop down...

VS のデバッグ ボタン

...クリックしてアタッチします。...and then click it to attach.

VS のデバッグ ボタン

サーバーを共有するShare a server

コラボレーション セッション ホストは、追加のローカル サーバーまたはサービスをゲストと共有したい場合があります。From time to time, as a collaboration session host you may find that you want to share additional local servers or services with guests. その範囲は、他の RESTful エンドポイントから、データベースや他のサーバーまでです。This can range from other RESTful end-points to databases or other servers. Visual Studio Live Share では、ローカル ポート番号を指定し、必要に応じて名前を付けてから、すべてのゲストと共有することができます。Visual Studio Live Share lets you specify a local port number, optionally give it a name, and then share it with all guests.

その後、ゲストは、そのポートで共有されているサーバーに、自分のローカル コンピューターから正確に同じポートでアクセスすることができます。The guests will then be able to access the server you shared on that port from their own local machine on the exact same port. たとえば、ポート 3000 で実行されている Web サーバーを共有した場合、ゲストは自分のコンピューターの http://localhost:3000 で、その同じ実行中の Web サーバーにアクセスできます。For example, if you shared a web server running on port 3000, the guest can access that same running web server on their own machine at http://localhost:3000! これは、ホストとゲストの間のセキュリティ保護された SSH または SSL トンネルを介して実現され、サービスによって認証されるため、コラボレーション セッション内のユーザーだけがアクセスするようにできます。This is accomplished via a secure SSH or SSL tunnel between the host and guests and authenticated via the service so you can be sure that only those in the collaboration session have access.

セキュリティのヒント: ホストはゲストと共有するポートをよく考えて選択する必要があり、(システム ポートを共有するのではなく) アプリケーション ポートを使用する必要があります。Security Tip: As a host, you should be very selective with the ports you share with guests and stick to application ports (rather than sharing a system port). ゲストから見ると、共有ポートは、サーバー/サービスが自分のコンピューターで実行している場合とまったく同じように動作します。For guests, shared ports will behave exactly like they would if the server/service was running on their own machine. これは非常に便利ですが、共有するポートを間違えると危険な場合もあります。This is very useful, but if the wrong port is shared can also be risky.

セキュリティのため、他のゲストは指定したポートで実行されているサーバーだけを使用できます。For security purposes, only servers running on ports you specify are available to other guests. さいわい、コラボレーション セッション ホストとしてサーバーを追加するのは簡単です。Fortunately, its easy to add one as the collaboration session host. 次の手順に従います。Here's how:

  1. 右上隅にある共有/セッション状態ボタンをクリックし、[共有サーバーを管理する] を選択しますClick on the share / session state button in the upper right corner and select "Manage Shared Local Servers"

    共有サーバーを管理する

  2. 表示されるダイアログで、[追加] をクリックし、ローカル環境でサーバーが実行されているポート番号を入力し、名前を入力し、Enter キーを押して、[OK] をクリックします。In the dialog that appears, click "Add" and enter the port number the server is running on locally, enter a name, press enter, then OK.

    共有サーバーを管理する

これで完了です。That's it! 指定したポートのサーバーが、各ゲストの localhost の同じポートにマップされます (そのポートが既に使用されていない場合)。The server on the port you specified will now be mapped to each guest's localhost on the same port (unless that port was already occupied)!

ポートがゲストのコンピューターで既に使用されている場合、別のポートが自動的に選択されます。If the port is already in use on a guest's machine, a different one is automatically selected. さいわい、ゲストは右上隅にある共有/セッション状態ボタンをクリックして [共有サーバーの表示] を選択することで、現在共有されているポートの一覧を見ることができます (指定されている場合は名前で)。Fortunately, as a guest you can see a list of currently shared ports (by name if specified) by clicking the share / session state button in the upper right corner and selecting "View Shared Local Servers."

共有サーバーの表示

セキュリティ上の理由から、ホストのコンピューター上で共有されるポートを "ゲストは制御できない" ことに注意してください。Note that guests cannot control which ports on the host's machine are shared for security reasons.

ホストがローカル サーバーの共有を停止するには、上と同じように右上隅にある共有/セッション状態ボタンをクリックし、[共有サーバーを管理する] を選択して、適切なポートを選択し、[削除] をクリックします。To stop sharing a local server, the host simply needs to click the share / session state button in the upper right corner as above, select "Manage Shared Local Servers", and select the appropriate port, and click "Remove".

ターミナルを共有するShare a terminal

最新の開発では、さまざまなコマンド ライン ツールを頻繁に使用します。Modern development makes frequent use of a wide array of command line tools. さいわい、Live Share を使うとホストは必要に応じてゲストと "ターミナルを共有" することができます。Fortunately, Live Share allows you, as a host, to optionally "share a terminal" with guests. 共有されたターミナルは、読み取り専用または完全な共同作業用にすることができます。このため、ホストとゲストの両方がコマンドの実行と結果の確認を行うことができます。The shared terminal can be read-only or fully collaborative so both you and the guests can run commands and see the results. ホストは、ゲストがターミナル出力を表示したり、ゲストが実際にテストやビルドの実行や、ホストのコンピューターでしか発生しない環境固有の問題のトリアージを行ったりすることを可能にできます。You can to give guests visibility to terminal output or let them get hands on and run tests, builds, or even triage environment specific problems that only happen on your machine.

ただし、ターミナルによりゲストは (自分でコマンドを実行できない場合でも) 少なくともホストが実行したコマンドの出力に読み取り専用でアクセスできるようになるため、既定ではターミナルは共有されませんHowever, terminals are not shared by default since they give guests at least read-only access to the output of commands you run (if not the ability to run commands themselves). これにより、ホストはリスクなしで自由にローカル ターミナルでコマンドを実行し、実際に必要なときにだけ共有することができます。This way you can freely run commands in local terminals without risk and only share when actually need to do so. さらに、ゲストが共有ターミナルを開始し、ホストが予期または監視していないことを実行することがないように、共有ターミナルを開始できるのはホストだけです。In addition, only hosts can start shared terminals to prevent guests from starting one up and doing something you are not expecting or watching.

ホストは、右上隅のセッション状態/共有ボタンをクリックし、[ターミナルの共有] メニュー項目のいずれかを選択することで、ターミナルを共有できます。As a host, you can share a terminal by clicking on the session state / share button in the upper right hand corner and selecting one of the "Share Terminal" menu items.

ターミナル メニュー

この時点で、メニューから読み取り専用ターミナルまたは読み取り/書き込みターミナルを選択できます。At this point, you can select a read-only or read/write terminal from the menu. ターミナルが読み取り/書き込みのときは、ホストを含むすべてのユーザーがターミナルに入力でき、ゲストが好ましくないことを行っている場合は簡単に介入できます。When the terminal is read/write, everyone can type in the terminal including the host which makes it easy to intervene if a guest is doing something you do not like. ただし、安全のため、ホストは、読み取り/書き込みアクセスはゲストが実際にそれを必要としていることがわかっている場合にのみ許可し、自分が実行するコマンドの出力をゲストに見せたいだけの場合は読み取り専用ターミナルを使用する必要があります。However, to be safe, you should only give read/write access to guests when you know they actually need it and stick with read-only terminals for scenarios where you just want the guest to see the output of any commands you run.

注意

コラボレーション セッションが読み取り専用モードの場合は、ホストが共有できるのは読み取り専用ターミナルだけです。If the collaboration session is in read-only mode, only read-only terminals can be shared by the host.

開始する共有ターミナルの種類を選択すると、新しい共有ターミナルが適切なアクセス許可を持つすべての参加者に表示されます。Once you've selected the kind of shared terminal you want to start, a new shared terminal will appear for all participants with the correct permissions. Visual Studio Code には組み込みのターミナル サポートがありますが、Visual Studio にはありません。While Visual Studio Code has a built in terminal support Visual Studio does not have one out of box. そのため、既定では、ターミナルを含む新しいウィンドウが表示されます。Therefore, by default, new window containing the terminal will appear. ただし、Whack Whack Terminal 拡張機能の場合は、Live Share は代わりに統合ターミナルを作成します。However, if the Whack Whack Terminal extension, Live Share will create an integrated terminal instead. 共有ターミナルを初めて開始または参加するときに、Visual Studio によってインストールするためのリンクが提供されます。Visual Studio will give you a link to install it the first time you start or join a shared terminal.

ターミナル インストール トースト通知

ターミナル セッションを終了するには、単に「exit」と入力するか、ターミナル ウィンドウを閉じます。そうすると、すべてのユーザーが切断されます。To end your terminal session, simply type exit or close the terminal window and everyone will be disconnected.

セッション状態Session states

コラボレーション セッションを開始するか、またはそれに参加し、共有コンテンツにアクセスできるようになると、右上隅の "Live Share" ボタンの表示が、アクティブなコラボレーション セッションの状態を反映するように更新されます。After you have started or joined collaboration session and have access to shared content, the "Live Share" button in the upper right hand corner updates its appearance to reflect the state of the active collaboration session.

通常表示される状態は次のとおりです。The following are the states you will typically see:

状態State ボタンButton 説明Description
非アクティブInactive VS の状態: 非アクティブ アクティブなコラボレーション セッションはなく、何も共有されていません。No active collaboration session and nothing is shared.
ホスト:共有進行中Host: Sharing In-Progress VS の状態: 共有進行中 コラボレーション セッションの開始中であり、コンテンツの共有は間もなく開始されます。A collaboration session is starting and content sharing will begin shortly.
ホスト:共有Host: Sharing VS の状態: 共有アクティブVS status: sharing active コラボレーション セッションはアクティブであり、コンテンツは共有されています。A collaboration session is active and content is shared.
ホスト:読み取り専用の共有Host: Sharing Read-only VS の状態: 読み取り専用の共有 読み取り専用のコラボレーション セッションを共有しています。Sharing a read-only collaboration session.
ゲスト:セッション参加中Guest: Joining Session VS Code の状態: 参加中 既存のコラボレーション セッションへの参加を行っています。Joining an existing collaboration session.
ゲスト:参加済みGuest: Joined VS ステータス: 参加済み アクティブなコラボレーション セッションに参加して接続しており、共有コンテンツを受信しています。Joined and connected to an active collaboration session and receiving shared content.
ゲスト:読み取り専用で参加済みGuest: Joined Read-only VS ステータス: 読み取り専用で参加済み アクティブな読み取り専用コラボレーション セッションに参加して接続しています。Joined and connected to an active read-only collaboration session.

ゲストの制限事項Guest limitations

現在、上で説明した機能を使用しているときにゲスト側ではいくつかの問題が発生しますが、コラボレーション セッション ホスト側では選択したツールの完全な機能が維持されます。While there are currently some shortcomings guests will experience while using the features described above, collaboration session hosts retain the complete functionality of their tool of choice. 詳しくは、次のトピックをご覧ください。See the following for more information:

次の手順Next Steps

詳細については、次の記事をご確認ください。Check out these additional articles for more information.

問題が発生していますか?Having problems? トラブルシューティングまたはフィードバックの送信に関するページをご覧ください。See troubleshooting or provide feedback.