手順 5: Python 環境へのパッケージのインストールStep 5: Install packages in your Python environment

前の手順:デバッガーでコードを実行するPrevious step: Run code in the debugger

Python 開発者コミュニティは、ユーザーが独自のプロジェクトに組み込むことのできる便利なパッケージを何千も作成してきました。The Python developer community has produced thousands of useful packages that you can incorporate into your own projects. Visual Studio には、Python 環境内のパッケージを管理するための UI が用意されています。Visual Studio provides a UI to manage packages in your Python environments.

環境の表示View environments

  1. [表示] > [その他のウィンドウ] > [Python 環境] メニュー コマンドを選びます。Select the View > Other Windows > Python Environments menu command. ソリューション エクスプローラーへのピアとして [Python 環境] ウィンドウが開き、利用可能なさまざまな環境が示されます。The Python Environments window opens as a peer to Solution Explorer and shows the different environments available to you. この一覧には、Visual Studio インストーラーを使用してインストールした環境と、個別にインストールした環境の両方が表示されます。The list shows both environments that you installed using the Visual Studio installer and those you installed separately. これには、グローバル環境、仮想環境、および Conda 環境が含まれます。That includes global, virtual, and conda environments. 太字で示されている環境は、新しいプロジェクトに使用される既定の環境です。The environment in bold is the default environment that's used for new projects. 環境の使用方法の詳細については、Visual Studio 環境で Python 環境を作成および管理する方法に関する記事をご覧ください。For additional information about working with environments, see How to create and manage Python environments in Visual Studio environments.

    [Python Environments (Python 環境)] ウィンドウ

    注意

    [ソリューション エクスプローラー] ウィンドウを選択し、Ctrl + K、Ctrl + ` キーボード ショートカットを使用して [Python 環境] ウィンドウを開くこともできます。You can also open the Python Environments window by selecting the Solution Explorer window and using the Ctrl+K, Ctrl+` keyboard shortcut. ショートカットが機能せず、メニューに [Python 環境] ウィンドウが見つからない場合は、Python ワークロードをインストールしていない可能性があります。If the shortcut doesn't work and you can't find the Python Environments window in the menu, it's possible you haven't installed the Python workload. Python をインストールする方法については、Visual Studio に Python サポートをインストールする方法に関する記事をご覧ください。See How to install Python support in Visual Studio for guidance about how to install Python.

  2. 環境の [概要] タブからは、環境の対話型ウィンドウと、環境のインストール フォルダーおよびインタープリターにすばやくアクセスできます。The environment's Overview tab provides quick access to an Interactive window for that environment along with the environment's installation folder and interpreters. たとえば、 [対話型ウィンドウを開く] を選択すると、その特定の環境の対話型ウィンドウが Visual Studio で表示されます。For example, select Open interactive window and an Interactive window for that specific environment appears in Visual Studio.

  3. 次に、 [ファイル] > [新規] > [プロジェクト] で、 [Python アプリケーション] テンプレートを選択して新しいプロジェクトを作成します。Now, create a new project with File > New > Project, selecting the Python Application template. 表示されるコード ファイルに、次のコードを貼り付けます。これにより、前のチュートリアルの手順のように余弦波が作成されますが、今回はグラフィカルにプロットされるだけです。In the code file that appears, paste the following code, which creates a cosine wave like the previous tutorial steps, only this time plotted graphically. または、前に作成したプロジェクトを使用して、そのコードを置き換えることもできます。Alternatively, you can use the project you previously created and replace the code.

    from math import radians
    import numpy as np     # installed with matplotlib
    import matplotlib.pyplot as plt
    
    def main():
        x = np.arange(0, radians(1800), radians(12))
        plt.plot(x, np.cos(x), 'b')
        plt.show()
    
    main()
    
  4. Python プロジェクトを開いた状態で、ソリューション エクスプローラーから [Python 環境] ウィンドウを開くこともできます。それには、 [Python 環境] を右クリックし、 [すべての Python 環境の表示] を選択しますWith a Python project open, you can also open the Python Environments window from Solution Explorer by right-clicking Python Environments and selecting View All Python Environments

    環境

  5. エディター ウィンドウでは、インポート ステートメント numpymatplotlib にマウス ポインターを合わせると、それらが解決されていないことがわかります。Looking at the editor window, you'll notice that if you hover over the numpy and matplotlib import statements that they are not resolved. これは、そのパッケージが既定のグローバル環境にインストールされていないためです。That's because the packages have not been installed to the default global environment.

    未解決のパッケージ インポート

[Python 環境] ウィンドウを使用したパッケージのインストールInstall packages using the Python Environments window

  1. [Python 環境] ウィンドウから、新しい Python プロジェクト用の既定の環境を選択し、 [パッケージ] タブを選択します。そうすると、現在環境にインストールされているパッケージの一覧が表示されます。From the Python Environments window, select the default environment for new Python projects and choose the Packages tab. You will then see a list of packages that are currently installed in the environment.

    環境にインストールされているパッケージ

  2. matplotlib をインストールするには、検索フィールドにその名前を入力して、 [次のコマンドを実行する: pip install matplotlib] オプションを選択します。Install matplotlib by entering its name into the search field and then selecting the Run command: pip install matplotlib option. これによって、matplotlib とそのすべての依存パッケージ (この場合は numpy が含まれます) がインストールされます。This will install matplotlib, as well as any packages it depends on (in this case that includes numpy).

    環境に matplotlib をインストールする

  3. 昇格に同意するように求められた場合は、同意します。Consent to elevation if prompted to do so.

  4. パッケージがインストールされると、 [Python 環境] ウィンドウにそのパッケージが表示されます。After the package is installed, it appears in the Python Environments window. アンインストールするには、パッケージの右にある [X] 選択します。The X to the right of the package uninstalls it.

    環境での matplotlib のインストール完了

    注意

    環境の下に小さい進行状況バーが表示され、Visual Studio が新しくインストールしたパッケージに対して、IntelliSense データベースを構築していることが示される場合があります。A small progress bar might appear underneath the environment to indicate that Visual Studio is building its IntelliSense database for the newly-installed package. [IntelliSense] タブにはより詳細な情報も表示されます。The IntelliSense tab also shows more detailed information. そのデータベースが完了するまで、エディターではそのパッケージのオートコンプリートや構文チェックなどの IntelliSense 機能がアクティブにならないことに注意してください。Be aware that until that database is complete, IntelliSense features like auto-completion and syntax checking won't be active in the editor for that package.

    Visual Studio 2017 バージョン 15.6 以降では、高速で IntelliSense を操作する異なった方法が使用されています。その効果に関するメッセージが [IntelliSense] タブに表示されます。Visual Studio 2017 version 15.6 and later uses a different and faster method for working with IntelliSense, and displays a message to that effect on the IntelliSense tab.

プログラムを実行するRun the program

  1. これで matplotlib がインストールされたので、プログラムをデバッガーと共に実行 (F5 キー) するか、デバッガーなしで実行 (Ctrl + F5 キー) して、出力を確認します。Now that matplotlib is installed, run the program with (F5) or without the debugger (Ctrl+F5) to see the output:

    matplotlib の出力例

次のステップNext step

詳しい説明Go deeper