Visual Studio 2017 for Mac バージョン 7.4 Visual Studio 2017 for Mac version 7.4


開発者コミュニティ | システム要件 | 互換性 | 再頒布可能コード | Xamarin | ブログ | サービスDeveloper Community | System Requirements | Compatibility | Distributable Code | Xamarin | Blogs | Servicing


注意

英語以外のバージョンからこのページにアクセスしていて、最新の内容を見たい場合は、このリリース ノートの英語版ページをご覧ください。If you are accessing this page from a non-English language version, and want to see the most up-to-date content, please visit this Release Notes page in English.

ヒント

このページの下部で、ページの言語を切り替えることができます。You can switch the page language at the bottom of this page. テキスト カーソルが既に赤い波線の行にある場合は、左余白に表示されているClick the アイコンをクリックするか、言語を検索するか、使用できる言語の一覧から選択します。 icon, search for your language, or select from the list of available languages.


Visual Studio 2017 for Mac を使用して、Xamarin、.NET Core、および Unity を使用したゲームでモバイル、Web、クラウド用のアプリを構築します。Use Visual Studio 2017 for Mac to build apps for mobile, web, and the cloud with Xamarin and .NET Core, as well as games with Unity.

Visual Studio for Mac 2017 の現在のリリースをダウンロードするDownload the Current Release of Visual Studio for Mac 2017

Download Visual Studio 2017 for Mac

Visual Studio 2017 for Mac の詳細については、「Mac システム要件」 と「Mac の対象プラットフォームと互換性」 を参照してください。To learn more about Visual Studio 2017 for Mac, see Mac System Requirements and Mac Platform Targeting and Compatibility.

他の関連ダウンロードについては、ダウンロードのページを参照してください。To learn more about other related downloads, see the Downloads page.

フィードバックFeedback

皆様のご意見をお待ちしております。We’d love to hear from you! 問題については Visual Studio for Mac IDE の [問題の報告] オプションを使用して報告し、フィードバックは開発者コミュニティ ポータルで追跡することができます。You can report a problem via the Report a Problem option the Visual Studio for Mac IDE and track your feedback in the Developer Community portal. ご意見やご要望は、UserVoice からお寄せください。For suggestions, let us know through UserVoice.

リリース履歴Release History


2018 年 3 月 5 日 - Visual Studio 2017 for Mac 7.4 (7.4.0.1033)March 5, 2018 - Visual Studio 2017 for Mac 7.4 (7.4.0.1033)

Visual Studio for Mac 7.4 のリリースにあたり、報告件数が多かったメモリ リーク、パフォーマンスの問題、安定性の問題を重点的に時間をかけて修正しました。For the Visual Studio for Mac 7.4 release, we've taken time to focus on fixing some of the top memory leaks, performance problems, and stability issues that have been reported to us. また、このリリースには Android Oreo 8.1 開発のサポートや Xamarin 開発者向けのいくつかの生産性向上機能のサポートが含まれています。This release also brings support for Android Oreo 8.1 development and several productivity enhancements for Xamarin developers.

リリースの特長Release Highlights

  • macOS High Sierra が公式にサポートされます。macOS High Sierra is now officially supported.
  • Xcode 9.3 のサポート。Support for Xcode 9.3.
  • C# 7.1 がサポートされます (「what's new in C# 7.1」(C# 7.1 の新機能) を参照)。C# 7.1 is now supported (see what's new in C# 7.1).
  • Android 8.1 Oreo のサポート。Support for Android 8.1 Oreo.
  • Xamarin.iOS のワイヤレス展開およびデバッグ。Wireless deployment and debugging for Xamarin.iOS.
  • C# エディターにコア アーキテクチャの変更が加えられました。この結果、IntelliSense のパフォーマンス/信頼性と入力の応答性がいずれも向上しています。Core architectural changes were made to the C# editor; both IntelliSense performance/reliability and typing responsiveness are improved as a result.

このリリースで修正された問題Issues fixed in this release

リリースの詳細Release in Detail

  • IntelliSense 候補モードと完了モードを切り替えるために [編集] > [Switch to Suggestion Mode](候補モードに切り替え) メニューが追加されました。Added an Edit > Switch to Suggestion Mode menu, to toggle between IntelliSense suggestion mode and completion mode. 提案モードでは、IntelliSense オートコンプリート候補がユーザーが入力したテキストを上書きするのは、IntelliSense 候補リストから候補を手動で選択した場合のみです。In suggestion mode, IntelliSense auto-complete suggestions will not override the text you've written unless you manually choose them from the IntelliSense suggestion list. 完了モードに戻すには、[編集] > [Switch to Completion Mode](完了モードに切り替え) メニューを選択します。To switch back to Completion Mode you can choose the Edit | Switch to Completion Mode menu. Visual Studio (Mixed) または Visual Studio (Windows) キー バインド スキームを使用している場合は、既定のキーボード ショートカット Ctrl + Alt + Space が提供されます。A default keyboard shortcut of Ctrl+Alt+Space is provided if you're using Visual Studio (Mixed) or Visual Studio (Windows) key binding schemes.

  • [Navigate To](ナビゲート先) 検索ボックスを開くショートカット Cmd + Shift + P が追加されました。フィルター処理されるため、現在のコンテキストに基づいて使用可能なコマンドを検索できます。Added a Cmd+Shift+P shortcut that will open the Navigate To search box, filtered so you can search for available commands based on your current context.

Debug source files option
"(図 1) コマンドのフィルター処理"(Figure 1) Command Filtering
  • デバッガーのソースの参照。Debugger source lookup.

    • ソリューション オプションの [デバッグ ソース ファイル] タブのサポートが追加されました ("図 2")。Added support for the Debug Source Files tab in solution options (Figure 2). UI を簡潔にするため、このメニューは最初のフォルダーを追加した後で表示されます。To keep the UI clean, this menu appears only after you add the first folder.

      Debug source files option
      "(図 2)デバッグ ソース ファイルのオプション"(Figure 2) Debug source files option
    • メソッドのスタック フレームまたはステップに移動しようとしたときに、デバッガーがソース ファイルを見つけられない場合、新しく [ソースが見つかりません] メッセージ ("図 3") が表示されます。If you try to navigate to a stack frame or step into a method and the debugger doesn't find source files, a new Source Not Found document (Figure 3) is shown. このメッセージによって、ソース ファイルがある場合に見つける方法が示されます。This document helps to provide some options to locate source files if you have them. これが役立つのは、CI でコンパイルされたアセンブリをデバッグしているときに、ユーザーにソース ファイルと .pdb ファイルのアクセス権がある場合です。This is useful when debugging assemblies that were compiled on CI and user has access to source files and .pdb file.

      New 'source not found' dialog
      (図 3) 新しい "ソースが見つかりません" ダイアログ(Figure 3) New "source not found" dialog
  • ファイルを検出するファイル監視機能がプロジェクトに追加されました。File watcher to detect files added to the project.

    Visual Studio for Mac は、.NET Core プロジェクトに対して追加または削除されたファイルを検出し、変更内容に応じて動的に [ソリューション] ウィンドウを更新するようになりました。Visual Studio for Mac will now detect files added to or removed from a .NET Core project and update the Solution window with the changes dynamically. この機能強化は、開発者コミュニティで報告された EF 移行後に必要なアンロード/リロードの問題に対処するものです。This improvement addressed the unload/reload required after EF migrations issue reported in the Developer Community.

  • .userprefs に .vs ディレクトリを使用します。Use .vs directory for .userprefs

    • Windows 上の Visual Studio との互換性を高めるため、Visual Studio for Mac によって生成されるユーザー プリファレンス ファイルはソリューションのディレクトリに格納されなくなりました。現在は .vs/SolutionName/xs/UserPrefs.xml に格納されます。To improve compatibility with Visual Studio on Windows the user preferences file generated by Visual Studio for Mac are no longer stored in the solution directory but are now stored in .vs/SolutionName/xs/UserPrefs.xml.

XamarinXamarin

  • Visual Studio for Mac で "Xamarin Test Cloud へのアップロード" 機能 (単体テスト ツリーを右クリックして起動) はサポートされなくなりました。We no longer support the “Upload to Xamarin Test Cloud” function in Visual Studio for Mac (invoked by right-clicking the Unit test tree). 前進テストは Visual Studio App Center CLI で発行できます。Moving forwards tests can be submitted through the Visual Studio App Center CLI.

  • IDE のコンポーネントのサポートを削除しました。We have removed the support for components in IDE. プロジェクトを開いたとき、含まれるコンポーネントが既に参照されている場合は、エラーが表示されます。If you open a project that has components already referenced, you will be met with an error. このエラーを修正するには、.csproj ファイルを手動で編集し、<XamarinComponentReference/> タグのすべての情報を削除する必要があります。The fix this error, you must edit the .csproj file manually and remove all information in the <XamarinComponentReference/> tags. 詳しくは、「Components migration guide」(コンポーネント移行ガイド) をご覧ください。For more information see the Components migration guide.

iOSiOS

  • iOS または AppleTV デバイスのワイヤレス展開およびデバッグのサポートが追加されました。We've added support for wireless deployment and debugging for iOS or AppleTV devices. デバイスがネットワーク経由で接続し、展開に使用できるようになると、デバイスが USB 経由で接続されている場合と同じように、デバイス ターゲットの一覧に表示されます。When a device is connected via a network and ready to be used for deployment, it now shows up in the device target list, as if the device were connected through USB. ("図 4"):(Figure 4):

    Apple device connected over Wi-Fi selected in device list
    "(Figure 4) ネットワーク経由で接続された Apple デバイスがデバイス リストに表示される"(Figure 4) Apple device connected over a network is displayed in device list

    この機能について詳しくは、「Wireless Deployment」(ワイヤレス展開) ガイドをご覧ください。For more information on this feature, see the Wireless Deployment guide.

  • Visual Studio for Mac は、アプリを起動する前に展開デバイスのロック解除を求める ("図 5") ようになり、デバッグ セッションが中断されません。Visual Studio for Mac now asks to unlock the deployment device before launching the app (Figure 5) and does not interrupt the debugging session:

    Alert advising user to unlock iOS device
    "(図 5) iOS デバイスのロック解除をユーザーに勧めるアラート"(Figure 5) Alert advising user to unlock iOS device
  • Visual Studio for Mac では、CoreML モデルがプロジェクトに追加されると C# バインディングが自動生成されるようになりました。CoreML モデルを簡単にすぐ使用できます。Visual Studio for Mac now auto-generates C# bindings for CoreML models when they are added to a project allowing for quick and easy usage of CoreML models.

  • プロビジョニングの機能強化:Provisioning Improvements:

    • このリリースでは、fastlane インストール ワークフローが向上しています。This release introduces a better fastlane installation workflow. fastlane がインストールされていない場合、プロビジョニング ドキュメントを読んで fastlane をインストールすることを勧めるエラー ダイアログが表示される代わりに、IDE 内で操作する方法を提供しています。If fastlane is not installed, instead of showing an error dialog asking you to read the provisioning documentation and install fastlane, we provide a way to do it within the IDE.
    • インターネットの速度とコンピューターの性能によって異なりますが、インストールが 2 分以内に完了します。Depending on the internet speed and computer parameters the installation can take up to two minutes. このため、fastlane はバックグラウンドでダウンロードすることをお勧めします。For this reason, fastlane will be downloaded in the background for your convenience.
    • Info.plist エディターの自動プロビジョニング ウィジェットの多数の UI を改善しました。We made a number of UI improvements to the automatic provisioning widget in Info.plist editor. 新しいウィジェットでは、手動と自動のプロビジョニング モードがはっきり区別され、プロビジョニングの状態がユーザーに通知されます。The new widget draws a definite distinction between manual and automatic provisioning modes and communicates provisioning status to the user.

AndroidAndroid

Android 8.1 Oreo はGoogle で提供される最新バージョンの Android です。Android 8.1 Oreo is the latest version of Android available from Google. Android 8.1 Oreo では、Android Go、Neural Networks API、Autofill Framework の更新、SharedMemory API など、Xamarin.Android 開発者にとって興味深い多くの新機能が提供されます。Android 8.1 Oreo offers many new features of interest to Xamarin.Android developers such as Android Go, Neural Networks API, Autofill Framework updates, SharedMemory API, and many more. これらの API が Xamarin.Android アプリで使用できるのは、Xamarin.Android 8.2 以上を使用する場合です。These APIs are available to Xamarin.Android apps when you use Xamarin.Android 8.2 and later.

  • SDK Tools 26 をインストールしているユーザー向けに Xamarin Android Device Manager (プレビュー) の統合が追加されています。We've added integration for the Xamarin Android Device Manager (preview) for users with SDK Tools 26 installed. 詳しくは、ドキュメントをご覧ください。For more information, refer to the documentation.

  • Android エミュレーターが HAXM を使用していない場合に警告が生成されるようになりました。You'll now be warned if the Android emulator is not using HAXM.

ビジュアル デザイナーVisual Designers

iOS DesigneriOS Designer
  • モード キー バインドの制約:Constraints Mode Key Bindings:

    新しいキー バインドにより、新しい制約モード (15.5 で導入) で作業がしやすくなります。New key bindings make it easier to work with the new constraints mode (introduced in 15.5). 例:For example:

    • 制約モードの切り替え: ⌘ EToggle constraints mode: ⌘ E
    • 一時的に制約モードを有効化: ⌃ を押し続けるTemporarily enable constraints mode: Hold ⌃
    • 制約モードでは制約の更新、それ以外ではフレームの更新: ⇧ ⌘ RIn constraints mode, update constraints; else update frames: ⇧ ⌘ R
  • 特性のバリエーションを tvOS で有効化できる:Trait Variations can now be enabled for tvOS :

    特性のバリエーションを tvOS ストーリーボードと XIB で有効化できるようになりました。これによりライト スタイルとダーク スタイルによるバリエーションが可能になります。Trait variations can now be enabled for tvOS storyboards and XIBs, which enables variation by light style or dark style.

  • ツールボックスから大きいアイテムをドラッグするときに自動ズームアウト:Automatic Zoom Out when dragging large items from the Toolbox:

    ツールボックスから大きいアイテムをドラッグするとき、デザイン サーフェスが自動的にズームアウトするようになりました。The design surface now automatically zooms out when you drag a large item from the toolbox. これで、大きなアイテムを XIB またはストーリーボードに配置しやすくなります。This makes it easier to place large items on your XIB or storyboard.

  • ズーム インジケーターとセレクター:Zoom Indicator and Selector:

    現在のズーム レベルのパーセンテージを表示し、ポップアップ リストからズーム レベルを選択できるようにします。Indicates current zoom level percentage and enables selecting zoom levels from a pop up list.

Android DesignerAndroid Designer
  • Android リソースの解析と処理がこのリリースで大幅に改善され、パフォーマンスと精度が全面的に向上しています。Android resource parsing and processing has been vastly revamped in this release resulting in increased performance and accuracy across the board.
  • Android Oreo (API 26) レンダリング サポートが追加されました。Added Android Oreo (API 26) rendering support.
  • カスタム フォントや適応可能なアイコンなどの Oreo 機能がサポートされるようになりました。Oreo features like custom fonts and adaptive icons are now supported.
  • レンダリング速度が向上しています。Rendering speed improvements.
  • IntelliSense オートコンプリートの操作性が向上しています。Improved IntelliSense completion experience.

Xamarin.FormsXamarin.Forms

XAML の編集を改善するためにいくつかのバグを修正しました。We fixed a number of bugs to improve XAML editing:

  • [修正済み] 新しい属性を要素に追加するために Enter を押した場合の、vs/vsmac に対する XML/XAML エディターの一貫性のない動作。[FIXED] Inconsistent behavior in XML/XAML editor between vs/vsmac when hitting "ENTER" in to add a new attribute to an element.
  • [修正済み] オートコンプリートに多数の要素が含まれない: ResourceDictionary、x:Double、x:Key など。[FIXED] Many elements are missing from completion: ResourceDictionary, x:Double, x:Key etc.
  • [修正済み] 名前でピリオドを入力すると IntelliSense が作動しません。[FIXED] No IntelliSense after typing period in name.
  • [修正済み] IntelliSense の 1 つのプラットフォームがありません。[FIXED] One Platform is missing from IntelliSense.
  • [修正済み] Tab キーで空白が入力され、インデント キーでタブが入力されます。[FIXED] Tab key inserts spaces, indenter inserts tabs.
  • [修正済み] XAML IntelliSense の一覧で、要素のプロパティが名前の長さ順に表示されます。[FIXED] XAML IntelliSense lists element properties sorted by length of name.

Xamarin Workbooks および InspectorXamarin Workbooks and Installer

Xamarin Inspector を Xamarin Workbooks から完全に分割しました。We have fully split Xamarin Inspector from Xamarin Workbooks. Inspector 拡張機能を使用する際に Workbooks のインストールは必要なくなりました。The Inspector extension no longer requires a Workbooks installation to function.

すべての Xamarin 製品のリリース ノートAll Xamarin Product release notes


2018 年 3 月 26 日 - Visual Studio 2017 for Mac 7.4. 1 (7.4.1.48)March 26, 2018 - Visual Studio 2017 for Mac 7.4.1 (7.4.1.48)


2018 年 4 月 3 日 - Visual Studio 2017 for Mac 7.4.2 (7.4.2.12)April 3, 2018 - Visual Studio 2017 for Mac 7.4.2 (7.4.2.12)

このリリースでは Xcode 9.3 がサポートされます。また、次の問題が対処されます。This release includes support for Xcode 9.3 and addresses the following issues:


2018 年 4 月 18 日 - Visual Studio 2017 for Mac 7.4.3 (7.4.3.10)April 18, 2018 - Visual Studio 2017 for Mac 7.4.3 (7.4.3.10)

このリリースでは、次の問題が対処されます。This release addresses the following issues:


Visual Studio 2017 for Mac の既知の問題Visual Studio 2017 for Mac Known Issues


Visual Studio 2017 for Mac リリース ノート履歴Visual Studio 2017 for Mac Release Notes History

Visual Studio 2017 for Mac バージョン 7.3 リリース ノートVisual Studio 2017 for Mac version 7.3 Release Notes

Visual Studio 2017 for Mac バージョン 7.2 リリース ノートVisual Studio 2017 for Mac version 7.2 Release Notes

Visual Studio 2017 for Mac バージョン 7.1 リリース ノートVisual Studio 2017 for Mac version 7.1 Release Notes

Visual Studio 2017 for Mac バージョン 7.0 リリース ノートVisual Studio 2017 for Mac version 7.0 Release Notes


ページのトップへ
Top of Page