Visual Studio Icon Visual Studio 2019 Preview リリース ノートVisual Studio 2019 Preview Release Notes


| 開発者コミュニティ | システム要件 | 互換性 | 再配賦可能コード | ライセンス条項 | ブログ | 既知の問題 || Developer Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Known Issues |


重要

このリリースは、"Go Live" ではなく、実稼働コンピューターでの使用や実稼働コードの作成を目的としていません。This release is not "go-live" and not intended for use on production computers or for creating production code. Visual Studio 2019 のインストールと更新に関する手順については、Visual Studio 2019 の最新リリースへの更新に関するこのドキュメントをご覧ください。For instructions on installing and updating Visual Studio 2019, see this documentation on updating Visual Studio 2019 to the most recent release.


Visual Studio 2019 の新機能What's New in Visual Studio 2019

Visual Studio 2019 Preview のリリースVisual Studio 2019 Preview Releases

Visual Studio 2019 ブログVisual Studio 2019 Blog

Visual Studio 2019 ブログは、Visual Studio エンジニアリング チームからの製品の分析情報の公式な情報源です。The Visual Studio 2019 Blog is the official source of product insight from the Visual Studio Engineering Team. Visual Studio 2019 リリースの詳細については、次の投稿を参照してください。You can find in-depth information about the Visual Studio 2019 releases in the following posts:


Visual Studio 2019 Preview 1Visual Studio 2019 Preview 1

リリース日: 2018 年 12 月 4 日released December 04, 2018

Visual Studio 2019 Preview 1 の新機能の概要Summary of What's New in Visual Studio 2019 Preview 1

IDEIDE

  • 既定でインストールされる Visual Studio Live Share を使用して他のユーザーとの共同作業を行えます。Collaborate with others using Visual Studio Live Share, which is installed by default. C++、VB.NET、および Razor に対する追加の言語サポートにより、ゲストはソリューション ビューを確認し、ソース管理の差異を共有できます。Additional language support for C++, VB.NET, and Razor gives guests a solution view and sharing of source control diffs.
  • 新しいスタート画面を介して、最近作業していたコードを開いたり、最もよく使用するフロー (複製、開く、新しいプロジェクトなど) のいずれかから開始したりすることができます。Open code you recently worked on or start from one of the most commonly used flows like clone, open, or new project through the new start window.
  • 人気度によって並べ替えられたテンプレート一覧を使用して、強化された検索エクスペリエンスやフィルターを備えた新規プロジェクトを作成できます。Create new projects with an improved search experience and filters using the new list of templates sorted by popularity.
  • 新たに加えられた一連の、シェルでの視覚的な変更により、コード用の縦方向の空間が広くなり、最新のルック アンド フィールが提供されています。Have more vertical room for your code and a modernized look and feel through a set of new visual changes in the shell.
  • モニターごとの認識のサポートが強化されましたので、ご利用のディスプレイの構成やスケーリングに関係なく IDE をより鮮明に表示できます。View a sharper version of your IDE regardless of your display configuration and/or scaling, as we have improved support for per monitor awareness.
  • Visual Studio 内で強化された、メニュー、コマンド、オプション、およびインストール可能コンポーネントに対する検索機能を使用できます。Use an improved search capability in Visual Studio for menus, commands, options, and installable components.
  • ドキュメントインジケーターを使用することで、ご利用のコード ファイルの "正常性" をすばやく把握できます。Quickly understand your code file's 'health' with a document indicator. インジケーターからのワンクリックでのコードのクリーンアップによって実行および構成を行うことができます。Run and configure through a one-click code cleanup from the indicator.
  • [オプション] ダイアログ内の新しいプレビュー機能ページを使用してオプトインしたプレビュー機能を簡単に管理できます。Easily manage the preview features you are opted in to with a new Preview Features page in the Options dialog.
  • MSBuild および Visual Studio では既定で .NET Framework 4.7.2 が対象とされるようになりました。MSBuild and Visual Studio now target .NET Framework 4.7.2 by default.

パフォーマンスPerformance

デバッグ全般General Debugging

ソース管理とチーム エクスプローラーSource Control and Team Explorer

  • チーム エクスプローラーで Git 一時退避をサポートする Git ツールを使用して別のタスクで作業ができるように、変更内容を一時的に格納します。Temporarily store changes so you can work on another task by using Team explorer's Git tools support for Git stash.
  • Visual Studio Market Place で使用可能なオプションの拡張機能 (Visual Studio 用のプル要求) をチェックアウトします。この拡張機能では、プル要求のレビューが Visual Studio に統合されます。Check out the optional extension available on the Visual Studio Market Place, Pull Requests for Visual Studio, that integrates Pull Request reviews into Visual Studio.
  • ユーザー固有の作業項目ビュー、作業項目に基づくブランチの作成、#mentions を使用した作業項目の検索、インライン編集などの開発者ワークフローに重点を置いた新しい Azure DevOps 作業項目エクスペリエンスを使用しています。Use the new Azure DevOps work item experience that focuses on developer workflows, including user-specific work item views, creating a branch from a work item, searching for work items with #mentions, and inline editing.

プログラミング言語Programming Languages

  • Visual Studio IntelliCode (コードに対して AI 支援の推奨事項が表示されるオプションの拡張機能) を使用することにより、C++ および XAML コードを記述する際に時間が節約されます。Save time when writing C++ and XAML code by using Visual Studio IntelliCode, an optional extension that gives AI-assisted recommendations for your code.
  • 組み込まれている F# 言語およびツールのオープン ソース共同作成について学習できます。Learn about the F# language and tools open source contributions that have been incorporated. これらの変更によって F# 機能セットが安定化されています。These changes have stabilized the existing F# feature set.
  • Python の [環境を追加] ダイアログを使用して、Python の仮想環境および conda 環境を容易に追加できます。Easily add Python virtual and conda environments using the Python Add Environment dialog.

Web テクノロジWeb Technologies

  • .NET Core 3.0 プロジェクトを操作するために追加されたサポートを活用します。Take advantage of the added support for working with .NET Core 3.0 projects.
  • ASP.NET の CPU プロファイルをチェックアウトします。Check out CPU profiling of ASP.NET.
  • Virtual Machines、Virtual Machine Scale Sets、および Azure Kubernetes Service 上で実行されている .NET Web アプリに対してスナップショット デバッガーを使用します。Use snapshot debugger for .NET web apps running on Virtual Machines, Virtual Machine Scale Sets, and Azure Kubernetes Service.

Xamarin を使用したモバイル開発Mobile Development with Xamarin

ユニバーサル Windows プラットフォーム (UWP)Universal Windows Platform (UWP)

  • XAML による IntelliCode 拡張機能を使用します。追加したサポートのヘルプも備えています。Use the IntelliCode extension with XAML with the help of our added support.

Visual Studio 2019 Preview 1 で修正された主要な問題Top Issues Fixed in Visual Studio 2019 Preview 1

ユーザーから報告され、Visual Studio 2019 バージョン 16.0 Preview 1 で修正された特定の問題をお探しの場合は、開発者コミュニティを参照してください。If you are looking for a specific customer-reported issue that has been fixed in Visual Studio 2019 version 16.0 Preview 1, visit Developer Community.


Visual Studio 2019 Preview 1 の新機能の詳細Details of What's New in Visual Studio 2019 Preview 1

スタート ウィンドウStart window

新しいスタート画面では、Visual Studio の起動時にご自分のコードにすばやくアクセスするのに役立つ効率化されたラウンチ エクスペリエンスが提供されています。The new start window provides a streamlined launch experience to help you quickly get to your code upon starting up Visual Studio.

  • 最近使ったプロジェクトとフォルダーを表示し、1 回のクリックでそれらを開くことができます。View your recent projects and folders, and open them with a single click. また、コンテキスト メニューからのリストに項目をピン留めしたり、そのリストから項目を削除したりできます。You can also pin and remove items from the list from the context menu.
  • 公開されている git URL を使用してコードを複製またはチェックアウトします。これにより、IDE でフォルダーも自動的に開かれます。Clone or checkout code by using any publicly available git URL, which will also automatically open the folder in the IDE.
  • ご利用のローカル ディスクまたはネットワーク共有内でプロジェクト、ソリューション、またはコードが含まれている任意のフォルダーを参照し、IDE でそれらを開くことができます。Browse your local disk or network share for projects, solutions, or any folders containing code, and open them in the IDE.
  • 作業を開始するときに役立つコードのスキャフォールディングを提供する新しいプロジェクトまたはソリューションを作成できます。Create a new project or solution that provides you with code scaffolding to help you get started.
  • ダウンロードしたワークロード用の最も一般的なテンプレートの一覧を検索してテンプレートを見つけたり、使用可能な言語、プラットフォーム、およびプロジェクトの種類をフィルター処理したりできます。Find templates by searching through a list of most popular templates for the workloads you've downloaded or filter through available languages, platforms, and project types. 2 ページのウィザードにより、一度に 1 つの意思決定に集中することができます。A two-page wizard allows you to concentrate on one decision at a time.
Start window
新しいスタート画面のエクスペリエンスNew Start Window Experience

シェルとプラットフォームShell and platform

  • 改善された新しい製品アイコンを使用して、開かれ使用されている Visual Studio のバージョンをすばやく見つけることができます。Quickly spot which version of Visual Studio you're opening and using via the new, improved product icon. この新しいアイコンは、さまざまな背景に対してもよりわかりやすくなっています。The new icon is also more visible against a variety of backgrounds.
  • 青のテーマの更新により実現された Visual Studio の最新のルック アンド フィールを体験できます。Microsoft のユーザー補助の標準を引き続き満たしながら、より明確なユーザー インターフェイスが提供されています。Experience a modernized look and feel of Visual Studio with our refreshed blue theme that gives you a cleaner user interface while still meeting our accessibility standards.
  • 簡潔さを目標とし、IDE 内の垂直方向の領域を再利用するという変更により、コードがより見やすくなります。See more of your code, through our changes that target compactness and reclaim vertical space in the IDE. 既存の機能を維持しながら、タイトル バーとメニュー バーを結合しました。We have combined the title bar and the menu bar while also preserving existing functionality.
  • 試験段階の新しい設定を介して Visual Studio をモニターごとの認識アプリケーションとしてを使用できます。Use Visual Studio as a Per-Monitor Awareness application through a new, experimental setting. この設定が有効になっている場合、ご利用のディスプレイの構成またはスケーリングに関係なく、シェルやエディターなどの Visual Studio のパーツをより鮮明にレンダリングすることができます。When on, this setting helps parts of Visual Studio, such as the shell and the editor, render more sharply regardless of your display configuration and/or scaling.
  • メニュー、コマンド、オプション、およびインストール可能なコンポーネントにわたる強化された検索エクスペリエンスを体験できます。Experience an enhanced search experience across menus, commands, options, and installable components. 新しい検索では、結果が動的に表示され、スペル ミスに対応し、検索結果に関連情報 (キーボード ショートカットなど) が提供されるようになりました。Our new search now displays results dynamically, accommodates spelling errors, and provides relevant information (such as keyboard shortcuts) inside the search results.
Visual Studio Search with results
Visual Studio で強化された検索Enhanced Search in Visual Studio
  • ドキュメントの正常性インジケーター機能によって、現在開いているファイルに関連付けられた正常性に関する情報を確認できます。View health information associated with your currently open file through the Document Health Indicator feature.
  • ドキュメントの正常性インジケーターからは、次のような情報が提供されます。The Document Health Indicator will provide you with information such as:
    • ポイント時のエラー、警告、および推奨事項の概要。A summary of errors, warnings, and suggestions on hover.
    • ファイル内でのクリック操作による次の問題への移動、または Shift キーを押しながらクリックすることによる次の問題への移動。Navigation to the next or previous issue in the file on Click or Shift + Click, respectively.
    • 右クリック メニューからコードのクリーンアップを構成または実行する機能。The ability to configure or run Code Cleanup from the right-click menu.
Document Health Indicator
ドキュメントの正常性インジケーターDocument Health Indicator
  • C# の開発者は、コードのクリーンアップを使用して、コーディングの最も一般的な提案事項の一部を迅速にクリーンアップすることができます。If you are a C# developer, you can quickly clean up some of the most common coding suggestions using Code Cleanup.
  • エディターの右下隅にあるドキュメントの正常性インジケーターを右クリックして、コードのクリーンアップを実行または構成します。Run or Configure Code Cleanup by right-clicking the Document Health Indicator in the bottom-right corner of the editor.
Document Health Indicator with Code Cleanup menu
ドキュメントの正常性インジケーター メニューDocument Health Indicator Menu
  • コードのクリーンアップを構成することで、実行させたい修正機能のセットを選択できます。Select the set of fixers you'd like to have run by configuring Code Cleanup.
Code Cleanup configuration dialog
コード クリーンアップの構成Configure Code Cleanup
  • クリップボード リングを展開するコンテキスト メニューを介して、ご利用のクリップボード履歴の内容を確認できます (Ctrl + Shift + V)See the contents of your clipboard history via a context menu that extends the Clipboard Ring (Ctrl + Shift + V).
Clipboard Ring context menu
クリップボード リングのコンテキスト メニューClipboard Ring Context Menu
  • Visual Studio 2019 以降にデータ ヒントを実装する方法としては、現在 IAsyncQuickInfoSourceProvider を推奨しています。The recommended way to implement data tooltips in Visual Studio 2019 and later is now IAsyncQuickInfoSourceProvider. レガシ エディター クイック ヒント API である IVsTextTipData および TextTipData は、Visual Studio 2019 Preview 1 では非推奨となっています。Legacy Editor Quick Info APIs IVsTextTipData and TextTipData are deprecated in Visual Studio 2019 Preview 1.
  • エディター スマート タグ (Microsoft.VisualStudio.Language.Intellisense 名前空間内の ISmartTag * インターフェイス ファミリ) は非推奨とされ、代わりに LightBulb API が使用されるようになりました。このエディター スマート タグは、Visual Studio 2019 Preview 1 以降ではサポートされなくなりました。The Editor Smart Tags (ISmartTag* family of interfaces in Microsoft.VisualStudio.Language.Intellisense namespace) have been deprecated in favor of the LightBulb API and are no longer supported starting with Visual Studio 2019 Preview 1.
  • ソリューション オプションである [ビルド構成の詳細を表示][常にソリューションを表示]、および [新しいプロジェクトを作成時に保存する] は、使用率が低いことが原因で削除されました。The solution options Show advanced build configurations, Always show solution, and Save new projects when created have been removed due to low usage. これらの値は、既定値の True に設定されています。These values have been set to their default value of True.
  • [ツール] > [オプション] > [環境] > [プレビュー機能] の順に選択すると表示される新しいプレビュー機能ページを使用して、特定のプレビュー機能に対するオプトインまたはオプトアウトを行うことができます。Opt in or out of certain preview features using the new Preview Features page found in Tools > Options > Environment > Preview Features.

機能拡張Extensibility

  • V1 vsixmanifest の拡張機能の形式でビルドされた拡張機能を Visual Studio 2019 にインストールできなくなります。You will no longer be able to install extensions built with the V1 vsixmanifest extension format in Visual Studio 2019. V1 は Visual Studio 2010 で導入されましたが、Visual Studio において信頼性の問題が発生する可能性があったために、Visual Studio 2017 で非推奨とされました。V1 was introduced in Visual Studio 2010 and was deprecated in Visual Studio 2017 because it could cause reliability issues with Visual Studio. Visual Studio 2019 では、V1 のサポートは完全に削除されています。In Visual Studio 2019, the support for V1 has been completely removed. Visual Studio 2019 を対象とする拡張機能は、V2 または V3 の vsixmanifest 形式で再ビルドする必要があります。Extensions targeting Visual Studio 2019 should be rebuilt V2 or V3 of the vsixmanifest format.
  • これで、拡張機能が自動で同期的に読み込まれると、通知されるようになります。You will now be notified when an extension is synchronously auto-loaded. 拡張機能は、このリリースでは通常どおり読み込まれて動作しますが、次の Visual Studio 2019 更新プログラムでは機能しないおそれがあるので注意してください。Note, the extension will load and work as normal in this release, but is at risk of not functioning in the next Visual Studio 2019 update. 詳細については、拡張機能の自動ロード動作を更新することによる重要なシナリオの反応性の改善するに関するブログ記事を参照してください。More details can be found on our blog post about improving the responsiveness of critical scenarios by updating auto load behavior for extensions.

パフォーマンスPerformance

  • ソリューションの読み込み完了時のアラートだけでなく、タスク ステータス センターにソリューション読み込みの進行状況も表示されるようになりました。You can now see your solution load progress in the Task Status Center, as well as alerts when your solution loads finish.
  • ソリューション フィルター ファイルを使用して、開いているソリューションに読み込むプロジェクトを選択します。Choose which projects to load on solution open with Solution Filter Files.
    • ソリューション フィルター ファイルを作成するには、自動的に開かれないようにしたいプロジェクトをアンロードし、ソリューションを右クリックして、[ソリューション フィルターとして保存] を選択します。Create a Solution Filter File by unloading projects you don't want opened automatically, right-clicking the solution, and selecting Save As Solution Filter. 次に、フィルター ファイルを使用して、その後の使用のためにソリューションを開くことができます。You can then use the filter file to open the solution for subsequent uses.
  • フォルダーを開くシナリオで Ctrl + T キーを押すと、強化されたビルド アセット検出とファイル検索を体験できます。Experience improved build asset discovery and file search when you Ctrl+T in Open Folder scenarios.
  • 入力時のパフォーマンスに対する補助コンポーネントの影響が Visual Studio エディターによって制限されるようになったことよるパフォーマンス向上に注目してください。Notice performance improvements now that the Visual Studio editor will limit the impact of auxiliary components on typing performance. 特に、入力の際には不要な操作である長時間実行は自動的にキャンセルされます。Particularly, it will auto-cancel any long-running, nonessential operations when typing.
  • Visual Studio 補助コンポーネントの制限動作を構成するには、[ツール] > [オプション] > [テキスト エディター] > [詳細設定] の順に選択します。You can configure the Visual Studio auxiliary component limitation behavior via Tools > Options > Text Editor > Advanced:
Visual Studio Typing Latency Options
Visual Studio の入力待機時間オプション Visual Studio Typing Latency Options
  • ソリューション エクスプローラーのツール ウィンドウで、前のセッションからのプロジェクト階層状態の復元を無効にできるようになりました。You can now disable the restoration of the project hierarchy state from the previous session in the Solution Explorer tool window. ソリューションを開くときに前のセッションからプロジェクト階層を復元するとソリューションの読み込みが遅れる可能性があるために、この変更を実装しました。We implemented this change because restoring the project hierarchy from previous session at solution open can delay solution load.
    • このオプションの切り替えは、[ツール] > [オプション] > [プロジェクトおよびソリューション] > [全般] で行います。Toggle this option in Tools > Options > Projects and Solutions > General.
  • 前のセッションからのツール ウィンドウの状態を復元することを無効にし、代わりに起動時に常にソリューション エクスプローラーとチーム エクスプローラーを読み込むことができるようになりました。You can now disable the restoration of the tool window's state from the previous session and instead always load Solution Explorer and Team Explorer at startup. 前のセッションからのツール ウィンドウを復元すると起動時のソリューション読み込みに遅延が生じる可能性があるために、この変更が実装されました。This change was implemented because restoring tool windows from previous sessions can delay solution loads at startup.
    • このオプションは、[ツール] > [オプション] > [環境] > [スタートアップ] で切り替えます。Toggle this option in Tools > Options > Environment > Startup.

デバッグ全般General Debugging

  • [ウォッチ]、[自動変数]、[ローカル] の各ウィンドウに統合した新しい検索機能を使用すると、キーワードによって強調表示、検索、移動を行うことができます。Highlight, find, and navigate with keywords using our new search feature that we integrated into the Watch, Autos, and Locals windows.
Searching for keywords in Watch
[ウォッチ] ウィンドウでの検索Searching in the Watch Window
  • リストされた項目にコンマを追加することで、[ウォッチ]、[自動変数]、および [ローカル] の各ウィンドウ内のデータを書式設定する指定子およびオプションのドロップダウンが表示されます。View a dropdown of specifiers and options to format data in the Watch, Autos, and Locals windows by appending a comma to a listed item.
Format Specifier Dropdown List in Watch
[ウォッチ] ウィンドウでの書式指定子のドロップダウン リストFormat Specifier Dropdown in Watch Window
  • .NET Core 用のカスタムおよび DataSet ビジュアライザーのサポートを使用できるようになりました。You can now use custom and DataSet visualizer support for .NET Core.
  • Windows 上で実行される C++ アプリケーションの場合、PDB は別個の 64 ビット プロセスで読み込まれるようになりました。For C++ applications running on Windows, PDB now load in a separate 64-bit process. この変更では、モジュールと PDB が多数含まれているアプリケーションをデバッグするときにメモリ不足が原因で発生するさまざまなクラッシュに対処しています。This change addresses a range of crashes caused by the debugger running out of memory when debugging applications that contain a large number of modules and PDBs.

ソース管理Source Control

  • チーム エクスプローラーの Git ツールで Git 一時退避がサポートされるようになったので、変更内容を一時的に格納して別のタスクで作業ができるようにします。Temporarily store changes so you can work on another task now that Team Explorer's Git tools support Git stash.
  • Visual Studio 2019 内の新しいプル要求エクスペリエンスを使用すると、IDE を離れなくても、Azure Repos からプル要求を確認、実行、さらにデバッグすることができます。Review, run, and even debug pull requests from Azure Repos without leaving the IDE using our brand-new pull request experience in Visual Studio 2019. 作業を開始するには、Visual Studio 用のプル要求拡張機能を Visual Studio Marketplace からダウンロードします。To get started, you can download the Pull Requests for Visual Studio extension from the Visual Studio Marketplace.
New Pull Request Experience
新しいプル要求エクスペリエンスNew Pull Request Experience

MSBuildMSBuild

  • MSBuild ツールセットのバージョンは、15.0 から Current に変更されました。The MSBuild toolset version has been changed from 15.0 to Current. MSBuild.exe は、現在 %VSINSTALLDIR%\MSBuild\Current\Bin\MSBuild.exe にあります。MSBuild.exe is now in %VSINSTALLDIR%\MSBuild\Current\Bin\MSBuild.exe.
  • MSBuild (および Visual Studio) では、.NET Framework 4.7.2 が対象とされるようになりました。MSBuild (and Visual Studio) now targets .NET Framework 4.7.2. MSBuild API の新しい機能を使用したい場合は、ご利用のアセンブリもアップグレードする必要があります。ただし、既存のコードは引き続き機能します。If you wish to use new MSBuild API features, your assembly must also upgrade, but existing code will continue to work.

C++C++

  • Visual Studio Live Share で C++ がサポートされるようになったことから、リアルタイムでの共同作業が可能です。Collaborate in real time now that Visual Studio Live Share supports C++.
  • オプションの拡張機能である IntelliCode を使用して時間を節約できます。この拡張機能では、高度なトレーニングとご利用のコード コンテキストを使用して、入力候補一覧の上部に使用頻度が高いものが配置されます。Save time by by using IntelliCode, an optional extension that uses its extensive training and your code context to put what you're most likely to use at the top of your completion list. C++ の場合、STL のような一般的なライブラリを使用しているときには、IntelliCode からほとんどのヘルプが提供されます。For C++, IntelliCode offers the most help when you are using popular libraries like STL.
  • 更新した [新しいプロジェクト] ダイアログ ボックスに合わせて、プロジェクト テンプレートの名前と説明をいくつか変更しました。We have modified several project template names and descriptions to fit with the updated New Project dialog.
  • 実験段階の Clang/C2 コンポーネントを削除しました。We have removed the Clang/C2 experimental component. /permissive- または /std:c++17 に完全に準拠した C++ 用の MSVC ツールセットを使用するか、Windows 用の Clang/LLVM ツールチェーンを使用します。Use the MSVC toolset for full C++ standards conformance with /permissive- and/or /std:c++17, or the Clang/LLVM toolchain for Windows. 詳細については、 Visual C++ チーム ブログ に関するページを参照してください。See the Visual C++ Team Blog for more details.
  • C++ コンパイラ/Gm スイッチは非推奨になりました。We have deprecated the C++ Compiler /Gm switch. ご自分のビルド スクリプト内の /Gm スイッチが明示的に定義されている場合は、それを無効にすることを検討してください。Consider disabling the /Gm switch in your build scripts if it's explicitly defined. あるいは、"警告をエラーとして扱う" (/WX) を使用しているとき、/Gm の非推奨化に関する警告はエラーとして扱われないので無視してもかまいません。Alternatively, you can also safely ignore the deprecation warning for /Gm as it will not be treated as error when using "Treat warnings as errors" (/WX).
  • C++ Android エクスペリエンスは、既定では Android SDK 25 および Android NDK 16b となりました。The C++ Android experience now defaults to Android SDK 25 and Android NDK 16b.

F# および F# ツールF# and F# tools

F# の場合は、Visual Studio 2019 の機能とインフラストラクチャを使用して、オープン ソース共同作成の組み込みと既存の F# 機能セットの安定化に重点を置きました。For F#, we focused on incorporating open source contributions and stabilizing the existing F# feature set with Visual Studio 2019 features and infrastructure.

  • 型プロバイダーを使用して入力候補一覧内に指定された型を大量に作成するときのメモリ使用量を改善しました (#5599)。We improved memory usage when using Type Providers to generate very large amounts of provided types in a completion list (#5599).
  • 実行する構造体および構造体レコード上のメソッドと、クラスおよびクラスに基づくレコード上のメソッドを最適化しました (#3057)。We optimized methods on structs and struct records to perform as well as methods on classes and class-based records (#3057).
  • F# コードで結合されたブール ロジックに対して出力される IL を最適化しました (#635)。We optimized the emitted IL for combined boolean logic in F# code (#635).
  • ユーザー定義の属性が Attribute クラスから継承されていない場合、警告が届くようになりました。When a user-defined attribute does not inherit from the Attribute class, you will now receive a warning.
  • プロジェクト ファイル内の AssemblyInformationVersionAttribute 値で、SourceLink などのシナリオをサポートする任意の値がサポートされるようになりました (#4822)。The AssemblyInformationVersionAttribute value in a project file now supports arbitrary values to support scenarios such as SourceLink (#4822).
  • アクティブ パターンに構文上の誤りがある場合に内部コンパイラ エラーが発生するというバグが Steffen Forkmann によって修正されました (#5745)。A bug where illegal syntax with Active Patterns would cause an internal compiler error has been fixed by Steffen Forkmann (#5745).
  • 唯一の違いがジェネリック パラメーターである型と一致させるために、再帰的なモジュール内のモジュールに Module サフィックスが誤って追加されるというバグが BooksBaum によって修正されました (#5794)。A bug where the Module suffix was erroneously added to a module in a recursive module to match a type where the only difference is a generic parameter was fixed by BooksBaum (#5794).
  • 型パラメーターが型名の横にないときのエラー メッセージに対する改善内容が Alan Ball によって改善されました (#4183)。An improvement to the error message when type parameters are not adjacent to a type name has been improved by Alan Ball (#4183).
  • Steffen ForkmannRobert Jeppesen によって、パフォーマンスに関するさまざまな改善が加えられました。Various performance improvements have been added by Steffen Forkmann and Robert Jeppesen.
  • Teo Tsirpanis によって、数値リテラルが無効な場合に生じるエラー メッセージ内に uint16 リテラル サフィックスが正しくリストされました (#5712)。The uint16 literal suffix is listed correctly in the error messages for invalid numeric literals, by Teo Tsirpanis (#5712).
  • 計算式に関するエラー メッセージでは、メッセージ内に async と記載されなくなりました。代わりに "計算式" と記載されます。これは、John Wostenberg によって行われました (#5343)。Error messages for computation expressions no longer state async in the message and instead refer to "computation expression(s)", by John Wostenberg (#5343).
  • F# インタラクティブ内での .dll の参照が誤っているときに返されるエラーメッセージが Bartoz Sypytkowski によって修正されました (#5416)。An error message when incorrectly referencing .dlls in F# interactive was fixed by Bartoz Sypytkowski (#5416).
  • "スマート" インデントがオンの場合に F# コードをエディターに貼り付けると、それが、現在のカーソル位置に基づいて適切なスコープに一致するようにフォーマットされるようになります。これは Saul Rennison によって実装されました (#4702)。With "Smart" indentation on, pasting F# code into the editor will now format it to match an appropriate scope based on the current cursor position, implemented by Saul Rennison (#4702).
  • open ステートメント コードの追加に対する修正プログラムにより、既定で、open ステートメントがファイルの上部に追加されるようになります。The Add open statement code fix will now default to adding the open statement at the top of the file.
  • 開かれていない名前空間からのシンボルが表示されないように、IntelliSense を変更しました。We changed IntelliSense so that it will no longer show symbols from unopened namespaces.
  • ユーザー コード内の match! により、後続のスコープに対する構造体ガイドラインとコードのアウトライン表示ノードが無効にされるというバグが修正されました (#5456)。We fixed a bug where match! in user code invalidated structure guidelines and code outlining nodes for subsequent scopes (#5456).
  • エディターでは byref 値、outref 値、および ref 値がレコード フィールドとして正しく色付けされるようになり、色付けの値は変更可能です (#5579)。The editor will now correctly color byref, outref, and ref values as record fields with the mutable value colorization (#5579).
  • 名前の変更リファクタリングにおいてシンボル名に含まれる ' 文字が認識されないというバグを修正しました (#5604)。We fixed a bug where the rename refactoring did not recognize the ' character in symbol names (#5604).

PythonPython

お客様からのフィードバックに基づき、Visual Studio 2019 では Python 環境を管理するためのエクスペリエンスが一新されています。Based on customer feedback, Visual Studio 2019 includes an overhauled experience for managing Python environments:

  • 環境を追加するための新しいダイアログを追加しました。これにより、仮想環境および conda 環境を作成する操作と、それらをご利用のプロジェクトに追加する操作が簡単になります。We added a new Add environment dialog that simplifies the experience of creating and adding virtual environments and conda environments in your project.
  • Visual Studio インストールのサイズを縮小し、アップグレード中のエラーを回避するために、Visual Studio インストーラーでは Anaconda の不要なバージョンがインストールされなくなりました。The Visual Studio installer no longer installs full versions of Anaconda to reduce the size of Visual Studio installs and avoid errors during upgrades.
    • このため、Anaconda または miniconda を手動でインストールし、[環境を追加] ダイアログ ボックスを使用してご利用のプロジェクトに Adaconda 環境を追加することをお勧めします。Instead, we recommend you install Anaconda or miniconda manually and add Adaconda environments to your project using the Add environment dialog.
  • requirements.txt (仮想環境) または environment.yml (conda 環境) がご利用のプロジェクトの root に存在する場合は、環境を追加するように求めるメッセージが自動的に表示されるようになります。You will now be automatically prompted to add an environment if a requirements.txt (virtual environment) or environment.yml (conda environment) is present at the root of your project.

JavaScript/TypeScriptJavaScript/TypeScript

レガシ JavaScript 言語サービスは、利用できなくなりました。The legacy JavaScript language service is no longer available. これまで、ユーザーはレガシ JavaScript 言語サービスを復元するオプションを使用できました。Previously, users had the option of restoring the legacy JavaScript language service. 今度、ユーザーは新しい JavaScript 言語サービスをすぐに利用できるようになります。Users will now have the new JavaScript language service out-of-the-box. 新しい言語サービスは、静的分析によって強化された TypeScript 言語サービスをベースにしています。The new language service is based on the TypeScript language service, which is powered by static analysis. これによりツールの機能が向上するため、JavaScript コードは型定義に基づく高度な IntelliSense の恩恵を受けられるようになります。This enables better tooling, so your JavaScript code can benefit from richer IntelliSense based on type definitions. 新しいサービスは、レガシ サービスと比べて簡易で、消費するメモリが少ないため、ユーザーは自分のコード スケールに応じて優れたパフォーマンスを得ることができます。The new service is lightweight and consumes less memory than the legacy service, providing users with better performance as their code scales.

.NET ツールと ASP.NET ツール.NET and ASP.NET Tools

  • .NET Core 3.0 を対象とする ASP.NET、Console、および Class Library プロジェクトを作成します (.NET Core 3.0 向けの Windows フォーム プロジェクトまたは WPF プロジェクトは、"dotnet new" コマンドを使用して作成することが必要になります)。Create ASP.NET, Console, and Class Library projects targeting .NET Core 3.0 (Windows Forms or WPF projects for .NET Core 3.0 will need to be created using the "dotnet new" command).
    • .NET Core 3.0 SDK をダウンロードし、インストールすることで、.NET Core 3.0 を対象とするプロジェクトをビルドし、デバッグします。Build and debug projects targeting .NET Core 3.0 by downloading and installing the .NET Core 3.0 SDK.
  • .NET Core プロジェクトと追加された互換性に対してコード メトリックを使用できます。Use code metrics with .NET Core projects with our added compatibility.
  • エディター設定を Editorconfig ファイルにエクスポートできます。そのためには、[ツール] > [オプション] > [テキスト エディター] > [C#] > [コード スタイル] の順に選択し、"設定から .editorconfig ファイルを作成" ボタンを使用します。Export editor settings to an Editorconfig file through Tools > Options > Text Editor > C# > Code Style with the button "Generate .editorconfig file from settings".
  • C# および Visual Basic の新しいRegexパーサー サポートを使用できます。Use C# and Visual Basic's new Regex parser support. 正規表現が認識されるようになりました。正規表現に関する言語機能が有効にされます。Regular expressions are now recognized, and language features are enabled on them. Regex 文字列が認識されるのは、Regex コンストラクターに文字列が渡されたとき、または文字列の直前に、文字列 language=regex を含むコメントが付いているときです。Regex strings are either recognized when a string is passed to the Regex constructor or when a string is immediately preceded with a comment containing the string language=regex. このリリースに含まれる言語機能としては、分類、かっこの一致、参照の強調表示、および診断があります。The language features included in this release are classification, brace matching, highlight references, and diagnostics.
Regular expressions now have parser support
正規表現パーサーのサポートRegular Expression Parser Support
  • 未使用のプライベート メンバーに関するデッド コード分析とオプションのコード修正によって、未使用のメンバーの宣言を削除できるようになりました。You can now use dead code analysis for unused private members with an optional code fix to remove unused member declaration.
  • アクセサーに対する参照の検索機能からは、そのアクセサーに関する結果が返されるのみとなりました。The Find References feature on an accessor now only returns results for that accessor.
  • deconstruct メソッドを作成するためのコード修正を加えました。We have added a code fix for generating a deconstruct method.
  • ファイルにコードを貼り付けるときに、"using" ステートメントを追加できます。"Using" statements can be added when code is pasted into a file. 不足している関連のインポートを追加するように求める認識済みのコードを貼り付けると、コード修正が表示されます。A code fix appears after pasting recognized code that prompts you to add relevant missing imports.
  • "Ctrl +" または "Alt + Enter" を使用して利用できるリファクタリングおリファクタリングよびクイック アクションが増えていますThere are now more refactorings and quick actions available by using "Ctrl + ." or "Alt + Enter":
    • "await" は暗黙的に指定されているが省略される場合。コンパイラの警告が表示されるようになりました。For cases where "await" is implied but omitted, there is now a compiler warning.
    • ローカル関数をメソッドに変換する場合。For converting a local function to a method.
    • タプルを名前付き構造体に変換する場合。For converting a tuple to a named-struct.
    • 匿名型をクラスに変換する場合。For converting an anonymous type to a class.
    • 匿名型をタプルに変換する場合。For converting an anonymous type to a tuple.
    • LINQ クエリまたは LINQ メソッドへの foreach ループの場合。For a foreach loop to LINQ query or to LINQ method.
  • これで、Azure Kubernetes サービスで実行される ASP .NET Core アプリケーションのサポートを追加できました。You now have added support for ASP .NET Core applications running in an Azure Kubernetes Service. 作業を開始するには、GitHub にあるこの docker 例を参照してください。To get started, see this docker example over on GitHub.
  • パフォーマンス プロファイラーの CPU 使用率ツールで ASP.NET がサポートされるようになりました。ASP.NET is now supported in the CPU Usage tool of the Performance Profiler.
CPU Usage Tool in Performance Profiler
パフォーマンス プロファイラーの CPU 使用率ツールCPU Usage Tool in Performance Profiler
  • すべての参照の検索 (Shift + F12) と CodeLens を使用して、.NET Core プロジェクト内の Razor (.cshtml) ファイルからの結果を表示できるようになりました。You can now use Find All References (Shift-F12) and CodeLens to show results from Razor (.cshtml) files in .NET Core projects. これで、関連する Razor ファイル内で識別されたコードに移動することができます。You can then navigate to the identified code in the relevant Razor files.
  • Windows Virtual Machines (VM) および VM Scale Sets で実行される ASP .NET (コアおよびデスクトップ) アプリケーションを対象とするためのサポートを追加しました。We've added support for targeting ASP .NET (core and desktop) applications running on Windows Virtual Machines (VM) and VM Scale Sets.
Snapshot debugger target selection UI
スナップショット デバッガーのターゲット選択 UISnapshot Debugger Target Selection UI
  • FxCop を使用してコード分析を実行するとき、警告が表示されるようになります。You will now receive a warning when running code analysis using FxCop. 今後、コード分析を実行する方法としては、.NET Compiler アナライザーの使用をお勧めします。.NET Compiler analyzers are the recommended way to perform code analysis going forward. 詳細については、.NET Compiler Platform アナライザーへの移行に関するページを参照してください。Read more on migrating to .NET compiler platform analyzers.
  • ポータブル クラス ライブラリ (PCL) プロジェクト テンプレートが利用できなくなりました。プロジェクトのサポートは既定ではインストールされなくなります。Portable Class Library (PCL) project templates are no longer available, and project support will not be installed by default. 複数のプラットフォームを対象とすることを目的とした新しいプロジェクトには、.NET Standard プロジェクト タイプを使用する必要があります。New projects intended to target multiple platforms should use the .NET Standard project type. PCL プロジェクトのサポートを必要とするお客様は、Visual Studio インストーラーの [個々のコンポーネント] タブからコンポーネントを個別にインストールする必要があります。Customers who require PCL project support must install the component separately from the Individual Components tab in the Visual Studio installer.
  • "Project.CopyWebSite" コマンドは使用できなくなりました。The "Project.CopyWebSite" command is no longer available. この機能は、.NET 向けの "Web サイト" プロジェクト タイプでしか使用できませんでした。This feature was only available on the "Web Site" project type for .NET. これには、2 つの Web サイトのそれぞれのファイルのバージョンが同じになるように、それらの Web サイトを同期する機能が用意されていました。It provided the ability to synchronize two web sites so that they have the same version of each file. Visual Studio 2019 では、Visual Studio の外部にあるリモート宛先からファイルをコピーして、プロジェクトを開くことができます。In Visual Studio 2019, you can copy the files from the remote destination outside of Visual Studio and then open the project.
  • リモートの FTP の場所から Web サイト プロジェクトを開く機能は削除されました。The ability to open a Web Site project from a remote FTP location has been removed. FTP ユーザーは、Visual Studio の外部にあるリモート宛先からファイルをコピーし、プロジェクトを開き、変更を加えてから、発行機能を使用して、ファイルをリモートの FTP の場所にプッシュして戻すことができます。FTP users can copy the files from the remote destination outside of Visual Studio, open the project and make changes, and then use publish to push them back to the remote FTP location.
  • ASP.NET および Web ワークロードでは、カスタム CoffeeScript 編集エクスペリエンスがインストールされなくなりました。The ASP.NET and Web workload no longer installs a custom CoffeeScript editing experience. Visual Studio の TextMate バンドルでは、CoffeeScript を操作するための優れたエクスペリエンスが提供されます。Visual Studio's TextMate bundles provide a superior experience for working with CoffeeScript.
  • CSSLint と CoffeeLint の組み込みのコピーによって現在生成されている CSS エラーと CoffeeScript エラーは、それらのファイルを編集する際に自動的に表示されることはなくなります。CSS and CoffeeScript errors that are currently generated by built-in copies of CSSLint and CoffeeLint will no longer automatically surface when editing those files. npm や Visual Studio タスク ランナー エクスプローラーなどのリンターを実行する場合は、別の方法を使用します。Use an alternative method for running linters such as npm or the Visual Studio Task Runner Explorer.
  • Visual Studio では、Knockout HTML 属性に対して IntelliSense が指定されなくなります。Visual Studio no longer provides IntelliSense for Knockout HTML attributes. Visual Studio 2019 では、属性を入力する必要があります。In Visual Studio 2019 you will need to type the attributes.
  • JavaScript をデバッグするために ASP.NET プロジェクト内でレガシ Chrome デバッガーを使用する機能は削除されました。The ability to use the Legacy Chrome debugger in ASP.NET projects for debugging JavaScript has been removed. Visual Studio に組み込まれている現在の Chrome デバッガーは引き続き使用することができます。You can continue to use the current Chrome debugger built into Visual Studio.

パフォーマンス ウィザードPerformance Wizard

Visual Studio 2019 では、パフォーマンス ウィザード内で使用することができたプロファイル エクスペリエンスがパフォーマンス プロファイラーに移動されました。In Visual Studio 2019, the profiling experiences that were available in the Performance Wizard have been moved to the Performance Profiler. サンプリングのための CPU 使用率ツールと、インストルメンテーション ツール内のインストルメンテーションは、パフォーマンス プロファイラーにあります。You can find the CPU Usage Tool for sampling, and instrumentation in the Instrumentation tool in the Performance Profiler. この変更によってパフォーマンス ウィザードは不要になり、Visual Studio 2019 からは削除されています。With this change the Performance Wizard is no longer needed and has been removed from Visual Studio 2019. さらに、VS パフォーマンス コマンド ライン ツール内のサンプリング オプションは削除されました。これに代わるコマンド ライン ツールが今後のプレビューでリリースされます。Additionally the sampling option in the VS Performance command line tools have been removed, a replacement command line tool will be released in an upcoming preview.

テスト ツールTest Tools

  • ソリューション エクスプローラーでテスト、テスト クラス、テスト プロジェクトを右クリックして、テストの実行やデバッグができるようになりました。You can now right-click on tests, test classes or test projects in the Solution Explorer to run or debug tests.
  • テスト実行により、プロジェクト プロパティに設定されているプロセッサ アーキテクチャが自動検出されます。Test runs now auto-detect what processor architecture is set in the project properties.
  • Selenium や Appium など OSS UI テスト ツールは勢いを増し、バックアップ強力なコミュニティの支持を得ています。OSS UI test tools such as Selenium and Appium have gained momentum and have a strong community backing. これらのフレームワークが業界標準となったので、UI 駆動型機能テストの自動化のためにコード化された UI テストを非推奨としました。Because these frameworks have become industry standards, we deprecated Coded UI test for automated UI-driven functional testing. Visual Studio 2019 は、コード化された UI テスト機能を備えた Visual Studio として最後のバージョンとなります。Visual Studio 2019 will be the final version of Visual Studio with Coded UI test features. Web アプリのテストには Selenium を使用し、デスクトップと UWP アプリのテストには Appium と WinAppDriver を一緒に使用することをお勧めします。We recommend using Selenium for testing web-applications and Appium with WinAppDriver for testing desktop and UWP apps.
  • Visual Studio 2019 は、ロード テスト機能を備えた Visual Studio として最後のバージョンとなります。Visual Studio 2019 will be the last version of Visual Studio with load test features. ロード テスト ツールを必要とするお客様には、Apache JMeter、Akamai CloudTest、Blazemeter などの代替のロード テスト ツールの使用をお勧めします。For customers requiring load testing tools, we recommend using alternate load testing tools such as Apache JMeter, Akamai CloudTest, Blazemeter.
  • Visual Studio 2019 では、前にパブリックとしてマークされていたがドキュメントに正式に記載されたことがないいくつかのテスト ウィンドウ API が削除されました。In Visual Studio 2019, some test window APIs that were previously marked public but were never officially documented have been removed. これらは、拡張機能の管理者に対して早期に警告を発するために、Visual Studio 2017 で非推奨とマークされていました。They were marked deprecated in Visual Studio 2017 to give extension maintainers an early warning. Microsoft の知る限りでは、これらの API に対して依存関係を築いている拡張機能はごくわずかです。To our knowledge, very few extensions have taken a dependency on these APIs. このような API には、IGroupByProvider、IGroupByProvider、KeyComparer、ISearchFilter、ISearchFilterToken、ISearchToken、SearchFilterTokenType などがあります。These APIs include IGroupByProvider, IGroupByProvider, KeyComparer, ISearchFilter, ISearchFilterToken, ISearchToken and SearchFilterTokenType. この変更がご利用の拡張機能に影響を与える場合は、開発者コミュニティで問題点を送信して、その旨をお知らせください。If this change affects your extension, please let us know by submitting an issue on Developer Community.

Xamarin を使用したモバイル開発Mobile Development with Xamarin

このリリースには、ワークロードのサイズと Android のビルドのパフォーマンスおよび信頼性の改善に加えて、Xamarin.Android および Xamarin.Forms の生産性向上のための機能強化が含まれています。This release includes improvements to workload size and Android build performance and reliability, as well as enhancements for Xamarin.Android and Xamarin.Forms productivity.

  • Xamarin ワークロードは 7.69 GB になりました。これは、Visual Studio 2017 バージョン 15.9 から 2 倍の削減、バージョン 15.7 と比較すると 3 倍の改善になります。The Xamarin workload is now just 7.69GB, a 2x reduction from Visual Studio 2017 version 15.9 and a 3x improvement over version 15.7.
  • IntelliCode 拡張機能で、Xamarin.Forms XAML がサポートされるようになりました。The IntelliCode extension now supports Xamarin.Forms XAML.

Android のビルドのパフォーマンスと信頼性 Android Build Performance and Reliability

Visual Studio 2017 バージョン 15.9 および Visual Studio for Mac 7.7 で、初回ビルドのパフォーマンスおよびビルドの正確性についての改善を行いました。In Visual Studio 2017 version 15.9 and Visual Studio for Mac 7.7, we made initial build performance and build correctness improvements. Visual Studio 2019 および Visual Studio for Mac 7.8 で、ビルドおよび配置をさらに速くしました。In Visual Studio 2019 and Visual Studio for Mac 7.8, we made building and deploying even faster.

Android Build Performance
Android のビルドがコーヒーを飲むより速くなりましたAndroid Build Now Faster than Grabbing a Cup of Coffee
  • Android の次世代のパッケージ ツールを利用できるようになります。You will now make use of Android's next generation packaging tooling. この機能を有効にするには、ご利用のプロジェクトの .csproj に MSBuild フラグを追加します。To enable this feature, add an MSBuild flag in your project's .csproj:
    • aapt2  では、Android パッケージがコンパイルとリンクの 2 つのステップに分割されます。aapt2 divides Android packaging into two steps: Compile and Link. これにより、インクリメンタル ビルドのパフォーマンスが向上し、以前のエラー レポートが提供されます。This improves performance for incremental builds and provides earlier error reporting. たとえば、1 つのファイルだけに変更がある場合は、そのファイルを再コンパイルするだけで済みます。For example, if there are changes in a single file, you only need to recompile that file. <AndroidUseAapt2>True</AndroidUseAapt2>
  • ご利用のプロジェクトでこのツールを有効にすると、ビルド時およびランタイムの両方でのパフォーマンスの向上が可能になります。By enabling this tool in your projects, you enable enhanced performance at both build time and runtime. これらのプロパティの詳細については、Xamarin.Android でのビルド プロセスに関する Microsoft のドキュメントを参照してください。For more details on these properties, see our documentation on the Build Process in Xamarin.Android.

Xamarin Android Designer の拡張機能 Xamarin Android Designer Enhancements

分割ビューでの相互作用に対して生産性向上のための機能強化を複数を行いました。We have made a number of productivity enhancements to the interactions in Split View.

  • ツールボックスからソース エディターに直接ドラッグ アンド ドロップすることができます。これは、ご利用の Android レイアウトをすばやくスキャホールディングするのに役立ちます。Drag and drop directly from the toolbox to the source editor to help quickly scaffold your Android layouts.
Android Designer Toolbox to Source Editor
  • ソース エディター内で XML 定義の範囲から要素を直接、選択できます。Select elements directly from their XML definition span in the source editor. キャレットの位置を、対応する Android ビューと同期させることで、これを実装しました。これにより、エディターから直接、プロパティ パネル内の要素のプロパティにすばやくアクセスすることができます。We implemented this by synchronizing the caret position with the corresponding Android view, allowing you to quickly access an element's properties in the property panel right from the editor.
Android Designer Source Editor to Property Editor
  • ご自分のコントロールで使用されている色を確認できるように、XML コードに対するインライン色プレビューを使用できます。Use an inline color preview to your XML code so you can see what colors are being used in your controls.
Android Designer Color Preview
  • 値にポインターを合わせることでクイック ヒント機能を使用できます。この機能では、値が定義されている場所や、色の 16 進数の値などの詳細を確認できます。Use our quick info feature by hovering over a value to find out more about it, such as where it's defined or what the hexadecimal value for the color is.
Android Designer Quick Info
アクションのクイック ヒントQuick Info in Action

Xamarin.Forms プロパティ パネル Xamarin.Forms Property Panel

プロパティ パネル内で Xamarin.Forms のコントロール、セル、およびレイアウトの最も一般的な属性を編集し、ご利用の XAML で直ちに反映されたそれらの変更内容を確認できるようになりました。You can now edit the most common attributes of Xamarin.Forms controls, cells, and layouts in a property panel and see those changes reflected immediately in your XAML.

Xamarin.Forms Property Panel
Xamarin.Forms プロパティ パネルXamarin.Forms Property Panel

Android Emulator の機能強化 Android Emulator Improvements

Visual Studio 2019 では、Android エミュレーター イメージをより簡単に作成できます。In Visual Studio 2019, Android emulator images are easier to create. また、Windows 10 の 2018 年 10 月の更新プログラム (バージョン 1809) では Window チームと共に作業を続けることで、Android エミュレーターが Hyper-V 上で実行されるときのパフォーマンスを向上させました。We've also continued to work with the Windows team in the Windows 10 October 2018 Update, version 1809, to improve the performance of the Android emulator when running on Hyper-V.

  • 新しいユーザーは実行アイコンを押すだけで最初のイメージを作成できます。New users can create their first image by simply pressing the run icon.
  • Microsoft のエミュレーター取得エクスペリエンスでは、お客様の設定に対して最適な構成が自動的に決定され、既定ではハードウェアの高速化 (Intel HAXM または Hyper-V を使用) とクイック起動が利用されます。Our emulator acquisition experience automatically determines the best configuration for your setup and takes advantage of hardware acceleration (with Intel HAXM or Hyper-V) and quick boot by default.
  • 別のイメージを作成する場合は、ドロップダウンから [Android Emulator の作成] を選択して、Android Device Manager を開きます。When you want to create another image, you can select Create Android Emulator from the dropdown to open the Android Device Manager.

ユニバーサル Windows プラットフォームUniversal Windows Platform

  • IntelliCode 拡張機能で、XAML がサポートされるようになりました。The IntelliCode extension now supports XAML.
  • Visual Studio 設定の複雑さを軽減しサイズを縮小するために、Visual Studio のインストールから Windows Phone エミュレーターが削除されています。To reduce Visual Studio setup complexity and size, Windows Phone emulators have been removed from Visual Studio installation. このため、エミュレーターを手動でダウンロードすることが必要になります。You will now need to download the emulators manually.
  • Windows 10 Fall Creators Update (ビルド 16299) の前の Windows 10 SDK をターゲットとする UWP アプリ用の XAML デザイン時ツールは、削除されました。XAML design time tooling for UWP apps targeting Windows 10 SDKs before the Windows 10 Fall Creators Update (build 16299) has been removed. ご利用のアプリケーションを Windows 10 バージョン 1709 以降に再ターゲットして、XAML デザイナーを使用するか、または XAML エディターを使用します。Retarget your applications to Windows 10 version 1709 or higher to use the XAML Designer, or use the XAML editor.
  • project.json を使用して NuGet の依存関係を定義する UWP テスト プロジェクトは、サポートされなくなりました。UWP test projects using project.json to define NuGet dependencies are no longer supported. 新しい PackageReference 形式を使用するように、ご利用のプロジェクトを更新する必要があります。You must upgrade your project to use the new PackageReference format.
  • Visual Studio 2019 で、UWP JavaScript アプリはサポートされなくなりました。UWP JavaScript apps are no longer supported in Visual Studio 2019. JavaScript UWP プロジェクト (拡張子 jsproj が付いたファイル) は、作成することも開くこともできません。You cannot create or open JavaScript UWP projects (files with extension jsproj). 詳細については、Windows で適切に実行されるプログレッシブ Web アプリ (PWA) の作成に関する Microsoft のドキュメントを参照してください。You can learn more via our documentation on creating Progressive Web Apps (PWAs) that run well on Windows.

Office ツール テンプレートの更新情報Office Tools Template Updates

Visual Studio 2019 で、Office、SharePoint、および VSTO のテンプレートに対していくつかの変更を加えました。In Visual Studio 2019, we made a few changes to the Office, SharePoint, and VSTO templates.

  • Visual Studio 2017 15.9 で追加された SharePoint 2019 のテンプレートは、Visual Studio 2019 でも利用できます。The SharePoint 2019 templates that were added in Visual Studio 2017 15.9 are also available in Visual Studio 2019.
  • SharePoint シーケンシャル ワークフローまたはステート マシン ワークフローのサポートを削除しました。We have removed support for SharePoint Sequential Workflow or State Machine Workflows. Visual Studio 2019 ではこれらのワークフローを作成することも開くこともできませんが、Visual Studio の以前のリリースではそれらの編集を引き続き行うことができます。While you will not be able to create or open these workflows in Visual Studio 2019, you can continue to edit them in previous releases of Visual Studio.
  • Office 2010 のテンプレートは使用できなくなります。Office 2010 templates will no longer be available. ただし、既存の Office 2010 プロジェクトについては、Visual Studio 2019 で引き続き開くことができます。However, you can still open existing Office 2010 projects in Visual Studio 2019.
  • Office 2013 および 2016 のテンプレートによって Office 2013 以降がサポートされていることを反映するために、それらのテンプレートの名前は変更されました。The Office 2013 and 2016 templates have been renamed to reflect that they support Office 2013 and above.

チーム エクスプローラーと Azure DevOpsTeam Explorer and Azure DevOps

Azure DevOps プロジェクトにチーム エクスプローラーを接続するとき、開発者向けの簡素化された新しいエクスペリエンスをリリースしています。We are releasing a new, streamlined, developer-centric experience when connecting Team Explorer to an Azure DevOps project.

  • 関連する作業項目に焦点を当てます。そのためには、自分に割り当てられた作業項目、フォローしている作業項目、ディスカッションで自分がメンションされた作業項目、および自分のアクティビティに基づく作業項目に基づいてご利用のビューをフィルター処理およびピボットします。Focus on relevant work items by filtering and pivoting your view based on work items assigned to you, ones that you're following, ones where you're mentioned in the discussion, and ones based on your activity.

    • 各ビュー内では、インラインでの作業項目の作成、シンプルなインライン編集の実行、作業項目への完了のマーク付け、保留中の変更への作業項目の関連付けを行うことができます。Within each view, you can create a work item inline, perform simple inline edits, mark a work item as complete, and associate a work item to pending changes.
  • 作業項目からローカル ブランチを作成します。この場合、そのローカル ブランチに加えた変更に作業項目が自動的に関連付けられます。Create a local branch from a work item which will automatically relate the work item to the changes made to that local branch. これが既定のエクスペリエンスです。This is the default experience. レガシ エクスペリエンスに切り替える場合は、Visual Studio で作業項目エクスペリエンスを設定することでそれを行います。Should you want to switch to the legacy experience, you can by setting the Work Items experience in Visual Studio. この新しいエクスペリエンスが該当するのは Git リポジトリの場合のみであることに注意してください。TFVC リポジトリ用の新しいエクスペリエンスは、次の更新プログラムで使用できるようになりますNote that this new experience is only true for Git repos. The new experience for TFVC repos will available in a following update.

    Azure DevOps Work Item Hub
    Azure DevOps の作業項目ハブAzure DevOps Work Item Hub
  • 保留中の変更のコミット メッセージ内で #mention を行うときに作業項目を検索します。Search for work items when doing a #mention in the pending changes commit message. 詳細については、「View and add work items using the Work Items page」 ([作業項目] ページを使用して作業項目を表示および追加する) を参照してください。For more details, see the View and add work items using the Work Items page.

    Azure DevOps #mentions
    Azure DevOps #mentionsAzure DevOps #mentions
  • Azure DevOps での採用率の低さが原因となって、Visual Studio 2019 用の Team Foundation Server Office Integration 2019 プラグインから Microsoft Project のサポートが削除されました。Support for Microsoft Project has been removed from the Team Foundation Server Office Integration 2019 plug-in for Visual Studio 2019 due to a low adoption rate in Azure DevOps. このため、作業項目を Excel にエクスポートしてから、手動でプロジェクトに貼り付けることが必要になります。You will now need to export your work items to Excel and manually paste them into Project.

  • Visual Studio 2019 用の Team Foundation Server Office Integration 2019 プラグインから PowerPoint のサポートが削除されました。Support for PowerPoint has been removed from the Team Foundation Server Office Integration 2019 plug-in for Visual Studio 2019. ただし、ユーザーは PowerPoint でストーリー ボードを作成し、Azure DevOps でそれらを作業項目に手動でリンクすることもできます。However, users can still create storyboards in PowerPoint and link them manually to work items in Azure DevOps.

Application Insights と HockeyAppApplication Insights and HockeyApp

  • Visual Studio 2019 では Application Insights の Trends ウィンドウが削除され、機能がより豊富な代替えツールが使用されます。The Application Insights Trends window has been removed in Visual Studio 2019 in favor of alternatives that are more feature-rich. 代わりに、Visual Studio で Application Insights の検索ウィンドウを使用することも、Azure portal で Application Insights の豊富な診断ツール セットを使用することもできます。Instead, you can use the Application Insights Search window in Visual Studio or the rich set of diagnostics tools in Application Insights in the Azure portal.
  • HockeyApp SDK の追加および新しいベータ版の配布の作成を行うためのウィザードが削除されました。The wizards for adding the HockeyApp SDK and creating new beta distributions have been removed. 代わりに、HockeyApp の後継として Visual Studio App Center の使用をお勧めします。We instead recommend using Visual Studio App Center, the successor to HockeyApp. Visual Studio でのこのようなショートカットを除けば、HockeyApp は引き続き通常どおり使用することができます。You can still use HockeyApp normally, except without these shortcuts in Visual Studio. HockeyApp の詳細については、Microsoft のサポート ページを確認してくださいIf you would like to learn more about HockeyApp, check out our support page.

Visual Studio 2019 Preview 1.1Visual Studio 2019 Preview 1.1 New Release icon

リリース日: 2018 年 12 月 10 日released December 10, 2018

Visual Studio 2019 Preview 1.1 で修正された問題Issues Fixed in Visual Studio 2019 Preview 1.1


既知の問題Known Issues

Visual Studio 2019 の既存のすべての既知の問題と、利用可能な回避策を以下のリンクから参照してください。See all existing known issues and available workarounds in Visual Studio 2019 by following the below link.

Visual Studio 2019 Known Issues


フィードバックFeedback

皆様のご意見をお待ちしております。We would love to hear from you! 問題がある場合は、インストーラーまたは Visual Studio IDE 自体の右上隅にある [問題の報告] オプションからお知らせください。For issues, let us know through the Report a Problem option in the upper right-hand corner of either the installer or the Visual Studio IDE itself. 次に、The Feedback Icon アイコンは、右上隅にあります。icon is located in the upper right-hand corner. 製品に関する提案をしたり、Visual Studio 開発者コミュニティで問題を追跡したりすることにより、質問、回答の検索、新機能を提案したりすることができます。You can make a product suggestion or track your issues in the Visual Studio Developer Community, where you can ask questions, find answers, and propose new features. ライブ チャット サポートを介して、無料のインストールのヘルプを取得することもできます。You can also get free installation help through our Live Chat support.


ブログBlogs

開発者ツールのブログ サイトで利用できる洞察と推奨事項を活用して、すべての新リリースを常に最新の状態に保ち、幅広い機能の深いダイブポストを含めることができます。開発者ツールのブログを参照すると、すべての新しいリリースに関する最新情報を入手することができ、さまざまな機能の詳細な記事が含まれています。Take advantage of the insights and recommendations available in the Developer Tools Blogs site to keep you up-to-date on all new releases and include deep dive posts on a broad range of features.

Developer Tools Blogs


Visual Studio 2019 リリース ノート履歴Visual Studio 2019 Release Notes History

過去のバージョンの Visual Studio 2017 に関連する詳細については、「Visual Studio 2019 リリース ノート履歴」のページを参照してください。For more information relating to past versions of Visual Studio 2017, see the Visual Studio 2019 Release Notes History page.


ページのトップへ
Top of Page