Visual Studio での R の使用Working with R in Visual Studio

R は、高い拡張性を備えた、統計コンピューティングおよびグラフィックス用の言語であり環境です。R is a highly extensible language and environment for statistical computing and graphics. R は GNU General Public License に基づき無料配布されており、コミュニティの強力なサポートを受けることができます。また、数学記号と式を含むプロットを出版品質で生成できる機能で知られています。It's distributed for free under the GNU General Public License, enjoys strong community support, and is known for its ability to produce publication-quality plots including mathematical symbols and formulae. R の詳細については、r-project.org と「An Introduction to R (R の概要)」をご覧ください。You can learn more about R at r-project.org and An Introduction to R.

R Tools for Visual Studio (RTVS) は Visual Studio 2017 と Visual Studio 2015 Update 3 以降向けの無料のオープンソース拡張機能であり、MIT ライセンスに基づいてリリースされていますR Tools for Visual Studio (RTVS) is a free, open-source extension for Visual Studio 2017 and Visual Studio 2015 Update 3 (or higher), released under the MIT license. (R インタープリターのバイナリとリンクする RHost という名前の 2 番目のオープン ソース コンポーネントは、GNU Public License V2 に基づいてリリースされています)。(A second open-source component called RHost, which links to the R interpreter binaries, is released under the GNU Public License V2.)

注意

RTVS は現在、Windows 上の Visual Studio でのみサポートされています。Visual Studio for Mac ではサポートされていません。RTVS is presently supported only in Visual Studio on Windows and not Visual Studio for Mac.

Visual Studio で R を使用するには、次の手順を実行します。To experience R in Visual Studio:

その後、以下のリンクから、R 関連の機能と Visual Studio 自体の一般的な機能の詳細を確認してください。Then follow the links below to learn more about R-related features as well as the general capabilities of Visual Studio itself.

機能Feature 説明Description Visual Studio の一般的なドキュメントGeneral Visual Studio Documentation
Visual Studio のプロジェクト システムVisual Studio project system 関連ファイルを使いやすい構造で整理および管理し、R コード、R ドキュメント、R Markdown、SQL クエリ、ストアド プロシージャなどのアイテムに関する便利なテンプレートを活用できます。Organize and manage related files in a convenient structure, and take advantage of useful templates for items such as R code, R documentation, R Markdown, SQL queries, and stored procedures. パッケージ マネージャーSQL Server integration も使用できます。Also enjoy the package manager and SQL Server integration. Visual Studio のソリューションおよびプロジェクトSolutions and Projects in Visual Studio
ワークスペースWorkspace RTVS は、ローカル ワークスペースとリモート ワークスペースへバインド可能です。これにより、ローカルで小規模なデータ セットを使用して R コードを開発してから、クラウドベースのより強力なコンピューター上で大規模なデータ セットを使用して簡単にコードを実行することができます。RTVS can bind to local and remote workspaces, allowing you to develop R code locally with smaller data sets, then easily run the code on more powerful cloud-based computers with much larger data sets. 適用なしn/a
R Tools オプションR Tools options RTVS のさまざまな側面を制御します。Control various aspects of RTVS. [オプション] ダイアログ ボックスOptions dialog box
豊富な編集、IntelliSense、コード スニペットRich editing, IntelliSense, and code snippets 構文の色分け、すべてのコードとライブラリ間での IntelliSense、コードのフォーマット、シグネチャ ヘルプ、定義への移動、すべての参照の検索、コード スニペットなどが含まれます。Includes syntax coloring, IntelliSense across all your code and libraries, code formatting, signature help, Go to Definition, Find All References, code snippets, and more. コード エディターとテキスト エディターでのコードの作成Writing Code in the Code and Text Editor
R MarkdownR Markdown R Markdown ドキュメントを使用すると、マークダウン コード ブロック内の統合された R コードを用いてデータの結果を共有できます。R Markdown documents help you share your data results, with integrated R code inside markdown code blocks. 適用なしn/a
対話型ウィンドウInteractive Window R で完全な REPL エクスペリエンスを実現でき、対話型ウィンドウでソース ファイルのコードを簡単に実行可能です。Provides a full REPL experience for R with the ability to easily run code in a source file in the interactive window. 適用なしn/a
データの視覚化Visualizing data プロットは R を使用する上で不可欠な部分であるため、RTVS では独立した複数のプロット ウィンドウを利用できます。各ウィンドウには、履歴とウィンドウ間のプロットの移動機能が備わっています。Plotting is an integral part of the R experience, and RTVS supports multiple, independent plot windows, each with their own history and the ability to move plots between windows. プロットはビットマップ ファイルと PDF ファイルに保存でき、またビットマップやメタファイルとしてクリップボードにコピーすることもできます。Plots can be saved to bitmap and PDF files, or copied to the clipboard as a bitmap or metafile. 適用なしn/a
Variable ExplorerVariable Explorer 並べ替え可能なテーブルを表示する機能と CSV へのエクスポート機能を備えており、グローバル スコープ内やパッケージ固有のスコープ内の変数を調査できます。Examine variables in the global or package-specific scopes, with the ability to view sortable tables and export to CSV. 適用なしn/a
フル機能のデバッグFull-featured debugging 対話型ウィンドウとの統合などがあります。Includes integration with the interactive window. Visual Studio でのデバッグDebugging in Visual Studio

よく寄せられる質問」もご覧ください。Also see Frequently asked questions.

次のビデオでも、R Tools の各機能の簡単なレビュー (5 分 48 秒) を確認できます。The following video also provides a brief (5m 48s) review of the R Tools capabilities:

フィードバックをお寄せください。Send us your feedback!

  1. Github の問題: RTVS チームへ問い合わせる場合は、GitHub 上で問題を報告するか、[R Tools] > [フィードバック] メニューを使用して行ってください。Github issues: The best way to reach the RTVS team is by filing an issue on GitHub, or by using the R Tools > Feedback menu.

  2. 気に入った機能の報告や問題点、改善点の報告: [R Tools] > [フィードバック] メニューから、フィードバックの送信と、問題の診断に役立つ RTVS ログ ファイルの添付を素早く行えますSend a Smile / Frown: The R Tools > Feedback menu is a quick way to send feedback and attach RTVS log files to assist in the diagnosis of your issue. (ログは、個別に送信できるように %temp%/RTVSlogs.zip に書き込まれています)。[ヘルプ] > [フィードバック] > [設定] メニュー コマンドから、またはインストール中に [Visual Studio telemetry](Visual Studio テレメトリ) をオフにした場合は、ログ機能が無効になります。(Logs are written into %temp%/RTVSlogs.zip in case you want to send them separately.) Logging is disabled if you've opted out of Visual Studio telemetry through the Help > Feedback > Settings menu command, or during installation.

  3. 電子メール: チーム (rtvsuserfeedback (at) microsoft.com) 宛にフィードバックを直接送信できます。Email: You can send direct feedback to the team at rtvsuserfeedback (at) microsoft.com.