R Tools for Visual Studio の使用を開始するGetting started with R Tools for Visual Studio

R Tools for Visual Studio (RTVS) をインストールすると (インストールに関するページを参照してください)、ツールが提供するエクスペリエンスをすばやく確認できます。Once you have R Tools for Visual Studio (RTVS) installed (see Installation), you can quickly get a taste of the experience that those tools provide. 次のセクションでは、簡単なツアーを紹介します。The following sections guide you through a short tour:

R プロジェクトの作成Create an R project

  1. Visual Studio を起動します。Start Visual Studio.
  2. [ファイル]、[新規]、[プロジェクト] の順に選択します。(Ctrl+Shift+N)Choose File > New > Project... (Ctrl+Shift+N)
  3. [テンプレート]、[R] で "R Project" を選択し、プロジェクトに名前と場所を指定し、[OK] を選択します。Select "R Project" from under Templates > R, give the project a name and location, and select OK:

    Visual Studio 内の R (VS2017 の RTVS) の [新しいプロジェクト] ダイアログ ボックス

  4. プロジェクトを作成すると、次のウィンドウが表示されます。Once the project is created, you see the following windows:

    • 右側には、Visual Studio ソリューション エクスプローラーがあり、ここには含まれるソリューション内にプロジェクトが表示されます。On the right is Visual Studio Solution Explorer, where you see your project inside a containing solution. (ソリューションには、複数のさまざまな種類のプロジェクトを含めることができます。詳細については、プロジェクトに関するページを参照してください。)(Solutions can contain any number of projects of different types; see Projects for details.
    • 左上には、新しい R ファイル (script.R) があり、ここでは、すべての Visual Studio の編集機能を使ってソース コードを編集することができます。On the top left is a new R file (script.R) where you can edit source code with all of Visual Studio's editing features.
    • 左下には、[R インタラクティブ] ウィンドウがあり、ここでは対話型でコードを開発およびテストすることができます。On the bottom left is the R Interactive window in which you can interactively develop and test code.

注意

プロジェクトを開かずに、別のプロジェクトの種類を読み込む場合にも、[R インタラクティブ] ウィンドウを使用できます。You can use the R Interactive window without having any projects open, and even when a different project type is loaded. いつでも [R Tools] > [Windows] > [R インタラクティブ] を選択するだけです。Just select R Tools > Windows > R Interactive at any time.

対話型ウィドウと IntelliSense の調査Explore the Interactive window and IntelliSense

  1. 3 + 4」と入力して Enter キーを押し、結果を表示して、対話型ウィンドウが動作していることをテストします。Test that the interactive window is working by typing in 3 + 4 and then Enter to see the result:

    Visual Studio 2017 (VS2017) の R 対話型ウィンドウ

  2. 少し複雑な「ds <- c(1.5, 6.7, 8.9) * 1:12」を入力してから、「ds」を入力して結果を表示します。Enter something a little more complicated, ds <- c(1.5, 6.7, 8.9) * 1:12, and then enter ds to see the result:

    その他の Visual Studio の R 対話型の例

  3. mean(ds)」と入力しますが、「m」や「me」と入力すると、すぐに Visual Studio IntelliSense でオート コンプリートの候補が表示されます。Type in mean(ds) but notice that as soon as you type m or me, Visual Studio IntelliSense provides auto-completion options. リストから目的のオート コンプリートを選択したら、Tab キーを押して挿入します。方向キーやマウスで選択を変更することができます。When the completion you want is selected in the list, press Tab to insert it; you can change the selection with the arrow keys or the mouse.

    コードの入力時に表示される IntelliSense

  4. mean が完成したら、先頭のかっこ「(」を入力すると、IntelliSense で関数に対するインライン ヘルプが示されることを確認できます。After completing mean, type the opening parenthesis ( and note how IntelliSense gives you inline help for the function:

    IntelliSense が示す関数のヘルプ

  5. mean(ds) を完成させ、Enter キーを押すと、結果が表示されます ([1] 39.51667)。Complete the line mean(ds) and press Enter to see the result ([1] 39.51667).

  6. 対話型ウィンドウはヘルプと統合されているため、たとえば、「?mean」と入力すると、Visual Studio の [R ヘルプ] ウィンドウにその関数のヘルプが表示されます。The Interactive window is integrated with help, so entering ?mean displays help for that function in the R Help window in Visual Studio. 詳細については、「R Tools for Visual Studio のヘルプ」を参照してください。For details, see Help in R Tools for Visual Studio.

    Visual Studio の [R ヘルプ] ウィンドウ

  7. 一部のコマンド (plot(1:100) など) では、出力が対話型ウィンドウに直接表示できない場合、Visual Studio 内に新しいウィンドウが開かれます。Some commands, such as plot(1:100), open a new window in Visual Studio when the output can't be displayed directly in the interactive window:

    Visual Studio でのプロットの表示

対話型ウィンドウでは、履歴の確認、ワークスペースの読み込みと保存、デバッガーへのアタッチを行ったり、コピー/貼り付けを使用せずにソース コード ファイルを操作したりすることができます。The interactive window also lets you review your history, load and save workspaces, attach to a debugger, and interact with source code files instead of using copy-paste. 詳細については、「Working with the R Interactive Window」 (対話型ウィンドウでの作業) を参照してください。See Working with the R Interactive Window for details.

コード編集機能の体験Experience code editing features

対話型ウィンドウでの簡単な作業例では、コード エディターでも動作する IntelliSense などの基本的な編集機能を紹介しました。Working briefly with the interactive window demonstrates basic editing features like IntelliSense that also work in the code editor. 以前と同じコードを入力すると、同じオート コンプリートおよび IntelliSense のメッセージ画面が表示されますが、出力は行われません。If you enter the same code as before, you see the same auto-completion and IntelliSense prompts, but not the output.

.R ファイルにコードを記述すると、すぐにすべてのコードが表示され、簡単に小さな変更を行い、対話型ウィンドウでコードをすばやく実行して結果を表示できます。Writing code in a .R file lets you see all your code at once, and makes it easier to make small changes and then quickly see the result by running the code in the interactive window. また、プロジェクトに必要なだけファイルを含めることもできます。You can also have as many files as you want in a project. コードがファイル内にある場合は、デバッガーでステップごとに実行することもできます (このトピックで後述します)。When code is in a file, you can also run it step-by-step in the debugger (discussed later in this topic). これらの機能は、計算アルゴリズムを開発して、1 つ以上のデータセットを操作するためにコードを記述する場合、特にすべての中間結果を確認する必要がある場合に、非常に役立ちます。These capabilities are helpful when you're developing computational algorithms and writing code to manipulate one or more datasets, especially when you want to examine all intermediate results.

例のように、次のステップでは、「Central Limit Theorem」 (中心極限定理) (Wikipedia) を調査する小さなコードを作成します。As an example, the following steps create a little code to explore the Central Limit Theorem (Wikipedia). (この例は、Paul Teetor による R クックブックから編集されています。)(This example is adapted from the R Cookbook by Paul Teetor.)

  1. script.R エディターで、次のコードを入力します。In the script.R editor, enter the following code:

    mu <- 50
    stddev <- 1
    N <- 10000
    pop <- rnorm(N, mean = mu, sd = stddev)
    plot(density(pop), main = "Population Density", xlab = "X", ylab = "")
    
  2. 結果をすばやく表示するには、すべてのコードを選択し (Ctrl + A キー)、Ctrl + Enter キーを押すか、右クリックして、[対話型で実行] を選択します。To quickly see the results, select all the code (Ctrl+A), then press Ctrl+Enter or right-click and select Execute In Interactive. 直接入力したかのように、選択したすべてのコードが対話型ウィンドウに入力され、結果がプロット ウィドウに表示されます。All the selected code is run in the interactive window as if you typed it directly, showing the result in a plot window:

    Visual Studio でのプロットの表示

  3. 1 行の場合は、いつでも Ctrl + Enter キーを押すだけで、対話型ウィンドウで行を実行できます。For a single line, just press Ctrl+Enter at any time to run that line in the interactive window.

ヒント

すばやくコードを実行するために、編集を行って Ctrl + Enter キーを押す (または、Ctrl + A キーですべてを選択して Ctrl + Enter キーを押す) パターンについて説明します。Learn the pattern of making edits and pressing Ctrl+Enter (or selecting everything with Ctrl+A and then pressing Ctrl+Enter) to quickly run the code. これは、同じ操作のためにマウスを使用するよりもはるかに効率的です。Doing so is much more efficient than using the mouse for the same operations.

さらに、Visual Studio フレームの外部にあるプロット ウィンドウにドラッグ アンド ドロップし、ディスプレイ上の他の目的の場所に配置できます。In addition, you can drag and drop the plot window out of the Visual Studio frame and place it whenever else you want on your display. 配置後は、必要なサイズにプロット ウィンドウのサイズを簡単に変更し、画像または PDF ファイルに保存できます。You can then resize the plot window to the dimensions you want and then save it to an image or PDF file.

  1. 追加のコード行を少し追加して、2 つ目のプロットを含めます。Add a few more lines of code to include a second plot:

    n <- 30
    samp.means <- rnorm(N, mean = mu, sd = stddev / sqrt(n))    
    lines(density(samp.means))
    
  2. もう一度 Ctrl + A キーと Ctrl + Enter キーを押し、コードを再実行します。次のような結果が生成されます。Press Ctrl+A and Ctrl+Enter again to run the code, producing the following result:

    Visual Studio での更新されたデュアル プロット

  3. 問題は、最初のプロットで垂直スケールが決定されるため、2 つ目のプロット (lines を含む) が収まらないことです。The problem is that the first plot determines the vertical scale, so the second plot (with lines) doesn't fit. この問題を解決するには、plot 呼び出しに ylim パラメーターを設定する必要がありますが、垂直方向の最大値を計算するには、適切にコードを追加する必要があります。To correct this problem, we need to set the ylim parameter on the plot call, but do so that properly we need to add code to calculate the maximum vertical value. plot を呼び出す前に samp.means を使用するように、コードを再配置する必要があるため、対話型ウィンドウで 1 行ずつ実行するのは不便です。Doing this line-by-line in the interactive window is inconvenient because we need to rearrange the code to use samp.means before calling plot. コード ファイルで、簡単に適切な編集を行うことができます。In a code file, though, we can easily make the appropriate edits:

    mu <- 50
    stddev <- 1
    N <- 10000
    pop <- rnorm(N, mean = mu, sd = stddev)
    
    n <- 30
    samp.means <- rnorm(N, mean = mu, sd = stddev / sqrt(n))
    max.samp.means <- max(density(samp.means)$y)
    
    plot(density(pop), main = "Population Density",
        ylim = c(0, max.samp.means),
        xlab = "X", ylab = "")
    lines(density(samp.means))
    
  4. もう一度 Ctrl + A キーと Ctrl + Enter キーを押すと、結果が表示されます。Ctrl+A and Ctrl+Enter again to see the result:

    適切にスケーリングされた Visual Studio の最新のデュアル プロット

エディターで操作できる内容は他にもあります。There's more you can do in the editor. 詳細については、「コードの編集」、「IntelliSense」、および「コード スニペット」を参照してください。For details, see editing code, IntelliSense, and code snippets.

コードのデバッグDebugging your code

Visual Studio の主な強みの 1 つは、デバッグ UI です。One of the key strengths of Visual Studio is its debugging UI. RTVS は、この強力な基盤の上にビルドされ、革新的な UI (変数エクスプローラー、データ テーブル ビューアーなど) を追加します。RTVS builds on top of this strong foundation and adds innovative UI such as the Variable Explorer and Data Table Viewer. ここでは、デバッグの概要を確認します。Here, let's just take a first look at debugging.

  1. 最初に、[R Tools] > [セッション] > [リセット] メニューを使用して、現在のワークスペースをリセットし、ここまでに実行したすべてをクリアします。To begin, reset the current workspace to clear everything you've done so far by using the R Tools > Session > Reset menu command. 既定では、対話型ウィンドウで行うすべてが、現在のセッションに入り、これはデバッガーでも使用されます。By default, everything you do in the interactive window accrues to the current session, which is then also used by the debugger. セッションをリセットすることで、既存のデータがない状態でデバッグ セッションを開始できます。By resetting the session, you ensure that the debugging session starts with no pre-existing data. ただし、ソース ファイルはワークスペースの外部で管理および保存されるため、[リセット] コマンドは script.R ソース ファイルに影響しません。The Reset command, however, doesn't affect your script.R source file, because that's managed and saved outside of the workspace.

  2. 前のセクションで作成された script.R ファイルを使用して、行にブレークポイントを設定します。行にキャレットを配置して F9 キーを押すか、[デバッグ] > [ブレークポイントの設定/解除] メニューを選択すると、この行は pop <- で開始されます。With the script.R file created in the previous section, set a breakpoint on the line that begins with pop <- by placing the caret on that line and then pressing F9, or selecting the Debug > Toggle Breakpoint menu command. または、左側の余白をクリックすると、1 つのステップでこの操作を行うことができます。この行には、赤いブレークポイントのドットが表示されます。Alternately, simply click in the left-hand margin (or gutter) for that line where the red breakpoint dot appears:

    エディターでのブレークポイントの設定

  3. ツール バーの [Source startup file](ソース スタートアップ ファイル) ボタンを選択するか、[デバッグ] > [Source startup file](ソース スタートアップ ファイル) メニュー アイテムを選択するか、F5 キーを押すかのいずれかを行って、script.R のコードでデバッガーを起動します。Launch the debugger with the code in script.R by either selecting the Source startup file button on the toolbar, selecting the Debug > Source startup file menu items, or pressing F5. Visual Studio がデバッグ モードに切り替わり、コードの実行が開始されます。Visual Studio enters its debugging mode and starts running the code. ただし、ブレークポイントを設定した行で停止します。It stops, however, on the line where you set the breakpoint:

    Visual Studio デバッガーのブレークポイントでの停止

  4. Visual Studio には、デバッグ中にコード行をステップ実行する機能があります。During debugging, Visual Studio provides the ability to step through your code line by line. また、関数へのステップイン、関数のステップ オーバー、呼び出し元コンテキストへの関数のステップ アウトを行うこともできます。You can also step into functions, step over them, or step out of them to the calling context. これらの機能は、他の機能と共に [デバッグ] メニューに表示されます (エディターのコンテキスト メニューを右クリックして、[デバッグ] ツール バーを選択)。These capabilities, along with others, can be found on the Debug menu, the right-click context menu in the editor, and the Debug toolbar:

    Visual Studio のデバッグ ツール バー

  5. ブレークポイントで停止すると、変数の値を調べることができます。When stopped at a breakpoint, you can examine the values of variables. Visual Studio で [自動変数] ウィンドウを検索して、[ローカル] という名前の下部のタブを選択します。Locate the Autos window in Visual Studio and select the tab along the bottom named Locals. [ローカル] ウィンドウには、プログラムの現在の位置でローカル変数が表示されます。The Locals window shows local variables at the current point in the program. 前に設定したブレークポイントで停止した場合、pop 変数がまだ定義されていないことがわかります。If you're stopped on the breakpoint set earlier, you see that the pop variable isn't yet defined. [デバッグ] > [ステップ オーバー] (F10 キー) を使用すると、pop の値が表示されます。Now use the Debug > Step Over command (F10), and you see the value for pop appear:

    Visual Studio の [ローカル] ウィンドウ

  6. さまざまなスコープ (グローバル スコープとパッケージ スコープを含む) で変数を調べるには、[変数エクスプローラー] を使用します。To examine variables in different scopes, including the global scope and package scopes, use the Variable Explorer. また、変数エクスプローラーでも、並べ替え可能な列を含む表形式ビューに切り替え、CSV ファイルにデータをエクスポートする機能が提供されます。The Variable Explorer also gives you the ability to switch to a tabular view with sortable columns and to export data to a CSV file.

    変数エクスプローラーの展開ビュー

  7. 引き続き 1 行ずつプログラムをステップ実行したり、[続行] (F5) を選択して完了 (次のブレークポイント) まで実行したりすることができます。You can continue stepping through the program line by line, or select Continue (F5) to run it to completion (or the next breakpoint).

さらに詳細を確認するには、「デバッグ」と「変数エクスプローラー」を参照してください。To go deeper, see Debugging and Variable Explorer.

次のステップNext steps

このチュートリアルでは、Visual Studio で対話型ウィンドウを使用して、コードの編集およびデバッグを行い、R プロジェクトの基本について学習しました。In this walkthrough you've learned the basics of R projects, using the interactive window, code editing, and debugging in Visual Studio. その他の機能を引き続き確認するには、次のトピック、および目次の内容を参照してください。To continue exploring more capabilities, see the following topics as well as topics shown in the table of contents: