Visual Studio で R プロジェクトを作成するCreating R projects in Visual Studio

R プロジェクト (.rxproj ファイル) は、プロジェクトに関連付けられているすべてのソースとコンテンツ ファイルを識別します。An R project (an .rxproj file) identifies all the source and content files associated with your project. R プロジェクトは、各ファイルのビルド情報の格納、ソース管理システムと統合するための情報の保持、論理コンポーネントへのアプリケーションの整理の補助なども行います。It also contains build information for each file, maintains the information to integrate with source-control systems, and helps you organize your application into logical components. ただし、インストールされているパッケージの一覧など、ワークスペース関連の情報は、ワークスペース自体とは別に保持されます。Workspace-related information such as the list of installed packages, however, is maintained separately in the workspace itself.

プロジェクトは常に Visual Studio のソリューション内で管理され、ソリューションは相互に参照する可能性のある任意の数のプロジェクトを含むことができます。Projects are always managed within a Visual Studio solution, which can contain any number of projects that can reference one another. Visual Studio で複数種類のプロジェクトを使用する」を参照してください。See Use multiple project types in Visual Studio.

新規 R プロジェクトを作成するCreating a new R project

  1. Visual Studio を起動します。Start Visual Studio.
  2. [ファイル]、[新規]、[プロジェクト] の順に選択します。(Ctrl+Shift+N)Choose File > New > Project... (Ctrl+Shift+N)
  3. [テンプレート]、[R] で "R Project" を選択し、プロジェクトに名前と場所を指定し、[OK] を選択します。Select "R Project" from under Templates > R, give the project a name and location, and select OK:

    Visual Studio 内の R (VS2017 の RTVS) の [新しいプロジェクト] ダイアログ ボックス

このコマンドにより、エディターに空の script.R ファイルが開き、プロジェクトが作成されます。This command creates a project with an empty script.R file open in the editor. また、ソリューション エクスプローラーでは、プロジェクト内に他の 2 つのファイルが表示されます。Notice also in Solution Explorer there are two other files in the project:

テンプレートから作成される R プロジェクトの内容

.Rhistory では、[R インタラクティブ] ウィンドウに入力したすべてのコマンドが記録されます。The .Rhistory records whatever commands you enter into the R Interactive window. [R ツール] > [Windows] > [履歴] コマンドで、専用の履歴ウィンドウを開くことができます。You can open a dedicated history window with the R Tools > Windows > History command. そのウィンドウには、履歴の内容を消去するためのツール バー ボタンとコンテキスト メニュー項目が含まれています。That window has a toolbar button and context menu items to clear history contents.

rproject.rproj ファイルには、Visual Studio では管理されていない一部の R 固有のプロジェクト設定が保持されています。The rproject.rproj file maintains certain R-specific project settings that aren't otherwise managed by Visual Studio:

プロパティProperty 既定値Default 説明Description
VersionVersion 11.0 プロジェクトの作成に使用された R Tools for Visual Studio のバージョン。The version of R Tools for Visual Studio used to create the project.
RestoreWorkspaceRestoreWorkspace 既定値Default プロジェクト ディレクトリの .RData ファイルから以前のワークスペース変数を自動的に読み込みます。Automatically load previous Workspace variables from the .RData file in the project directory.
SaveWorkspaceSaveWorkspace 既定値Default プロジェクトを閉じるときに、現在のワークスペース変数をプロジェクト ディレクトリの .RData ファイルに保存します。Save current workspace variables to the .RData file in the project directory when closing a project.
AlwaysSaveHistoryAlwaysSaveHistory 既定値Default プロジェクトを閉じるときに、現在の対話型ウィンドウ履歴をプロジェクト ディレクトリの .RHistory ファイルに保存します。Save current Interactive Window history to the .RHistory file in the project directory when closing a project.
EnableCodeIndexingEnableCodeIndexing [はい]Yes コード検索速度を向上するために、バックグラウンドのインデックス作成タスクを実行するかどうかを決定します。Determines whether to run a background indexing task to speed code searches.
UseSpacesForTabUseSpacesForTab [はい]Yes エディターで Tab キーが押されたときに、スペースを挿入するか (Yes)、またはタブ文字を挿入するか (No) を決定します。Determines whether to insert spaces (Yes) or a Tab character (No) when the Tab key is pressed in the editor.
NumSpacesForTabNumSpacesForTab 22 UseSpacesForTab が Yes の場合に挿入するスペースの数。The number of spaces to insert if UseSpacesForTab is Yes.
エンコードEncoding UTF-8UTF-8 .R ファイルの既定のエンコーディング。The default encoding for .R files.
RnwWeaveRnwWeave SweaveSweave Rnw ファイルを編集するときに使用するパッケージ。Package to use when weaving a Rnw file.
LaTeXLaTeX pdfLaTeXpdfLaTeX RMarkdwon を PDF に変換するときに使用するライブラリ。Library to use when converting RMarkdwon to PDF.

ファイルのフォルダーを R プロジェクトに変換するConverting a folder of files to an R project

プロジェクトで管理したい .R ファイルの既存のフォルダーがある場合は、次の手順を実行します。If you have an existing folder of .R files that you want to manage in a project, do the following steps:

  1. 前のセクションに従って Visual Studio で新しいプロジェクトを作成します。Create a new project in Visual Studio as in the previous section.
  2. プロジェクト フォルダーにファイルをコピーします。Copy your files into the project folder.
  3. Visual Studio ソリューション エクスプローラーでプロジェクトを右クリックし、[追加]、[既存の項目] の順に選択し、追加するファイルを参照します。In the Visual Studio Solution Explorer, right-click the project, select Add > Exiting Item, and browse to the files you want to add. それらのファイルは [OK] を選択するとプロジェクト ツリーに表示されます。Those files appear in your project tree after selecting OK.
  4. コードをサブフォルダーに移動して整理するには、プロジェクトを右クリックし、[追加]、[新しいフォルダー] の順に選択し、そのフォルダーにファイルをコピーして、手順 3 の既存の項目を追加します。To organize code into subfolders, right-click the project, select Add > New Folder first, then copy your files into that folder and add those existing items in step 3.

プロジェクト プロパティProject properties

プロジェクトのプロパティ ページを開くには、ソリューション エクスプローラーでプロジェクトを右クリックし、[プロパティ] を選択するか、[プロジェクト] > [<プロジェクト名> のプロパティ]* メニュー項目を選択します。To open the project property pages, right-click the project in **Solution Explorer and select Properties, or select the *Project > (project name) properties... menu item. 開いているウィンドウには、次のようなプロジェクトのプロパティが表示されます。The window that opens displays project properties:

タブTab プロパティProperty 説明Description
実行Run スタートアップ ファイルStartup file [Source startup file](ソース スタートアップ ファイル) コマンドを選択し、F5 キーを押し、[デバッグ]、[デバッグの開始] の順に選択するか、[デバッグ]、[デバッグなしで開始] の順に選択して実行するファイルの名前。The name of the file that is run with Source startup file command, F5, Debug > Start debugging, or Debug > Start without debugging. プロジェクトでファイルを右クリックし、[R スタートアップ スクリプトとして設定] を選択して、そのファイルをスタートアップ ファイルとして設定することもできます。Right-clicking the file in the project and selecting Set as startup R script also sets it as the startup file.
Reset R Interactive on Run (実行時に R インタラクティブをリセットする)Reset R Interactive on Run プロジェクトの実行時に、インタラクティブ ウィンドウのワークスペースのすべての変数を消去します。Clears all variables from the interactive window's workspace when running the project. この操作を実行することで、前回の実行結果のワークスペース内容が確実に消去されます。Doing so guarantees that there's no residual workspace contents from pervious runs.
Remote Project Path (リモート プロジェクト パス)Remote Project Path リモート ワークスペースのパス。Path to a remote workspace.
Transfer files on run (実行時にファイルを転送する)Transfer files on run [Files to transfer](転送するファイル) のフィルターに従って、実行ごとにプロジェクト ファイルをリモート ワークスペースにコピーするかどうかを指定します。Indicates whether the project files, subject to the filter in Files to transfer, are to be copied to a remote workspace with each run.
Files to transfer (転送するファイル)Files to transfer [Transfer files on run](実行時にファイルを転送する) がオンの場合に、コピーする特定のファイルを示すファイル名とワイルドカード。Filenames and wildcards indicating the specific files to copy to a remote workspace if Transfer files on run is selected.
設定Settings (Settings.R ファイル)(Settings.R file) プロジェクト内にある Settings.R または *.Settings.R ファイルに由来する R プロジェクト設定。R project settings come from Settings.R or *.Settings.R files that are located inside the project. 設定ファイルがない場合は、変数を追加してページを保存すると、既定の Settings.R ファイルが作成されます。If there is no settings file, you can add variables, save the page, and a default Settings.R file is created for you. また、*[ファイル]、[新しい項目の追加] メニュー コマンドの順に選択して、設定ファイルをプロジェクトに追加することもできます。You can also add settings file to the project through the *File > Add New Item... menu command.
設定は R コードとして保存され、そのファイルをソースにして他のモジュールを実行できるので、事前に定義した設定で環境を事前に設定することができます。Settings are stored as R code and the file can be sourced before running other modules, thus pre-populating environment with the predefined settings.

R 固有のプロジェクト コマンドR-specific project commands

Visual Studio プロジェクトでは、右クリック メニューと [プロジェクト] メニューのどちらからでも、複数の一般的なコマンドを使用できます。Visual Studio projects support a number of general commands through both the right-click menu and the Project menu. これらの一般的な機能については、「Visual Studio のソリューションおよびプロジェクト」を参照してください。For details on these general capabilities, see Solutions and Projects in Visual Studio. ただし、Keep in mind, however, that

R Tools for Visual Studio (RTVS) の右クリック メニューには、R プロジェクト、およびプロジェクト内のファイルとフォルダー用の独自のコマンドが多数追加されています。R Tools for Visual Studio (RTVS) adds a number of its own commands to the right-click menu for an R project and also files and folders within the project.

コマンドCommand 説明Description
[作業ディレクトリをここに設定]Set Working Directory Here R インタラクティブ ウィンドウの作業ディレクトリをプロジェクト フォルダーに設定します。これは、プロジェクト内の任意のサブフォルダーでも使用することができます。Sets the R Interactive window's working directory to the project folder, which can also be used on any subfolder within a project.
[含んでいるフォルダーを開く]Open Containing Folder Windows エクスプローラーで選択したファイルの場所を開きます。Opens Windows Explorer at the location of the selected file.
[R スクリプトを追加]Add R Script 既定の名前で新しい .R ファイルを作成して開きます。Creates and opens a new .R file with a default name. また、[追加]、[新しい項目] コマンドの順に選択して .R ファイルや他のファイルの種類を作成することもできます。You can also use the Add > New Item... command to create .R files as well as a number of other file types. R 固有の項目テンプレート」を参照してください。See R-specific item templates.
[R Markdown を追加]Add R Markdown 既定の名前で新しい .rmd ドキュメントを作成して開きます。Creates and opens new .rmd document with a default name. また、[追加]、[新しい項目] コマンドの順に選択して .rmd ファイルや他のファイルの種類を作成することもできます。You can also use the Add > New Item... command to create .rmd files as well as a number of other file types. R 固有の項目テンプレート」を参照してください。See R-specific item templates.
[ストアド プロシージャの公開]Publish Stored Procedures プロセスを開始して、R スクリプトにストアド プロシージャが含まれている場合はそれを公開します。Starts a process to publish any stored procedures contained in R scripts. SQL Server ストアド プロシージャの使用」を参照してください。See Working with SQL Server stored procedures.

R 固有の項目テンプレートR-specific item templates

RTVS には、各ファイルの種類用に複数のテンプレートが含まれています。RTVS includes a number of templates for specific file types. このテンプレートにアクセスするには、R プロジェクトを右クリックして [追加]、[新しい項目] の順に選択するか、[プロジェクト]、[新しい項目の追加] の順に選択するか、[ファイル]、[新規]、[ファイル] の順に選択して、[R] タブを選択します。テンプレートを確認するには、新しいプロジェクトを作成してさまざまな種類のファイルを挿入してみることをお勧めします。You access templates by right-clicking an R project and selecting Add > New Item..., by selecting Project > Add New Item..., or by using File > New > File... and selecting the R tab. The best way to explore a template is to create a new project and insert files of each type.

注意

[追加]、[新しい項目] コマンドの順に選択すると、以下の一覧にはない一般的なファイルの種類も表示されます。[ファイル]、[新規]、[ファイル] の順に選択した場合は、[全般] タブに表示されます。The Add > New Item... commands also display general file types that aren't listed in the table; with File > New > File... those types are contained instead on the General tab.

ファイルの種類File Type 説明Description
R スクリプトR Script R コマンド ラインに入力できるものと同じコマンドを含むテキスト ファイル。A text file containing the same commands that can be entered on the R command line.
R MarkdownR Markdown R Markdown ドキュメントを含むファイル。A file containing an R Markdown document.
R 設定R Settings R アプリケーション設定を含むファイル。A file that holds R application settings.
R ドキュメントR Documentation 名前、エイリアス、およびタイトルの各フィールドのみを含む一般的な R ドキュメント ファイル。A generic R documentation file containing only name, alias, and title fields.
R ドキュメント (関数)R Documentation (Function) 関数を説明するコメントが指定された多くのフィールドを含む R ドキュメント ファイル。An R documentation file containing many fields with comments for describing a function.
R ドキュメント (データセット)R Documentation (Dataset) データセットを説明するコメントが指定された多くのフィールドを含む R ドキュメント ファイル。An R documentation file containing many fields with comments for describing a dataset.
SQL クエリSQL Query 空の .sql ファイル。And empty .sql file. SQL Server Integration」(SQL Server の統合) を参照してください。See SQL Server integration.
R を使用したストアド プロシージャStored Procedure with R 子の SQL クエリと子のストアド プロシージャ テンプレート ファイルを含む R ファイル。An R file with child SQL Query and child stored procedure template file. SQL Server Integration」(SQL Server の統合) を参照してください。See SQL Server integration.

Visual Studio で複数種類のプロジェクトを使用するUse multiple project types in Visual Studio

Visual Studio ソリューションには、1 つの論理的な場所に関連するプロジェクトを集めて管理できる便利な場所が用意されています。Visual Studio Solutions provide a convenient place to gather and manage related projects in one logical place. この場所を利用してコードを整理し、チーム内のコラボレーションを容易にすることができます。Solutions help keep your code organized and facilitates collaboration within teams.

以下の例では、R と Azure Machine Learning を使用して構築したモデルを含む R プロジェクト、Python/scikit-learn プロジェクト、演算処理が集中するモジュールを含む C++ プロジェクト、データ管理用の SQL プロジェクト、結果を公開する Web サイト用の Python/Bottle プロジェクトがソリューションに含まれています。In the example below, the solution contains an R project with a model built using R and Azure Machine Learning, a Python/scikit-learn project, a C++ project containing modules for intensive computational work, a SQL project for data management, and a Python/Bottle project for the web site that publishes the result:

ソリューション内の複数の関連するプロジェクトが表示された Visual Studio ソリューション エクスプローラー

太字のプロジェクトはソリューションの "スタートアップ" プロジェクトです。これを変更するには、別のプロジェクトを右クリックし、[スタートアップ プロジェクトに設定] を選択します。The project highlighted with boldface is the "startup" project for the solution; to change it, right-click a different project and select Set as startup project.

注意

現時点では、明示的に R から C#/C++ 言語に統合する機能はありません (Python 用にはあります。「Python 用 C++ 拡張機能の作成」を参照してください)。At present, there isn't any explicit R to C#/C++ language integration in place (as there is for Python, see Creating a C++ extension for Python). ただし、R 用の C# および C++ ブリッジを提供するライブラリは利用できます。However there are libraries available that provide C# and C++ bridges for R.

プロジェクトとソリューションの一般的な管理方法の詳細については、「Visual Studio のソリューションおよびプロジェクト」を参照してください。For more information on managing projects and solutions in general, see Solutions and Projects in Visual Studio.