変数エクスプローラーVariable Explorer

変数エクスプローラー ウィンドウは、[R Tools] > [ウィンドウ] > [変数エクスプローラー] (または、 [R Tools] > [データ サイエンスの設定] を使用した場合は Ctrl + 8 キー) を使用して開きます。このウィンドウには、現在の R セッションでの特定のスコープにあるすべての変数が表示されます。The Variable Explorer window, opened using R Tools > Windows > Variable Explorer (or Ctrl+8 if you've used R Tools > Data Science Settings), shows all variables at a given scope in the current R session. たとえば、変数エクスプローラーを開いて対話型ウィンドウに以下の行を入力したとします。For example, if you're opened the Variable Explorer and enter the following lines in the interactive window:

x <- 42
y <- 43
n <- c(1,2,3,5,8,13)

変数エクスプローラー ウィンドウには次のように表示されます。The Variable Explorer window then appears as follows:

Visual Studio の変数エクスプローラー ウィンドウ

より複雑な R データ フレームが定義されているセッションでは、データに移動できます。If you have a more complex R data frame defined in the session, you can navigate into the data. たとえば、cars <- mtcars の実行後、変数エクスプローラーでさまざまなノードを展開して、データセット内を移動することができます。For example, after running cars <- mtcars you can navigate through the dataset by expanding the different nodes in the Variable Explorer:

変数エクスプローラーの展開ビュー

変数を削除するには、右クリックして [削除] を選択するか、変数を選択して Del キーを押します。To delete variables, right-click and select Delete, or select the variable and press the Delete key.

インクリメンタル検索を使用して、データ フレームで測定項目を検索することもできます。You can also search for an observation in a data frame using incremental search. まず検索対象データ フレームのノードを展開してから、検索ボックスに検索語句を入力します。First, expand the nodes in the data frame that you want to search, then enter search terms in the search box.

詳細 (テーブル) ビューDetails (table) view

多くの場合データは表形式であるため、複合データ型を個別のテーブルとして表示できます。そのためには、虫眼鏡アイコンを選択するか、右クリックして [詳細の表示] を選択します。Because data is often tabular, you can view any complex data type as a separate table by selecting the magnifying glass icon or right-clicking and selecting Show Details.

変数エクスプローラー

列見出しをクリックすると、その列を基準にデータが並べ替えられます (クリックするたびに昇順と降順が切り替わります)。Clicking on a column heading sorts the data by column (alternating between ascending and descending). Shift キーを押しながら他の列をクリックすると、それらの列が並べ替えの対象として追加されます。Holding down Shift and clicking on additional columns adds those columns to the sorting as well. Shift キーを押さずに 1 つの列をクリックすると、単一の列を基準にした並べ替えに戻ります。Clicking a column without Shift returns to single column sorting.

列見出しをクリックする順序によって、並べ替えの実行順序が決まります。The sequence in which you click the column headings determines the order in which the sorting is performed. たとえば、Shift キーを押しながら cyl 列をクリックし、次に Shift キーを押したまま mpg 列を 2 回クリックすると、リストはシリンダー数の昇順に並べ替えられた後、燃費の降順に並べ替えられます。For example, Shift-clicking the cyl column, then Shift-clicking the mpg column twice, sorts the list for ascending cylinders and descending miles-per-gallon:

2 つの列を基準にしたデータの並べ替えを示すテーブル ビュー。

変数エクスプローラーとテーブル ビューは、別の Visual Studio ウィンドウに表示されるため、作業しやすい配置になるように並べて表示できます。Because Variable Explorer and the table views are in separate Visual Studio windows, you can arrange them however you like for side-by-side work. 一般的な操作手順については、「Visual Studio のウィンドウ レイアウトをカスタマイズする」を参照してください。See Customize window layouts in Visual Studio for general instructions.

Excel (またはその他の CSV に対応したアプリケーション) で開くOpen in Excel (or other CSV-capable application)

さらに処理したり分析したりするには、セッション変数を CSV にエクスポートすると便利なことがよくあります。For further manipulation and analysis, it's often useful to export session variables to CSV. エクスポートは、変数エクスプローラーの各ノードの横にある小さい Excel のアイコン (Excel エクスポート アイコン) を使うか、項目を右クリックして [CSV アプリで開く] を選びます。Exporting is done with the small Excel icon (Excel export icon) next to each node in the Variable Explorer, or by right-clicking an item and selecting Open in CSV App. このアイコンを選択すると、%userprofile%\Documents\RTVS_CSV_Exports フォルダーの新規 CSV ファイルにデータが書き込まれ、そのファイルが起動されて、.csv の拡張子に関連付けられているアプリケーションで開きます。Selecting the icon writes the data to a new CSV file in the %userprofile%\Documents\RTVS_CSV_Exports folder and then launches that file, which opens it in whatever application is associated with the .csv extension.

スコープScopes

既定では、変数エクスプローラーはグローバル スコープで開かれます。By default the Variable Explorer opens to the global scope. ウィンドウ上部のドロップダウンからパッケージを選択することで、パッケージ スコープに切り替えることができます。You can switch to a package scope by selecting a package from the drop-down at the top of the window.

パッケージ スコープが表示された変数エクスプローラー

また、デバッガーのブレークポイントで停止したとき、関数スコープに切り替えることもできます (変数エクスプローラーがデバッグ中のコードの関数スコープに自動的に切り替わることはありません)。You can also switch to a function scope when stopped at a breakpoint in the debugger (note that Variable Explorer does not automatically switch to the function scope of the code being debugged):

デバッグ中のデータ フレームが表示された変数エクスプローラー

デバッガーでコードをステップ実行するときには、変数エクスプローラーが自動的に関数スコープに切り替わり、関数のローカル変数などが表示されます。Variable Explorer automatically changes function scope as you step through code in the debugger, such as showing local variables in a function.

変数エクスプローラーへのデータのインポートImporting data into Variable Explorer

変数エクスプローラー ツール バーの 2 つのコマンド ([R Tools] > [データ] メニューから選択することもできます) を使用して、外部 CSV データセットを R セッションにインポートできます。[データセットを Web URL から R セッションにインポートする][データセットをテキスト ファイルから R セッションにインポートする]の 2 つです。Two commands on the Variable Explorer toolbar, which are also available through the R Tools > Data menu, import external CSV datasets into your R session: Import Dataset into R Session from Web URL and Import Dataset into R Session from Text File.

インポートする CSV ファイルを指定すると、Visual Studio の [データセットのインポート] ダイアログ ボックスが表示されます。このダイアログ ボックスで、データ ファイルの解析方法 (つまり、フィールド区切り記号は何か、引用符をどう扱うかなど) を制御するオプションを指定します。Once you've identified the CSV file to import, Visual Studio displays an Import Dataset dialog in which you have options to control how that data file is parsed (that is, what the field separator is and how to handle quotes). インポートしたデータ フレームのプレビューと元のデータ ファイルを表示することもできます。You can also see a preview of the imported data frame and the original data file:

[データセットのインポート] ダイアログ ボックス