R でデータを視覚化するCreating visual data plots with R

データ サイエンティストのワークフローにおいて、プロットは重要な部分を担います。Plotting is a key part of a data scientist's workflow. R Tools for Visual Studio (RTVS) では、あらゆるプロット行為は 1 つまたは複数のプロット ウィンドウを中心に行われます。プロット ウィンドウはこの重要な行為の生産性を上げるように設計されています。In R Tools for Visual Studio (RTVS), all plotting activity centers around one or more plot windows, which are designed to improve your productivity with this key activity.

ヒーローのイメージをプロットする

このトピックの内容In this topic:

次の動画 (2 分 02 秒) は RTVS によるプロットを簡単に説明しています。The following video (2m 02s) provides a brief tour of plotting in RTVS:

プロット ウィンドウThe plot window

プロット ウィンドウには一連のプロットが入ります。各プロットは plot コマンドで生成されます。A plot window holds a series of plots, where each plot is generated by a plot command. たとえば、plot(1:100) を使用すると、プロット ウィンドウがない場合に新しく作成されます。For example, using plot(1:100) creates a new plot window if one isn't already available:

1 ~ 100 の線形プロット

技術的には、R plot コマンドがその出力を R グラフィックス デバイスにレンダリングし、プロット ウィンドウが R グラフィックス デバイスのコンテンツをレンダリングします。そのため、各プロット ウィンドウにデバイス番号が与えられます。Technically speaking, R plot commands render their output to an R graphics device; a plot window renders the contents of an R graphics device, which is why each plot window is given a device number.

プロット ウィンドウは Visual Studio プロジェクトに依存せず、プロジェクトを読み込んだり、閉じたりしても、プロット ウィンドウは開いている状態を維持します。Plot windows are independent of Visual Studio projects, and remain open as you load and close projects.

プロットの生成には "アクティブな" プロット ウィンドウが使用されます。前のプロットはプロット履歴に保存されます (「プロット履歴」参照)。Generating a plot uses the "active" plot window, saving any previous plot it the plot history (see Plot history). たとえば、「plot(100:1)」と入力すると、最初のプロットが下の行に置き換えられます。For example, enter plot(100:1) and the first plot is replaced with a downward line.

他のすべての Visual Studio ウィンドウと同様に、Like all other Visual Studio windows. プロット ウィンドウのレイアウトはカスタマイズできます (「Visual Studio のウィンドウ レイアウトをカスタマイズする」参照)。the plot window supports customized layouts (see Customize window layouts in Visual Studio. プロット ウィンドウは Visual Studio フレーム内のさまざまな場所にドッキングできます。このとき、そのフレームの中でサイズが変更されます。あるいは、フレームから完全に引き出し、フレームに関係なくサイズを変更できます。Plot windows can be docked at different locations within the Visual Studio frame, resized within that frame, or pulled out of the frame entirely for independent resizing.

プロット ウィンドウのサイズを変更すると必ずプロットが再レンダリングされ、最良の画質が与えられます。Resizing a plot window always re-renders the plot to provide the best quality image. プロットのサイズ変更は通常、次のセクションで説明するコマンドを利用し、プロットをファイルまたはクリップボードにエクスポートする前に行います。You typically want to resize a plot before exporting the plot to a file or to the clipboard using the commands described in the next section.

プロット ウィンドウ コマンドPlot window commands

プロット ウィンドウのツールバーには適用できるコマンドが表示されます。コマンドの大半は、[R Tools]、[プロット] メニューの順に選択しても表示できます。The plot window's toolbar holds applicable commands, most of which are also available through the R Tools > Plots menu.

ボタンButton コマンドCommand 説明Description
新しいプロット ウィンドウ ボタン 新しいプロット ウィンドウNew plot window 個別のプロット ウィンドウとその履歴を作成します。Creates a separate plot window with its own history. 複数のプロット ウィンドウ」を参照してください。See Multiple plot windows.
プロット ウィンドウをアクティブにするボタン プロット ウィンドウをアクティブにするActivate plot window 後続の plot ウィンドウが現在のプロット ウィンドウにレンダリングされるように、現在のプロット ウィンドウをアクティブ ウィンドウとして設定します。Sets the current plot window as the active window, so that subsequent plot commands are rendered to that window. 複数のプロット ウィンドウ」を参照してください。See Multiple plot windows. 複数のプロット ウィンドウ」を参照してください。See Multiple plot windows.
プロット履歴ウィンドウ ボタン プロット履歴ウィンドウPlot history window 履歴にあるすべてのプロットをサムネイルとして表示した状態でウィンドウを開きます。Opens a window with all the plots in the history shown as thumbnails. プロット履歴」を参照してください。See Plot history.
プロット履歴ボタン 前/次のプロットPrevious/Next Plot 履歴の前のプロット/次のプロットに移動します。Navigates to the previous or next plot in the history. Ctrl + Alt + F11 (前) と Ctrl + Alt + F12 (次) でも移動できます。You can also navigate the history with Ctrl+Alt+F11 (Previous) and Ctrl+Alt+F12 (Next). プロット履歴」を参照してください。See Plot history.
イメージとして保存ボタン イメージとして保存Save As Image ファイル名の入力を求め、現在のプロット (ウィンドウ コンテンツ、ウィンドウ サイズ) をイメージ ファイルに保存します。Prompts for a filename and saves the current plot (the window contents, at the window size) to an image file. 利用できる形式は .png.jpg.bmp.tif です。Available formats are .png, .jpg, .bmp, and .tif.
PDF として保存ボタン PDF として保存Save As PDF 現在のウィンドウ サイズで現在のプロットを PDF ファイルに保存します。Saves the current plot to a PDF file, using the current window size. PDF が拡大または縮小されると、プロットは再レンダリングされます。The plot will re-render if the PDF is scaled.
ビットマップとしてコピー ボタン ビットマップとしてコピーCopy As Bitmap 現在のウィンドウ サイズでプロットをラスター ビットマップとしてクリップボードにコピーします。Copies the plot to the clipboard as a raster bitmap, using the current window size.
メタファイルとしてコピー ボタン メタファイルとしてコピーCopy As Metafile プロットを Windows メタファイル としてクリップボードにコピーします (Wikipedia)。Copies the plot to the clipboard as a Windows metafile (Wikipedia).
プロットの削除ボタン プロットの削除Remove Plot 履歴から現在のプロットを削除します。Removes the current plot from the history.
すべてのプロットをクリア ボタン すべてのプロットをクリアClear All Plots 履歴からプロットをすべて削除します (確認が求められます)。Removes all plots from the history (prompts for confirmation).

複数のプロット ウィンドウMultiple plot windows

データ サイエンティストは多くの異なるデータセットから多くのプロットを操作することがよくあるので、RTVS では必要な数だけ独立したプロット ウィンドウを作成できます。Because data scientists often work with many plots from many different datasets, RTVS lets you create as many independent plot windows. これらのウィンドウは、Visual Studio のフレーム内またはフレーム外に好きなように配置できます。You can then arrange those windows however you like within the Visual Studio frame or outside that frame altogether. (ウィンドウのドッキングとサイズ変更に関する全般情報については、「Visual Studio のウィンドウ レイアウトをカスタマイズする」を参照してください。)(See Customize window layouts in Visual Studio for general information on docking and resizing windows.)

新しいプロット ウィンドウはツールバーのボタンか、[R Tools]、[プロット]、[新しいプロット ウィンドウ] で作成できます。You create a new plot window using the toolbar button or R Tools > Plots > New Plot Window. 新しいプロット ウィンドウは "アクティブ" ウィンドウとなり、新しいプロットがレンダリングされます。The new plot window becomes the active window, which is where new plots are rendered. アクティブ ウィンドウを変更するには、アクティブにするウィンドウに切り替え、[プロット ウィンドウをアクティブにする] ツールバー ボタンか、[R Tools]、[プロット]、[プロット ウィンドウをアクティブにする] を選択します。To change the active window, switch to it and select the Activate Plot Window toolbar button or R Tools > Plots > Activate Plot Window.

プロットも非依存オブジェクトです。つまり、プロット ウィンドウ間でコピーしたり、移動したりできます。マウスでドラッグ アンド ドロップするか、右クリック コンテキストや [編集] メニューの [コピー][切り取り][貼り付け] コマンドを使用します。Plots, too, are independent objects, which means you can copy or move them between plot windows using either drag-and-drop with the mouse, or by using the Copy, Cut, and Paste commands on the right-click context and Edit menus.

ドラッグ アンド ドロップの既定の動作はコピーです。移動するには、Shift キーを押しながらドラッグ アンド ドロップします。The default behavior for drag-and-drop is copy; to move, drag-and-drop while holding down the Shift key.

プロット履歴Plot history

プロット コマンドは各ウィンドウのプロット履歴に保存されます。セッション内のすべてのプロットが保存されます。Plot commands are maintained in a plot history for each window, ensuring that all your plotting within a session is preserved. 履歴内を移動するには、プロット ウィンドウ ツールバーの矢印ボタンを使用するか、Ctrl + Alt + F11 と Ctrl + Alt + F12 を使用します。To navigate the history, use the arrow buttons on the plot window toolbar, or Ctrl+Alt+F11 and Ctrl+Alt+F12. ツールバーのボタンか、[R Tools]、[プロット] メニュー コマンドを使用し、単一プロットを削除したり、ウィンドウからすべてのプロットを消去したりできます。You can also remove single plots or clear all plots from the window again using toolbar buttons or the R Tools > Plots menu commands.

プロットのコレクション全体を表示するには、ツールバーのボタンか、[R Tools]、[プロット]、[プロット履歴ウィンドウ] を使用してプロット履歴ウィンドウを開きます。To see the entire collection of plots, open the plot history window using the toolbar button or R Tools > Plots > Plot History Window. 履歴により、そのウィンドウに表示されていたプロットのサムネイルが一覧表示されます。プロット ウィンドウ (またはデバイス) 別に分類されます。The history gives you a list of thumbnails for the plots that have been displayed in that window, grouped by the different plot windows (or devices). ツールバーのズーム ボタンを使用すると、サムネイルのサイズが変更されます。Using the zoom buttons on the toolbar changes the size of the thumbnails.

プロット履歴ウィンドウ

プロットを関連ウィンドウで開くには、そのプロットをダブルクリックして選択し、[プロットの表示] ツールバー ボタンを選択するか、右クリックして [プロットの表示] を選択します。To open a plot in its associated window, double-click that plot, select it, and then select the Show Plot toolbar button or right-click and select Show Plot. 個々のプロットを選択し、右クリック コンテキストか [編集] メニューからコピー、切り取り、削除することもできます。You can also select an individual plot and copy, cut, or delete from the right-click context or Edit menus.

すべてのウィンドウにわたり、プロット履歴の有効期間はインタラクティブ R セッションの有効期間によって決まります。The lifetime of your plot history across all windows is bound to the lifetime of your interactive R session. R セッションをリセットするか、Visual Studio を終了して再起動すると、プロット履歴がリセットされます。If you reset your R session, or exit and restart Visual Studio, your plot history is reset.

プロット ウィンドウをプログラムで操作するProgrammatically manipulating plot windows

R コードからプロット ウィンドウをプログラムで操作できます。デバイス番号を利用し、特定のプロット ウィンドウを特定します。You can programmatically manipulate plot windows from R code, using device numbers to identify specific plot windows.

  • dev.list(): 現在の R セッション内のグラフィックス デバイスをすべて一覧表示します。dev.list(): List all of the graphics devices within the current R session.
  • dev.new(): 新しいグラフィックス デバイス (新しいプロット ウィンドウ) を作成します。dev.new(): Create a new graphics device (a new plot window).
  • dev.set(<device number>): アクティブなグラフィックス デバイスを設定します。dev.set(<device number>): Set the active graphics device.
  • dev.off(): アクティブなデバイスを削除します。dev.off(): Delete the active device.