単体テスト プロジェクトを作成するCreate a unit test project

単体テストでは、多くの場合、テスト対象のコードの構造を再現します。Unit tests often mirror the structure of the code under test. たとえば、製品のコード プロジェクトごとに単体テスト プロジェクトを作成します。For example, a unit test project would be created for each code project in the product. テスト プロジェクトは本稼働コードと同じソリューションに置くことも、別個のソリューションに置くこともできます。The test project can be in the same solution as the production code, or it can be in a separate solution. 1 つのソリューションに複数の単体テスト プロジェクトを置くこともできます。You can have multiple unit test projects in a solution.

注意

ネイティブ コードの単体テストの場所とテスト プロジェクトの構造は、このトピックの説明にある構造とは異なっていても構いません。The location of unit tests for native code and the test project structure can be different than the structure that is described in this topic. 詳細については、「既存の C++ アプリケーションへの単体テストの追加」を参照してください。For more information, see Adding unit tests to existing C++ applications.

単体テスト プロジェクトを作成するには:To create a unit test project:

  1. [ファイル] メニューの [新規作成] をクリックし、 [プロジェクト] をクリックします (キーボード: Ctrl + Shift + N)。On the File menu, choose New and then choose Project (Keyboard Ctrl + Shift + N).

  2. [新しいプロジェクト] ダイアログ ボックスで、[インストール済み] ノードを展開して、テスト プロジェクトで使用する言語を選択し、[テスト] をクリックします。In the New Project dialog box, expand the Installed node, choose the language that you want to use for your test project, and then choose Test.

  3. Microsoft 単体テスト フレームワークの 1 つを使用するには、プロジェクト テンプレートの一覧から [単体テスト プロジェクト] を選択します。To use one of the Microsoft unit test frameworks, choose Unit Test Project from the list of project templates. それ以外の場合は、使用する単体テスト フレームワークのプロジェクト テンプレートを選択します。Otherwise, choose the project template of the unit test framework that you want to use. この例の Accounts プロジェクトをテストするために、プロジェクトの名前を AccountsTests に設定します。To test the Accounts project of our example, you would name the project AccountsTests.

  4. 単体テスト プロジェクトに、テスト対象のコードへの参照を追加します。In your unit test project, add a reference to the code under test. 同じソリューションのコード プロジェクトへの参照を作成する方法は次のようになります。Here's how to create the reference to a code project in the same solution:

    1. ソリューション エクスプローラーでプロジェクトを選択します。Select the project in Solution Explorer.

    2. [プロジェクト] メニューの [参照の追加]をクリックします。On the Project menu, choose Add Reference....

    3. [参照マネージャー] ダイアログ ボックスで、[ソリューション] ノードを開き、[プロジェクト] を選択します。In the Reference Manager dialog box, open the Solution node and choose Projects. コード プロジェクトの名前を選択し、ダイアログ ボックスを閉じます。Check the code project name and close the dialog box.

  5. テストするコードが別の場所にある場合、「プロジェクト内の参照の管理」を参照してください。If the code that you want to test is in another location, see Managing references in a project for information about adding references.

次の手順Next steps

単体テストの記述Writing unit tests

次のいずれかのセクションを参照してください。See one of the following sections: