Windows インストーラーを使用して Office ソリューションを配置します。Deploy an Office solution by using Windows Installer

Visual Studio 2013Visual Studio 2013を使用して Office ソリューション用の Windows インストーラーを作成する方法について説明します。Learn how to create a Windows Installer for your Office solution by using Visual Studio 2013Visual Studio 2013.

Visual Studio を使用して Windows インストーラーを作成すると、エンド ユーザーのコンピューターに対する管理アクセスを必要とする Office ソリューションを配置できます。By using Visual Studio to create a Windows Installer, you can deploy an Office solution that requires administrative access on the end user's computer. たとえば、1 台のコンピューターのすべてのユーザーを対象にして、1 度のみの実行でソリューションをインストールするファイルを使用することができます。For example, you can use such a file to install a solution only once for all users of a computer. これ以外に、ClickOnce を使用して Office ソリューションを配置することもできますが、そのソリューションは、コンピューター上のユーザーごとに個別にインストールする必要があります。You can also deploy an Office solution by using ClickOnce, but that solution must be installed separately for each user of the computer.

このトピックの内容In this topic

ClickOnce を使用して Office ソリューションをデプロイする方法の詳細については、次を参照してください。 ClickOnce を使用して Office ソリューションを配置します。For more information about how to deploy an Office solution by using ClickOnce, see Deploy an Office solution by using ClickOnce.

使用して、Windows インストーラー ファイルを作成する方法についてはVisual Studio 2010Visual Studio 2010を参照してくださいVisual Studio 2010 Tools for Windows インストーラーを使用して Office ソリューションのデプロイします。For information about how to create a Windows Installer file by using Visual Studio 2010Visual Studio 2010, see Deploy a Visual Studio 2010 Tools for Office solution using Windows Installer.

サンプルのダウンロードDownload samples

このトピックでは、次のダウンロード可能なサンプルを参照します。This topic refers to the following downloadable samples.

サンプルSample

説明Description

ExcelAddInExcelAddIn

32 ビット版または 64 ビット版の Office を実行しているコンピューターにインストールできる Excel VSTO アドイン。An Excel VSTO Add-in that you can install on a computer that runs a 32-bit or 64-bit version of Office.

ExcelWorkbookExcelWorkbook

32 ビット版または 64 ビット版の Office を実行しているコンピューターにインストールできる Excel ドキュメントレベルのカスタマイズ。An Excel document-level customization that you can install on a computer that runs a 32-bit or 64-bit version of Office.

ソリューションに信頼を付与する方法の決定Decide how to grant trust to the solution

ユーザーのコンピューターでソリューションを実行する前に、次の方法のいずれかで信頼を付与する必要があります。そうしない場合は、ユーザーはソリューションをインストールするときに、信頼プロンプトに応答する必要が生じます。Before a solution can run on user computers, you must grant trust in either of the following ways, or users must respond to a trust prompt when they install the solution.

Note

ドキュメント レベルのカスタマイズでは、ドキュメントの位置も信頼する必要があります。For document-level customizations, the location of the document must also be trusted. 詳細については、次を参照してください。ドキュメントに信頼を付与します。For more information, see Grant trust to documents.

InstallShield Limited Edition の入手Get InstallShield Limited Edition

InstallShield Limited Edition (ISLE) を使用して、Windows インストーラー ファイルを作成することもできます。Visual Studio をインストールする場合は、ISLE を無料で使用できます。You can create a Windows Installer file by using InstallShield Limited Edition (ISLE), which is free if you've installed Visual Studio. ISLE は、以前のバージョンの Visual Studio で提供されていた、セットアップと配置を対象とするプロジェクト テンプレートの機能を置き換えます。ISLE replaces the functionality of the project templates for setup and deployment that previous versions of Visual Studio offered.

InstallShield Limited Edition の入手方法To get InstallShield Limited Edition

  1. メニュー バーで、[ファイル] > [新規作成] > [プロジェクト] を選択します。On the menu bar, choose File > New > Project.

    [新しいプロジェクト] ダイアログ ボックスが表示されます。The New Project dialog box opens.

  2. テンプレート ペインで、 [その他のプロジェクトの種類] を展開し、 [セットアップと配置] テンプレートをクリックします。In the templates pane, expand Other Project Types, and then choose the Setup and Deployment template.

  3. [セットアップと配置] に関するプロジェクトの種類の一覧で、 [InstallShield Limited Edition の有効化] をクリックし、 [OK] をクリックします。In the list of project types for Setup and Deployment, choose Enable InstallShield Limited Edition, and then choose the OK button.

    InstallShield Limited Edition の入手方法に関する情報を示すページが表示されます。A page appears that provides information about how to get InstallShield Limited Edition.

  4. このページで、 [ダウンロード Web サイトにアクセスします。] リンクをクリックします。On that page, choose the Go to the download web site link.

  5. InstallShield Limited Edition のダウンロード ページで、必要な情報を適切なフィールドに入力し、 [Download now] リンクをクリックします。On the download page for InstallShield Limited Edition, enter the required information into the appropriate fields, and then choose the Download Now link.

    この製品をダウンロードし、インストールしてアクティブにすると、 [InstallShield Limited Edition Project] のプロジェクト テンプレートが Visual Studio 内に表示されます。After you download, install, and activate the product, the InstallShield Limited Edition Project template appears in Visual Studio.

セットアップ プロジェクトの作成Create a setup project

  1. Visual StudioVisual Studioで、配置しようとする Office プロジェクトを開きます。In Visual StudioVisual Studio, open the Office project that you want to deploy.

    このトピックに関連付けられた VSTO アドインの例には、 ExcelAddInという名前のプロジェクトが含まれています。The VSTO Add-in samples that are associated with this topic contain a project that's named ExcelAddIn. ドキュメント レベルのカスタマイズの例には、 ExcelWorkbookという名前のプロジェクトが含まれています。The document-level customization samples contain a project that's named ExcelWorkbook. ここでは、これらの 2 つの名前のどちらかを使用して、ソリューション内で Office プロジェクトを参照します。This topic will refer to the Office project in your solution by using one of those two names.

  2. メニュー バーで、ファイル > 追加 > 新しいプロジェクトします。On the menu bar, choose File > Add > New Project.

    [新しいプロジェクトの追加] ダイアログ ボックスが表示されます。The Add New Project dialog box opens.

  3. テンプレート ペインで、 [その他のプロジェクトの種類] を展開し、 [セットアップと配置] テンプレートをクリックします。In the templates pane, expand Other Project Types, and then choose the Setup and Deployment template.

  4. [セットアップと配置] に対応するプロジェクトの種類の一覧で、 [InstallShield Limited Edition Project] をクリックし、プロジェクトに名前を付けた後、 [OK] をクリックします。In the list of project types for Setup and Deployment, choose InstallShield Limited Edition Project, name the project, and then choose the OK button.

    ソリューションに作成した、InstallShield セットアップ プロジェクトが表示されます。The InstallShield setup project that you created appears in your solution.

    このトピックで使用するサンプルには OfficeAddInSetupという名前のセットアップ プロジェクトが含まれています。The samples for this topic contain a setup project that's named OfficeAddInSetup. ここでは、同じ名前を使用して、ソリューション内でセットアップ プロジェクトを参照します。This topic will refer to the setup project in your solution by using the same name.

プロジェクト出力の追加Add the project output

Office プロジェクトの出力を含めるように、 OfficeAddInSetup プロジェクトを構成します。You configure the OfficeAddInSetup project to include the output of your Office project. VSTO アドイン プロジェクトの場合は、プロジェクト出力は、ソリューション アセンブリのみです。For VSTO Add-in projects, the project output is the solution assembly only. ドキュメント レベルのカスタマイズ プロジェクトの場合は、プロジェクト出力には、ソリューション アセンブリに加えて、ドキュメント自体も含まれています。For document-level customization projects, the project output includes not only the solution assembly but also the document itself.

プロジェクト出力を追加するにはTo add the project output

  1. ソリューション エクスプローラーで、 [OfficeAddInSetup] プロジェクト ノードを展開し、次の図に示す [Project Assistant] ファイルをクリックします。In Solution Explorer, expand the OfficeAddInSetup project node, and then choose the Project Assistant file, which the following illustration shows.

    プロジェクト アシスタント ファイル ソリューション エクスプ ローラーでProject Assistant File in Solution Explorer

  2. メニュー バーで、ビュー > オープンします。On the menu bar, choose View > Open.

  3. [Project Assistant] ページの下部で、次の図に示す [Application Files] をクリックします。At the bottom of the Project assistant page, choose the Application Files button, which the following illustration shows.

    アプリケーション ファイル ボタン。The Application Files button.

  4. [Application Files] ページで、 [Add Project Outputs] をクリックします。In the Application Files page, choose the Add Project Outputs button.

  5. [Visual Studio Output Selector] ダイアログ ボックスで、 [Primary Output] チェック ボックスをオンにし、 [OK] をクリックします。In the Visual Studio Output Selector dialog box, select the Primary Output check box, and then choose the OK button.

配置マニフェストとアプリケーション マニフェストの追加Add the deployment and application manifests

  1. [Application Files] ページで、 [Add Files] をクリックします。In the Application Files page, choose the Add Files button.

  2. [Open] ダイアログ ボックスで、 ExcelAddIn プロジェクトの出力ディレクトリを参照します。In the Open dialog box, browse to the output directory of the ExcelAddIn project.

    選択したビルド構成にもよりますが、通常、出力ディレクトリは、プロジェクトのルート ディレクトリ内にある bin\release サブフォルダーです。Usually, the output directory is the bin\release subfolder of the project root directory, depending on the build configuration that you choose.

  3. 出力ディレクトリで、 ExcelAddIn.vstoExcelAddIn.dll.manifest の両方のファイルを選択し、 [Open] をクリックします。In the output directory, choose the ExcelAddIn.vsto and ExcelAddIn.dll.manifest files, and then choose the Open button.

    次の図のように、 [Application Files] ページには、プロジェクトの出力ファイル、配置マニフェスト、およびアプリケーション マニフェストが含まれています。The Application Files page now contains the project output file, the deployment manifest, and the application manifest, as the following illustration shows.

    セットアップ プロジェクトの出力ファイル。The output files of your setup project.

依存コンポーネントを前提条件として構成Configure the dependent components as prerequisites

セットアップ アプリケーション内で、次のコンポーネントに加えて、ソリューションを実行するために必要な他のすべてのコンポーネントがも含める必要があります。In your setup application, you must include not only the following components but also any other components that are required for your solution to run.

  • Office ソリューションが対象とする .NET Framework のバージョン。The version of the .NET Framework that your Office solution targets.

  • Microsoft Visual Studio 2010 Tools for Office RuntimeThe Microsoft Visual Studio 2010 Tools for Office Runtime.

前提条件として .NET Framework 4 または .NET Framework 4.5 を追加します。Add the .NET Framework 4 or the .NET Framework 4.5 as a prerequisite

  1. ソリューション エクスプローラーで、 [OfficeAddInSetup] プロジェクト ノードを展開し、 [Specify Application Data] ノードを展開してから、次の図に示す [Redistributables] ファイルをクリックします。In Solution Explorer, expand the OfficeAddInSetup project node, expand the Specify Application Data node, and then choose the Redistributables file, which the following illustration shows.

    ソリューション エクスプ ローラーで、再頒布可能パッケージ ファイルThe Redistributables file in Solution Explorer

  2. メニュー バーで、ビュー > オープンします。On the menu bar, choose View > Open.

    [Redistributables] ページが開きます。The Redistributables page opens.

  3. 再頒布可能コンポーネントの一覧で、ソリューションが対象とする .NET Framework のバージョンに対応する適切なチェック ボックスをオンにします。In the list of redistributable components, select appropriate the check box for the version of the .NET Framework that your solution targets.

    たとえば、ソリューションで .NET Framework 4.5.NET Framework 4.5を対象とする場合は、 [Microsoft .NET Framework 4.5 Full] チェック ボックスをオンにします。For example, if your solution targets the .NET Framework 4.5.NET Framework 4.5, select the Microsoft .NET Framework 4.5 Full check box. 前提条件であるコンポーネントを追加する前に、InstallShield で必要とされる再頒布可能コンポーネントをインストールするかどうかを問い合わせるダイアログ ボックスが表示される可能性があります。A dialog box might appear asking whether you want to install the redistributable component, which InstallShield requires before you can add the component as a prerequisite. このダイアログ ボックスが表示されない場合、コンポーネントがコンピューターに既に存在します。If this dialog box doesn't appear, the component already exists on your computer.

  4. このダイアログ ボックスが表示された場合は、 [No] をクリックします。If this dialog box appears, choose the No button.

Visual Studio 2010 Tools for Office Runtime の追加Add the Visual Studio 2010 Tools for Office Runtime

[Redistributables] ページには [Microsoft VSTO 2010 Runtime] という名前の項目が含まれていますが、これはランタイムの古いバージョンを参照しています。The Redistributables page contains an item that's named Microsoft VSTO 2010 Runtime, but it refers to an older version of the runtime. したがって、最新バージョンを参照する構成ファイルを手動で作成することができます。Therefore, you could manually create a configuration file that refers to the most recent version. そのファイルを、 [Redistributables] ページに表示される他の項目すべてに対応する構成ファイルと同じディレクトリに配置する必要があります。You must then put that file into the same directory as the configuration files for all of the other items that appear in the Redistributables page.

前提条件として、Visual Studio 2010 Tools for Office ランタイムを追加するにはTo add the Visual Studio 2010 Tools for Office runtime as a prerequisite

  1. メモ帳を開き、次の XML をテキスト ファイルに貼り付けます。Open Notepad, and then paste the following XML into a text file.

    <?xml version="1.0" encoding="UTF-8"?>
    <SetupPrereq>
    <conditions>
        <condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VSTO Runtime Setup\v4R" FileName="Version" ReturnValue="10.0.50903" Bits="2"></condition>
    <condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VSTO Runtime Setup\v4R" FileName="Version" ReturnValue="10.0.50903" Bits="2"></condition>
    </conditions>
    <files>
        <file LocalFile="<ISProductFolder>\SetupPrerequisites\VSTOR\vstor_redist.exe" URL="http://download.microsoft.com/download/C/0/0/C001737F-822B-48C2-8F6A-CDE13B4B9E9C/vstor_redist.exe" CheckSum="88b8aa9e8c90818f98c80ac4dd998b88" FileSize=" 0,40117912"></file>
    </files>
    <execute file="vstor_redist.exe" returncodetoreboot="1641,3010" requiresmsiengine="1">
    </execute>
    <properties Id="{15965040-56BB-49B8-A88F-3525C48D9BA8}" Description="This prerequisite installs the most recent version of the Microsoft Visual Studio 2010 Tools for Office Runtime." >
    </properties>
    
    </SetupPrereq>
    
  2. Visual Studio での GUID の生成。Generate a GUID in Visual Studio. [ツール] メニューの [GUID の作成] をクリックします。On the Tools menu, choose Create GUID.

  3. [GUID ジェネレーター] プログラム内で、 [4. レジストリ形式 ( {xxxxxxx-xxxx ... xxxx })] オプション ボタンをクリックし、 [コピー] をクリックし、 [終了] をクリックします。In the GUID generator program, choose the Registry Format option button, choose the Copy button, and then choose the Exit button.

  4. メモ帳で、テキスト Your GUID goes here の位置に GUID を貼り付け、そのテキストを置換します。In Notepad, replace the text Your GUID goes here by pasting the GUID in its place.

    次の図のように、 <properties> 要素は、次の例のようになります。The <properties> element of your file resembles the following.

    <properties Id="{87989B73-21DC-4403-8FD1-0C68A41A6D8C}" Description="This prerequisite installs the most recent version of the Microsoft Visual Studio 2010 Tools for Office Runtime." >
    </properties>
    
  5. メモ帳でメニュー バー、ファイル > 保存します。On the menu bar in Notepad, choose File > Save.

  6. [名前を付けて保存] ダイアログ ボックスで、 [デスクトップ] フォルダーを参照します。In the Save As dialog box, browse to your Desktop folder.

  7. 型として保存一覧で、選択すべてのファイル (*.*).In the Save as type list, choose All Files (*.*).

  8. [ファイル名] ボックスに、「 Visual Studio 2010 Tools for Office Runtime.prq」と入力し、 [保存] をクリックします。In the File name box, enter Visual Studio 2010 Tools for Office Runtime.prq, and then choose the Save button.

    Note

    このファイルが前提条件であることを識別できるように、ファイル名の末尾に「 .prq 」を追加してください。Make sure that you add .prq at the end of the file name to identify this file as a prerequisite file.

  9. メモ帳を閉じます。Close Notepad.

  10. デスクトップフォルダーをコピー、 Visual Studio 2010 Tools for Office Runtime.prqファイルをコンピューターに、次のディレクトリのいずれかにします。From your Desktop folder, copy the Visual Studio 2010 Tools for Office Runtime.prq file to one of the following directories on your computer.

32 ビット オペレーティング システム: %ProgramFiles%\InstallShield\2013LE\SetupPrerequisites\For 32-bit operating systems: %ProgramFiles%\InstallShield\2013LE\SetupPrerequisites\

64 ビット オペレーティング システム: % %programfiles (x86) %\2013LE\SetupPrerequisites\For 64-bit operating systems: %ProgramFiles(x86)%\2013LE\SetupPrerequisites\

  1. InstallShield プロジェクトの [Redistributable] ページで、次の図に示すように、再頒布可能コンポーネントの一覧を更新するために [Refresh] をクリックします。In the Redistributable page of the InstallShield project, choose the Refresh button to refresh the list of redistributable components, as the following illustration shows.

更新ボタン。The refresh button.

  1. 再頒布可能コンポーネントの一覧で、 [Visual Studio 2010 Tools for Office Runtime] チェック ボックスをオンにします。In the list of redistributable components, select the Visual Studio 2010 Tools for Office Runtime check box.

再頒布可能コンポーネントをインストールするかどうかを問い合わせるダイアログ ボックスが表示される可能性があります。A dialog box might appear asking whether you want to install the redistributable component. このダイアログ ボックスが表示されない場合に進んで、ユーザーのコンピューターにソリューションを配置する場所を指定するこのトピックの「します。If this dialog box doesn't appear, you can skip to the Specify where you want to deploy the solution on the user's computer section of this topic.

  1. このダイアログ ボックスが表示された場合は、 [No] をクリックします。If this dialog box appears, choose the No button.

ユーザーのコンピューター上でのソリューションのインストール場所の指定Specify where to install the solution on the user's computer

  1. ソリューション エクスプローラーで、 [OfficeAddInSetup] ノードを展開し、 [Organize your Setup] ノードを展開してから [General Information] ファイルをクリックします。In Solution Explorer, expand the OfficeAddInSetup node, expand the Organize your Setup node, and then choose the General Information file.

  2. メニュー バーで、ビュー > オープンします。On the menu bar, choose View > Open.

  3. プロパティの一覧で、 [INSTALLDIR] プロパティの隣にある [参照] ボタンをクリックします。In the list of properties, choose the Browse button next to the INSTALLDIR property.

  4. Set INSTALLDIR ダイアログ ボックスで、ソリューションをインストールするユーザーのコンピューター上のフォルダーを選択します。In the Set INSTALLDIR dialog box, choose a folder on the user's computer where you want to install the solution.

    Note

    Set INSTALLDIR ダイアログ ボックスで、一覧の中にある任意のフォルダーに対応するショートカット メニューを開いて、サブディレクトリを作成することもできます。You can also create subdirectories in the Set INSTALLDIR dialog box by opening the shortcut menu for any folder in the list.

VSTO アドインの構成します。Configure a VSTO Add-in

コンピューターを使用するすべてのユーザーに対して (コンピューター単位)、またはインストールを実行するユーザーに対してのみ (ユーザー単位)、VSTO アドインをインストールするかどうかを指定できます。You can specify whether you want your VSTO Add-in to be installed for all users of the computer (per-computer), or only for the user performing the installation (per-user).

コンピューター単位のインストールをサポートする場合は、2 つの別々のインストーラーを作成します。If you want to support per-computer installations, create two separate installers. Office のバージョン (32 ビットおよび 64 ビット)、またはユーザーが実行されている Windows のバージョン (32 ビットおよび 64 ビット) に基づいてインストーラーを分割できます。You can split installers based on the Office version (32-bit and 64-bit) or on the Windows version (32-bit and 64-bit) that the user is running.

ユーザー単位のインストールでは、Office または Windows のバージョンにかかわらず、必要なインストーラーは 1 つだけです。Per-user installations require only one installer regardless of Office or Windows version.

Note

このセクションでは、VSTO アドインを配置する場合にのみ適用されます。This section applies only if you're deploying a VSTO Add-in. 直ちに移動できますドキュメント レベルのカスタマイズを配置する場合、ドキュメント レベルのカスタマイズを構成するセクション。If you're deploying a document-level customization, you can immediately go to the Configure a document-level customization section.

ユーザー単位またはコンピューター単位のインストールをサポートするかどうかを指定するにはTo specify whether you want to support per-user or per-computer installations

  1. ソリューション エクスプローラーで、 [OfficeAddInSetup] ノードを展開し、 [Organize Your Setup] ノードを展開してから [General Information] ファイルをクリックします。In Solution Explorer, expand the OfficeAddInSetup project node, expand the Organize Your Setup node, and then choose the General Information file.

  2. メニュー バーで、ビュー > オープンします。On the menu bar, choose View > Open.

    セットアップ プロジェクトのプロパティが表示されます。The properties of the setup project appear.

  3. [AllUSERS] プロパティの一覧で、コンピューター上のすべてのユーザーに対してこのソリューションをインストールするか、またはこのソリューションをインストールしようとするユーザーのみに対してインストールするかを指定します。In the list for the AllUSERS property, specify whether you want this solution to be installed for all users of the computer or for only the user who installs the solution.

    現在のユーザー用の VSTO アドインをインストールするには、選択ALLUSERS =""(per-user installation) します。To install the VSTO Add-in for the current user, choose ALLUSERS="" (Per-user installation). コンピューターのすべてのユーザーに対して VSTO アドインをインストールするには、 [ALLUSERS=1 (Per-machine installation)] を選びます。To install the VSTO Add-in for all users of the computer, choose ALLUSERS=1 (Per-machine installation)

    次の手順では、Office アプリケーションを検出し、読み込む VSTO アドインを有効にするレジストリ キーを作成します。In the next procedure, you'll create registry keys to enable the Office application to discover and load the VSTO Add-in. 参照してくださいVSTO アドインのレジストリ エントリします。See Registry entries for VSTO Add-ins.

レジストリ キーを作成するにはTo create registry keys

  1. ソリューション エクスプローラーで、 [Project Assistant] ノードをクリックします。In Solution Explorer, choose the Project Assistant node.

    メニュー バーで、ビュー > オープンします。On the menu bar, choose View > Open.

  2. [Project Assistant] ページの下部で、次の図に示す [Application Registry] をクリックします。At the bottom of the Project assistant page, choose the Application Registry button, which the following illustration shows.

    アプリケーション レジストリ ボタン。The Application Registry button.

    [Application Registry] ページが表示されます。The Application Registry page appears.

  3. [Do you want to configure the registry data that your application will install?] の下で、 [Yes] オプション ボタンをクリックします。Under Do you want to configure the registry data that your application will install?, choose the Yes option button.

  4. Destination computer's Registry view一覧で、キー階層を作成するインストーラーの種類を有効を追加します。In the Destination computer's Registry view list, add the key hierarchy that enables the type of installer you want to create.

    このセクションで構成するパスは、ユーザー単位のインストーラーとコンピューター単位のインストーラーのどちらを作成するかによって異なります。The path that you configure in this section depends on whether you create a per-user installer or a per-computer installer.

    ユーザー単位のインストーラーPer-user installer

    HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

    Office のバージョンに基づくコンピューター単位のインストーラーPer-computer installers based on Office version

Office のバージョンOffice version

InstallShield の構成パスInstallShield Configuration Path

32 ビット32-bit

HKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

64 ビット64-bit

HKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

Windows のバージョンに基づくコンピューター単位のインストーラーPer-computer installers based on Windows version

Windows のバージョンWindows version

InstallShield の構成パスInstallShield Configuration Path

32 ビット32-bit

HKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

64 ビット64-bit

HKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

HKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

Note

64 ビット Windows 用のインストーラーでは、64 ビット Windows を実行するコンピューターで 32 ビットおよび 64 ビット バージョンの Office を実行する可能性があるために、2 つのレジストリ パスが必要です。An installer for 64-bit Windows requires two registry paths because it's possible for users to run 32-bit and 64-bit versions of Office on a computer that runs 64-bit Windows.

Note

ベスト プラクティスとして、VSTO アドインの名前の先頭を、自分の会社の名前にします。As a best practice, start the name of your VSTO Add-in with the name of your company. この規則では、キーが一意になるし、別のサプライヤーから VSTO アドインとの競合の可能性が低くなります可能性が高くなります。This convention increases the chance that the key will be unique and decreases the chance of conflict with a VSTO Add-in from another supplier. 同じ名前を持つ複数のアドインは、たとえば、互いのレジストリ キーを上書きする可能性があります。Add-ins that have the same name can, for example, overwrite each other's registration keys. この手法で、キーが一意になることを保証できるわけではありませんが、名前が競合する可能性を小さくすることができます。This approach can't guarantee that the key will be unique but can reduce potential name collisions.

  1. キーの階層を作成した後は、ショートカット メニューを開き、 SampleCompany.ExcelAddInキーの選択新規を選び、文字列値After you've created the hierarchy of keys, open the shortcut menu for the SampleCompany.ExcelAddIn key, choose New, and then choose String Value.

    新しい文字列値が先のコンピューターのレジストリ データ一覧。The new string value appears in the Destination computer's Registry data list. この文字列値の名前が強調表示されていて、その名前を変更することができます。The name of the string value is highlighted so that you can rename it.

  2. 値の名前を「 Description」に変更します。Rename the value to Description.

  3. この手順を繰り返して、次の値を追加します。Repeat this process to create the following values.

値型Value Type

名前Name

[Key]String Value

FriendlyNameFriendlyName

DWORD 値DWORD Value

LoadBehaviorLoadBehavior

[Key]String Value

ManifestManifest

  1. [Description] 値のショートカット メニューを開き、 [Modify] をクリックします。Open the shortcut menu for the Description value, and then choose Modify.

    [データの編集] ダイアログ ボックスが表示されます。The Edit Data dialog box appears.

  2. [Value data] テキスト ボックスに「 Excel Demo Add-In」と入力し、 [OK] ボタンを選びます。In the Value data text box, enter Excel Demo Add-In, and then choose the OK button.

    この説明は、ユーザーが Office アプリケーションを開き、 [オプション] ダイアログ ボックスの [アドイン] ウィンドウでこの VSTO アドインを選んだときに表示されます。This description appears when the user opens the Office application, opens the Options dialog box, and then, in the Add-Ins pane, chooses the VSTO Add-in.

  3. [FriendlyName] 値のショートカット メニューを開き、 [Modify] をクリックします。Open the shortcut menu for the FriendlyName value, and then choose Modify.

[データの編集] ダイアログ ボックスが表示されます。The Edit Data dialog box appears.

  1. [Value data] テキスト ボックスに「 Excel Demo Add-In」と入力し、 [OK] ボタンを選びます。In the Value data text box, enter Excel Demo Add-In, and then choose the OK button.

この文字列は、Office アプリケーションの [COM アドイン] ダイアログ ボックスに表示されます。This string appears in the COM Add-Ins dialog box in the Office application. 既定では、文字列の値は、VSTO アドインの ID です。By default, the value of the string is the VSTO Add-in ID.

  1. [LoadBehavior] 値のショートカット メニューを開き、 [Modify] をクリックします。Open the shortcut menu for the LoadBehavior value, and then choose Modify.

[データの編集] ダイアログ ボックスが表示されます。The Edit Data dialog box appears.

  1. [Value data] テキスト ボックスに「 3」と入力し、 [OK] ボタンを選びます。In the Value data text box, enter 3, and then choose the OK button.

アプリケーションの起動時に、3 という値を使用して VSTO アドインが読み込まれます。A value of 3 loads the VSTO Add-in when the application starts. LoadBehavior 値の詳細については、次を参照してください。 VSTO アドインのレジストリ エントリします。For more information about LoadBehavior values, see Registry entries for VSTO Add-ins.

  1. [Manifest] 値のショートカット メニューを開き、 [Modify] をクリックします。Open the shortcut menu for the Manifest value, and then choose Modify.

[データの編集] ダイアログ ボックスが表示されます。The Edit Data dialog box appears.

  1. [Value data] テキスト ボックスに「 file:///[INSTALLDIR]ExcelAddIn.vsto|vstolocal」と入力し、 [OK] ボタンを選びます。In the Value data text box, enter file:///[INSTALLDIR]ExcelAddIn.vsto|vstolocal, and then choose the OK button.

Visual Studio 2010 Tools for Office Runtime は、配置マニフェストを見つけるために、このパスを使用します。The Visual Studio 2010 Tools for Office Runtime uses this path to locate the deployment manifest. このパスの [INSTALLDIR] の部分は、InstallShield セットアップ プロジェクトの [一般情報] プロパティ ページ内の INSTALLDIR プロパティへのマップを行うマクロです。The [INSTALLDIR] portion of this path is a macro that maps to the INSTALLDIR property in the General Information property page of your InstallShield setup project. このプロパティは、VSTO アドインのインストール先になる、ターゲット コンピューター上の位置を指定します。This property specifies the location on the target computer to install the VSTO Add-in. |vstolocal サフィックスにより、ClickOnce キャッシュではなく、インストール フォルダーからソリューションが読み込まれます。The |vstolocal suffix ensures that your solution is loaded from the installation folder, not the ClickOnce cache.

Important

Outlook 用 VSTO アドインでカスタム フォーム領域を作成する場合は、領域を Outlook に登録するレジストリ エントリを作成する必要があります。If you create a custom form region in a VSTO Add-in for Outlook, you must create more registry entries to register the region with Outlook. 詳細については、次を参照してください。フォーム領域の Outlook 用のレジストリ エントリします。For more information, see Registry entries for Outlook form regions.

Configure a document-level customizationConfigure a document-level customization

このセクションでは、ドキュメント レベルのカスタマイズを配置する場合にのみ適用されます。This section applies only if you're deploying a document-level customization. 直ちに移動できますが、VSTO アドインを配置する場合、セットアップ プロジェクトのビルドセクション。If you're deploying a VSTO Add-in, you can go immediately to the Build the setup project section.

ドキュメント レベルのカスタマイズには、レジストリ キーを使用しないでください。Document-level customizations don't use registry keys. その代わりに、カスタム ドキュメント プロパティの中に、配置マニフェストの場所が格納されます。Instead, custom document properties contain the location of the deployment manifest.

カスタム プロパティを変更するには、ドキュメント レベルのカスタマイズをドキュメントから削除し、適切なプロパティを変更します、ドキュメントにカスタマイズを再アタッチされますプログラムを作成します。To modify custom properties, you create a program that removes the document-level customization from the document, modifies the appropriate properties, and then reattaches customization to the document. その後、プログラムを実行するカスタム アクションを作成し、そのアクションをセットアップ プロジェクトに追加します。You then create a custom action that runs the program, and you add that action to your setup project.

ドキュメントのプロパティを変更するプログラムを作成するにはTo create a program that modifies document properties

  1. メニュー バーで、ファイル > 追加 > 新しいプロジェクトします。On the menu bar, choose File > Add > New Project.

    [新しいプロジェクトの追加] ダイアログ ボックスが表示されます。The Add New Project dialog box appears.

  2. [テンプレート] ペインで、使用する言語のノードの下にある [Windows] フォルダーを展開します。In the templates pane, under the node for the language that you want to use, choose the Windows folder.

  3. [Windows] のプロジェクトの種類の一覧で、 [コンソール アプリケーション] テンプレートを選択します。In the list of project types for Windows, choose the Console Application template.

  4. プロジェクトに「 SetExcelDocumentProperties」という名前を付けて [OK] ボタンを選びます。Name the project SetExcelDocumentProperties, and then choose the OK button.

  5. ソリューション エクスプローラーで、 [すべてのファイルの表示] をクリックし、 [SetExcelDocumentProperties] プロジェクト ノードのショートカット メニューを開き、 [参照の追加] をクリックします。In Solution Explorer, choose the Show All Files button, open the shortcut menu for the SetExcelDocumentProperties project node, and then choose Add Reference.

  6. [参照マネージャー] ダイアログ ボックスで、 [拡張機能] タブをクリックしてから、次のアセンブリの隣にあるチェック ボックスをオンにし、 [OK] をクリックします。In the Reference Manager dialog box, choose the Extensions tab, and then select the check box next to the following assemblies, and then choose the OK button.

    • Microsoft.VisualStudio.Tools.Applications.RuntimeMicrosoft.VisualStudio.Tools.Applications.Runtime

    • Microsoft.VisualStudio.Tools.Applications.ServerDocumentMicrosoft.VisualStudio.Tools.Applications.ServerDocument

  7. ソリューション エクスプローラーで、 [Program.cs] ファイル (C# アプリケーションの場合)、または [Module1.vb] ファイル (Visual Basic アプリケーションの場合) をクリックします。In Solution Explorer, choose the Program.cs file (for C# applications) or the Module1.vb file (for Visual Basic applications).

  8. メニュー バーで、ビュー > オープンします。On the menu bar, choose View > Open.

  9. このファイルの内容全体を次のコードで置き換えます。Replace the contents of the entire file with the following code.

Imports Microsoft.VisualStudio.Tools.Applications.Runtime
Imports Microsoft.VisualStudio.Tools.Applications

Module Module1

    Sub Main()

        Dim assemblyLocation As String = ""
        Dim solutionID As Guid
        Dim deploymentManifestLocation As Uri = Nothing
        Dim documentLocation As String = ""
        Dim nonpublicCachedDataMembers As String() = Nothing

        Dim CommandLineArgs As  _
            System.Collections.ObjectModel.ReadOnlyCollection(Of String) = _
            My.Application.CommandLineArgs

        For i As Integer = 0 To CommandLineArgs.Count - 1

            Console.WriteLine(CommandLineArgs(i))
            Dim oArugment As String() = CommandLineArgs(i).Split("=")

            Select Case oArugment(0)

                Case "/assemblyLocation"
                    assemblyLocation = oArugment(1)

                Case "/deploymentManifestLocation"
                    If Not Uri.TryCreate(oArugment(1), UriKind.Absolute, _
                                         deploymentManifestLocation) Then
                        MsgBox("Error creating URI")
                    End If

                Case "/documentLocation"
                    documentLocation = oArugment(1)

                Case "/solutionID"
                    solutionID = Guid.Parse(oArugment(1))
            End Select
        Next
        Try
            ServerDocument.RemoveCustomization(documentLocation)
            ServerDocument.AddCustomization(documentLocation, assemblyLocation, _
                                            solutionID, deploymentManifestLocation, _
                                            True, nonpublicCachedDataMembers)

            Console.WriteLine("Insallation Location Modified Successfully")

        Catch ex As System.IO.FileNotFoundException
            Console.WriteLine("The specified document does not exist.")
            Console.ReadLine()


        Catch ex As System.IO.IOException
            Console.WriteLine("The specified document is read-only.")
            Console.ReadLine()


        Catch ex As InvalidOperationException

            Console.WriteLine("The customization could not be removed.\n" &
                ex.Message)
            Console.ReadLine()


        Catch ex As DocumentNotCustomizedException
            Console.WriteLine("The document could not be customized.\n" &
                ex.Message)
            Console.ReadLine()

        End Try
    End Sub

End Module
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using Microsoft.VisualStudio.Tools.Applications.Runtime;
using Microsoft.VisualStudio.Tools.Applications;

namespace SetExcelDocumentProperties
{
    class Program
    {
        static void Main(string[] args)
        {
            string assemblyLocation = "";
            Guid solutionID = new Guid();
            Uri deploymentManifestLocation = null;
            string documentLocation = "";
            string[] nonpublicCachedDataMembers = null;

            for (int i = 0; i <= args.Count() - 1; i++)
            {
                Console.WriteLine(args[i]);
                string[] oArugment = args[i].Split('=');

                switch (oArugment[0])
                {
                    case "/assemblyLocation":
                        assemblyLocation = oArugment[1];
                        break;
                    case "/deploymentManifestLocation":
                        if (!Uri.TryCreate(oArugment[1], UriKind.Absolute, out deploymentManifestLocation))
                        {
                            Console.WriteLine("Error creating URI");
                        }
                        break;
                    case "/documentLocation":
                        documentLocation = oArugment[1];
                        break;
                    case "/solutionID":
                        solutionID = Guid.Parse(oArugment[1]);
                        break;
                }
            }
            try
            {
                ServerDocument.RemoveCustomization(documentLocation);
                ServerDocument.AddCustomization(documentLocation, assemblyLocation,
                                            solutionID, deploymentManifestLocation,
                                            true, out nonpublicCachedDataMembers);

            }
            catch (System.IO.FileNotFoundException)
            {
                Console.WriteLine("The specified document does not exist.");
            }
            catch (System.IO.IOException)
            {
                Console.WriteLine("The specified document is read-only.");
            }
            catch (InvalidOperationException ex)
            {
                Console.WriteLine("The customization could not be removed.\n" +
                    ex.Message);
            }
            catch (DocumentNotCustomizedException ex)
            {
                Console.WriteLine("The document could not be customized.\n" +
                    ex.Message);
            }
        }
    }
}
  1. プロジェクトをコンパイルします。Compile the project.

プログラムを実行するカスタム アクションを追加するにはTo add a custom action that runs your program

  1. ソリューション エクスプローラーで、 [OfficeAddInSetup] プロジェクト ノードを展開し、次の図に示す [Project Assistant] ファイルをクリックします。In Solution Explorer, expand the OfficeAddInSetup project node, and then choose the Project Assistant file, which the following illustration shows.

    プロジェクト アシスタント ファイル ソリューション エクスプ ローラーでProject Assistant File in Solution Explorer

  2. メニュー バーで、ビュー > オープンします。On the menu bar, choose View > Open.

  3. [Project Assistant] ページの下部で、次の図に示す [Application Files] をクリックします。At the bottom of the Project assistant page, choose the Application Files button, which the following illustration shows.

    アプリケーション ファイル ボタン。The Application Files button.

  4. [Application Files] ページで、 [Add Project Outputs] をクリックします。In the Application Files page, choose the Add Project Outputs button.

    [Visual Studio Output Selector] ダイアログ ボックスが表示されます。The Visual Studio Output Selector dialog box appears.

  5. [SetExcelDocumentProperties] ノードの下で、 [プライマリ出力] チェック ボックスをオンにし、 [OK] をクリックします。Under the SetExcelDocumentProperties node, select the Primary Output check box, and then choose the OK button.

  6. ソリューション エクスプローラーで、 [OfficeAddInSetup] ノードの下にある [Define Setup Requirements and Actions] ノードを展開してから [カスタム アクション] フォルダーをクリックします。In Solution Explorer, under the OfficeAddInSetup node, expand the Define Setup Requirements and Actions node, and then choose the Custom Actions folder.

  7. メニュー バーで、ビュー > オープンします。On the menu bar, choose View > Open.

    イベントの一覧は、画面の端にあるウィンドウの中に表示されます。A list of events appear in a pane to the side of the screen.

    Note

    InstallShield Limited Edition で使用できるのは、この一覧に表示されるイベントのいくつかのみです。Only a few events that appear in this list are available in InstallShield Limited Edition. この手順を使用して、プログラムを実行します、 After Setup Complete Success ダイアログイベント。In this procedure, you'll run the program by using the After Setup Complete Success dialog event.

  8. イベントの一覧で、 [Custom Actions During Installation] の下にある、 [After Setup Complete Success dialog] イベントのショートカット メニューを開き、 [New EXE] をクリックします。In the list of events, under Custom Actions During Installation, open the shortcut menu for the After Setup Complete Success dialog event, and then choose New EXE.

    [NewCustomAction1] という名前のカスタム アクションが、 [After Setup Complete Success dialog] イベントの下に表示されます。A custom action that's named NewCustomAction1 appears under the After Setup Complete Success dialog event. カスタム アクションに対応する一連のプロパティは、イベントの隣にあるウィンドウの中に表示されます。A set of properties for the custom action appears in a pane next to the events.

    Important

    [After Setup Complete Success dialog] の 2 種類のイベントは、イベントの一覧に表示されます。Two After Setup Complete Success dialog events appear in the list of events. [Custom Actions During Installation] ノードの下で、 [After Setup Complete Success dialog] イベントのインスタンスを選択してください。Make sure that you choose the instance of the After Setup Complete Success dialog event that appears under the Custom Actions During Installation node.

  9. [ソースの場所] のプロパティの一覧で、 [Installed with the Product] をクリックします。In the list for the Source Location property, choose Installed with the Product.

  10. [ファイル名] プロパティの隣にある [参照] ボタンをクリックします。Choose the Browse button next to the File Name property.

  11. [Browse for a Destination File] ダイアログ ボックスで、 [SetExcelDocumentProperties.Primary.output] ファイルを選択し、 [開く] をクリックします。In the Browse for a Destination File dialog box, browse to the SetExcelDocumentProperties.Primary.output file, and then choose the Open button.

    このファイルの場所は、セットアップ プロジェクトの [INSTALLDIR] プロパティで指定したフォルダーによって異なります。The location of this file depends on the folder that you specified for the INSTALLDIR property of the setup project. たとえば、プロパティを [PersonalFolder]DemoWorkbookAppという名前のフォルダーに設定した場合は、 [ProgramFilesFolder] \DemoWorkbookApp を参照して、 SetExcelDocumentProperties.Primary.outputファイルを見つけることができます。For example, if you set that property to a folder that's named [PersonalFolder]DemoWorkbookApp, you can find the SetExcelDocumentProperties.Primary.output file by browsing to [ProgramFilesFolder]\DemoWorkbookApp.

    次のいくつかの手順では、ドキュメントのソリューション ID を取得し、パラメーターとしてコンソール アプリケーションにその ID を渡すします。In the next few steps, you'll get the solution ID of the document and then pass that ID as a parameter to the console application. ドキュメント、配置マニフェスト、およびドキュメントのアセンブリの場所も渡す必要があります。You'll also pass the location of the document, the deployment manifest, and the document assembly.

  12. [ExcelWorkbook] プロジェクトのショートカット メニューを開き、オペレーティング システムに応じて、 [エクスプローラーでフォルダーを開く] 、または [エクスプローラーでフォルダーを開く] をクリックします。Open the shortcut menu for the ExcelWorkbook project, and then choose Open Folder in Windows Explorer or Open Folder in File Explorer depending on your operating system.

    ソリューションを含むフォルダーが開きます。The folder that contains your solution opens.

  13. ソリューションに対応するプロジェクト ファイルをメモ帳で開きます。Open the project file of your solution in Notepad. Visual Basic プロジェクト ファイルの名前はExcelWorkbook.vbprojします。For Visual Basic projects, the name of the file is ExcelWorkbook.vbproj. C# プロジェクト、ファイルの名前はexcelworkbook.csproj ですします。For C# projects, the name of the file is ExcelWorkbook.csproj.

  14. プロジェクト ファイルでの検索、 <SolutionID> 要素、その値をクリップボードにコピーし、し、メモ帳を閉じます。In the project file, search for the <SolutionID> element, copy its value to the Clipboard, and then close Notepad.

    この値を、パラメーターとしてコンソール アプリケーションに渡します。You pass this value into the console app as a parameter.

  15. [NewCustomAction1] プロパティ ページで、 [コマンド ライン] プロパティを次のテキスト行に設定します。In the properties page of NewCustomAction1, set the Command Line property to the following line of text.

/assemblyLocation="[INSTALLDIR]ExcelWorkbook.dll" /deploymentManifestLocation="[INSTALLDIR]ExcelWorkbook.vsto" /documentLocation="[INSTALLDIR]ExcelWorkbook.xlsx" /solutionID="Your Solution ID"
  1. Your Solution ID を、クリップボードにコピーしたソリューション ID で置き換えます。Replace Your Solution ID with the solution ID that you copied to the Clipboard.

Important

インストーラーをテストし、このカスタム アクションで実行するコンソール アプリケーションが INSTALLDIR ディレクトリ内のドキュメントにアクセスできることを確認します。Test your installer to verify that the console application that this custom action runs can access documents in the [INSTALLDIR] directory. 一部のディレクトリ ユーザーのコンピューターには、(たとえば、Program Files ディレクトリ) の管理アクセスを必要があります。Some directories on the user's computer might require administrative access (for example, the Program Files directory). 管理アクセス権を必要とするディレクトリにソリューションをデプロイする場合を開く必要があります、プロパティのダイアログ ボックス、 setup.exeファイルで、選択、 の互換性 、タブを選び、このプログラムを管理者として実行インストーラーを配布する前に、チェック ボックス。If you're deploying your solution to a directory that requires administrative access, you should open the Properties dialog box of the setup.exe file, choose the Compatibility tab, and then select the Run this program as administrator check box before you distribute the installer. ユーザーが管理者権限でセットアップ プログラムを実行しない場合は、ディレクトリをユーザーがアクセスする [INSTALLDIR] プロパティを設定、既になど、ドキュメントディレクトリ。If you don't want users to run the setup program with administrative permissions, set the [INSTALLDIR] property to a directory to which the user probably has access already, such as the Documents directory. 詳細については、次を参照してください。、を指定するユーザーのコンピューターにソリューションをインストールこのトピックの「します。For more information, see the Specify Where You Want to Install the Solution on the user's computer section of this topic.

Build the setup projectBuild the setup project

  1. ソリューション エクスプローラーで、 [Prepare for Release] ノードを展開し、 [Releases] ファイルをクリックします。In Solution Explorer, expand the Prepare for Release node, and then choose the Releases file.

  2. メニュー バーで、ビュー > オープンします。On the menu bar, choose View > Open.

    横のウィンドウで [Builds] エクスプローラーが開き、作成しようとするリリースの種類を選択できます。The Builds explorer opens in a side pane so that you can choose the type of release that you want to create.

  3. [Builds] エクスプローラーで、 [SingleImage] フォルダーを選択します。In the Builds explorer, choose the SingleImage folder.

  4. [Builds] エクスプローラーの横にあるペインで、 [Setup.exe] タブをクリックします。In the pane next to the Builds explorer, choose the Setup.exe tab.

  5. [Setup.exe] プロパティ ページで、 [InstallShield Prerequisites Location] の一覧から、 [Download From The Web] をクリックします。In the Setup.exe property page, from the InstallShield Prerequisites Location list, choose Download From The Web.

  6. メニュー バーで [ビルド] > [構成マネージャー] の順に選択します。On the menu bar, choose Build > Configuration Manager.

  7. [Active solution configuration] の一覧で [SingleImage] をクリックします。In the Active solution configuration list, choose SingleImage.

  8. OfficeAddInSetup プロジェクトの [Configuration] 列にある [Project contexts] の表で、 [SingleImage] をクリックしてから [Close] をクリックします。In the Project contexts table, in the Configuration column of the OfficeAddInSetup project, choose SingleImage, and then choose the Close button.

  9. メニュー バーで、ビルド > OfficeAddInSetup のビルドします。On the menu bar, choose Build > Build OfficeAddInSetup.

    ビルドが完了すると、見つけることができます、 setup.exeのファイル、 OfficeAddInSetupプロジェクトの次の場所。OfficeAddInSetupProjectRoot\OfficeAddInSetup\Express\SingleImage\DiskImages\DISK1\After the build completes, you can locate the setup.exe file of the OfficeAddInSetup project at the following location: OfficeAddInSetupProjectRoot\OfficeAddInSetup\Express\SingleImage\DiskImages\DISK1\

関連項目See also