WinDbg でのデバッガー コマンドの入力Entering Debugger Commands in WinDbg

デバッガーコマンドウィンドウは、WinDbg の主要なデバッグ情報ウィンドウです。The Debugger Command window is the primary debugging information window in WinDbg. このウィンドウでは、デバッガーコマンドを入力し、コマンドの出力を表示できます。You can enter debugger commands and view the command output in this window.

メモ このウィンドウでは、タイトルバーに "Command" が表示されます。Note This window displays "Command" in the title bar. ただし、このドキュメントでは、Microsoft MS-DOS コマンドを発行するために使用されるコマンドプロンプトウィンドウと混同しないように、"デバッガーコマンドウィンドウ" として常にこのウィンドウを参照しています。However, this documentation always refers to this window as "the Debugger Command window" to avoid confusing it with the Command Prompt windows that are used to issue Microsoft MS-DOS commands.

デバッガーコマンドウィンドウを開くOpening the Debugger Command Window

デバッガーコマンドウィンドウを開くには、[表示] メニューの [コマンド] をクリックします。To open the Debugger Command window, choose Command from the View menu. (ALT + 1 キーを押す か、 ツールバーの ![ デバッガーコマンドウィンドウ] ボタンのスクリーンショット) を選択することもでき ます。(You can also press ALT+1 or select the Command button (screen shot of the debugger command window button) on the toolbar. ALT + SHIFT + 1 を押すと、デバッガーコマンドウィンドウが閉じます)。ALT+SHIFT+1 closes the Debugger Command window.)

次のスクリーンショットは、デバッガーのコマンドウィンドウの例を示しています。The following screen shot shows an example of a Debugger Command window.

デバッガーコマンドウィンドウの例のスクリーンショット

[デバッガーコマンド] ウィンドウの使用Using the Debugger Command Window

デバッガーコマンドウィンドウが2つのペインに分割されます。The Debugger Command window is split into two panes. ウィンドウの下部にある小さいペイン (コマンド入力ウィンドウ) にコマンドを入力すると、ウィンドウの上部にある大きなウィンドウに出力が表示されます。You type commands in the smaller pane (the command entry pane) at the bottom of the window and view the output in the larger pane at the top of the window.

コマンド入力ウィンドウで、上方向キーと下方向キーを使用して、コマンド履歴をスクロールします。In the command entry pane, use the UP ARROW and DOWN ARROW keys to scroll through the command history. コマンドが表示されたら、それを編集するか、enter キーを押してコマンドを実行します。When a command appears, you can edit it or press ENTER to run the command.

デバッガーコマンドウィンドウには、追加のコマンドを含むショートカットメニューがあります。The Debugger Command window contains a shortcut menu with additional commands. このメニューにアクセスするには、ウィンドウのタイトルバーを選択して保持するか (または右クリック)、ウィンドウの右上隅の近くにあるアイコンを選択します (To access this menu, select and hold (or right-click) the title bar of the window or select the icon near the upper-right corner of the window (デバッガーコマンドウィンドウにアクセスするためのボタンのスクリーンショットショートカットメニューscreen shot of the button for accessing the debugger command window toolbar shortcut menu ).). 次の一覧では、メニューコマンドの一部について説明します。The following list describes some of the menu commands:

  • コマンド出力に追加する と、コマンド出力にコメントが追加されます ( Edit |コマンド出力コマンドに追加 します。Add to command output adds a comment to the command output, similar to the Edit | Add to Command Output command.

  • コマンドの出力をクリア すると、ウィンドウ内のすべてのテキストが削除されます。Clear command output deletes all of the text in the window.

  • テキストの色の選択と選択の色 の変更...デバッガーで選択されているテキストを表示するテキストの色を選択できるダイアログボックスを表示しコマンドウィンドウします。Choose text color and recolor selection... opens a dialog box that enables you to choose the text color in which to display the text that is selected in the Debugger Command window.

  • [右端 で折り返す] をオンまたはオフにします。Word wrap turns the word wrap status on and off. このコマンドは、この状態が選択された後に使用するコマンドだけでなく、ウィンドウ全体に影響を及ぼします。This command affects the whole window, not only commands that you use after this state is selected. 多くのコマンドと拡張機能では書式付き表示が生成されるため、右端での折り返しを使用しないことをお勧めします。Because many commands and extensions produce formatted displays, it is not recommended that you use word wrap.

  • [現在の場所 としてマーク] コマンドウィンドウの現在のカーソル位置にマーカーを設定します。Mark current location sets a marker at the current cursor location in the command window. マークの名前は、カーソルの右側の行の内容です。The name of the mark is the contents of the line to the right of the cursor.

  • [マークに移動 ] を選択すると、ウィンドウがスクロールされ、選択したマークを含む行がウィンドウの上部に配置されます。Go to mark causes the window to scroll so that the line that contains the chosen mark is positioned at the top of the window.

  • [フローティング] を指定すると、ドッキング位置にドラッグした場合でも、ウィンドウがドッキング解除されたままになります。Always floating causes the window to remain undocked, even if it is dragged to a docking location.

  • [フレームで移動] ウィンドウがドッキング解除されている場合でも、WinDbg フレームが移動されるとウィンドウが移動します。Move with frame causes the window to move when the WinDbg frame is moved, even if the window is undocked. ドッキングウィンドウ、タブ付きウィンドウ、フローティングウィンドウの詳細については、「 windows の配置」を参照してください。For more information about docked, tabbed, and floating windows, see Positioning the Windows.