収束 NIC の物理スイッチ構成Physical switch configuration for Converged NIC

適用先:Windows Server (半期チャネル)、Windows Server 2016Applies to: Windows Server (Semi-Annual Channel), Windows Server 2016

このトピックでは、物理スイッチを構成するためのガイドラインを提供します。In this topic, we provide you with guidelines for configuring your physical switches.

コマンドとその用途は次のとおりです。Nic が接続されている環境のポートを確認する必要があります。These are only commands and their uses; you must determine the ports to which the NICs are connected in your environment.

重要

VLAN および非ドロップポリシーが、SMB が構成されている優先順位に設定されていることを確認します。Ensure that the VLAN and no-drop policy is set for the priority over which SMB is configured.

Arista スイッチ ( dc - 7050s - 64、EOS - 4.13.7 m)Arista switch (dcs-7050s-64, EOS-4.13.7M)

  1. (管理者モードに移行します。通常はパスワードの入力を求めます。)en (go to admin mode, usually asks for a password)
  2. (構成モードに入る構成)config (to enter into configuration mode)
  3. 実行 ( 中の現在の構成を表示します)show run (shows current running configuration)
  4. Nic が接続されているスイッチポートを見つけます。find out switch ports to which your NICs are connected to. これらの例では、14/1、15/1、16/1、17/1 です。In these example, they are 14/1,15/1,16/1,17/1.
  5. int eth 14/1、15/1、16/1、17/1 は、 ( これらのポートの構成モードに入ります)int eth 14/1,15/1,16/1,17/1 (enter into config mode for these ports)
  6. dcbx モード ieeedcbx mode ieee
  7. 優先順位-フロー制御モードオンpriority-flow-control mode on
  8. switchport トランクネイティブ vlan 225switchport trunk native vlan 225
  9. switchport トランクが許可された vlan 100-225switchport trunk allowed vlan 100-225
  10. switchport モードのトランクswitchport mode trunk
  11. 優先順位フロー制御優先順位3×ドロップpriority-flow-control priority 3 no-drop
  12. qos 信頼 cosqos trust cos
  13. [実行の表示] ( ポートで構成が正しく設定されていることを確認します。)show run (verify that configuration is setup correctly on the ports)
  14. (スイッチの再起動をまたいで設定を維持する wr)wr (to make the settings persists across switch reboot)

ヒント:Tips:

  1. No #command # はコマンドを否定します。No #command# negates a command
  2. 新しい VLAN を追加する方法: ( ストレージネットワークが vlan 100 にある場合は、int vlan 100)How to add a new VLAN: int vlan 100 (If storage network is on VLAN 100)
  3. 既存の Vlan を確認する方法: vlan を表示するHow to check existing VLANs : show vlan
  4. Arista スイッチの構成の詳細については、次を参照してください: Arista EOS 手動For more information on configuring Arista Switch, search online for: Arista EOS Manual
  5. 次のコマンドを使用して、PFC 設定を確認します: 優先順位フロー制御カウンターの詳細を表示します。Use this command to verify PFC settings: show priority-flow-control counters detail

Dell スイッチ ( S4810、FTOS 9.9 ( 0.0))Dell switch (S4810, FTOS 9.9 (0.0))

    !
    dcb enable
    ! put pfc control on qos class 3
    configure
    dcb-map dcb-smb
    priority group 0 bandwidth 90 pfc on
    priority group 1 bandwidth 10 pfc off
    priority-pgid 1 1 1 0 1 1 1 1
    exit
    ! apply map to ports 0-31
    configure
    interface range ten 0/0-31
    dcb-map dcb-smb
    exit

Cisco スイッチ ( の "3132" バージョン 6.0 ( 2 ) U6 ( 1))Cisco switch (Nexus 3132, version 6.0(2)U6(1))

グローバルGlobal

    class-map type qos match-all RDMA
    match cos 3
    class-map type queuing RDMA
    match qos-group 3
    policy-map type qos QOS_MARKING
    class RDMA
    set qos-group 3
    class class-default
    policy-map type queuing QOS_QUEUEING
    class type queuing RDMA
    bandwidth percent 50
    class type queuing class-default
    bandwidth percent 50
    class-map type network-qos RDMA
    match qos-group 3
    policy-map type network-qos QOS_NETWORK
    class type network-qos RDMA
    mtu 2240
    pause no-drop
    class type network-qos class-default
    mtu 9216
    system qos
    service-policy type qos input QOS_MARKING
    service-policy type queuing output QOS_QUEUEING
    service-policy type network-qos QOS_NETWORK

ポート固有Port specific

    switchport mode trunk
    switchport trunk native vlan 99
    switchport trunk allowed vlan 99,2000,2050   çuse VLANs that already exists
    spanning-tree port type edge
    flowcontrol receive on (not supported with PFC in Cisco NX-OS)
    flowcontrol send on (not supported with PFC in Cisco NX-OS)
    no shutdown
    priority-flow-control mode on