2. プロジェクトの初期化と最初のアプリケーションの配置2. Initializing your project and deploying your first application

このチュートリアルでは、新しい Unity プロジェクトを作成し、それを Mixed Reality ツールキット (MRTK) 開発用に構成し、MRTK をインポートする方法について学習します。In this tutorial, you'll learn how to create a new Unity project, configure it for Mixed Reality Toolkit (MRTK) development, and import MRTK. また、Visual Studio で基本的な Unity シーンを構成およびビルドし、HoloLens 2 に配置する方法についても説明します。You'll also walk through configuring, building, and deploying a basic Unity scene from Visual Studio to your HoloLens 2. HoloLens 2 に配置すると、HoloLens によって認識されたサーフェスに対応する空間マッピングのメッシュが表示されるはずです。Once you have deployed it to your HoloLens 2, you should see a spatial mapping mesh covering the surfaces that are perceived by the HoloLens. さらに、手の追跡用の手と指のインジケーターと、アプリのパフォーマンスを監視するためのフレームレート カウンターも表示されるはずです。Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on app performance.

目標Objectives

  • HoloLens 開発用に Unity を構成する方法について学習するLearn how to configure Unity for HoloLens development
  • アプリをビルドして HoloLens に配置する方法について学習するLearn how to build and deploy your app to HoloLens
  • HoloLens 2 デバイスで空間マッピング メッシュ、ハンド メッシュ、フレームレート カウンターを体験するExperience the spatial mapping mesh, hand meshes, and the framerate counter on HoloLens 2 device

手順の概要Steps overview

概要手順 1 1. 新しい Unity プロジェクトを作成しますOverview Step 1 1. Create a new Unity project

概要手順 2 2. MRTK をプロジェクトにインポートしますOverview Step 2 2. Import MRTK into the project

概要手順 3 3. MRTK を使用して新しいシーンを構成しますOverview Step 3 3. Configure a new scene with MRTK

概要手順 4 4. Unity プロジェクトをビルドしますOverview Step 4 4. Build Unity Project

概要手順 5 5. UWP プロジェクトをビルドしますOverview Step 5 5. Build UWP Project

概要手順 6 6. デバイスで Project を実行しますOverview Step 6 6. Run Project on the Device

Unity プロジェクトの作成Creating the Unity project

Unity Hub を起動し、 [Projects](プロジェクト) タブを選択し、 [New](新規) ボタンの横にある 下矢印 をクリックします。Launch Unity Hub, select the Projects tab, and click the down arrow next to the New button:

Unity Hub with New button highlighted

前提条件」に指定されている Unity の バージョン を、ドロップダウンで選択します。In the dropdown, select the Unity version specified in the Prerequisites:

Unity Hub with NEW version selector dropdown

ヒント

Unity Hub で特定の Unity バージョンが利用できない場合は、Unity のアーカイブのダウンロードに関するページから、そのインストールを開始できます。If the particular Unity version is not available in Unity Hub, you can initiate the installation from Unity's Download Archive.

[Create a new project](新規プロジェクトの作成) ウィンドウで、以下のようにします。In the Create a new project window:

  • [Templates](テンプレート)3D に設定されていることを確認しますEnsure Templates is set to 3D
  • "MRTK チュートリアル" など、適切な [Project Name](プロジェクト名) を入力しますEnter a suitable Project Name, for example, MRTK Tutorials
  • プロジェクトを格納するための適切な [Location](場所) を選択します。たとえば、D:\MixedRealityLearning などChoose a suitable Location to store your project, for example, D:\MixedRealityLearning
  • [Create](作成) ボタンをクリックして、新しい Unity プロジェクトを作成して起動しますClick the Create button to create and launch your new Unity project
Unity Hub with Create a new project window filled out

注意事項

Windows で作業している場合は、255 文字の MAX_PATH 制限があります。When working on Windows, there is a MAX_PATH limit of 255 characters. そのため、Unity プロジェクトはドライブのルートの近くに保存する必要があります。Consequently, you should save the Unity project close to the root of the drive.

Unity によってプロジェクトが作成されるまで待ちます。Wait for Unity to create the project:

Unity create new project in progress

ビルド プラットフォームを切り替えるSwitching the build platform

Unity メニューで、 [File](ファイル) > [Build Settings...](ビルド設定...) を選択し、[Build Settings](ビルド設定) ウィンドウを開きます。In the Unity menu, select File > Build Settings... to open the Build Settings window:

Unity の [Build Settings...](ビルド設定...) メニュー パス

[Build Settings](ビルド設定) ウィンドウで、 [Universal Windows Platform](ユニバーサル Windows プラットフォーム) を選択し、次のようにします。In the Build Settings window, select Universal Windows Platform and:

  1. [Target Device](ターゲット デバイス)[HoloLens] に設定しますSet Target device to HoloLens
  2. [Architecture](アーキテクチャ)[ARM 64] に設定しますSet Architecture to ARM 64
  3. [Build Type](ビルドの種類)[D3D Project](D3D プロジェクト) に設定します。Set Build Type to D3D Project
  4. [Target SDK Version](ターゲット SDK バージョン)[Latest installed](最新のインストール) に設定しますSet Target SDK Version to Latest Installed
  5. [最小プラットフォーム バージョン][10.0.1024.0] に設定しますSet Minimum Platform Version to 10.0.1024.0
  6. [Visual Studio Version](Visual Studio のバージョン)[Latest installed](最新のインストール) に設定しますSet Visual Studio Version to Latest installed
  7. [Build and Run on](ビルドおよび実行対象)[USB Device](USB デバイス) に設定しますSet Build and Run on to USB Device
  8. デバッグに関する既知のパフォーマンスの問題があるため、 [Build configuration](ビルド構成)[Release](リリース) に設定しますSet Build configuration to Release because there are known performance issues with Debug
  9. [Switch Platform](プラットフォームの切り替え) ボタンをクリックしますClick the Switch Platform button

ユニバーサル Windows プラットフォーム設定が設定された Unity ビルド設定

Unity がプラットフォームの切り替えを完了するまで待ちます。Wait for Unity to finish switching the platform:

プラットフォームの切り替えが進行中の Unity

Unity でプラットフォームの切り替えが完了したら、 [x] アイコンをクリックして、[ビルド設定] ウィンドウを閉じます。When Unity has finished switching the platform, click the x icon to close the Build Settings window.

Mixed Reality Toolkit のインポートと Unity プロジェクトの構成Importing the Mixed Reality Toolkit and Configuring the Unity project

Mixed Reality Toolkit を Unity プロジェクトにインポートするには、Mixed Reality Feature Tool を使用する必要があります。これにより、開発者は Mixed Reality 機能パッケージの検出、更新、Unity プロジェクトへの追加ができます。To Import Mixed Reality Toolkit into the Unity Project you will have to use Mixed Reality Feature Tool which allows developers to discover, update, and add Mixed Reality feature packages into Unity projects. 名前またはカテゴリでパッケージを検索し、それらの依存関係を確認し、インポートする前にプロジェクト マニフェスト ファイルに提案された変更を確認することもできます。You can search packages by name or category, see their dependencies, and even view proposed changes to your projects manifest file before importing.

Microsoft ダウンロード センターから最新バージョンの Mixed Reality Feature Tool をダウンロードし、ダウンロードが完了したら、ファイルを解凍してデスクトップに保存します。Download the latest version of the Mixed Reality Feature Tool from the Microsoft Download Center, When the download is complete, unzip the file and save it to your desktop.

注意

Mixed Reality Feature Tool を実行する前に、.NET 5.0 ランタイムをインストールしてください。Before you can run the Mixed Reality Feature Tool please install .NET 5.0 runtime

ダウンロードしたフォルダーから実行可能ファイル MixedRealityFeatureTool を開き、Mixed Reality Feature Tool を起動します。Open the executable file MixedRealityFeatureTool from the downloaded folder to launch the Mixed Reality Feature Tool.

Opening MixedRealityFeatureTool

MixedRealityFeatureTool が開いたら、 [スタート] をクリックして、Mixed Reality Feature Tool の使用を開始します。Once MixedRealityFeatureTool is opened, click on Start to get started with Mixed Reality Feature Tool.

MixedRealityFeatureTool main screen

最初の手順では、省略記号 ボタンを使用して Mixed Reality Feature Tool が [プロジェクト パス] を指すようにします。[プロジェクト パス] の横にある 3 つのドットの省略記号ボタンをクリックして、エクスプローラーでプロジェクト フォルダー (D:\MixedRealityLearning\MRTK Tutorials など) を参照します。The first step is to point the Mixed Reality Feature Tool to your Project path using the ellipsis button, click on the Three dots ellipsis button next to the Project path and browse to your project folder in the explorer for example D:\MixedRealityLearning\MRTK Tutorials.

Adding Unity Path for MixedRealityFeatureTool

プロジェクトのフォルダーを見つけたら、[開く] ボタンをクリックして、Mixed Reality Feature Tool に戻ります。When you have located your project's folder, click the Open button to return to the Mixed Reality Feature Tool. 次に、 [機能の検出] をクリックします。Then click on Discover Features.

注意

Unity プロジェクト フォルダーを参照するときに表示されるダイアログには、ファイル名として '' が含まれています。The dialog that's displayed when browsing for the Unity project folder contains '' as the file name. フォルダーを選択できるようにするには、ファイル名に値が必要です。There must be a value for the file name to enable the folder to be selected.

重要

Mixed Reality Feature Tool によって、検証が実行され、Unity プロジェクト フォルダーに移動したことが確認されます。The Mixed Reality Feature Tool performs validation to ensure that it has been directed to a Unity project folder. このフォルダーには、Assets、Packages、Project Settings フォルダーが含まれている必要があります。The folder must contain Assets, Packages and Project Settings folders.

機能は、見つけやすくするためにカテゴリ別にグループ化されています。 [Mixed Reality Toolkit] ドロップダウンをクリックして Mixed Reality Toolkit に関連するパッケージを探し、 [プラットフォーム サポート] ドロップダウンをクリックして、さまざまなサポートされるプラットフォームに関連するパッケージを見つけます。Features are grouped by category to make things easier to find, click on Mixed Reality Toolkit dropdown to find packages relating to the Mixed Reality Toolkit and click on Platform Support dropdown to find packages relating various supporting platforms.

MixedRealityFeatureTool Discover Features

[Mixed Reality Toolkit Foundation] をオンにして、その横にあるドロップダウンをクリックして [MRTK 2.7.2] を選択します。また、 [Mixed Reality OpenXR Plugin 1.0.0] をオンにして、その横にあるドロップダウンをクリックして使用可能な最新バージョンを選択し、 [機能の取得] ボタンをクリックして選択したパッケージをダウンロードします。Check the Mixed Reality Toolkit Foundation and click on the dropdown next to it to select MRTK 2.7.2, also check the Mixed Reality OpenXR Plugin 1.0.0 and click on the dropdown next to it to select most recent version available, then click on Get features button to download the selected packages.

MixedRealityFeatureTool Open MixedReality

次に [Validate](検証) ボタンをクリックして、選択したパッケージを検証すると、 [No validation issues were detected](検証の問題は検出されませんでした) というメッセージを含むポップアップが表示されます。 [OK] をクリックしてポップアップを閉じ、 [Import](インポート) ボタンをクリックします。Next click on the Validate button to validate the selected package, you will get a popup with message No validation issues were detected click on OK to close the popup and click on Import button.

MixedRealityFeatureTool Select required package

Mixed Reality Toolkit をプロジェクトに追加するには、Approve(承認) ボタンをクリックします。Click on Approve Button to add the Mixed Reality Toolkit into the project.

MixedRealityFeatureTool Validate package

Unity プロジェクトを構成するConfiguring the Unity project

Unity で前のセクションのパッケージのインポートを完了すると、Unity エディターを再起動して新しいプラグイン システムのバックエンドに対して有効にするように警告するメッセージが表示されます。 [はい] をクリックしますAfter Unity has finished importing the package from the previous section, a warning message appears to restart the unity editor to enable to backends for new plugin system, click on Yes

Unity Restart Option

Unity が再起動されると、[MRTK プロジェクト コンフィギュレーター] ウィンドウが表示されます。Once the Unity restarts MRTK Project Configurator window should appear. 表示されない場合は、 [Mixed Reality] > [ツールキット] > [ユーティリティ] > [MRTK のプロジェクトの構成] に移動して手動で開くことができます。If it doesn't, you can manually open it by going to Mixed Reality > Toolkit > Utilities > Configure Project for MRTK:

[MRTK プロジェクト コンフィギュレーター] ウィンドウを開く

[Unity OpenXR プラグイン] をクリックして XR プラグイン管理を有効化し、必要なパッケージをプロジェクトに追加します。Click on Unity OpenXR Plugin to Enable XR Plugin Management and add its required packages into your project.

Unity OpenXR プラグインを追加するAdd Unity OpenXR Plugin

これにより、XR プラグイン管理に必要な Unity パッケージがインポートされます。完了したら、[MRTK プロジェクト コンフィギュレーター] で [XR プラグイン管理設定の表示] をクリックします。This will import required unity packages for XR Plugin Management, once done click on Show XR Plug-In Management Settings in MRTK project Configurator.

XR プラグイン管理設定の表示Show XR Plug-In Management Settings

これにより、 [プロジェクト設定] ウィンドウが開きます。This opens Project Settings window. [プロジェクト設定] ウィンドウの [XR プラグイン管理] で、ユニバーサル Windows プラットフォーム設定 (Windows ロゴのタブ) にいることを確認します。In the Project Settings window under XR Plug-in Management Ensure that you are in Universal Windows Platform settings (Windows logo tab). また、 [起動時に XR を初期化する] がオンになっていることを確認し、 [OpenXR] チェック ボックスと [Microsoft HoloLens 機能セット] チェック ボックスをオンにして有効にします。Also Ensure Initialize XR on Startup is checked, then click OpenXR checkbox and Microsoft HoloLens feature set checkbox to enable them.

Open XR を有効にする

[OpenXR] チェック ボックスをオンにすると、[MRTK プロジェクト コンフィギュレーター] ウィンドウに [設定の適用] ボタンと更新されたメッセージが表示されます。Once you check OpenXR checkbox, MRTK Project Configurator window will show updated message with Apply Settings button. [設定の適用] ボタンをクリックします。Click Apply Settings button.

[プロジェクト設定] ウィンドウ 1

[設定の適用] をクリックすると、コンソールに次のエラー メッセージが表示される場合があります。When you click Apply Settings, you might see this error message in the Console. これが唯一のエラーである場合、またはエラーがない場合は続行できます。You can proceed if this is the only error or there is no error.

OpenXR リモート処理のエラー メッセージ

OpenXR の構成を検証するには、 [XR プラグイン管理][OpenXR] をクリックして、次の項目を確認します。To validate OpenXR configuration, click OpenXR under XR Plug-in Management and check these items:

  • 深度送信モード: 深度 16 ビットDepth Submission Mode: Depth 16 Bit
  • インタラクション プロファイル: Microsoft ハンド インタラクション プロファイルInteraction Profiles: Microsoft Hand Interaction Profile

[プロジェクト設定] ウィンドウ 2

ヒント

深度形式を 16 ビットに減らすことはオプションですが、プロジェクトでのグラフィックス パフォーマンスの向上につながる可能性があります。Reducing the Depth Format to 16-bit is optional but may help improve graphics performance in your project. このトピックの詳細については、MRTK の「パフォーマンス」ドキュメントの「深度バッファー共有 (HoloLens)」セクションを参照してください。To learn more about this topic, you can refer to the Depth buffer sharing (HoloLens) section of MRTK's Performance documentation.

[MRTK プロジェクト コンフィギュレーター] ウィンドウで、 [次へ] をクリックし、 [適用] ボタンをクリックして設定を適用します。In the MRTK Project Configurator window, click on Next, then click the Apply button to apply the settings. (閉じた場合は、 [Mixed Reality] > [ツールキット] > [ユーティリティ] > [MRTK のプロジェクトの構成] に移動して手動で開くことができます)(If you closed it, you can manually open it by going to Mixed Reality > Toolkit > Utilities > Configure Project for MRTK)

[プロジェクト設定] ウィンドウ 3

[プロジェクト設定] ウィンドウ 4

[適用] をクリックすると、入力システムを有効にするために Unity によって再起動が試みられます。 [適用] をクリックして Unity エディターを再起動しますOnce you click on Apply, Unity will try to restart for the input system to take into effect, click on Apply to restart the Unity editor

追加のプロジェクト設定を構成するConfigure additional project settings

Unity のメニューで、[Edit](編集) > [Project Settings...](プロジェクトの設定...) を選択して [Project Settings](プロジェクトの設定) ウィンドウを開きます。In the Unity menu, select Edit > Project Settings... to open the Project Settings window.

[Project Settings](プロジェクト設定) ウィンドウで、 [Player](プレイヤー) > [Publishing Settings](公開の設定) の順に選択してから、 [Package name](パッケージ名) フィールドに適切な名前 (たとえば MRTKTutorials-GettingStarted) を入力します。In the Project Settings window, select Player > Publishing Settings, then in the Package name field, enter a suitable name, for example, MRTKTutorials-GettingStarted:

Unity の公開設定

注意

'パッケージ名' は、アプリの一意の識別子です。The 'Package name' is the unique identifier for the app. 以前にインストールしたアプリが上書きされないように、アプリを配置する前にこの識別子を変更する必要があります。You should change this identifier before deploying the app to avoid overwriting previously installed apps.

ヒント

'製品名' は、HoloLens の [スタート] メニューに表示される名前です。The 'Product Name' is the name displayed in the HoloLens Start menu. 開発中にアプリを見つけやすくするには、名前の前にアンダースコアを追加し、上部にくるように並べ替えます。To make the app easier to locate during development, add an underscore in front of the name to sort it to the top.

シーンを作成して MRTK を構成するCreating the scene and configuring MRTK

Unity メニューで、 [ファイル] > [新しいシーン] を選択します。In the Unity menu, select File > New Scene:

Unity の [New Scene](新しいシーン) メニュー パス

[新しいシーン] ウィンドウで、 [基本 (組み込み)] を選択し、 [作成] をクリックして新しいシーンを作成します。In the New Scene window select Basic (Built-in) and click on create to create a new scene:

Unity の [新しいシーン] ウィンドウ

注意

上のスクリーンショットは Unity バージョン 2020 のものです。Unity 2019 を使用している場合は、 [作成] をクリックすると、新しい空のシーンが作成されます。Above screenshot is from Unity Version 2020, if you are using Unity 2019 when you click on create a new empty scene will be created.

Unity メニューで、 [Mixed Reality] > [ツールキット] > [シーンに追加して構成する] を選択して、MRTK を現在のシーンに追加します。In the Unity menu, select Mixed Reality > Toolkit > Add to Scene and Configure... to add the MRTK to your current scene:

Unity の [Add to Scene and Configure...](シーンに追加して構成する...) メニュー パス

[Hierarchy](階層) ウィンドウで MixedRealityToolkit オブジェクトを選択したままとし、[Inspector](インスペクター) ウィンドウで、MixedRealityToolkit 構成プロファイルが DefaultMixedRealityToolkitConfigurationProfile に設定されていることを確認します。With the MixedRealityToolkit object still selected in the Hierarchy window, in the Inspector window, verify that the MixedRealityToolkit configuration profile is set to DefaultMixedRealityToolkitConfigurationProfile:

DefaultMixedRealityTookitConfigurationProfile が選択された Unity MixedRealityToolkit コンポーネント

Unity メニューで、 [File](ファイル) > [Save As...](名前を付けて保存...) を選択して [Save Scene](シーンの保存) ウィンドウを開きます。In the Unity menu, select File > Save As... to open the Save Scene window:

Unity の [Save As...](名前を付けて保存...) メニュー パス

プロジェクトの [アセット] > [シーン] の下にシーンを保存します。Save the scene in you project under Asset > Scenes.

Unity のシーン保存の [Save](保存) プロンプト ウィンドウ

手動の操作をオブジェクトに追加するAdding hand interaction to an object

Unity メニューで、 [GameObject] > [3D オブジェクト] > [キューブ] を選択して、キューブ オブジェクトをシーンに追加します。In the Unity menu, select GameObject > 3D Object > Cube to add a cube object to the scene.

シーンへのキューブの追加

[階層] ウィンドウで [キューブ] オブジェクトをクリックし、[インスペクター] ウィンドウで [変換] コンポーネントを次のように構成しますClick the Cube object in the Hierarchy window, then in the Inspector window configure its Transform component as follows

  • 位置: X = 0、Y = -0.1、Z = 0.5Position: X = 0, Y = -0.1, Z = 0.5
  • 回転:X = 0、Y = 0、Z = 0Rotation: X = 0, Y = 0, Z = 0
  • スケール: X = 0.1、Y = 0.1、Z = 0.1Scale: X = 0.1, Y = 0.1, Z = 0.1

Unity の 1 単位は 1 m です。1 Unity unit is 1 meter. キューブのサイズを 10x10x10 cm に更新し、ヘッドセットの位置 (0、0、0) から 50cm に配置しました。We have updated cube's size to 10x10x10 cm, placed at 50cm from the headset position (0,0,0). 快適に対話式操作を行うことができるように目の高さの 10cm 下です。10cm below the eye level for comfortable interaction.

既定のスケール (1、1、1) を使用すると、キューブが大きすぎます。If you use the default scale (1,1,1), the cube will be too big. 既定の位置 (0、0、0) を使用すると、キューブがヘッドセットと同じ位置に配置され、後ろに移動するまで見ることできません。If you use the default position (0,0,0), the cube will be placed at the same position as your headset and you won't be able to see it until you move backward.

変換情報の調整

シーン内のオブジェクトに焦点を合わせるには、キューブ オブジェクトをダブルクリックして、もう一度少しズームインします。To focus in on the objects in the scene, you can double-click on the Cube object, and then zoom slightly in again. または、F キーを使用してオブジェクトをズームし、焦点を合わせることもできます。Or you can use F key to zoom and focus on the object.

追跡対象の手でオブジェクトを操作してつかむには、オブジェクトに次のコンポーネントが必要です。To interact and grab an object with tracked hands, the object must have:

  • [ボックス コライダー] などのコライダー コンポーネント (Unity のキューブには、既定でボックス コライダーが既にあります)Collider component such as Box Collider (Unity's cube already has a Box Collider by default)
  • Object Manipulator (Script) コンポーネントObject Manipulator (Script) component
  • NearInteractionGrabbable (スクリプト) コンポーネントNearInteractionGrabbable(Script) component

MRTK の ObjectManipulator スクリプトを使用すると、片手または両手を使用してオブジェクトを移動、拡大縮小、回転できるようになります。MRTK's ObjectManipulator script makes an object movable, scalable, and rotatable using one or two hands. このスクリプトでは、ユーザーが自分の手でホログラムを直接操作できるように、直接操作入力モデルをサポートします。This script supports the direct manipulation input model as the script enables the user to touch holograms directly with their hands.

[Hierarchy](階層) ウィンドウで [Cube](キューブ) を選択した状態で、[Inspector](インスペクター) ウィンドウの [Add Component](コンポーネントの追加) ボタンをクリックし、Object Manipulator スクリプトを検索して選択し、Object Manipulator スクリプトをキューブ オブジェクトに追加します。With the Cube still selected in the Hierarchy window, in the Inspector window ,click on Add Component button, then search and select Object Manipulator script to add the Object Manipulator script to the cube object.

キューブへの Object Manupulator の追加

同様に繰り返して、Near Interaction Grabbable スクリプト をキューブに追加します。Repeat the same to add Near Interaction Grabbable script to the cube

キューブへの Near Interaction Grabable の追加

注意

Object Manipulator (Script) を追加すると、この場合、Object Manipulator (Script) は Constraint Manager (Script) に依存しているため、それが自動的に追加されます。When you add a Object Manipulator (Script), in this case, the Constraint Manager (Script) is automatically added because Object Manipulator (Script) depends on it.

MRTK 入力シミュレーションを使用した Unity エディターでのアプリケーションのテストTesting your application in Unity editor with MRTK input simulation

MRTK の入力シミュレーションを使用すると、デバイスにビルドしてデプロイすることなく、Unity エディターでさまざまな種類の対話式操作をテストできます。With MRTK's input simulation, you can test various types of interactions in the Unity editor without building and deploying to a device. これにより、設計および開発プロセスで複数のアイデアをすばやく繰り返すことができます。This allows you quickly iterate your ideas in the design and development process. キーボードとマウスの組み合わせを使用して、シミュレートされた入力を制御します。Use keyboard and mouse combinations to control simulated inputs.

再生ボタンをクリックして、再生モードに入ります。Click the play button and enter the play mode. 左 Shift キーまたは Space キーを押したままにしてコントローラー (シミュレートされた手) を表示します。マウスの移動によってコントローラーを動かしたり、マウス ホイールを使用してそれをカメラの遠くまたは近くに動かすこともできます。Hold the Left Shift or Space key to bring up the controller (simulated hands), Mouse movement will move the controller and also it can be moved further or closer to the camera using the mouse wheel. ポインターをキューブ上に移動したら、マウスの左ボタン を押しながら、キューブ オブジェクトをつかみます。Once the pointer is on the Cube press and hold Left Mouse Button to grab the Cube object.

  • カメラを動かすには、W、A、S、D、Q、E キーを押します。Press W, A, S, D, Q, E keys to move the camera.
  • 周囲を見回すには、マウスの右ボタン を押したまま、マウスを動かします。Hold the Right mouse button and move the mouse to look around.
  • シミュレートされた手を表示するには、Space キー (右手) または 左 Shift キー (左手) を押しますTo bring up the simulated hands, press Space bar(Right hand) or Left Shift key(Left hand)
  • シミュレートされた手をビュー内に保持するには、T キーまたは Y キーを押しますTo keep simulated hands in the view, press T or Y key
  • シミュレートされた手を回転するには、Ctrl キーを押しながらマウスを移動しますTo rotate simulated hands, press and hold Ctrl key and move mouse

ゲーム モード

HoloLens 2 デバイス用にアプリケーションをビルドするBuilding your application to your HoloLens 2

1.Unity プロジェクトのビルド1. Build the Unity project

Unity メニューで、 [File](ファイル) > [Build Settings...](ビルド設定...) を選択し、[Build Settings](ビルド設定) ウィンドウを開きます。In the Unity menu, select File > Build Settings... to open the Build Settings window.

[Build Settings](ビルド設定) ウィンドウで、 [Add Open Scenes](開いているシーンを追加する) ボタンをクリックして、 [Scenes In Build](ビルド内のシーン) リストの現在のシーンを追加します。次に [Build](ビルド) ボタンをクリックして、[Build Universal Windows Platform](ユニバーサル Windows プラットフォームのビルド) ウィンドウを開きます。In the Build Settings window, click the Add Open Scenes button to add your current scene to the Scenes In Build list, then click the Build button to open the Build Universal Windows Platform window:

UWP が選択されている [Build Settings](ビルド設定) ウィンドウが表示された Unity

[Build Universal Windows Platform](ユニバーサル Windows プラットフォームのビルド) ウィンドウで、ビルドを格納する適切な場所 (たとえば D:\MixedRealityLearning\Builds) を選択し、新しいフォルダーを作成して適切な名前 (たとえば GettingStarted) を付け、 [Select Folder](フォルダーの選択) ボタンをクリックしてビルド処理を開始します。In the Build Universal Windows Platform window, choose a suitable location to store your build, for example, D:\MixedRealityLearning\Builds, create a new folder and give it a suitable name, for example, GettingStarted, and then click the Select Folder button to start the build process:

[フォルダーの選択] プロンプト ウィンドウが表示されている [Build Settings](ビルド設定) ウィンドウが表示された Unity

Unity がビルド処理を完了するまで待ちます。Wait for Unity to finish the build process:

ビルド処理が進行中の Unity

2.アプリのビルドと配置2. Build and deploy the application

ビルド処理が完了すると、お客様がビルドを格納した場所を開くように Unity から Windows ファイル エクスプローラーに指示が出されます。When the build process has completed, Unity will prompt Windows File Explorer to open the location you stored the build. フォルダー内を移動し、ソリューション ファイルをダブルクリックして Visual Studio で開きます。Navigate inside the folder, and double-click the solution file to open it in Visual Studio:

新しく作成された Visual Studio ソリューションが選択された Windows エクスプローラー

注意

Visual Studio から新しいコンポーネントをインストールするよう求められたら、少し時間を取って、「 ツールのインストール 」ドキュメントで示されている、前提条件となるすべてのコンポーネントが用意できていることを確認してください。If Visual Studio asks you to install new components, take a moment to check that you have all the prerequisite components in the Install the Tools documentation.

[マスター] または [リリース] 構成を選択し、 [ARM64] アーキテクチャを選択し、ターゲットとして [デバイス] を選択して、HoloLens 用に Visual Studio を構成します。Configure Visual Studio for HoloLens by selecting the Master or Release configuration, the ARM64 architecture, and Device as target:

HoloLens 2 に配置するように構成された Visual Studio

ヒント

HoloLens (第 1 世代) に配置する場合は、x86 アーキテクチャを選択します。If you're deploying to HoloLens (1st generation), select the x86 architecture.

注意

HoloLens の場合、通常は ARM アーキテクチャ用にビルドします。For HoloLens, you will typically build for the ARM architecture. ただし、Unity 2019.3 には、Visual Studio で ARM をビルド アーキテクチャとして選択した場合にエラーを引き起こす既知の問題が存在します。However, there is a known issue in Unity 2019.3 that causes errors when selecting ARM as the build architecture in Visual Studio. 推奨される回避策は、ARM64 用にビルドすることです。The recommended workaround is to build for ARM64. それがオプションでない場合は [Edit](編集) > [Project Settings](プロジェクト設定) > [Player](プレイヤー) > [Other Settings](他の設定) の順に選択して、 [Graphics Jobs](グラフィック ジョブ) を無効にします。If that is not an option, go to Edit > Project Settings > Player > Other Settings and disable Graphics Jobs.

注意

ターゲット オプションとして [デバイス] が表示されない場合は、Visual Studio ソリューションのスタートアップ プロジェクトを IL2CPP プロジェクトから UWP プロジェクトに変更することが必要な場合があります。If you don't see Device as a target option, you may need to change the startup project for the Visual Studio solution from the IL2CPP project to the UWP project. それを行うには、ソリューション エクスプローラーで、[YourProjectName (Universal Windows)](YourProjectName (ユニバーサル Windows)) を右クリックし、 [スタートアップ プロジェクトに設定] を選択します。To do this, in the Solution Explorer, right-click on YourProjectName (Universal Windows) and select Set as StartUp Project.

ご利用のコンピューターに HoloLens を接続し、 [デバッグ] > [デバッグなしで開始] の順に選択して、ご利用のデバイス用にビルドして配置します。Connect your HoloLens to your computer, then select Debug > Start Without Debugging to build and deploy to your device:

Visual Studio の [デバッグなしで開始] メニュー パス

重要

デバイスに対してビルドする前に、デバイスが開発者モードになっており、かつ、開発コンピューターとペアリングされている必要があります。Before building to your device, the device must be in Developer Mode and paired with your development computer. この両方のステップを完了するには、こちらの手順に従います。Both of these steps can be completed by following these instructions.

ヒント

また、HoloLens Emulator に配置することも、サイドローディング用のアプリ パッケージを作成することもできます。You can also deploy to the HoloLens Emulator or create an App Package for sideloading.

[デバッグなしで開始] を使用すると、Visual Studio デバッガーがアタッチされていない状態でも、ご利用のデバイス上でアプリが自動的に起動します。Using Start Without Debugging automatically starts the app on your device without the Visual Studio debugger attached.

アプリを自動的に起動せずに、ご利用のデバイスに配置するには、 [ビルド] > [ソリューションの配置] の順に選択します。Select Build > Deploy Solution to deploy to your device without having the app start automatically.

注意

アプリでは、診断プロファイラーが表示される場合があります。このオン、オフを切り替えるには、音声コマンド「診断を切り替え」を使用します。You may notice the Diagnostics profiler in the app, which you can toggle on or off by using the speech command "Toggle Diagnostics". アプリへの変更がパフォーマンスに影響を与える可能性がある場合は、開発中の多くは、プロファイラーを表示したままにしておくことをお勧めします。It's recommended that you keep the profiler visible most of the time during development to understand when changes to the app may impact performance. たとえば、HoloLens アプリは 60 FPS で継続的に実行する必要があります。For example, HoloLens apps should continuously run at 60 FPS.

結論Congratulations

これで、最初の HoloLens アプリが展開されました。You've now deployed your first HoloLens app. アプリが開かれると、前面にキューブ オブジェクトが表示され、それを移動することでキューブを操作できるようになるほか、動き回ってみると、HoloLens によって認識されたサーフェスを覆う空間マッピングのメッシュが表示されるはずです。Once the app is opened you should see a Cube object in front of you and should be able to interact with the cube by moving it and also as you walk around, you should see a spatial mapping mesh covering the surfaces that are perceived by the HoloLens. さらに、手の追跡用の手と指のインジケーターと、アプリのパフォーマンスを監視するためのフレームレート カウンターも表示されるはずです。Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on app performance. これらの機能は、MRTK に含まれている基本的なもののほんの一部です。These features are just a few foundational pieces included with MRTK. 次のチュートリアルでは、コンテンツをシーンに追加して、HoloLens と MRTK の機能を調べます。In the upcoming tutorials, you'll add content to your scene to explore the capabilities of HoloLens and the MRTK.