2.Photon Unity Networking の設定2. Setting up Photon Unity Networking

概要Overview

このチュートリアルでは、Photon Unity Networking (PUN) を使用して共有エクスペリエンスの作成準備をします。In this tutorial, you will prepare for creating a shared experience using Photon Unity Networking (PUN). PUN アプリの作成方法、PUN アセットを Unity プロジェクトにインポートする方法、Unity プロジェクトを PUN アプリに接続する方法について説明します。You will learn how to create a PUN app, import PUN assets into your Unity project, and connect your Unity project to the PUN app.

目標Objectives

  • PUN アプリを作成する方法を学習するLearn how to create a PUN app
  • PUN アセットを探してインポートする方法を学習するLearn how to find and import the PUN assets
  • Unity プロジェクトを PUN アプリに接続する方法を学習するLearn how to connect your Unity project to the PUN app

Unity プロジェクトの作成と準備Creating and preparing the Unity project

このセクションでは、新しい Unity プロジェクトを作成し、MRTK 開発用に準備します。In this section, you will create a new Unity project and get it ready for MRTK development.

このためには、まず「プロジェクトの初期化と最初のアプリケーションの配置」に従ってください (デバイスにアプリケーションをビルドする手順は除きます)。これには、次の手順が含まれます。For this, first follow the Initializing your project and deploying your first application, excluding the Build your application to your device instructions, which includes the following steps:

  1. Unity プロジェクトを作成し、"MRTK チュートリアル" などの適切な名前を付けるCreating the Unity project and give it a suitable name, for example, MRTK Tutorials
  2. ビルド プラットフォームを切り替えるSwitching the build platform
  3. TextMeshPro の重要なリソースをインポートするImporting the TextMeshPro Essential Resources
  4. Mixed Reality Toolkit をインポートするImporting the Mixed Reality Toolkit
  5. Unity プロジェクトを構成するConfiguring the Unity project
  6. シーンを作成して構成し、シーンに MultiUserCapabilities などの適切な名前を付けるCreating and configuring the scene and give the scene a suitable name, for example, MultiUserCapabilities

次に、「空間認識表示オプションの変更」の指示に従い、次の作業を行います。Then follow the Changing the Spatial Awareness Display Option instructions to:

  1. MRTK 構成プロファイルDefaultHoloLens2ConfigurationProfile に変更しますChange the MRTK configuration profile for to the DefaultHoloLens2ConfigurationProfile
  2. 空間認識メッシュ表示オプション[Occlusion](オクルージョン) に変更しますChange the spatial awareness mesh display options to Occlusion.

その他の機能を有効にするEnabling additional capabilities

Unity メニューで [Edit](編集) > [Project Settings](プロジェクトの設定) を選択して、[Player Settings](プレーヤーの設定) ウィンドウを開きます。次に、 [Player](プレーヤー) > [Publishing Settings](発行の設定) セクションを見つけます。In the Unity menu, select Edit > Project Settings... to open the Player Settings window, then locate the Player > Publishing Settings section:

[Player](プレーヤー) 設定が表示された Unity

[Publishing Settings](公開の設定) で、 [Capabilities](機能) セクションまで下にスクロールして、上の「Unity プロジェクトを構成する」手順で有効にした InternetClientMicrophoneSpatialPerceptionGazeInput の機能が有効になっていることを再確認します。In the Publishing Settings, scroll down to the Capabilities section and double-check that the InternetClient, Microphone, SpatialPerception, and GazeInput capabilities, which you enabled during the Configuring the Unity project step above, are enabled.

その後、次の追加機能を有効にします。Then enable the following additional capabilities:

  • InternetClientServer 機能InternetClientServer capability
  • PrivateNetworkClientServer 機能PrivateNetworkClientServer capability

[Capabilities](機能) 設定が表示された Unity

組み込みの Unity パッケージのインストールInstalling inbuilt Unity packages

Unity メニューで、 [Window](ウィンドウ) > [Package Manager](パッケージ マネージャー) の順に選択して、[Package Manager](パッケージ マネージャー) ウィンドウを開きます。次に、 [AR Foundation] を選択し、 [Install](インストール) ボタンをクリックしてパッケージをインストールします。In the Unity menu, select Window > Package Manager to open the Package Manager window, then select AR Foundation and click the Install button to install the package:

AR Foundation が選択されている [Package Manager](パッケージ マネージャー) が表示された Unity

注意

次のセクションでインポートする Azure Spatial Anchors SDK で必要になるため、AR Foundation パッケージをインストールします。You are installing the AR Foundation package because it is required by the Azure Spatial Anchors SDK you will import in the next section.

チュートリアルのアセットのインポートImporting the tutorial assets

次の Unity カスタム パッケージを、記載されている順で ダウンロードして インポート します。Download and import the following Unity custom packages in the order they are listed:

チュートリアルのアセットをインポートすると、プロジェクト ウィンドウは次のようになります。After you have imported the tutorial assets your Project window should look similar to this:

チュートリアルのアセットがインポートされた後の Unity の [Hierarchy](階層)、[Scene](シーン)、[Project](プロジェクト) ウィンドウ

ヒント

Unity カスタム パッケージをインポートする方法については、「Mixed Reality Toolkit をインポートする」の手順を参照してください。For a reminder on how to import a Unity custom package, you can refer to the Importing the Mixed Reality Toolkit instructions.

注意

MultiUserCapabilities チュートリアル アセット パッケージをインポートすると、型または名前空間が存在しないことを示すいくつかの CS0246 エラーが [Console](コンソール) ウィンドウに表示されます。After importing the MultiUserCapabilities tutorial assets package, you will see several CS0246 errors in the Console window stating that the type or namespace is missing. これは想定されているものであり、次のセクションで PUN アセットをインポートする際に解決されます。This is expected and will be resolved in the next section when you import the PUN assets.

PUN アセットをインポートするImporting the PUN assets

Unity メニューで、 [Window](ウィンドウ)[Asset Store](アセット ストア) の順に選択して [Asset Store](アセット ストア) ウィンドウを開き、Exit Games から [PUN 2 - FREE] を検索して選択し、 [Download](ダウンロード) ボタンをクリックしてアセット パッケージを自分の Unity アカウントにダウンロードします。In the Unity menu, select Window > Asset Store to open the Asset Store window, search for and select PUN 2 - FREE from Exit Games, click the Download button to download the asset package to your Unity account.

ダウンロードが完了したら、 [Import](インポート) ボタンをクリックして [Import Unity Package](Unity パッケージのインポート) ウィンドウを開きます。When the download is complete, click the Import button to open the Import Unity Package window:

[PUN 2 - Free] が表示された [Asset Store](アセット ストア) が表示された Unity

[Import Unity Package](Unity パッケージのインポート) ウィンドウで、 [All](すべて) ボタンをクリックしてすべてのアセットが選択されていることを確認し、 [Import](インポート) ボタンをクリックしてアセットをインポートします。In the Import Unity Package window, click the All button to ensure all the assets are selected, then click the Import button to import the assets:

PUN 2 のインポート ウィンドウが表示された Unity

Unity でインポート プロセスが完了したら、[Pun Wizard](Pun ウィザード) ウィンドウが表示されて [PUN Setup](PUN 設定) メニューが読み込まれます。今はこのウィンドウを無視するか、閉じて構いません。Once Unity has completed the import process, the Pun Wizard window will appear with the PUN Setup menu loaded, you can ignore or close this window for now:

[PUN Setup](PUN 設定) ウィンドウが表示された Unity

PUN アプリケーションの作成Creating the PUN application

このセクションでは、Photon アカウントを作成し (まだ作成していない場合)、新しい PUN アプリを作成します。In this section, you will create a Photon account, if you don't already have one, and create a new PUN app.

使用したいアカウントが既にある場合は Photon ダッシュボード に移動してサインインします。なければ、 [こちらから作成してください] リンクをクリックして手順に従い、新しいアカウントを登録します。Navigate to the Photon dashboard and sign in if you already have an account you want to use, otherwise, click the Create One link and follow the instructions to register a new account:

Photon ログイン ページ

サインインしたら、 [Create a New App](新しいアプリの作成) ボタンをクリックします。Once signed in, click the Create a New App button:

Photon ダッシュボードの開始ページ

[Create a New Application](新しいアプリケーションの作成) ページで、次の値を入力します。On the Create a New Application page, enter the following values:

  • [Photon Type](Photon の種別) には、[PUN] を選択しますFor Photon Type, select PUN
  • [Name](名前) には、適切な名前 (MRTK チュートリアル など) を入力しますFor Name, enter a suitable name, for example, MRTK Tutorials
  • [Description](説明) には、必要に応じて適切な説明を入力しますFor Description, optionally enter a suitable description
  • "URL" フィールドは空のままにしますFor Url, leave the field empty

[Create](作成する) をクリックして新しいアプリを作成します。Then click the Create button to create the new app:

Photon のアプリケーションの作成ページ

Photon で作成プロセスが完了すると、新しい PUN アプリがダッシュボードに表示されます。Once Photon has finished the creation process, the new PUN app will appear on your dashboard:

Photon のアプリケーション ページ

Unity プロジェクトを PUN アプリケーションに接続するConnecting the Unity project to the PUN application

このセクションでは、Unity プロジェクトを前のセクションで作成した PUN アプリに接続します。In this section, you will connect your Unity project to the PUN app you created in the previous section.

Photon ダッシュボードで、 "App ID"(アプリ ID) フィールドをクリックしてアプリ ID を表示し、クリップボードにコピーします。On the Photon dashboard, click the App ID field to reveal the app ID, then copy it to your clipboard:

アプリ ID が選択されている Photon アプリケーション ページ

Unity メニューで、 [Window](ウィンドウ) > [Photon Unity Networking] > [PUN Wizard](PUN ウィザード) を選択して [Pun Wizard](Pun ウィザード) ウィンドウを開き、 [Setup Project](プロジェクトの設定) ボタンをクリックして [PUN Setup](PUN 設定) メニューを開いて次のように構成します。In the Unity menu, select Window > Photon Unity Networking > PUN Wizard to open the Pun Wizard window, click the Setup Project button to open the PUN Setup menu, and configure it as follows:

  • "AppId or Email"(アプリ ID またはメール) フィールドで、前のステップでコピーした PUN アプリ ID を貼り付けますIn the AppId or Email field, paste the PUN app ID you copied in the previous step

[Setup Project](プロジェクトの設定) ボタンをクリックしてアプリ ID を適用します。Then click the Setup Project button to apply the app ID:

アプリ ID が入力された [PUN Setup](PUN 設定) が表示された Unity

Unity で PUN 設定プロセスが完了すると、[PUN Setup](PUN 設定) メニューに [Done!](完了) というメッセージが表示され、Once Unity has finished the PUN setup process, the PUN Setup menu will display the message Done! [Project](プロジェクト) ウィンドウで PhotonServerSettings アセットが自動的に選択され、そのプロパティが [Inspector](インスペクター) ウィンドウに表示されます。and automatically select the PhotonServerSettings asset in the Project window, so its properties are displayed in the Inspector window:

[Setup Project](プロジェクトの設定) が適用された [PUN Setup](PUN 設定) が表示された Unity

結論Congratulations

PUN アプリを作成して、これを Unity プロジェクトに接続できました。You have successfully created a PUN app and connected it to your Unity project. 次の手順では、他のユーザーとの接続を許可して複数のユーザーが互いを見られるようにします。Your next step is to allow connections with other users so that multiple users can see each other.