Unity Visual Studio ソリューションのエクスポートとビルドExporting and building a Unity Visual Studio solution

アプリケーションでシステムキーボードを使用しない場合は、アプリケーションで使用されるメモリが少し少なく、起動時間が少し短縮されるため、 D3Dを使用することをお勧めします。If you don't intend on using the system keyboard in your application, our recommendation is to use D3D as your application will use slightly less memory and have a slightly faster launch time. プロジェクトで TouchScreenKeyboard API を使用してシステムキーボードを使用している場合は、 XAMLとしてエクスポートする必要があります。If you are using the TouchScreenKeyboard API in your project to use the system keyboard, you need to export as XAML.

Unity からエクスポートする方法How to export from Unity

Unity のビルド設定Unity build settings
Unity のビルド設定Unity build settings

  1. Unity からプロジェクトをエクスポートする準備ができたら、[ファイル] メニューを開き、[ビルドの設定] を選択します。When you are ready to export your project from Unity, open the File menu and select Build Settings...
  2. [開いているシーンの追加] をクリックして、ビルドにシーンを追加します。Click Add Open Scenes to add your scene to the build.
  3. [ビルドの設定] ダイアログで、HoloLens をエクスポートする次のオプションを選択します。In the Build Settings dialog, choose the following options to export for HoloLens:
    • プラットフォーム: ユニバーサル Windows プラットフォーム を必ず選択して スイッチ プラットフォーム 選択を有効にします。Platform: Universal Windows Platform and be sure to select Switch Platform for your selection to take effect.
    • SDK: ユニバーサル 10します。SDK: Universal 10.
    • UWP のビルドの種類: D3Dします。UWP Build Type: D3D.
  4. 省略可能:Unity C#プロジェクト: た.Optional: Unity C# Projects: Checked.

注意

このチェックボックスをオンにすると、次のことができます。Checking this box allows you to:

  • Visual Studio リモートデバッガーでアプリをデバッグします。Debug your app in the Visual Studio remote debugger.
  • WinRT Api に IntelliSense をC#使用しながら、Unity プロジェクトのスクリプトを編集します。Edit scripts in the Unity C# project while using IntelliSense for WinRT APIs.
  1. [ビルドの設定... ] ウィンドウで、[プレーヤーの設定] を開きます。From the Build Settings... window, open Player Settings...
  2. [ユニバーサル Windows プラットフォーム] タブの設定を選択します。Select the Settings for Universal Windows Platform tab.
  3. [ XR Settings ] グループを展開します。Expand the XR Settings group.
  4. [ XR の設定] セクションで、[サポートされている仮想 reality] チェックボックスをオンにして、新しい仮想デバイスの一覧を追加し、 "Windows Mixed reality" がサポートされているデバイスとして表示されていることを確認します。In the XR Settings section, check the Virtual Reality Supported checkbox to add a new Virtual Reality Devices list and confirm "Windows Mixed Reality" is listed as a supported device.
  5. [ビルドの設定] ダイアログに戻ります。Return to the Build Settings dialog.
  6. [ビルド] を選択します。Select Build.
  7. 表示された [エクスプローラー] ダイアログボックスで、Unity のビルド出力を保持する新しいフォルダーを作成します。In the Windows Explorer dialog that appears, create a new folder to hold Unity's build output. 一般に、"App" というフォルダーに名前を指定します。Generally, we name the folder "App".
  8. 新しく作成したフォルダーを選択し、[フォルダーの選択] をクリックします。Select the newly created folder and click Select Folder.
  9. Unity のビルドが完了すると、Windows エクスプローラーウィンドウが開き、プロジェクトのルートディレクトリが表示されます。Once Unity has finished building, a Windows Explorer window will open to the project root directory. 新しく作成したフォルダーに移動します。Navigate into the newly created folder.
  10. このフォルダー内にある生成された Visual Studio ソリューションファイルを開きます。Open the generated Visual Studio solution file located inside this folder.

Unity から再エクスポートする場合When to re-export from Unity

Unity からアプリC#をエクスポートするときに [プロジェクト] チェックボックスをオンにすると、すべての unity スクリプトファイルを含む Visual Studio ソリューションが作成されます。Checking the "C# Projects" checkbox when exporting your app from Unity creates a Visual Studio solution that includes all your Unity script files. これにより、Unity から再エクスポートせずにスクリプトを反復処理することができます。This allows you to iterate on your scripts without re-exporting from Unity. ただし、スクリプトの内容を変更するだけでなく、プロジェクトに変更を加える場合は、Unity から再エクスポートする必要があります。However, if you want to make changes to your project that aren't just changing the contents of scripts, you will need to re-export from Unity. Unity から再エクスポートする必要のある時間の例を次に示します。Some examples of times you need to re-export from Unity are:

  • [プロジェクト] タブでアセットを追加または削除します。You add or remove assets in the Project tab.
  • すべての値は、[インスペクター] タブで変更します。You change any value in the Inspector tab.
  • [階層] タブでオブジェクトを追加または削除します。You add or remove objects from the Hierarchy tab.
  • Unity プロジェクトの設定を変更しますYou change any Unity project settings

Unity Visual Studio ソリューションのビルドと配置Building and deploying a Unity Visual Studio solution

アプリのビルドと配置の残りの部分は、 Visual Studioで行われます。The remainder of building and deploying apps happens in Visual Studio. Unity ビルド構成を指定する必要があります。You will need to specify a Unity build configuration. Unity の名前付け規則は、Visual Studio で通常使用されているものとは異なる場合があります。Unity's naming conventions may differ from what you're usually used to in Visual Studio:

構成Configuration 説明Explanation
デバッグDebug すべての最適化とプロファイラーが有効になります。All optimizations off and the profiler is enabled. スクリプトのデバッグに使用します。Used to debug scripts.
マスタMaster すべての最適化が有効になり、プロファイラーは無効になります。All optimizations are turned on and the profiler is disabled. ストアにアプリを送信するために使用されます。Used to submit apps to the Store.
リリースRelease すべての最適化が有効になり、プロファイラーが有効になります。All optimizations are turned on and the profiler is enabled. アプリのパフォーマンスを評価するために使用されます。Used to evaluate app performance.

上記の一覧は、Visual Studio プロジェクトを生成する必要がある一般的なトリガーのサブセットです。Note, the above list is a subset of the common triggers that will cause the Visual Studio project to need to be generated. 一般に、Visual Studio 内から .cs ファイルを編集する場合、Unity 内からプロジェクトを再生成する必要はありません。In general, editing .cs files from within Visual Studio will not require the project to be regenerated from within Unity.

トラブルシューティングTroubleshooting

.Cs ファイルの編集が Visual Studio プロジェクトで認識されていない場合は、Unity の [ビルド] メニュー C#から VS プロジェクトを生成するときに、"unity プロジェクト" がオンになっていることを確認してください。If you find that edits to your .cs files are not being recognized in your Visual Studio project, ensure that "Unity C# Projects" is checked when you generate the VS project from Unity's Build menu.