注意

Mixed Reality Academy チュートリアルは、HoloLens (第1世代) と Mixed Reality イマーシブヘッドセットを念頭に置いて設計されています。The Mixed Reality Academy tutorials were designed with HoloLens (1st gen) and Mixed Reality Immersive Headsets in mind. そのため、これらのデバイスの開発に関するガイダンスをまだ探している開発者には、これらのチュートリアルを残しておくことが重要です。As such, we feel it is important to leave these tutorials in place for developers who are still looking for guidance in developing for those devices. これらのチュートリアルは いない 最新のツールセットや相互作用が使用されている HoloLens 2 で更新されます。These tutorials will not be updated with the latest toolsets or interactions being used for HoloLens 2. サポートされているデバイスでの作業を続行するために管理されます。They will be maintained to continue working on the supported devices. 今後、HoloLens 2 向けの開発方法を示す新しい一連のチュートリアルが掲載されています。There will be a new series of tutorials that will be posted in the future that will demonstrate how to develop for HoloLens 2. この通知は、これらのチュートリアルが投稿されたときのリンクと共に更新されます。This notice will be updated with a link to those tutorials when they are posted.


MR 基本 100:Unity の概要MR Basics 100: Getting started with Unity

このチュートリアルでは、Unity でビルドされた基本的な mixed reality アプリを作成する手順について説明します。This tutorial will walk you through creating a basic mixed reality app built with Unity.

デバイスのサポートDevice support

までCourse HoloLensHoloLens イマーシブ ヘッドセットImmersive headsets
MR 基本 100:Unity の概要MR Basics 100: Getting started with Unity ✔️✔️ ✔️✔️

必須コンポーネントPrerequisites

章 1-新しいプロジェクトを作成するChapter 1 - Create a New Project

Unity を使用してアプリをビルドするには、最初にプロジェクトを作成する必要があります。To build an app with Unity, you first need to create a project. このプロジェクトはいくつかのフォルダーに整理されています。最も重要なのは、アセットフォルダーです。This project is organized into a few folders, the most important of which is your Assets folder. これは、Maya、Max 映画4D または Photoshop などのデジタルコンテンツ作成ツール、Visual Studio で作成するすべてのコード、または任意のコードエディターを使用して作成したすべてのアセットと、Unity によって作成された複数のコンテンツファイルを格納するフォルダーです。、アニメーション、およびその他の Unity アセットタイプがエディターに含まれています。This is the folder that holds all assets you import from digital content creation tools such as Maya, Max Cinema 4D or Photoshop, all code you create with Visual Studio or your favorite code editor, and any number of content files that Unity creates as you compose scenes, animations and other Unity asset types in the editor.

UWP アプリをビルドして展開するために、Unity はプロジェクトを Visual Studio ソリューションとしてエクスポートできます。このソリューションには、必要なすべての資産とコードファイルが含まれます。To build and deploy UWP apps, Unity can export the project as a Visual Studio solution that will contain all necessary asset and code files.

  1. Unity を開始するStart Unity
  2. 新規の選択Select New
  3. プロジェクト名を入力します (例: "MixedRealityIntroduction")Enter a project name (e.g. "MixedRealityIntroduction")
  4. プロジェクトを保存する場所を入力してくださいEnter a location to save your project
  5. 3dの切り替えが選択されていることを確認するEnsure the 3D toggle is selected
  6. [プロジェクトの作成] の選択Select Create project

おめでとう、すべての設定が完了したら、今すぐに mixed reality カスタマイズを開始できます。Congrats, you are all setup to get started with your mixed reality customizations now.

Chapter 2-カメラの設定Chapter 2 - Setup the Camera

Unity のメインカメラは、ヘッドの追跡とステレオスコピックのレンダリングを処理します。The Unity Main Camera handles head tracking and stereoscopic rendering. メインカメラには、mixed reality と共に使用するためのいくつかの変更が加えられています。There are a few changes to make to the Main Camera to use it with mixed reality.

  1. ファイル > 新しいシーンの選択Select File > New Scene

まず、ユーザーの開始位置を (X: として) 想像すると、アプリのレイアウトが簡単になります。0、 Y:0、 Z:0)。First, it will be easier to lay out your app if you imagine the starting position of the user as (X: 0, Y: 0, Z: 0). メインカメラはユーザーのヘッドの移動を追跡しているため、ユーザーの開始位置を設定することによって、メインカメラの開始位置を設定できます。Since the Main Camera is tracking movement of the user's head, the starting position of the user can be set by setting the starting position of the Main Camera.

  1. [階層] パネルの [メインカメラ] を選択します。Select Main Camera in the Hierarchy panel
  2. [インスペクター ] パネルで変換コンポーネントを見つけて、位置を (X:0、 Y:1、 Z:-10) から (X:0、 Y:0、 Z:0In the Inspector panel, find the Transform component and change the Position from (X: 0, Y: 1, Z: -10) to (X: 0, Y: 0, Z: 0)

次に、カメラの既定の背景はいくつかの点を考慮する必要があります。Second, the default Camera background needs some thought.

HoloLens アプリケーションの場合、実際の世界は、スカイボックステクスチャではなく、カメラがレンダリングするすべての要素の背後に表示されます。For HoloLens applications, the real world should appear behind everything the camera renders, not a Skybox texture.

  1. メインカメラが [階層] パネルで選択された状態で、[インスペクター ] パネルの [カメラ] コンポーネントを見つけて、[クリアフラグ] ボックスを [スカイボックス] から [純色] に変更します。With the Main Camera still selected in the Hierarchy panel, find the Camera component in the Inspector panel and change the Clear Flags dropdown from Skybox to Solid Color.
  2. 背景色ピッカーを選択し、 RGBA値を (0, 0, 0, 0) に変更します。Select the Background color picker and change the RGBA values to (0, 0, 0, 0)

イマーシブヘッドセットを対象とする mixed reality アプリケーションでは、Unity が提供する既定のスカイボックステクスチャを使用できます。For mixed reality applications targeted to immersive headsets, we can use the default Skybox texture that Unity provides.

  1. メインカメラを [階層] パネルで選択した状態で、[インスペクター ] パネルの [カメラ] コンポーネントを見つけて、[フラグのクリア] ドロップダウンを [スカイボックス] にします。With the Main Camera still selected in the Hierarchy panel, find the Camera component in the Inspector panel and keep the Clear Flags dropdown to Skybox.

3番目の方法として、Unity の近くのクリッププレーンを考えて、ユーザーがオブジェクトまたはオブジェクトにアプローチしているときに、ユーザーに近いオブジェクトが表示されないようにします。Third, let us consider the near clip plane in Unity and prevent objects from being rendered too close to the users eyes as a user approaches an object or an object approaches a user.

Hololens アプリケーションでは、near クリッププレーンをhololens 推奨0.85 メーターに設定できます。For HoloLens applications, the near clip plane can be set to the HoloLens recommended 0.85 meters.

  1. メインカメラを [階層] パネルで選択した状態で、[インスペクター ] パネルの [カメラ] コンポーネントを見つけて、[近距離クリップ平面] フィールドを既定の0.3から HoloLens 推奨0.85 に変更します。.With the Main Camera still selected in the Hierarchy panel, find the Camera component in the Inspector panel and change the Near Clip Plane field from the default 0.3 to the HoloLens recommended 0.85.

イマーシブヘッドセットを対象とする mixed reality アプリケーションでは、Unity が提供する既定の設定を使用できます。For mixed reality applications targeted to immersive headsets, we can use the default setting that Unity provides.

  1. メインカメラを [階層] パネルで選択した状態で、[インスペクター ] パネルの [カメラ] コンポーネントを見つけて、[近くのクリッププレーン] フィールドを既定の0.3にします。With the Main Camera still selected in the Hierarchy panel, find the Camera component in the Inspector panel and keep the Near Clip Plane field to the default 0.3.

最後に、ここまでの進行状況を保存しておきます。Finally, let us save our progress so far. シーンの変更を保存するには、> [名前を付けてシーンを保存] を選択し、シーンに「 Main」という名前を付けて、[保存] を選択します。To save the scene changes, select File > Save Scene As, name the scene Main, and select Save.

Chapter 3-プロジェクト設定のセットアップChapter 3 - Setup the Project Settings

この章では、開発用に Windows Holographic SDK を対象とするのに役立つ Unity プロジェクト設定をいくつか設定します。In this chapter, we will set some Unity project settings that help us target the Windows Holographic SDK for development. また、アプリケーションの品質設定をいくつか設定します。We will also set some quality settings for our application. 最後に、ビルドターゲットが Windows ストアに設定されていることを確認します。Finally, we will ensure our build targets are set to Windows Store.

Unity のパフォーマンスと品質の設定Unity performance and quality settings

HoloLens の Unity 品質設定Unity quality settings for HoloLens

HoloLens の Unity 品質設定

HoloLens で高フレームレートを維持することは非常に重要であるため、品質設定をチューニングしてパフォーマンスを最速にすることをお勧めします。Since maintaining high framerate on HoloLens is so important, we want the quality settings tuned for fastest performance. 詳細については、「 Unity のパフォーマンスに関する推奨事項」を参照してください。For more detailed performance information, Performance recommendations for Unity.

  1. [プロジェクト設定の編集 > の > 品質] を選択します。Select Edit > Project Settings > Quality
  2. Windows ストアのロゴの下にあるドロップダウンを選択し、[非常に低い] を選択します。Select the dropdown under the Windows Store logo and select Very Low. Windows ストアの列のボックスと非常に少ない行が緑色になっている場合は、設定が正しく適用されていることがわかります。You'll know the setting is applied correctly when the box in the Windows Store column and Very Low row is green.

Occluded を対象とする mixed reality アプリケーションでは、品質設定を既定値のままにすることができます。For mixed reality applications targeted to occluded displays, you can leave the quality settings to its default values.

ターゲット Windows 10 SDKTarget Windows 10 SDK

ターゲット Windows Holographic SDKTarget Windows Holographic SDK

ターゲット Windows Holographic SDK

エクスポートしようとしているアプリが2D ビューではなくイマーシブビューを作成する必要があることを Unity に知らせる必要があります。We need to let Unity know that the app we are trying to export should create an immersive view instead of a 2D view. これを行うには、Windows 10 SDK を対象とする Unity で仮想現実のサポートを有効にします。We do this by enabling Virtual Reality support on Unity targeting the Windows 10 SDK.

  1. [ Edit > Project Settings > Player] にアクセスします。Go to Edit > Project Settings > Player.
  2. [プレーヤー設定] の [インスペクター] パネルで、[ Windows ストア] アイコンを選択します。In the Inspector Panel for Player Settings, select the Windows Store icon.
  3. [ XR Settings ] グループを展開します。Expand the XR Settings group.
  4. [表示] セクションで、[サポートされている仮想現実] チェックボックスをオンにして、新しい仮想現実の sdkリストを追加します。In the Rendering section, check the Virtual Reality Supported checkbox to add a new Virtual Reality SDKs list.
  5. [ Windows Mixed Reality ] が一覧に表示されていることを確認します。Verify that Windows Mixed Reality appears in the list. 表示されてい + ない場合は、一覧の下部にあるボタンを選択し、[ Windows Mixed Reality] を選択します。If not, select the + button at the bottom of the list and choose Windows Mixed Reality.

注意

Windows ストアアイコンが表示されない場合は、インストール前に windows ストア .Net Scripting バックエンドが選択されていることを確認してください。If you do not see the Windows Store icon, double check to make sure you selected the Windows Store .NET Scripting Backend prior to installation. インストールされていない場合は、正しい Windows インストールを使用して Unity を再インストールする必要があります。If not, you may need to reinstall Unity with the correct Windows installation.

.NET の構成を確認するVerify .NET Configuration

.NET の構成を確認する

  1. Edit > Project Settings > Player (これは前の手順のままである場合があります) に進みます。Go to Edit > Project Settings > Player (you may still have this up from the previous step).
  2. [プレーヤー設定] の [インスペクター] パネルで、[ Windows ストア] アイコンを選択します。In the Inspector Panel for Player Settings, select the Windows Store icon.
  3. [その他の設定] 構成セクションで、[スクリプトバックエンド] が [ .net ] に設定されていることを確認します。In the Other Settings Configuration section, make sure that Scripting Backend is set to .NET

適用されたすべてのプロジェクト設定を取得するためのすばらしいジョブ。Awesome job on getting all the project settings applied. 次に、ホログラムを追加してみましょう。Next, let us add a hologram!

Chapter 4-キューブの作成Chapter 4 - Create a cube

Unity プロジェクトでのキューブの作成は、Unity で他のオブジェクトを作成するのと同じです。Creating a cube in your Unity project is just like creating any other object in Unity. Unity の座標系は現実世界にマップされているため、ユーザーの前にキューブを配置するのは簡単です。 Unity の1つのメーターは実際の世界では約1メートルです。Placing a cube in front of the user is easy because Unity's coordinate system is mapped to the real world - where one meter in Unity is approximately one meter in the real world.

  1. 階層パネルの左上隅にある [作成] ドロップダウンを選択し、[ 3d オブジェクト > キューブ] を選択します。In the top left corner of the Hierarchy panel, select the Create dropdown and choose 3D Object > Cube.
  2. [階層] パネルで、新しく作成したキューブを選択します。Select the newly created Cube in the Hierarchy panel
  3. インスペクター変換コンポーネントを検索し、位置を (X:0、 Y:0、 Z:2)。In the Inspector find the Transform component and change Position to (X: 0, Y: 0, Z: 2). これにより、ユーザーの開始位置の前にキューブ2のメーターが配置されます。This positions the cube 2 meters in front of the user's starting position.
  4. 変換コンポーネントで、ローテーションをに変更します (X:45、 Y:45、 Z:45) とスケールの変更 (X:0.25、 Y:0.25、 Z:0.25)。In the Transform component, change Rotation to (X: 45, Y: 45, Z: 45) and change Scale to (X: 0.25, Y: 0.25, Z: 0.25). これにより、キューブが0.25 メートルにスケールされます。This scales the cube to 0.25 meters.
  5. シーンの変更を保存するには、ファイル > シーンの保存 を選択します。To save the scene changes, select File > Save Scene.

章 5-Unity エディターからデバイスを確認するChapter 5 - Verify on device from Unity editor

キューブを作成したので、デバイスのクイックチェックを実行します。Now that we have created our cube, it is time to do a quick check in device. これは、Unity エディター内から直接行うことができます。You can do this directly from within the Unity editor.

初期セットアップInitial setup

  1. 開発用 PC の Unity で、[ファイル > ビルドの設定] ウィンドウを開きます。On your development PC, in Unity, open File > Build Settings window.
  2. プラットフォームユニバーサル Windows プラットフォームに変更し、[ Switch platfrom.details.heap.alignedallocate ] をクリックします。Change Platform to Universal Windows Platform and click Switch Platfrom

HoloLens で Unity リモート処理を使用するFor HoloLens use Unity Remoting

  1. HoloLens で、Windows ストアから入手できるHolographic リモート処理プレーヤーをインストールして実行します。On your HoloLens, install and run the Holographic Remoting Player, available from the Windows Store. デバイスでアプリケーションを起動すると、待機状態になり、デバイスの IP アドレスが表示されます。Launch the application on the device, and it will enter a waiting state and show the IP address of the device. IP を書き留めます。Note down the IP.
  2. ウィンドウ > XR > Holographic エミュレーションを開きます。Open Window > XR > Holographic Emulation.
  3. [エミュレーションモード] を [なし] から [リモート] から [デバイス] に変更します。Change Emulation Mode from None to Remote to Device.
  4. [リモートコンピューター] に、前にメモした HOLOLENS の IP アドレスを入力します。In Remote Machine, enter the IP address of your HoloLens noted earlier.
  5. [接続] をクリックします。Click Connect.
  6. 接続の状態 が緑色に変わっていることを確認します。Ensure the Connection Status changes to green Connected.
  7. これで、Unity エディターで [再生] をクリックできるようになりました。Now you can now click Play in the Unity editor.

これで、デバイスとエディターでキューブを表示できるようになります。You will now be able to see the cube in device and in the editor. エディターでアプリを実行するのと同じように、一時停止、検査、およびデバッグを行うことができます。これは、アプリケーションをエディターで実行するのと同じです。ただし、これは基本的には、ホストコンピューターとデバイス間のネットワーク間で送受信されるビデオ、オーディオ、デバイスの入力を使用します。You can pause, inspect objects, and debug just like you are running an app in the editor, because that’s essentially what’s happening, but with video, audio, and device input transmitted back and forth across the network between the host machine and the device.

その他の mixed reality がサポートするヘッドセットの場合For other mixed reality supported headsets

  1. USB ケーブルと HDMI またはディスプレイポートケーブルを使用して、ヘッドセットを開発用 PC に接続します。Connect the headset to your development PC using the USB cable and the HDMI or display port cable.
  2. Mixed Reality ポータルを起動し、最初の実行エクスペリエンスを完了していることを確認します。Launch the Mixed Reality Portal and ensure you have completed the first run experience.
  3. Unity から、再生ボタンを押すことができます。From Unity, you can now press the Play button.

これで、混合現実のヘッドセットとエディターでキューブのレンダリングを確認できるようになります。You will now be able to see the cube rendering in your mixed reality headset and in the editor.

第6章-Visual Studio からデバイスへのビルドと配置Chapter 6 - Build and deploy to device from Visual Studio

これで、プロジェクトを Visual Studio にコンパイルし、ターゲットデバイスにデプロイする準備ができました。We are now ready to compile our project to Visual Studio and deploy to our target device.

Visual Studio ソリューションへのエクスポートExport to the Visual Studio solution

  1. [ビルドの設定] ウィンドウ > ファイルを開きます。Open File > Build Settings window.
  2. シーンを追加するには、[開いているシーンの追加] をクリックします。Click Add Open Scenes to add the scene.
  3. プラットフォームユニバーサル Windows プラットフォームに変更し、プラットフォームの切り替え をクリックします。Change Platform to Universal Windows Platform and click Switch Platform.
  4. Windows ストアの設定では、 SDKUniversal 10です。In Windows Store settings ensure, SDK is Universal 10.
  5. ターゲットデバイスの場合は、occluded の任意のデバイスに表示するか、またはHoloLensに切り替えます。For Target device, leave to Any Device for occluded displays or switch to HoloLens.
  6. UWP ビルドの種類D3Dである必要があります。UWP Build Type should be D3D.
  7. UWP SDKは、インストールされている最新の状態のままにすることができます。UWP SDK could be left at Latest installed.
  8. [デバッグ] でUnity C#プロジェクトを確認します。Check Unity C# Projects under Debugging.
  9. [Build] をクリックします。Click Build.
  10. エクスプローラーで、[新しいフォルダー ] をクリックし、フォルダーに 「App」 という名前を指定します。In the file explorer, click New Folder and name the folder "App".
  11. アプリフォルダーを選択した状態で、[フォルダーの選択] ボタンをクリックします。With the App folder selected, click the Select Folder button.
  12. Unity のビルドが完了すると、Windows エクスプローラーウィンドウが表示されます。When Unity is done building, a Windows File Explorer window will appear.
  13. エクスプローラーでアプリフォルダーを開きます。Open the App folder in file explorer.
  14. 生成された Visual Studio ソリューションを開きます (この例では MixedRealityIntroduction)。Open the generated Visual Studio solution (MixedRealityIntroduction.sln in this example)

Visual Studio ソリューションをコンパイルするCompile the Visual Studio solution

最後に、エクスポートされた Visual Studio ソリューションをコンパイルしてデプロイし、デバイスで試します。Finally, we will compile the exported Visual Studio solution, deploy it, and try it out on the device.

  1. Visual Studio の上部のツールバーを使用して、ターゲットをデバッグからリリースに変更し、 ARMからX86に変更します。Using the top toolbar in Visual Studio, change the target from Debug to Release and from ARM to X86.

この手順は、デバイスとエミュレーターの間の配置で異なります。The instructions differ for deploying to a device versus the emulator. セットアップに一致する指示に従います。Follow the instructions that match your setup.

Wi-fi 経由で mixed reality デバイスに展開するDeploy to mixed reality device over Wi-Fi

  1. [ローカルコンピューター ] ボタンの横にある矢印をクリックし、[配置ターゲット] を [リモートコンピューター] に変更します。Click on the arrow next to the Local Machine button, and change the deployment target to Remote Machine.
  2. Mixed reality デバイスの IP アドレスを入力し、HoloLens とWindowsで他のデバイスの認証モードを Universal (暗号化されていないプロトコル) に変更します。Enter the IP address of your mixed reality device and change Authentication Mode to Universal (Unencrypted Protocol) for HoloLens and Windows for other devices.
  3. [デバッグ > デバッグなしで開始] をクリックします。Click Debug > Start without debugging.

HoloLens の場合、初めてデバイスをデプロイする場合は、 Visual Studio を使用してペアリングする必要があります。For HoloLens, If this is the first time deploying to your device, you will need to pair using Visual Studio.

USB 経由で mixed reality デバイスに展開するDeploy to mixed reality device over USB

デバイスが USB ケーブル経由で接続されていることを確認します。Ensure you device is plugged in via the USB cable.

  1. HoloLens の場合は、[ローカルコンピューター ] ボタンの横にある矢印をクリックし、展開ターゲットを [デバイス] に変更します。For HoloLens, click on the arrow next to the Local Machine button, and change the deployment target to Device.
  2. PC に接続されている occluded デバイスを対象にするには、設定をローカルコンピューターに保持します。For targeting occluded devices attached to your PC, keep the setting to Local Machine. Mixed Reality ポータルが実行されていることを確認します。Ensure you have the Mixed Reality Portal running.
  3. [デバッグ > デバッグなしで開始] をクリックします。Click Debug > Start without debugging.

Emulator に配置Deploy to Emulator

  1. デバイスボタンの横にある矢印をクリックし、ドロップダウンから [ HoloLens Emulator] を選択します。Click on the arrow next to the Device button, and from drop down select HoloLens Emulator.
  2. [デバッグ > デバッグなしで開始] をクリックします。Click Debug > Start without debugging.

アプリを試してみるTry out your app

アプリがデプロイされたので、キューブ全体を移動して、その前に世界中の状態が維持されることを確認します。Now that your app is deployed, try moving all around the cube and observe that it stays in the world in front of you.

関連項目See also