2. プロジェクトの初期化と最初のアプリケーションの配置2. Initializing your project and deploying your first application

概要Overview

このチュートリアルでは、新しい Unity プロジェクトを作成し、それを Mixed Reality ツールキット (MRTK) 開発用に構成し、MRTK をインポートする方法について学習します。In this tutorial, you'll learn how to create a new Unity project, configure it for Mixed Reality Toolkit (MRTK) development, and import MRTK. また、Visual Studio で基本的な Unity サンプル シーンを構成およびビルドし、ご利用の HoloLens 2 またはエミュレーターに配置する方法についても学習します。You'll also walk through configuring, building, and deploying the basic Unity sample scene from Visual Studio to your HoloLens 2 or emulator.

目標Objectives

  • HoloLens 開発用に Unity を構成する方法について学習するLearn how to configure Unity for HoloLens development
  • アプリをビルドして HoloLens に配置する方法について学習するLearn how to build and deploy your app to HoloLens
  • 空間マッピングのメッシュ、ハンド メッシュ、およびフレームレート カウンターを体験するExperience the spatial mapping mesh, hand meshes, and the framerate counter

Unity プロジェクトの作成Creating the Unity project

Unity Hub を起動し、 [Projects](プロジェクト) タブを選択し、 [New](新規) ボタンの横にある下矢印をクリックします。Launch Unity Hub, select the Projects tab, and click the down arrow next to the New button:

mr-learning-base

前提条件」に指定されている Unity のバージョンを、ドロップダウンで選択します。In the dropdown, select the Unity version specified in the Prerequisites:

mr-learning-base

ヒント

Unity Hub で特定の Unity バージョンが利用できない場合は、Unity のアーカイブのダウンロードに関するページから、そのインストールを開始できます。If the particular Unity version is not available in Unity Hub, you can initiate the installation from Unity's Download Archive.

[Create a new project](新規プロジェクトの作成) ウィンドウで、以下のようにします。In the Create a new project window:

  • [Templates](テンプレート)3D に設定されていることを確認しますEnsure Templates is set to 3D
  • "MRTK チュートリアル" など、適切な [Project Name](プロジェクト名) を入力しますEnter a suitable Project Name, for example, MRTK Tutorials
  • プロジェクトを格納するための適切な [Location](場所) を選択します。たとえば、D:\MixedRealityLearning などChoose a suitable Location to store your project, for example, D:\MixedRealityLearning
  • [Create](作成) ボタンをクリックして、新しい Unity プロジェクトを作成して起動しますClick the Create button to create and launch your new Unity project

mr-learning-base

注意事項

Windows で作業している場合は、255 文字の MAX_PATH 制限があります。When working on Windows, there is a MAX_PATH limit of 255 characters. そのため、Unity プロジェクトはドライブのルートの近くに保存する必要があります。Consequently, you should save the Unity project close to the root of the drive.

Unity によってプロジェクトが作成されるまで待ちます。Wait for Unity to create the project:

mr-learning-base

ビルド プラットフォームを切り替えるSwitching the build platform

Unity メニューで、 [File](ファイル) > [Build Settings...](ビルド設定...) を選択し、[Build Settings](ビルド設定) ウィンドウを開きます。In the Unity menu, select File > Build Settings... to open the Build Settings window:

mr-learning-base

[Build Settings](ビルド設定) ウィンドウで、 [Universal Windows Platform](ユニバーサル Windows プラットフォーム) を選択して、 [Switch Platform](プラットフォームの切り替え) ボタンをクリックします。In the Build Settings window, select Universal Windows Platform and click the Switch Platform button:

mr-learning-base

Unity がプラットフォームの切り替えを完了するまで待ちます。Wait for Unity to finish switching the platform:

mr-learning-base

Unity でプラットフォームの切り替えが完了したら、赤色の x アイコンをクリックして、[Build Settings](ビルド設定) ウィンドウを閉じます。When Unity has finished switching the platform, click the red x icon to close the Build Settings window:

mr-learning-base

TextMeshPro の重要なリソースをインポートするImporting the TextMeshPro Essential Resources

Unity メニューで、 [Window](ウィンドウ) > [TextMeshPro] > [Import TMP Essential Resources](TMP の重要なリソースをインポート) の順に選択して、[Import Unity Package](Unity パッケージのインポート) ウィンドウを開きます。In the Unity menu, select Window > TextMeshPro > Import TMP Essential Resources to open the Import Unity Package window:

mr-learning-base

[Import Unity Package](Unity パッケージのインポート) ウィンドウで、 [All](すべて) ボタンをクリックしてすべてのアセットが選択されていることを確認し、 [Import](インポート) ボタンをクリックしてアセットをインポートします。In the Import Unity Package window, click the All button to ensure all the assets are selected, then click the Import button to import the assets:

mr-learning-base

ヒント

TextMeshPro の重要なリソースは、MRTK の UI 要素で必要です。The TextMeshPro Essential Resources are required by MRTK's UI elements. ご自分のプロジェクトで MRTK の UI 要素を使用する予定がない場合は、この手順を省略できます。You can skip this step if you are not planning to use MRTK's UI elements in your project.

Mixed Reality Toolkit をインポートするImporting the Mixed Reality Toolkit

Unity カスタム パッケージをダウンロードします。Download the Unity custom package:

Unity メニューで、 [Assets](アセット) > [Import Package](パッケージのインポート) > [Custom Package...](カスタム パッケージ...) を選択して [Import package...](パッケージのインポート...) ウィンドウを開きます。In the Unity menu, select Assets > Import Package > Custom Package... to open the Import package... window:

mr-learning-base

[Import package...](パッケージのインポート...) ウィンドウで、ダウンロードした Microsoft.MixedReality.Toolkit.Unity.Foundation.2.4.0.unitypackage を選択し、 [Open](開く) ボタンをクリックします。In the Import package... window, select the Microsoft.MixedReality.Toolkit.Unity.Foundation.2.4.0.unitypackage you downloaded and click the Open button:

mr-learning-base

[Import Unity Package](Unity パッケージのインポート) ウィンドウで、 [All](すべて) ボタンをクリックしてすべてのアセットが選択されていることを確認し、 [Import](インポート) ボタンをクリックしてアセットをインポートします。In the Import Unity Package window, click the All button to ensure all the assets are selected, then click the Import button to import the assets:

mr-learning-base

Unity プロジェクトを構成するConfiguring the Unity project

1. MRTK プロジェクト コンフィギュレーター設定を適用する1. Apply the MRTK Project Configurator settings

Unity によって前のセクションからのパッケージのインポートが完了すると、[MRTK Project Configurator](MRTK プロジェクト コンフィギュレーター) ウィンドウが表示されます。After Unity has finished importing the package from the previous section, the MRTK Project Configurator window should appear. そうならない場合に、そのコンフィギュレーター ウィンドウを開くには、Unity メニューに移動し、 [Mixed Reality Toolkit] > [Utilities](ユーティリティ) > [Configure Unity Project](Unity プロジェクトの構成) の順に選択します。If it doesn't, open the Configurator window by going to the Unity menu and selecting Mixed Reality Toolkit > Utilities > Configure Unity Project:

mr-learning-base

[MRTK Project Configurator](MRTK プロジェクト コンフィギュレーター) ウィンドウで、 [Modify Configurations](構成の変更) セクションを展開し、他のすべてのオプションを確実にオンにしてから、 [Apply](適用) ボタンをクリックして設定を適用します。In the MRTK Project Configurator window, expand the Modify Configurations section, ensure all options are checked, and click the Apply button to apply the settings:

mr-learning-base

2.追加のプロジェクト設定を構成する2. Configure additional project settings

Unity メニューで、 [Edit](編集) > [Project Settings...](プロジェクト設定...) を選択し、[Project Settings](プロジェクト設定) ウィンドウを開きます。In the Unity menu, select Edit > Project Settings... to open the Project Settings window:

mr-learning-base

[Project Settings](プロジェクト設定) ウィンドウで、 [Player](プレイヤー) > [XR Settings](XR 設定) の順に選択し、[ + ] アイコンをクリックします。Windows Mixed reality を選択して Windows Mixed Reality SDK を追加します。In the Project Settings window, select Player > XR Settings, click the + icon, and select Windows Mixed Reality to add the Windows Mixed Reality SDK:

mr-learning-base

Unity によって Windows Mixed Reality SDK のインポートが完了すると、[MRTK Project Configurator](MRTK プロジェクト コンフィギュレーター) ウィンドウが再び表示されます。After Unity has finished importing the Windows Mixed Reality SDK, the MRTK Project Configurator window should appear again. そうならない場合は、Unity メニューを使用してそれを開きます。If it doesn't, use the Unity menu to open it.

[MRTK Project Configurator](MRTK プロジェクト コンフィギュレーター) ウィンドウで、 [Audio Spatializer] ドロップダウンを使用して [MS HRTF Spatializer] を選択してから、 [Apply](適用) ボタンをクリックしてこの設定を適用します。In the MRTK Project Configurator window, use the Audio spatializer dropdown to select the MS HRTF Spatializer, then click the Apply button to apply the setting:

mr-learning-base

[Project Settings](プロジェクト設定) ウィンドウで、 [Player](プレーヤー) > [XR Settings](XR 設定) を選択してから、 [Depth Format](深度形式) ドロップダウンを使用して [16-bit depth](16 ビット深度) を選択します。In the Project Settings window, select Player > XR Settings, then use the Depth Format dropdown to select 16-bit depth:

mr-learning-base

[Project Settings](プロジェクト設定) ウィンドウで、 [Player](プレイヤー) > [Publishing Settings](公開の設定) の順に選択してから、 [Package name](パッケージ名) フィールドに適切な名前 (たとえば MRTKTutorials-GettingStarted) を入力します。In the Project Settings window, select Player > Publishing Settings, then in the Package name field, enter a suitable name, for example, MRTKTutorials-GettingStarted:

mr-learning-base

注意

'パッケージ名' は、アプリの一意の識別子です。The 'Package name' is the unique identifier for the app. 以前にインストールしたアプリが上書きされないように、アプリを配置する前にこの識別子を変更する必要があります。You should change this identifier before deploying the app to avoid overwriting previously installed apps.

ヒント

'製品名' は、HoloLens の [スタート] メニューに表示される名前です。The 'Product Name' is the name displayed in the HoloLens Start menu. 開発中にアプリを見つけやすくするには、名前の前にアンダースコアを追加し、上部にくるように並べ替えます。To make the app easier to locate during development, add an underscore in front of the name to sort it to the top.

シーンを作成して構成するCreating and configuring the scene

Unity メニューで、 [File](ファイル) > [New Scene](新しいシーン) の順に選択して新しいシーンを作成します。In the Unity menu, select File > New Scene to create a new scene:

mr-learning-base

Unity メニューで、 [Mixed Reality Toolkit] > [Add to Scene and Configure...](シーンに追加して構成する...) の順に選択して、MRTK を現在のシーンに追加します。In the Unity menu, select Mixed Reality Toolkit > Add to Scene and Configure... to add the MRTK to your current scene:

mr-learning-base

[Hierarchy](階層) ウィンドウで MixedRealityToolkit オブジェクトを選択したままとし、[Inspector](インスペクター) ウィンドウで、MixedRealityToolkit 構成プロファイルが DefaultMixedRealityToolkitConfigurationProfile に設定されていることを確認します。With the MixedRealityToolkit object still selected in the Hierarchy window, in the Inspector window, verify that the MixedRealityToolkit configuration profile is set to DefaultMixedRealityToolkitConfigurationProfile:

mr-learning-base

重要

通常、HoloLens 向けの開発時には DefaultHoloLens2ConfigurationProfile を使用します。Typically, you will use the DefaultHoloLens2ConfigurationProfile when developing for HoloLens. ただし、このチュートリアルでは、DefaultMixedRealityToolkitConfigurationProfile を使用します。そして、次のチュートリアル「MRTK プロファイルの構成」で、DefaultHoloLens2ConfigurationProfile に変更します。However, for this tutorial, you will use the DefaultMixedRealityToolkitConfigurationProfile, then in the next tutorial, Configuring the MRTK profiles, you will change to the DefaultHoloLens2ConfigurationProfile.

Unity メニューで、 [File](ファイル) > [Save As...](名前を付けて保存...) を選択して [Save Scene](シーンの保存) ウィンドウを開きます。In the Unity menu, select File > Save As... to open the Save Scene window:

mr-learning-base

[Save Scene](シーンの保存) ウィンドウで、プロジェクトの [Scenes](シーン) フォルダーに移動し、シーンに適切な名前を付け (たとえば、GettingStarted)、 [Save](保存) ボタンをクリックしてシーンを保存します。In the Save Scene window, navigate to your project's Scenes folder, give your scene a suitable name, for example, GettingStarted, and click the Save button to save the scene:

mr-learning-base

HoloLens 2 デバイス用にアプリケーションをビルドするBuilding your application to your HoloLens 2

1.Unity プロジェクトのビルド1. Build the Unity project

Unity メニューで、 [File](ファイル) > [Build Settings...](ビルド設定...) を選択し、[Build Settings](ビルド設定) ウィンドウを開きます。In the Unity menu, select File > Build Settings... to open the Build Settings window.

[Build Settings](ビルド設定) ウィンドウで、 [Add Open Scenes](開いているシーンを追加する) ボタンをクリックして、 [Scenes In Build](ビルド内のシーン) リストの現在のシーンを追加します。次に [Build](ビルド) ボタンをクリックして、[Build Universal Windows Platform](ユニバーサル Windows プラットフォームのビルド) ウィンドウを開きます。In the Build Settings window, click the Add Open Scenes button to add your current scene to the Scenes In Build list, then click the Build button to open the Build Universal Windows Platform window:

mr-learning-base

[Build Universal Windows Platform](ユニバーサル Windows プラットフォームのビルド) ウィンドウで、ビルドを格納する適切な場所 (たとえば D:\MixedRealityLearning\Builds) を選択し、新しいフォルダーを作成して適切な名前 (たとえば GettingStarted) を付け、 [Select Folder](フォルダーの選択) ボタンをクリックしてビルド処理を開始します。In the Build Universal Windows Platform window, choose a suitable location to store your build, for example, D:\MixedRealityLearning\Builds, create a new folder and give it a suitable name, for example, GettingStarted, and then click the Select Folder button to start the build process:

mr-learning-base

Unity がビルド処理を完了するまで待ちます。Wait for Unity to finish the build process:

mr-learning-base

2.アプリのビルドと配置2. Build and deploy the application

ビルド処理が完了すると、お客様がビルドを格納した場所を開くように Unity から Windows ファイル エクスプローラーに指示が出されます。When the build process has completed, Unity will prompt Windows File Explorer to open the location you stored the build. フォルダー内を移動し、ソリューション ファイルをダブルクリックして Visual Studio で開きます。Navigate inside the folder, and double-click the solution file to open it in Visual Studio:

mr-learning-base

注意

Visual Studio から新しいコンポーネントをインストールするよう求められたら、少し時間を取って、「 ツールのインストール 」ドキュメントで示されている、前提条件となるすべてのコンポーネントが用意できていることを確認してください。If Visual Studio asks you to install new components, take a moment to check that you have all the prerequisite components in the Install the Tools documentation.

[マスター] または [リリース] 構成を選択し、 [ARM64] アーキテクチャを選択し、ターゲットとして [デバイス] を選択して、HoloLens 用に Visual Studio を構成します。Configure Visual Studio for HoloLens by selecting the Master or Release configuration, the ARM64 architecture, and Device as target:

mr-learning-base

ヒント

HoloLens (第 1 世代) に配置する場合は、x86 アーキテクチャを選択します。If you're deploying to HoloLens (1st generation), select the x86 architecture.

注意

HoloLens の場合、通常は ARM アーキテクチャ用にビルドします。For HoloLens, you will typically build for the ARM architecture. ただし、Unity 2019.3 には、Visual Studio で ARM をビルド アーキテクチャとして選択した場合にエラーを引き起こす既知の問題が存在します。However, there is a known issue in Unity 2019.3 that causes errors when selecting ARM as the build architecture in Visual Studio. 推奨される回避策は、ARM64 用にビルドすることです。The recommended workaround is to build for ARM64. それがオプションでない場合は [Edit](編集) > [Project Settings](プロジェクト設定) > [Player](プレイヤー) > [Other Settings](他の設定) の順に選択して、 [Graphics Jobs](グラフィック ジョブ) を無効にします。If that is not an option, go to Edit > Project Settings > Player > Other Settings and disable Graphics Jobs.

注意

ターゲット オプションとして [デバイス] が表示されない場合は、Visual Studio ソリューションのスタートアップ プロジェクトを IL2CPP プロジェクトから UWP プロジェクトに変更することが必要な場合があります。If you don't see Device as a target option, you may need to change the startup project for the Visual Studio solution from the IL2CPP project to the UWP project. それを行うには、ソリューション エクスプローラーで、[YourProjectName (Universal Windows)](YourProjectName (ユニバーサル Windows)) を右クリックし、 [スタートアップ プロジェクトに設定] を選択します。To do this, in the Solution Explorer, right-click on YourProjectName (Universal Windows) and select Set as StartUp Project.

ご利用のコンピューターに HoloLens を接続し、 [デバッグ] > [デバッグなしで開始] の順に選択して、ご利用のデバイス用にビルドして配置します。Connect your HoloLens to your computer, then select Debug > Start Without Debugging to build and deploy to your device:

mr-learning-base

重要

デバイスに対してビルドする前に、デバイスが開発者モードになっており、かつ、開発コンピューターとペアリングされている必要があります。Before building to your device, the device must be in Developer Mode and paired with your development computer. この両方のステップを完了するには、こちらの手順に従います。Both of these steps can be completed by following these instructions.

ヒント

また、HoloLens Emulator に配置することも、サイドローディング用のアプリ パッケージを作成することもできます。You can also deploy to the HoloLens Emulator or create an App Package for sideloading.

[デバッグなしで開始] を使用すると、Visual Studio デバッガーがアタッチされていない状態でも、ご利用のデバイス上でアプリが自動的に起動します。Using Start Without Debugging automatically starts the app on your device without the Visual Studio debugger attached.

アプリを自動的に起動せずに、ご利用のデバイスに配置するには、 [ビルド] > [ソリューションの配置] の順に選択します。Select Build > Deploy Solution to deploy to your device without having the app start automatically.

注意

アプリでは、診断プロファイラーが表示される場合があります。このオン、オフを切り替えるには、音声コマンド Toggle Diagnostics を使用します。You may notice the Diagnostics profiler in the app, which you can toggle on or off by using the speech command Toggle Diagnostics. アプリへの変更がパフォーマンスに影響を与える可能性がある場合は、開発中の多くは、プロファイラーを表示したままにしておくことをお勧めします。It's recommended that you keep the profiler visible most of the time during development to understand when changes to the app may impact performance. たとえば、HoloLens アプリは 60 FPS で継続的に実行する必要があります。For example, HoloLens apps should continuously run at 60 FPS.

結論Congratulations

これで、最初の HoloLens アプリが展開されました。You've now deployed your first HoloLens app. 手順に従うと、HoloLens によって認識されたサーフェイスに対応する空間マッピングのメッシュが表示されるはずです。As you walk around, you should see a spatial mapping mesh covering the surfaces that are perceived by the HoloLens. さらに、手の追跡用の手と指のインジケーターと、アプリのパフォーマンスを監視するためのフレームレート カウンターも表示されるはずです。Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on app performance. これらの機能は、MRTK に含まれている基本的なもののほんの一部です。These features are just a few foundational pieces included with MRTK. 次のチュートリアルでは、コンテンツをシーンに追加して、HoloLens と MRTK の機能を調べます。In the upcoming tutorials, you'll add content to your scene to explore the capabilities of HoloLens and the MRTK.

次のチュートリアル:3. MRTK プロファイルの構成Next Tutorial: 3. Configuring the MRTK profiles