ML 学習ベース モジュール - プロジェクトの初期化と最初のアプリケーションMR Learning Base Module - Project Initialization and First Application

この最初のレッスンでは、Mixed Reality ツールキットが提供し、HoloLens 2 用の最初のアプリケーションを起動してデバイスにデプロイする必要のある機能について学習します。In this first lesson, you will learn some of the capabilities the Mixed Reality Toolkit has to offer, start your first application for the HoloLens 2, and deploy it to the device.

目標Objectives

  • HoloLens 用 Unity の開発を最適化する。Optimize Unity for HoloLens development.
  • アセットをインポートし、シーンをセットアップする。Import assets and setup the scene.
  • 空間のメッシュ、手の形のメッシュ、およびフレームレート カウンターの視覚化。Visualization of the spatial mesh, hand meshes, and the framerate counter.

手順Instructions

新しい Unity プロジェクトを作成しますCreate new Unity project

  1. Unity を起動します。Start Unity.
  2. [新規] を選択します。Select New. Lesson1 Chapter1 Step2Lesson1 Chapter1 Step2
  3. プロジェクト名を入力します (例: "MixedRealityBase")。Enter a project name (e.g. "MixedRealityBase"). Lesson1 Chapter1 Step3Lesson1 Chapter1 Step3
  4. プロジェクトを保存する場所を入力します。Enter a location to save your project. Lesson1 Chapter1 Step4Lesson1 Chapter1 Step4
  5. プロジェクトが [3D] に設定されていることを確認します。Make sure the project is set to 3D. Lesson1 Chapter1 Step5Lesson1 Chapter1 Step5
  6. [プロジェクトの作成] をクリックします。Click Create Project. Lesson1 Chapter1 Step6Lesson1 Chapter1 Step6

Windows Mixed Reality 用に Unity プロジェクトを構成するConfigure the Unity project for Windows Mixed Reality

  1. [ファイル] > [ビルド設定] の順に移動して、ビルド設定ウィンドウを開きます。Open the build settings window by going to File>Build Settings. Lesson1 Chapter4 Step1Lesson1 Chapter4 Step1
  2. [ユニバーサル Windows プラットフォーム] を選択して [ユニバーサル Windows プラットフォーム] に切り替えてから、[プラットフォームの切り替え] ボタンをクリックしてプラットフォームを切り替えます。Switch to “Universal Windows Platform” by selecting “Universal Windows Platform” and then click the “Switch Platform” button to switch platforms. HoloLens 2 でアプリを実行するには、ユニバーサル Windows プラットフォーム (UWP) である必要があります。Apps running on HoloLens 2 are required to be Universal Windows Platform (UWP). Lesson1 Chapter4 Step2Lesson1 Chapter4 Step2
  3. 下の図に示されているように、ビルド ウィンドウで [プレーヤー設定] をクリックして仮想現実を有効にしてから、[インスペクター] パネルの [XR 設定] の下の [仮想現実のサポート] チェック ボックスをオンにします。Enable virtual reality by clicking on Player Settings in the Build Window, and then in the inspector panel enable the “Virtual Reality Supported” checkbox under XR Settings, as shown in the image below. [インスペクター] パネルを表示するためには、邪魔にならないように [ビルド設定] ウィンドウをドラッグする必要がある場合があることに注意してください。Please note that you may need to drag the "Build Settings" window out of the way in order to see the inspector panel. [仮想現実のサポート] チェック ボックスは、立体視 (それぞれの目で異なる画像をレンダリングする) を有効にすることを指すため、Mixed Reality / AR ヘッドセットにも適用されます。Lesson1 Chapter4 Step3The "Virtual Reality Supported" checkbox also applies to Mixed Reality / AR headsets because it refers to the enabling of stereoscopic vision (rendering different images for each eye.) Lesson1 Chapter4 Step3
  4. 同じ [インスペクター] パネルで、[公開設定] の下の [機能] セクションの [空間認知] チェック ボックスがオンになっていることを確認します。In the same inspector panel, check that the “Spatial Perception” checkbox in the capabilities section is enabled, under Publishing Settings. [空間認知] を使用すると、HoloLens 2 などの Mixed Reality デバイスで空間マッピングのメッシュを視覚化できます。Spatial Perception will allow us to visualize the spatial mapping mesh on a mixed reality device such as the HoloLens 2. [公開設定] は、[インスペクター] パネルの [XR 設定] の上、[その他の設定] の下にあります。Publishing settings are found in the Inspector panel, above "XR Settings" and under "Other Settings." Lesson1 Chapter4 Step4Lesson1 Chapter4 Step4

注: このセクションでは使用していませんが、有効にできるその他の一般的な機能には、[マイク] (音声コマンド用) と [InternetClient] (ネットワーク接続が必要なサービスの接続用) が含まれていますNOTE: While not used in this section, some other common capabilities you may want to enable include Microphone (for voice commands) and InternetClient (for connecting to services requiring a network connection)

Mixed Reality ツールキットをインポートするImport the Mixed Reality Toolkit

  1. Mixed Reality Toolkit の Unity パッケージをダウンロードし、PC 上のフォルダーに保存します。Download the Mixed Reality Toolkit unity package and save it to a folder on your PC.

  2. [アセット] > [インポート] > [カスタム パッケージ] の順にクリックして、Mixed Reality Toolkit パッケージをインポートします。Import the Mixed Reality Toolkit package by clicking on Assets>Import>Custom Package. 手順 1 でダウンロードした Mixed Reality Toolkit パッケージを見つけて開き、インポート プロセスを開始します。Find the Mixed Reality Toolkit package downloaded in Step 1 and open it to begin the importing process. インポート プロセスには数分お待ちください。Please allow a few minutes for the importing process. Lesson1 Chapter2 Step2a Lesson1 Chapter2 Step2bLesson1 Chapter2 Step2a Lesson1 Chapter2 Step2b

  3. 次のポップアップ ウィンドウで、[インポート] をクリックして Mixed Reality Toolkit のインポートを開始します。In the next pop-up window, click “Import” to begin importing the Mixed Reality Toolkit. 図に示されているように、すべての項目を必ずオンにしてください。Ensure all items are checked, as shown in the image. Mixed Reality Toolkit の既定の設定を適用するよう求めるポップアップ ダイアログ ボックスを表示されたら、[適用] をクリックします。If you see a pop-up dialog box asking to apply Mixed Reality Toolkit default settings, click "Apply." Lesson1 Chapter2 Step3 Lesson1 Chapter2 Step3Lesson1 Chapter2 Step3 Lesson1 Chapter2 Step3

Mixed Reality ツールキットを構成するConfigure the Mixed Reality Toolkit

  1. メニュー バーで [Mixed Reality Toolkit] > [構成] の順に選択して、Mixed Toolkit を構成します。Configure the Mixed Toolkit by selecting from the menu bar Mixed Reality Toolkit > Configure. Mixed Reality Toolkit をインポートした後でこのメニュー項目が表示されない場合は、Unity を再起動してください。If you don't see this menu item after importing the mixed reality toolkit, please restart Unity. Lesson1 Chapter3 Step1Lesson1 Chapter3 Step1
  2. これでシーンに、いくつかの新しい項目と、Mixed Reality Toolkit からの変更が表示されます。Your scene will now have several new items and modifications in it from the Mixed Reality Toolkit. [ファイル] > [名前を付けて保存] の順にクリックして別の名前でシーンを保存し、シーンに名前を付けます (例: BaseScene)。Save your scene under a different name by clicking on File>Save As and give your scene a name, e.g., BaseScene. プロジェクトのアセット フォルダー内の [シーン] フォルダーにシーンを保存することで、シーンを整理します。Keep your scene organized by saving it to the “Scenes” folder in your project’s Assets folder. Lesson1 Chapter3 Step2a Lesson1 Chapter3 Step2bLesson1 Chapter3 Step2a Lesson1 Chapter3 Step2b

デバイスへのアプリケーションのビルドBuild your application to your device

  1. 前のセクションで [ビルド設定] ウィンドウを閉じた場合は、[ファイル] > [ビルド設定] の順に移動して [ビルド設定] ウィンドウを再度開きます。If you closed the Build Settings window from the previous sections, open the build settings window again by going to File>Build Settings. Lesson1 Chapter5 Step1Lesson1 Chapter5 Step1

  2. [開いているシーンの追加] ボタンをクリックして、試したいシーンが [ビルド内のシーン] リストに含まれていることを確認します。Ensure the scene you want to try is in the “Scenes in Build” list by clicking on the “Add Open Scenes” button.

  3. [ビルド] ボタンを押して、ビルド プロセスを開始します。Press the Build button to begin the build process. Lesson1 Chapter5 Step3Lesson1 Chapter5 Step3

  4. アプリケーション用の新しいフォルダーを作成して、名前を付けます。Create and name a new folder for your application. 下の図では、アプリケーションを含めるために [App] という名前のフォルダーが作成されています。In the image below, a folder with the name “App” was created to contain the application. [フォルダーの選択] をクリックして、新しく作成したフォルダーへのビルドを開始します。Click “Select Folder” to begin building to the newly created folder. ビルドが完了したら、Unity の [ビルド設定] ウィンドウを閉じてもかまいません。After the build has completed, you may close the "Build Settings" window in Unity. Lesson1 Chapter5 Step4Lesson1 Chapter5 Step4

注: ビルドが失敗した場合は、もう一度構成してみるか、Unity を再起動してから再度ビルドしてください。NOTE: If the build fails, try building again or restarting Unity and building again. [エラー:CS0246 = “XX” という名前の型または名前空間が見つかりませんでした (ディレクトリの使用またはアセンブリ参照が不足しています)] のようなエラーが表示される場合は、Windows 10 SDK (10.0.18362.0) のインストールが必要な場合がありますIf you see an error such as "Error: CS0246 = The type or namespace name “XX” could not be found (are you missing a using directive or an assembly reference?)", then you may need to install Windows 10 SDK (10.0.18362.0)

  1. ビルドが完了したら、新しくビルドされたアプリケーション ファイルが含まれている、新しく作成されたフォルダーを開きます。After the build is completed, open the newly created folder containing your newly built application files. [MixedRealityBase.sln] ソリューション (または、プロジェクトの代替名を使用した場合は対応する名前) をダブルクリックして、Visual Studio でソリューション ファイルを開きます。Double click on the “MixedRealityBase.sln” solution (or the corresponding name, if you used an alternative name for your project) to open the solution file in Visual Studio.

注:必ず、新しく作成したフォルダー (つまり、前の手順で名前付け規則に従っている場合は、[App] フォルダー) を開いてください。そのフォルダーの外部に同じような名前の .sln ファイルがあり、ビルド フォルダー内の .sln ファイルと混同してはならないためです。Note: Be sure to open the newly created folder (i.e., the "App" folder, if following the naming conventions from the previous steps), as there will be a similarly named .sln file outside of that folder that is not to be confused with the .sln file inside the build folder.

Lesson1 Chapter5 Step5

注:Visual Studio から新しいコンポーネントをインストールするよう求められたら、少し時間を取って、「ツールのインストール」ページで示されている、前提条件となるすべてのコンポーネントがインストールされていることを確認してくださいNote: If Visual Studio asks you to install new components, please take a moment to ensure that all prerequisite components are installed as specified in the "Install the Tools" page

  1. USB ケーブルを使って HoloLens 2 を PC に接続します。Plug your HoloLens 2 into your PC with the USB cable. これらのレッスンの手順では、HoloLens 2 デバイスを使ってテストをデプロイすることを前提としていますが、HoloLens 2 エミュレーターにデプロイすることも、サイドローディング用のアプリ パッケージを作成することもできますWhile these lesson instructions assume you will be deploying a testing with a HoloLens 2 device, you may also choose to deploy to the HoloLens 2 emulator or choose to create an app package for sideloading

  2. デバイスにビルドする前に、デバイスが開発者モードであることを確認してください。Before building to your device, ensure that the device is in Developer Mode. HoloLens 2 に初めてデプロイする場合は、Visual Studio により、PIN を使用して HoloLens 2 をペアリングするよう求められる場合があります。If this is your first time deploying to the HoloLens 2, Visual Studio may ask you to pair your HoloLens 2 with a pin. 開発者モードを有効にするか、Visual Studio とペアリングする必要がある場合は、こちらの手順に従ってください。Please follow these instructions if you need to enable developer mode or pair with Visual Studio.

  3. [リリース] 構成と [ARM] アーキテクチャを選択して、HoloLens 2 へのビルド用に Visual Studio を構成します。Configure Visual Studio for building to your HoloLens 2 by selecting the “Release” configuration and the “ARM” architecture. Lesson1 Chapter5 Step8Lesson1 Chapter5 Step8

  4. 最後の手順は、[デバッグ] > [デバッグなしで開始] を選択して、デバイスにビルドすることです。The final step is to build to your device by selecting Debug>Start without Debugging. [デバッグなしで開始] を選択すると、ビルドが成功した時点でアプリケーションがデバイスですぐに起動しますが、Visual Studio にデバッグ情報は表示されません。Selecting “Start without Debugging” will cause the application to immediately start on your device upon a successful build, but without Debugging information appearing in Visual Studio. これは、アプリケーションが停止することなく HoloLens 2 上で実行されている間は、USB ケーブルを取り外すことができることも意味します。This also means that you can disconnect your USB cable while your application is running on your HoloLens 2 without stopping the application. また、[ビルド] > [ソリューションの配置] を選択することで、アプリケーションを自動的に起動せずにデバイスに配置することもできます。You may also select Build>Deploy Solution to deploy to your device without having the application automatically start. Lesson1 Chapter5 Step9Lesson1 Chapter5 Step9

結論Congratulations

これで、最初の HoloLens 2 アプリケーションがデプロイされました。You now have now deployed your first HoloLens 2 application. 手順に従うと、HoloLens 2 によって認識されたすべてのサーフェイスをカバーする空間のメッシュが表示されるはずです。As you walk around, you should see a spatial mesh cover all the surfaces that have been perceived by the HoloLens 2. さらに、手の追跡用の手と指のインジケーターと、アプリのパフォーマンスを監視するためのフレームレート カウンターも表示されるはずです。Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on app performance. これらは、Mixed Reality ツールキットに含まれている、すぐに使用できる基礎となる部分のほんの一部です。These are just a few of the foundational pieces, included out of the box, with the Mixed Reality Toolkit. 以降のレッスンでは、HoloLens 2 と Mixed Reality Toolkit の機能を十分に検討できるように、シーンへのコンテンツや対話機能の追加を始めます。In the lessons to come, you will start adding more content and interactivity to your scene, so you can fully explore the capabilities of the HoloLens 2 and the Mixed Reality Toolkit.

注:音声コマンドを使用してフレームレート カウンターを切り替える方法については、レッスン 5 で説明しますNote: You will cover how to toggle the frame rate counter using a voice command in Lesson 5

次のレッスン: ユーザー インターフェイス、手の追跡、Mixed Reality Toolkit の構成Next Lesson: User Interface, Hand Tracking, and Mixed Reality Toolkit Configuration