2.プロジェクトと最初のアプリケーションの初期化2. Initializing your project and first application

概要Overview

この最初のレッスンでは、Mixed Reality ツールキット (MRTK) によって提供され、HoloLens 2 用の最初のアプリケーションを起動してデバイスにデプロイされる必要のあるいくつかの機能について学習します。In this first lesson, you'll learn about some of the capabilities the Mixed Reality Toolkit (MRTK) has to offer, start your first application for the HoloLens 2, and deploy it to the device.

目標Objectives

  • HoloLens 用 Unity の開発を構成する。Configure Unity for HoloLens development.
  • アセットをインポートし、シーンをセットアップする。Import assets and set up the scene.
  • 空間マッピングのメッシュ、ハンド メッシュ、およびフレームレート カウンターの視覚化。Visualization of the spatial mapping mesh, hand meshes, and the framerate counter.

新しい Unity プロジェクトを作成しますCreate new Unity project

  1. Unity を起動します。Start Unity.

  2. [新規] を選択します。Select New.

    レッスン 1 セクション 1 手順 2

  3. プロジェクト名を入力します (例: "MixedRealityBase")。Enter a project name (e.g. "MixedRealityBase").

    レッスン 1 セクション 1 手順 3

  4. プロジェクトを保存する場所を入力します。Enter a location to save your project.

    レッスン 1 セクション 1 手順 4

  5. プロジェクトが [3D] に設定されていることを確認します。Make sure the project is set to 3D.

    レッスン 1 セクション 1 手順 5

  6. [プロジェクトの作成] をクリックします。Click Create Project.

    レッスン 1 セクション 1 手順 6

Windows Mixed Reality 用に Unity プロジェクトを構成するConfigure the Unity project for Windows Mixed Reality

  1. [ファイル] > [ビルド設定] の順に移動して、 [ビルド設定] ウィンドウを開きます。Open the Build Settings window by going to File > Build Settings.

    レッスン 1 セクション 2 手順 1

  2. [ユニバーサル Windows プラットフォーム ] を選択して、 [Switch Platform](プラットフォームの切り替え) ボタンをクリックしてプラットフォームを切り替えます。Select the Universal Windows Platform and click the Switch Platform button to switch platforms. HoloLens 2 上で実行されるアプリケーションは、ユニバーサル Windows プラットフォーム (UWP) に対応している必要があります。Applications running on HoloLens 2 are required to be Universal Windows Platform (UWP) compatible.

    レッスン 1 セクション 2 手順 2

  3. 下の図に示されているように、ビルド ウィンドウで [プレーヤー設定] ボタンをクリックして仮想現実を有効にしてから、[インスペクター] パネルの [XR 設定] 下にある [仮想現実のサポート] チェック ボックスをオンにします。Enable virtual reality by clicking the Player Settings button in the Build Window, and enable the Virtual Reality Supported checkbox under XR Settings from the inspector panel, as shown in the image below. 状況によっては、[インスペクター] パネルを表示するために、邪魔にならないように [ビルド設定] ウィンドウをドラッグする必要があることに注意してください。Note that you might need to drag the Build Settings window out of the way in order to see the inspector panel. [仮想現実のサポート] チェック ボックスは、立体視 (それぞれの目で異なる画像をレンダリングする) を有効にすることを指すため、Mixed Reality および Augmented Reality ヘッドセットにも適用されます。The Virtual Reality Supported checkbox also applies to Mixed Reality and Augmented Reality headsets because it refers to the enabling of stereoscopic vision (rendering different images for each eye.)

    レッスン 1 セクション 2 手順 3

  4. また、[XR の設定] 下で [Stereo Rendering Mode](ステレオ レンダリング モード)[Single Pass Instanced](単一パスのインスタンス化) に変更します。Also under XR Settings, change the Stereo Rendering Mode to Single Pass Instanced. このパイプラインのレンダリング スタイルは通常、HoloLens 2 においてパフォーマンスが最も高くなります。This rendering pipeline style is generally most performant for HoloLens 2. Unity 環境における他の高パフォーマンスの構成に関心がある場合は、こちらの手順に従ってください。If interested in other performant configurations for your Unity environment, follow these instructions.

    レッスン 1 セクション 2 手順 4

  5. 同じ [インスペクター] パネルで、 [公開設定] の下の [機能] セクションにある [空間認識] チェック ボックスがオンになっていることを確認します。From the same inspector panel, ensure that the Spatial Perception checkbox in the capabilities section is enabled under Publishing Settings. 空間認識を使用すると、HoloLens 2 などの Mixed Reality デバイス上で空間マッピングのメッシュを視覚化できます。Spatial Perception allows us to visualize the spatial mapping mesh on a mixed reality device, such as HoloLens 2. [公開設定] は、[インスペクター] パネル内の [XR 設定] の上、[その他の設定] の下にあります。Publishing Settings are found in the inspector panel, above XR Settings and under Other Settings.

    レッスン 1 セクション 2 手順 5

    注意

    このセクションでは使用していませんが、有効にできるその他の一般的な機能には、 [マイク] (音声コマンド用) と [InternetClient] (ネットワーク接続が必要なサービスの接続用) が含まれています。While not used in this section, some other common capabilities you might want to enable include the Microphone for voice commands, and InternetClient for connecting to services requiring a network connection.

Mixed Reality ツールキットをインポートするImport the Mixed Reality Toolkit

  1. Mixed Reality Toolkit の Unity Foundation パッケージ バージョン 2.1.0 をダウンロードし、PC 上のフォルダーに保存します。Download the Mixed Reality Toolkit Unity foundation package version 2.1.0 and save it to a folder on your PC.

  2. 前の手順でダウンロードした Mixed Reality Toolkit パッケージをインポートします。Import the Mixed Reality Toolkit package that you downloaded in the previous step. まず、 [資産] > [インポート] > [カスタム パッケージ] の順にクリックし、Microsoft.MixedReality.Toolkit.Unity.Foundation.2.1.0.unitypackage を選択して開き、インポート処理を開始します。Start by clicking on Assets > Import > Custom Package, select Microsoft.MixedReality.Toolkit.Unity.Foundation.2.1.0.unitypackage and open it to begin the importing process. インポート プロセスが完了するまで数分間お待ちください。Allow a few minutes for the importing process to complete.

    レッスン 1 セクション 3 手順 2a

    レッスン 1 セクション 3 手順 2b

  3. 次のポップアップ ウィンドウで、 [インポート] をクリックして、選択したパッケージの Unity プロジェクトへのインポートを開始します。In the next pop-up window, click Import to begin importing the selected package into the Unity project. 図に示されているように、すべての項目のチェックを必ずオンにしてください。Ensure all items are checked as shown in the image.

    レッスン 1 セクション 3 手順 3

    注意

    Mixed Reality Toolkit の既定の設定を適用するかを尋ねるポップアップのダイアログ ボックスが表示されたら、 [適用] をクリックします。If you see a pop-up dialog box asking to apply the Mixed Reality Toolkit default settings, click Apply. MRTK では、自動セットアップのためにインポートが行われる場合、不足している推奨設定についてプロジェクトが分析されます。MRTK analyzes your project for any missing recommended settings when imported for automated setup. 設定によっては、ポップアップ表示は、以下の図と異なる場合があります。Depending on your settings, the pop-up might look different than the image below.

    レッスン 1 セクション 3 手順 4 注意 1

Mixed Reality ツールキットを構成するConfigure the Mixed Reality Toolkit

  1. [Mixed Reality Toolkit] > [Add to Scene and Configure..](シーンに追加して構成する) の順に選択して、 [Mixed reality Toolkit] を現在のシーンに追加します。Add the Mixed Reality Toolkit to your current scene by selecting Mixed Reality Toolkit > Add to Scene and Configure.. メニュー バーから行います。from the menu bar. Mixed Reality Toolkit をインポートした後でこのメニュー項目が表示されない場合は、Unity を再起動してください。If you don't see this menu item after importing the mixed reality toolkit, restart Unity.

    レッスン 1 セクション 4 手順 1

    注意

    Mixed Reality Toolkit 向けのプロファイルを選択するためのポップアップ ダイアログ ボックスが表示される場合があります。You may see a pop-up dialog box for selecting a profile for the Mixed Reality Toolkit. DefaultHoloLens2ConfigurationProfile という名前のプロファイルをダブルクリックして選択します。Choose the profile named DefaultHoloLens2ConfigurationProfile by double-clicking it.

  2. シーンには、新しい項目と変更がいくつか追加される予定です。Your scene will have several new items and modifications. [ファイル] > [名前を付けて保存] の順にクリックして別の名前でシーンを保存します。シーンには、BaseScene などの名前を付けます。Save your scene under a different name by clicking File > Save As..., and give your scene a name, such as BaseScene. シーンをプロジェクトの [アセット] フォルダー内の [シーン] フォルダーに保存して、整理します。Keep your scene organized by saving it to the Scenes folder in your project’s Assets folder.

    レッスン 1 セクション 4 手順 2a

    レッスン 1 セクション 4 手順 2b

デバイスへのアプリケーションのビルドBuild your application to your device

  1. 前のセクションで [ビルド設定] ウィンドウを閉じた場合は、 [ファイル] > [ビルド設定] の順に移動して [ビルド設定] ウィンドウを再度開きます。If you closed the Build Settings window from the previous sections, open the Build Settings window again by going to File > Build Settings.

    レッスン 1 セクション 5 手順 1

  2. Unity でシーンが開いているときに、 [Add Open Scenes](開いているシーンの追加) ボタンをクリックして、 [Scenes in Build](ビルド内のシーン) に先ほど作成したシーンがあることを確認します。Ensure the scene you just created is in the Scenes in Build list by clicking on the Add Open Scenes button while your scene is open in Unity.

  3. [ビルド] ボタンを押して、ビルド プロセスを開始します。Press the Build button to begin the build process.

    レッスン 1 セクション 5 手順 3

  4. アプリケーション用の新しいフォルダーを作成して、名前を付けます。Create and name a new folder for your application. 下の図では、アプリケーションを格納するための App という名前のフォルダーが作成されています。In the image below, a folder with the name App was created to contain the application. [フォルダーの選択] をクリックして、新しく作成したフォルダーへのビルドを開始します。Click Select Folder to begin building to the newly created folder. ビルドが完了したら、Unity の [ビルド設定] ウィンドウを閉じてもかまいません。After the build has completed, you can close the Build Settings window in Unity.

    レッスン 1 セクション 5 手順 4

    重要

    ビルドが失敗した場合は、もう一度構成してみるか、Unity を再起動してから再度ビルドしてください。If the build fails, try building again or restarting Unity and building again. "エラー:CS0246 = “XX” という名前の型または名前空間が見つかりませんでした (using ディレクティブまたはアセンブリ参照が不足しています)" のようなエラーが表示される場合があります。If you see an error, such as "Error: CS0246 = The type or namespace name “XX” could not be found (are you missing a using directive or an assembly reference?). その場合は、必要に応じて Windows 10 SDK (10.0.18362.0) をインストールします。If so, you might need to install Windows 10 SDK (10.0.18362.0)

  5. ビルドが完了したら、新しくビルドされたアプリケーション ファイルが含まれている、新しく作成されたフォルダーを開きます。After the build is completed, open the newly created folder containing your newly built application files. MixedRealityBase.sln ソリューション (または、プロジェクトの代替名を使用した場合は対応する名前) をダブルクリックして、Visual Studio でソリューション ファイルを開きます。Double-click on the MixedRealityBase.sln solution, or the corresponding name, if you used an alternative name for your project, to open the solution file in Visual Studio.

    注意

    必ず、新しく作成したフォルダー (つまり、前の手順での名前付け規則に従っている場合は、 [App] フォルダー) を開いてください。そのフォルダーの外部に同じような名前の .sln ファイルがあり、ビルド フォルダー内の .sln ファイルと混同しないようにするためです。Be sure to open the newly created folder (i.e. the App folder, if following the naming conventions from the previous steps), as there will be a similarly named .sln file outside of that folder, that is not to be confused with the .sln file inside the build folder. フォルダー構造は、以下の画像のようになります。The folder structure should look similar to the image below.

    Visual Studio から新しいコンポーネントをインストールするよう求められたら、少し時間を取って、「ツールのインストール」ページで示されている、前提条件となるすべてのコンポーネントがインストールされていることを確認してくださいIf Visual Studio asks you to install new components, take a moment to ensure that all prerequisite components are installed as specified in the "Install the Tools" page

    レッスン 1 セクション 5 手順 5

  6. HoloLens 2 を PC に接続します。Connect your HoloLens 2 into your PC. これらの手順では、HoloLens 2 デバイスにデプロイすることを前提としていますが、HoloLens 2 エミュレーターにデプロイすることも、サイドローディング用のアプリ パッケージを作成することもできますWhile these instructions assume you will be deploying to a HoloLens 2 device, you might also choose to deploy to the HoloLens 2 emulator or choose to create an app package for sideloading

    重要

    デバイスをビルドする前に、デバイスが "開発者モード" であり、かつ、開発コンピューターと一組になっている必要があります。Before building to your device, the device must be in Developer Mode and paired with your development machine. この両方のステップを完了するには、こちらの手順に従います。Both of these steps can be completed by following these instructions

  7. [リリース] または [マスター] 構成、 [ARM] アーキテクチャ、ターゲットとして [デバイス] を選択して、HoloLens 2 に対するビルド用に Visual Studio を構成します。Configure Visual Studio for building to your HoloLens 2 by selecting the Release or Master configuration, the ARM architecture, and Device as target.

    レッスン 1 セクション 5 手順 8

  8. 最後の手順として、 [デバッグ] > [デバッグなしで開始] を選択してビルドし、デバイスにデプロイします。The final step is to build and deploy to your device by selecting Debug > Start without debugging. [デバッグなしで開始] を選択すると、ビルドが成功した時点でアプリケーションがデバイス上ですぐに起動しますが、デバッガーがアタッチされていない状態であり、Visual Studio にデバッグ情報は表示されません。Selecting Start without Debugging causes the application to immediately start on your device upon a successful build, but without the debugger attached and information appearing in Visual Studio. これは、アプリケーションが停止することなく HoloLens 2 上で実行されている間は、USB ケーブルを取り外すことができることも意味します。This also means that you can disconnect your USB cable while your application is running on your HoloLens 2 without stopping the application.

    注意

    また、 [ビルド] > [ソリューションの配置] を選択することで、アプリケーションを自動的に起動せずにデバイスにデプロイすることもできます。You might also select Build > Deploy Solution to deploy to your device without having the application automatically start.

    レッスン 1 セクション 5 手順 9

結論Congratulations

これで、最初の HoloLens 2 アプリケーションがデプロイされました。You have now deployed your first HoloLens 2 application. 手順に従うと、HoloLens 2 によって認識されたすべてのサーフェイスに対応する空間マッピングのメッシュが表示されるはずです。As you walk around, you should see a spatial mapping mesh covering all the surfaces that have been perceived by the HoloLens 2. さらに、ハンド トラッキング用の手および指に対するインジケーターと、アプリケーションのパフォーマンスを監視するためのフレーム レート カウンターも表示されるはずです。Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on application performance. これらは、Mixed Reality ツールキットに含まれている、すぐに使用できる基礎となる部分のほんの一部です。These are just a few of the foundational pieces, included out of the box, with the Mixed Reality Toolkit. 以降のレッスンでは、HoloLens 2 と Mixed Reality Toolkit の機能を十分に探索できるように、シーンにコンテンツや対話機能を追加する作業を開始します。In the lessons to come, you will start adding more content and interactivity to your scene so that you can fully explore the capabilities of HoloLens 2 and the Mixed Reality Toolkit.

注意

アプリ上で、ビジュアル プロファイラーに気が付く場合があります。In the app, you may notice the visual profiler. 音声コマンドを使用してフレーム レート カウンターを切り替える方法については、レッスン 5 で説明します。You will cover how to toggle the frame rate counter using a voice command in Lesson 5. 一般に、コードの変更によってパフォーマンスが影響を受ける可能性がある場合は、開発中に常にビジュアル プロファイラーを表示したままにしておくことをお勧めします。It is generally recommended to keep the visual profiler visible at all times during development to understand when code changes may have impacted perf. HoloLens 2 アプリケーションは、60 FPS で継続的に実行される必要があります。HoloLens 2 application should continuously run at 60 FPS.

次のレッスン:3.ユーザー インターフェイスの作成と Mixed Reality ツールキットの構成Next Lesson: 3. Creating user interface and configure Mixed Reality Toolkit