グラフィックス ツールへの貢献 — MRTK3

パッケージを更新する

  1. リポジトリをフォークし、ブランチを作成します。 推奨されるブランチの名前付けは .user/username/feature
  2. Unity でサンプル プロジェクトを GraphicsToolsUnityProject 複製して開きます。
  3. 必要な変更を加えます。 既定では、パッケージ内 MRTK Graphics Tools のすべての編集はグラフィックス ツール パッケージに発行されます。 (サンプルを更新する場合は、次のセクションを参照してください)。
  4. 分岐をフォークにプッシュし、pull request を作成します。 pull request に変更の説明を追加します。 画像や gif は常に高く評価されます。

パッケージ サンプルの更新

サンプルは、Unity のサンプルレコメンデーションの概要に従って Samples~ サブフォルダーの下に存在します。 「~」 文字を使用すると、 Samples~ フォルダーが Unity によってインポートされなくなります。 これは、パッケージ マネージャー経由でパッケージを含む場合に最適です。 ただし、パッケージ のサンプルを更新する場合ではありません。

サンプルに変更を加える場合は、Unity プロジェクトのディレクトリ構造に対して一時的なローカル変更を行う必要があります。

  1. Unity で GraphicsToolsUnityProject を開きます。 既定では、[サンプル] フォルダーは MRTK Graphics Tools パッケージに表示されません。 サンプルを表示するには、ファイル メニュー バーから [ウィンドウ] > [グラフィックス ツール] > [サンプルを表示する] を選択します。
  2. サンプルに必要な変更を加えます。
  3. 重要: 完了し、変更をコミットする前に、必ずサンプルを非表示にしてください。 [ウィンドウ グラフィックス ツール] > を選択し、>ファイル メニュー バーから [サンプルを非表示にする] を選択します。

ヒント

サンプルを編集した後に ウィンドウ > グラフィックス ツール > の [サンプルを非表示にする ] メニュー項目を呼び出すと、Git はすべてのサンプル ファイルが変更されたと考えます。 サンプルが非表示になると、実際に変更されたファイルが git で明らかになります。