테이블 형식 모델 프로젝트 만들기Create a tabular model project

적용 대상: SQL Server 2019 이상 Analysis Services Azure Analysis Services Power BI Premium

이 단원에서는 Microsoft Analysis Services 프로젝트와 함께 Visual Studio를 사용 하 여 새 테이블 형식 모델 프로젝트를 만듭니다.In this lesson, you use Visual Studio with Microsoft Analysis Services projects to create a new tabular model project. 새 프로젝트가 만들어지면 데이터를 추가하고 모델을 작성할 수 있습니다.Once your new project is created, you can begin adding data and authoring your model. 이 단원에서는 Visual Studio의 테이블 형식 모델 작성 환경에 대해 간략히 소개합니다.This lesson also gives you a brief introduction to the tabular model authoring environment in Visual Studio.

이 단원을 완료하기 위한 예상 시간: 10분Estimated time to complete this lesson: 10 minutes

사전 요구 사항Prerequisites

이 문서는 테이블 형식 모델 제작 자습서의 첫 번째 단원입니다.This article is the first lesson in a tabular model authoring tutorial. 이 단원을 완료하기 위해 마련해야 하는 몇 가지 필수 구성 요소가 있습니다.To complete this lesson, there are several prerequisites you need to have in-place. 자세한 내용은 Analysis Services 놀이 Works 자습서를 참조 하세요.To learn more, see Analysis Services - Adventure Works tutorial.

새 테이블 형식 모델 프로젝트 만들기Create a new tabular model project

새 테이블 형식 모델 프로젝트를 만들려면To create a new tabular model project

  1. Visual Studio의 시작에서 새 프로젝트 만들기를 클릭 합니다.In Visual Studio, in Get started, click Create a new project.

  2. 새 프로젝트 만들기에서 테이블 형식 프로젝트 Analysis Services를 검색 한 다음 선택 합니다.In Create a new project, search for and then select Analysis Services Tabular Project.

  3. 새 프로젝트 구성프로젝트 이름AW Internet Sales를 입력 합니다.In Configure your new project, in Project name, type AW Internet Sales. 프로젝트 파일의 위치를 지정 합니다.Specify a location for the project files. 프레임 워크 를 기본값으로 둡니다.Leave Framework the default.

    기본적으로 솔루션 이름은 프로젝트 이름과 같게 되지만 다른 솔루션 이름을 입력할 수 있습니다.By default, Solution Name is the same as the project name; however, you can type a different solution name.

  4. 만들기를 클릭합니다.Click Create.

  5. 테이블 형식 모델 디자이너 대화 상자에서 통합된 작업 영역을 선택합니다.In the Tabular model designer dialog box, select Integrated workspace.

    작업 영역은 모델을 작성하는 동안 프로젝트와 동일한 이름을 가진 테이블 형식 모델 데이터베이스를 호스팅합니다.The workspace hosts a tabular model database with the same name as the project during model authoring. 통합된 작업 영역은 Visual Studio에서 기본 제공 인스턴스를 사용하므로 모델 작성만을 위해 별도의 Analysis Services 서버 인스턴스를 설치할 필요가 없음을 의미합니다.Integrated workspace means Visual Studio uses a built-in instance, eliminating the need to install a separate Analysis Services server instance just for model authoring. 자세히 알아보려면 작업 영역 데이터베이스를 참조 하세요.To learn more, see Workspace database.

  6. 호환성 수준에서 SQL Server 2019/Azure Analysis Services (1500) 를 선택한 다음 확인을 클릭 합니다.In Compatibility level, select SQL Server 2019 / Azure Analysis Services (1500), and then click OK.

    통합 작업 영역 옵션과 호환성 수준 드롭다운 목록이 포함 된 테이블 형식 모델 디자이너 대화 상자의 스크린샷

완료 되 면 새 테이블 형식 모델 프로젝트가 Visual Studio에서 열립니다.When complete, your new tabular model project will open in Visual Studio.

테이블 형식 모델 제작 환경 이해Understanding the tabular model authoring environment

새 테이블 형식 모델 프로젝트를 만들었으므로 이제 Visual Studio에서 테이블 형식 모델 제작 환경을 살펴보겠습니다.Now that you've created a new tabular model project, let's take a moment to explore the tabular model authoring environment in Visual Studio.

프로젝트가 만들어지면 Visual Studio에서 해당 프로젝트가 열립니다.After your project is created, it opens in Visual Studio. 오른쪽의 테이블 형식 모델 탐색기에 모델에 있는 개체의 트리 보기가 표시됩니다.On the right side, in Tabular Model Explorer, you see a tree view of the objects in your model. 데이터를 아직 가져오지 않았으므로 폴더는 비어 있습니다.Since you haven't yet imported data, the folders are empty. 메뉴 모음처럼 작업을 수행하기 위해 개체 폴더를 마우스 오른쪽 단추로 클릭할 수 있습니다.You can right-click an object folder to perform actions, similar to the menu bar. 이 자습서를 단계별로 실행하는 동안 테이블 형식 모델 탐색기를 사용하여 모델 프로젝트의 다양한 개체로 이동합니다.As you step through this tutorial, you use the Tabular Model Explorer to navigate different objects in your model project.

테이블 형식 모델 탐색기 대화 상자의 스크린샷

솔루션 탐색기 탭을 클릭 합니다. 여기에 model.bim 파일이 표시 됩니다.Click the Solution Explorer tab. Here, you see your Model.bim file. 왼쪽 (model.bim 탭이 있는 빈 창)에 디자이너 창이 표시 되지 않으면 솔루션 탐색기AW Internet Sales Project에서 model.bim 파일을 두 번 클릭 합니다.If you don't see the designer window to the left (the empty window with the Model.bim tab), in Solution Explorer, under AW Internet Sales Project, double-click the Model.bim file. Model.bim 파일은 모델 프로젝트에 대한 메타데이터를 포함합니다.The Model.bim file contains the metadata for your model project.

Model.bim 파일이 강조 표시 된 솔루션 탐색기 섹션의 스크린샷

Model.bim을 클릭합니다.Click Model.bim. 속성 창에 모델 속성이 표시되며 가장 중요한 속성은 DirectQuery 모드입니다.In the Properties window, you see the model properties, most important of which is the DirectQuery Mode property. 이 속성은 모델이 메모리 내 모드(Off) 또는 DirectQuery 모드(On)로 배포되는지를 지정합니다.This property specifies if the model is deployed in In-Memory mode (Off) or DirectQuery mode (On). 이 자습서의 경우 메모리 내 모드로 모델을 작성 및 배포합니다.For this tutorial, you author and deploy your model in In-Memory mode.

호환성 수준 옵션이 강조 표시 되 고 SQL Server 2019/Azure Analysis Services (1500) 설정이 out 인 속성 창의 스크린샷

모델 프로젝트를 만들 때 도구 메뉴 > 옵션 대화 상자에 지정할 수 있는 데이터 모델링 설정에 따라 특정 모델 속성이 자동으로 설정됩니다.When you create a model project, certain model properties are set automatically according to the Data Modeling settings that can be specified in the Tools menu > Options dialog box. 데이터 Backup, 작업 영역 보존 및 작업 영역 서버 속성은 작업 영역 데이터베이스가 백업되고 메모리 내 보존되며 빌드되는 방식과 위치를 지정합니다.Data Backup, Workspace Retention, and Workspace Server properties specify how and where the workspace database (your model authoring database) is backed up, retained in-memory, and built. 필요한 경우 나중에 이러한 설정을 변경할 수 있지만 지금은 이러한 속성을 그대로 둡니다.You can change these settings later if necessary, but for now, leave these properties as they are.

솔루션 탐색기에서 AW Internet Sales(프로젝트)를 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.In Solution Explorer, right-click AW Internet Sales (project), and then click Properties. AW Internet Sales 속성 페이지 대화 상자가 나타납니다.The AW Internet Sales Property Pages dialog box appears. 이러한 속성 중 일부는 모델을 배포할 때 나중에 설정합니다.You set some of these properties later when you deploy your model.

Analysis Services 프로젝트 확장을 설치 하면 몇 가지 새 메뉴 항목이 Visual Studio 환경에 추가 되었습니다.When you installed the Analysis Services projects extension, several new menu items were added to the Visual Studio environment. 확장 메뉴를 클릭 합니다.Click the Extensions menu. 여기에서 데이터를 가져오고, 작업 영역 데이터를 새로 고치며, Excel에서 모델을 찾아보고, 큐브 뷰 및 역할을 만들며, 모델 뷰를 선택하고 계산 옵션을 설정합니다.From here, you can import data, refresh workspace data, browse your model in Excel, create perspectives and roles, select the model view, and set calculation options. 테이블 메뉴를 클릭합니다.Click the Table menu. 여기에서 관계를 만들고 관리할 수 있으며 날짜 테이블 설정을 지정하고 파티션을 만들며 테이블 속성을 편집할 수 있습니다.From here, you can create and manage relationships, specify date table settings, create partitions, and edit table properties. 메뉴를 클릭하면 테이블에서 열을 추가 및 삭제하고 열을 고정하며 정렬 순서를 지정할 수 있습니다.If you click the Column menu, you can add and delete columns in a table, freeze columns, and specify sort order. 또한 확장은 막대에 일부 단추를 추가 합니다.The extension also adds some buttons to the bar. 가장 유용한 기능은 선택한 열에 대한 표준 집계 측정값을 만드는 자동 합계 기능입니다.Most useful is the AutoSum feature to create a standard aggregation measure for a selected column. 다른 도구 모음 단추를 사용하면 자주 사용하는 기능과 명령에 빠르게 액세스할 수 있습니다.Other toolbar buttons provide quick access to frequently used features and commands.

테이블 형식 모델 제작과 관련된 다양한 기능의 위치와 대화 상자를 살펴보십시오.Explore some of the dialogs and locations for various features specific to authoring tabular models. 일부 항목은 아직 활성화되지 않았지만 테이블 형식 모델 작성 환경에 대한 유용한 정보를 얻을 수 있습니다.While some items are not yet active, you can get a good idea of the tabular model authoring environment.

다음 단계Next step

단원 2: 데이터 가져오기Lesson 2: Get data