Azure Monitor에서 뷰 디자이너를 사용 하 여 사용자 지정 보기 만들기Create custom views by using View Designer in Azure Monitor

Azure Monitor에서 뷰 디자이너를 사용 하 여 Log Analytics 작업 영역에서 데이터를 시각화 하는 데 도움이 될 수 있는 다양 한 사용자 지정 보기를 Azure Portal 만들 수 있습니다.By using View Designer in Azure Monitor, you can create a variety of custom views in the Azure portal that can help you visualize data in your Log Analytics workspace. 이 문서에는 뷰 디자이너 개요 및 사용자 지정 보기를 만들고 편집하는 절차가 제공됩니다.This article presents an overview of View Designer and procedures for creating and editing custom views.

중요

Azure Monitor의 뷰는 추가 기능을 제공 하는 통합 문서로 전환 되었습니다.Views in Azure Monitor have been transitioned to workbooks which provide additional functionality. 기존 보기를 통합 문서로 변환 하는 방법에 대 한 자세한 내용은 Azure Monitor 뷰 디자이너에서 통합 문서 전환 가이드를 참조 하세요.See Azure Monitor view designer to workbooks transition guide for details on converting your existing views to workbooks.

뷰 디자이너에 대한 자세한 내용은 다음을 참조하세요.For more information about View Designer, see:

  • 타일 참조: 사용자 지정 보기에서 사용 가능한 각 타일의 설정에 대한 참조 가이드를 제공합니다.Tile reference: Provides a reference guide to the settings for each of the available tiles in your custom views.
  • 시각화 요소 참조: 사용자 지정 보기에서 사용 가능한 시각화 요소의 설정에 대한 참조 가이드를 제공합니다.Visualization part reference: Provides a reference guide to the settings for the visualization parts that are available in your custom views.

개념Concepts

보기는 Azure Portal의 Azure Monitor 개요 페이지에 표시 됩니다.Views are displayed in the Azure Monitor Overview page in the Azure portal. 인사이트 섹션에서 기타를 클릭하여 Azure Monitor 메뉴에서 이 페이지를 엽니다.Open this page from the Azure Monitor menu by clicking More under the Insights section. 각 사용자 지정 보기의 타일은 사전순으로 표시 되 고, 모니터링 솔루션에 대 한 타일이 동일한 작업 영역에 설치 됩니다.The tiles in each custom view are displayed alphabetically, and the tiles for the monitoring solutions are installed the same workspace.

개요 페이지

뷰 디자이너로 만든 보기에는 다음 표에 설명된 요소가 포함됩니다.The views that you create with View Designer contain the elements that are described in the following table:

부분Part 설명Description
타일Tiles Azure Monitor 개요 페이지에 표시 됩니다.Are displayed on your Azure Monitor Overview page. 각 타일에는 해당 타일이 나타내는 사용자 지정 보기의 시각적 요약이 표시됩니다.Each tile displays a visual summary of the custom view it represents. 각 타일 유형은 레코드의 다른 시각화를 제공합니다.Each tile type provides a different visualization of your records. 사용자 지정 보기를 표시하려면 타일을 선택합니다.You select a tile to display a custom view.
사용자 지정 보기Custom view 타일을 선택하면 표시됩니다.Displayed when you select a tile. 각 보기는 시각화 요소를 하나 이상 포함합니다.Each view contains one or more visualization parts.
시각화 요소Visualization parts 하나 이상의 로그 쿼리를 기반으로 Log Analytics 작업 영역에 데이터 시각화를 제공 합니다.Present a visualization of data in the Log Analytics workspace based on one or more log queries. 대부분의 요소는 대략적인 시각화를 제공하는 헤더와 상위 결과를 표시하는 목록을 포함합니다.Most parts include a header, which provides a high-level visualization, and a list, which displays the top results. 각 요소 유형은 Log Analytics 작업 영역에 레코드의 다른 시각화를 제공합니다.Each part type provides a different visualization of the records in the Log Analytics workspace. 파트에서 요소를 선택 하 여 자세한 레코드를 제공 하는 로그 쿼리를 수행 합니다.You select elements in the part to perform a log query that provides detailed records.

필요한 사용 권한Required permissions

보기를 만들거나 수정 하려면 Log Analytics 작업 영역에서 참가자 수준 이상의 권한이 필요 합니다.You require at least contributor level permissions in the Log Analytics workspace to create or modify views. 이 권한이 없으면 뷰 디자이너 옵션이 메뉴에 표시 되지 않습니다.If you don't have this permission, then the View Designer option won't be displayed in the menu.

기존 보기로 작업Work with an existing view

뷰 디자이너로 만든 보기에는 다음 옵션이 표시됩니다.Views that were created with View Designer display the following options:

개요 메뉴

옵션은 다음 표에 설명되어 있습니다.The options are described in the following table:

옵션Option 설명Description
새로 고침Refresh 최신 데이터로 보기를 새로 고칩니다.Refreshes the view with the latest data.
로그Logs 로그 쿼리를 사용 하 여 데이터를 분석 하는 Log Analytics 을 엽니다.Opens the Log Analytics to analyze data with log queries.
편집Edit 뷰 디자이너에서 보기를 열어서 내용과 구성을 편집합니다.Opens the view in View Designer to edit its contents and configuration.
복제Clone 새 보기를 만든 후 뷰 디자이너에서 엽니다.Creates a new view and opens it in View Designer. 새 보기의 이름은 원래 이름과 동일하지만 복사본이 추가됩니다.**The name of the new view is the same as the original name, but with Copy appended to it.
날짜 범위Date range 보기에 포함된 데이터의 날짜와 시간 범위 필터를 설정합니다.Set the date and time range filter for the data that's included in the view. 이 날짜 범위는 보기의 쿼리에서 데이터 범위가 설정되기 전에 적용됩니다.This date range is applied before any date ranges set in queries in the view.
+ 보기에 대해 정의된 사용자 지정 필터를 정의합니다.Define a custom filter that's defined for the view.

새 보기 만들기Create a new view

Log Analytics 작업 영역의 메뉴에서 뷰 디자이너를 선택하여 뷰 디자이너에서 새 보기를 만들 수 있습니다.You can create a new view in View Designer by selecting View Designer in the menu of your Log Analytics workspace.

뷰 디자이너 타일

뷰 디자이너 작업Work with View Designer

뷰 디자이너를 사용하여 새 보기를 만들거나 기존 보기를 편집합니다.You use View Designer to create new views or edit existing ones.

뷰 디자이너에는 세 개의 창이 있습니다.View Designer has three panes:

  • 디자인: 만들거나 편집하는 사용자 지정 보기가 포함됩니다.Design: Contains the custom view that you're creating or editing.
  • 컨트롤: 디자인 창에 추가하는 타일과 요소가 포함됩니다.Controls: Contains the tiles and parts that you add to the Design pane.
  • 속성: 타일 또는 선택한 요소의 속성이 표시됩니다.Properties: Displays the properties of the tiles or selected parts.

뷰 디자이너

보기 타일 구성Configure the view tile

사용자 지정 보기에는 타일 하나만 있을 수 있습니다.A custom view can have only a single tile. 현재 타일을 보거나 다른 타일을 선택하려면 컨트롤 창에서 타일 탭을 선택합니다.To view the current tile or select an alternate one, select the Tile tab in the Control pane. 속성 창에 현재 타일의 속성이 표시됩니다.The Properties pane displays the properties of the current tile.

타일 참조의 정보에 따라 타일 속성을 구성한 다음, 적용을 클릭하여 변경 내용을 저장합니다.You can configure the tile properties according to the information in the Tile reference and then click Apply to save the changes.

시각화 요소 구성Configure the visualization parts

보기에는 시각화 요소가 얼마든지 포함될 수 있습니다.A view can include any number of visualization parts. 보기에 요소를 추가하려면 보기 탭을 선택한 다음, 시각화 요소를 선택합니다.To add parts to a view, select the View tab, and then select a visualization part. 속성 창에 선택한 요소의 속성이 표시됩니다.The Properties pane displays the properties of the selected part.

시각화 요소 참조의 정보에 따라 보기 속성을 구성한 다음, 적용을 클릭하여 변경 내용을 저장합니다.You can configure the view properties according to the information in the Visualization part reference and then click Apply to save the changes.

보기에는 시각화 요소의 행 하나만 있습니다.Views have only one row of visualization parts. 기존 요소를 새 위치로 끌어서 다시 정렬할 수 있습니다.You can rearrange the existing parts by dragging them to a new location.

요소의 오른쪽 위에 있는 X를 클릭하면 보기에서 시각화 요소를 제거할 수 있습니다.You can remove a visualization part from the view by selecting the X at the top right of the part.

편집 모드에서 보기 작업을 수행하는 옵션이 다음 표에 설명되어 있습니다.The options for working with views in edit mode are described in the following table.

편집 메뉴

옵션Option 설명Description
저장Save 변경 내용을 저장하고 보기를 닫습니다.Saves your changes and closes the view.
취소Cancel 변경 내용을 무시하고 보기를 닫습니다.Discards your changes and closes the view.
보기 삭제Delete View 보기를 삭제합니다.Deletes the view.
내보내기Export 다른 작업 영역으로 가져올 수 있는 Azure Resource Manager 템플릿으로 보기를 내보냅니다.Exports the view to an Azure Resource Manager template that you can import into another workspace. 파일 이름은 보기 이름이며 확장명은 omsview입니다.The name of the file is the name of the view, and it has an omsview extension.
가져오기Import 다른 작업 영역에서 내보낸 omsview 파일을 가져옵니다.Imports the omsview file that you exported from another workspace. 이렇게 하면 기존 보기의 구성을 덮어씁니다.This action overwrites the configuration of the existing view.
복제Clone 새 보기를 만든 후 뷰 디자이너에서 엽니다.Creates a new view and opens it in View Designer. 새 보기의 이름은 원래 이름과 동일하지만 복사본이 추가됩니다.**The name of the new view is the same as the original name, but with Copy appended to it.

다음 단계Next steps