Notebooks 사용

Notebook은 실행 가능한 셀(명령)의 컬렉션입니다. Notebook을 사용할 때는 주로 셀을 개발하고 실행합니다.

모든 Notebook 작업은 UI 작업에서 지원되지만 바로 가기 키를 사용하여 많은 작업을 수행할 수도 있습니다. 키보드 아이콘 아이콘을 클릭하여 바로 가기 표시를 전환합니다.

Notebook 개발

이 섹션에서는 Notebook 셀을 개발하고 Notebook을 탐색하는 방법을 설명합니다.

이 섹션에서는 다음 작업을 수행합니다.

Notebook 정보

Notebook에는 Notebook을 관리하고 Notebook 내에서 작업을 수행할 수 있는 도구 모음이 있습니다.

Notebook 도구 모음

실행할 수 있는 하나 이상의 셀(또는 명령)

Notebook 셀

셀의 맨 오른쪽에 있는 셀 작업 셀에는실행,대시보드편집의세 가지 메뉴가 있습니다.

실행 아이콘 - 대시보드 - 편집

및 두 가지 작업: 셀 최소화 숨기기 및 삭제 삭제 아이콘.

셀 추가

셀을 추가하려면 위쪽 또는 아래쪽에 있는 셀 위에 마우스를 놓고 셀 추가 아이콘을 클릭하거나 맨 오른쪽에 있는 Notebook 셀 메뉴에 액세스하고, 아래쪽의 Caret를 클릭하고 위의 셀 추가 또는 아래 셀 추가를선택합니다.

셀 삭제

맨 오른쪽에 있는 셀 작업 메뉴로 이동하여 아이콘 삭제(삭제)를 클릭합니다.

셀을 삭제하면 기본적으로 삭제 확인 대화 상자가 표시됩니다. 이후 확인 대화 상자를 사용하지 않도록 설정하려면 이 대화 상자를 다시 표시 안 함 확인란을 선택하고 확인을클릭합니다. 사용자 설정 아이콘 사용자 설정User Settings Icon Notebook설정 명령 삭제 확인 켜기 옵션을 사용하여 확인 대화 상자 설정을 전환할 수도 있습니다.

삭제된 셀을 복원하려면 셀 삭제 취소 편집을 선택하거나 ( Z ) 바로 가기 키를 사용합니다.

셀 잘라내기

맨 오른쪽에 있는 셀 작업 메뉴로 이동하고, Caret 아래로를클릭하고, 셀 잘라내기를선택합니다.

( ) 바로 가기 키를 사용할 수도 X 있습니다.

삭제된 셀을 복원하려면 셀 잘라내기 실행 취소 편집을 선택하거나 ( Z ) 바로 가기 키를 사용합니다.

여러 셀 또는 모든 셀 선택

이전 셀과 다음 셀 각각에 대해 Shift Up 또는 Down을 사용하여 인접한 Notebook 셀을 선택할 수 있습니다. 여러 셀을 복사, 잘라내기, 삭제 및 붙여넣을 수 있습니다.

모든 셀을 선택하려면 편집 모든 셀 선택을 선택하거나 명령 모드 바로 가기 Cmd+A를사용합니다.

기본 언어

Notebook의 기본 언어는 Notebook 이름 옆에 있는 단추로 표시됩니다. 다음 Notebook에서 기본 언어는 SQL.

Notebook 기본 언어

기본 언어를 변경하려면 다음을 수행합니다.

  1. 언어 단추를 클릭합니다. 기본 언어 변경 대화 상자가 표시됩니다.

    기본 언어 변경

  2. 기본 언어 드롭다운에서 새 언어를 선택합니다.

  3. 변경을 클릭합니다.

  4. 기존 명령이 계속 작동하도록 하기 위해 이전 기본 언어의 명령에는 언어 매직 명령이 자동으로 접두사로 지정됩니다.

언어 혼합

기본적으로 셀은 Notebook의 기본 언어를 사용합니다. 언어 단추를 클릭하고 드롭다운에서 언어를 선택하여 셀의 기본 언어를 재정의할 수 있습니다.

셀 언어 드롭다운

또는 셀의 시작 부분에 언어 매직 명령을 사용할 수 %<language> 있습니다. 지원되는 매직 명령은 %python , , 및 %r%scala%sql 입니다.

참고

언어 매직 명령을 호출하면 명령이 Notebook의 실행 컨텍스트에서 REPL로 디스패치됩니다. 한 언어로 정의된 변수(따라서 해당 언어에 대한 REPL)는 다른 언어의 REPL에서 사용할 수 없습니다. REPL은 DBFS의 파일 또는 개체 스토리지의 개체와 같은 외부 리소스를 통해서만 상태를 공유할 수 있습니다.

Notebook은 다음과 같은 보조 매직 명령도 지원합니다.

  • %sh: Notebook에서 셸 코드를 실행할 수 있습니다. 셸 명령의 종료 상태가 0이 아닌 경우 셀을 실패하려면 -e 옵션을 추가합니다. 이 명령은 작업자가 아닌 Apache Spark 드라이버에서만 실행됩니다. 모든 노드에서 셸 명령을 실행하려면 init 스크립트를 사용합니다.
  • %fs: 파일 시스템 명령을 사용할 수 dbutils 있습니다. 예를 들어 명령을 dbutils.fs.ls 실행하여 파일을 나열하려면 를 대신 지정할 수 %fs ls 있습니다. 자세한 내용은 %fs 매직 명령 사용을 참조하세요.
  • %md: 텍스트, 이미지, 수학 수식, 방정식을 포함하는 다양한 유형의 설명서를 포함할 수 있습니다. 다음 섹션을 참조하세요.

설명서 포함

Notebook에 설명서를 포함하려면 셀의 언어 단추에서 Markdown을 선택하거나 매직 명령을 사용하여 Markdown 셀을 만들 수 있습니다. 셀의 내용은 HTML로 렌더링됩니다. 예를 들어 이 조각에는 수준 1 제목에 대한 태그가 포함됩니다.

%md # Hello This is a Title

HTML 제목으로 렌더링됩니다.

Notebook HTML 제목

축소 가능한 제목

Markdown 머리글이 포함된 셀 이후에 나타나는 셀을 머리글 셀로 축소할 수 있습니다. 다음 이미지는 다음 두 셀이 축소된 제목 1이라는 수준 1 제목을 보여줍니다.

축소된 셀

제목을 확장하고 축소하려면 및 를 +- 클릭합니다.

내용 숨기기 및 표시도 참조하세요.

Notebook 전체에서 Markdown 제목이 포함된 셀 후 셀을 확장하거나 축소하려면 보기 메뉴에서 모든 제목 확장 또는 모든 제목 축소를 선택합니다.

보기 메뉴의 모두 확장-축소

상대 경로를 사용하여 Markdown 셀의 다른 Notebook 또는 폴더에 연결할 수 있습니다. 앵커 href 태그의 특성을 상대 경로로 지정하고 부터 $ Unix 파일 시스템에서와 동일한 패턴을 따릅니다.

%md
<a href="$./myNotebook">Link to notebook in same folder as current notebook</a>
<a href="$../myFolder">Link to folder in parent folder of current notebook</a>
<a href="$./myFolder2/myNotebook2">Link to nested notebook</a>

이미지 표시

FileStore에저장된 이미지를 표시하려면 구문을 사용합니다.

%md
![test](files/image.png)

예를 들어 FileStore에 Databricks 로고 이미지 파일이 있다고 가정합니다.

dbfs ls dbfs:/FileStore/
databricks-logo-mobile.png

Markdown 셀에 다음 코드를 포함하는 경우:

Markdown 셀의 이미지

이미지가 셀에 렌더링됩니다.

렌더링된 이미지

수학 수식 표시

Notebook은 수학 수식 및 수식을 표시하기 위해 KaTeX를 지원합니다. 예제:

%md
\\(c = \\pm\\sqrt{a^2 + b^2} \\)

\\(A{_i}{_j}=B{_i}{_j}\\)

$$c = \\pm\\sqrt{a^2 + b^2}$$

\\[A{_i}{_j}=B{_i}{_j}\\]

The following bicycle parts are replaceable:로

렌더링된 수식 1

%md
\\( f(\beta)= -Y_t^T X_t \beta + \sum log( 1+{e}^{X_t\bullet\beta}) + \frac{1}{2}\delta^t S_t^{-1}\delta\\)

where \\(\delta=(\beta - \mu_{t-1})\\)

The following bicycle parts are replaceable:로

렌더링된 수식 2

HTML 포함

함수를 사용하여 Notebook에 HTML을 포함할 수 displayHTML 있습니다. 이 작업을 수행하는 방법에 대한 예제는 Notebook의 HTML, D3 및 SVG를 참조하세요.

참고

displayHTMLiframe은 도메인에서 제공되며 databricksusercontent.com iframe 샌드박스에는 allow-same-origin 특성이 포함됩니다. databricksusercontent.com은 브라우저에서 액세스할 수 있어야 합니다. 현재 회사 네트워크에서 차단하고 있는 경우 허용 목록에 추가해야 합니다.

명령 주석

명령 주석을 사용하여 공동 작업자와 토론할 수 있습니다.

주석 사이드바를 전환하려면 Notebook의 오른쪽 위에 있는 주석 단추를 클릭합니다.

Notebook 주석 토글

명령에 주석을 추가하려면 다음을 수행합니다.

  1. 명령 텍스트를 강조 표시하고 주석 거품을 클릭합니다.

    주석 열기

  2. 주석을 추가하고 주석을 클릭합니다.

    주석 추가

주석을 편집, 삭제 또는 회신하려면 주석을 클릭하고 작업을 선택합니다.

주석 편집

셀 표시 변경

Notebook에 대한 세 가지 표시 옵션이 있습니다.

  • 표준 보기: 결과가 코드 셀 바로 뒤 표시됩니다.
  • 결과만: 결과만 표시됩니다.
  • Side-by-Side: 코드 및 결과 셀이 나란히 표시되고 결과가 오른쪽에 표시됩니다.

보기 메뉴 보기 메뉴로 이동하여 표시 옵션을 선택합니다.

side-by-side 보기

줄 및 명령 번호 표시

줄 번호 또는 명령 번호를 표시하려면 보기 메뉴 보기 메뉴로 이동하여 줄 번호 표시 또는 명령 번호 표시를 선택합니다. 표시되면 동일한 메뉴에서 다시 숨길 수 있습니다. 바로 가기 키 Control+L을 사용하여 줄 번호를 사용하도록 설정할 수도 있습니다.

보기 메뉴를 통해 줄 또는 명령 번호 표시

Notebook에서 사용하도록 설정된 줄 및 명령 번호

줄 또는 명령 번호를 사용하도록 설정하면 Databricks는 기본 설정을 저장하고 해당 브라우저에 대한 다른 모든 Notebook에 표시합니다.

셀 위의 명령 번호는 해당 특정 명령에 연결됩니다. 셀에 대한 명령 번호를 클릭하면 해당 명령에 고정할 URL이 업데이트됩니다. Notebook에서 특정 명령에 연결하려면 명령 번호를 마우스 오른쪽 단추로 클릭하고 링크 주소 복사를선택합니다.

텍스트 찾기 및 바꾸기

Notebook 내에서 텍스트를 찾아서 바꾸려면 찾기 및 바꾸기 편집을선택합니다. 현재 일치 항목은 주황색으로 강조 표시되고 다른 모든 일치 항목은 노란색으로 강조 표시됩니다.

일치하는 텍스트

현재 일치 항목을 바꾸려면 바꾸기를클릭합니다. Notebook의 모든 일치 항목을 바꾸려면 모두 바꾸기를클릭합니다.

일치 항목 간에 이동하려면 PrevNext 단추를 클릭합니다. Shift+Enter를 누르고 를 입력하여 각각 이전 및 다음 일치 항목으로 이동할 수도 있습니다.

찾기 및 바꾸기 도구를 닫려면 아이콘 삭제를 클릭하거나 esc 키를누릅니다.

자동 완성

자동 완성 Azure Databricks 사용하여 코드 세그먼트를 입력할 때 자동으로 완료할 수 있습니다. Azure Databricks 로컬 및 서버의 두 가지 자동 완성 유형을 지원합니다.

로컬 자동 완성은 Notebook에 정의된 단어를 완료합니다. 서버 자동 완성은 정의된 형식, 클래스 및 개체뿐만 아니라 SQL 데이터베이스 및 테이블 이름에 대한 클러스터에 액세스합니다. 서버 자동 완성을 활성화하려면 Notebook을 클러스터에 연결하고 완성 가능한 개체를 정의하는 모든 셀을 실행합니다.

중요

R Notebook의 서버 자동 완성은 명령 실행 중에 차단됩니다.

자동 완성을 트리거하려면 완성 가능한 개체를 입력한 후 Tab 키를 누릅니다. 예를 들어 및 의 정의가 포함된 셀을 정의하고 실행한 MyClassinstance 후에는 의 메서드를 완성할 수 있으며 Tab 키를 instance 누르면 유효한 완성 목록이 표시됩니다. MyClass

트리거 자동 완성

형식 완성 및 SQL 데이터베이스 및 테이블 이름 완성은 동일한 방식으로 작동합니다.

형식 완성 — - SQL 완료

Databricks Runtime 7.4 이상에서는 완성 가능한 Python 개체를 입력한 후 Shift+Tab을 눌러 Python 문서 실행 힌트를 표시할 수 있습니다. docstrings에는 개체에 대한 함수와 동일한 정보가 help() 포함됩니다.

Python docstring

서식 SQL

Azure Databricks Notebook 셀에서 SQL 코드의 서식을 빠르고 쉽게 지정할 수 있는 도구를 제공합니다. 이러한 도구는 코드의 서식을 유지하려는 노력을 줄이고 Notebook에서 동일한 코딩 표준을 적용하는 데 도움이 됩니다.

다음과 같은 방법으로 포맷터를 트리거할 수 있습니다.

  • 단일 셀

    • 바로 가기 키: Cmd+Shift+F를누릅니다.

    • 명령 상황에 맞는 메뉴: SQL 셀의 명령 컨텍스트 드롭다운 메뉴에서 SQL 서식을 선택합니다. 이 항목은 SQL Notebook 셀과 %sql%sql있는 셀에만 표시됩니다.

      명령 컨텍스트에서 SQL 서식 지정

  • 여러 셀

    여러 SQL 셀을 선택한 다음, 서식 편집 SQL 셀을선택합니다. 둘 이상의 언어로 된 셀을 선택하면 SQL 셀만 서식이 지정됩니다. 여기에는 를 사용하는 이 %sql 포함됩니다.

    편집 메뉴에서 SQL 서식 지정

서식 지정 후 이전 예제의 첫 번째 셀은 다음과 같습니다.

서식 지정 후 SQL

목차 보기

자동으로 생성된 목차를 표시하려면 Notebook의 왼쪽 위에 있는 화살표(사이드바와 맨 위 셀 사이)를 클릭합니다. 목차는 Notebook에 사용되는 Markdown 제목에서 생성됩니다.

TOC 열기

목차를 닫려면 왼쪽 화살표를 클릭합니다.

TOC 닫기

어둡게 모드에서 Notebook 보기

어둡게 모드로 Notebook을 표시하도록 선택할 수 있습니다. 어둡게 모드를 설정하거나 해제하려면 Notebook 테마 보기를 선택하고 밝은 테마 또는 어두운테마 를 선택합니다.

Notebook 밝게 또는 어둡게 모드

Notebook 실행

이 섹션에서는 하나 이상의 Notebook 셀을 실행하는 방법을 설명합니다.

이 섹션에서는 다음 작업을 수행합니다.

요구 사항

Notebook을 클러스터에 연결해야 합니다. 클러스터가 실행되고 있지 않으면 하나 이상의 셀을 실행할 때 클러스터가 시작됩니다.

셀 실행

셀 작업 메뉴 맨 오른쪽의 셀 작업에서실행 아이콘을 클릭하고 셀 실행을선택하거나 Shift+Enter를 누릅니다.

중요

Notebook 셀의 최대 크기(콘텐츠 및 출력 모두)는 16MB입니다.

예를 들어 미리 정의된 변수 를 참조하는 이 Python 코드 조각을 실행해 sparkspark보세요.

spark

그런 다음, 몇 가지 실제 코드를 실행합니다.

1+1 # => 2

참고

Notebook에는 다음과 같은 다양한 기본 설정이 있습니다.

  • 셀을 실행하면 Notebook이 메시지를 표시하지 않고 실행 중인 클러스터에 자동으로 연결됩니다.
  • Shift+Enter를누르면 셀이 표시되지 않으면 Notebook이 자동으로 다음 셀로 스크롤됩니다.

이러한 설정을 변경하려면 사용자 설정 아이콘 사용자 설정 NotebookUser Settings Icon 설정 선택하고 해당 확인란을 구성합니다.

위 또는 아래 모두 실행

셀 앞이나 후에 모든 셀을 실행하려면 셀 작업 메뉴 맨 오른쪽의 셀 작업으로 이동하여 실행 메뉴를 클릭하고 위에서 모두 실행 또는 아래에서 모두실행을선택합니다.

아래의 모든 실행은 현재 있는 셀을 포함합니다. 위의 모든 실행은 실행하지 않습니다.

모든 셀 실행

Notebook의 모든 셀을 실행하려면 Notebook 도구 모음에서 모두 실행을 선택합니다.

중요

탑재 및 분리 단계가 동일한 Notebook에 있는 경우 모두 실행을 수행하지 마십시오. 이로 인해 경합 상태가 발생할 수 있으며 탑재 지점이 손상될 수 있습니다.

셀당 여러 출력 보기

Python Notebook이 아닌 Notebook의 %python Python Notebook 및 셀은 셀당 여러 출력을 지원합니다.

한 셀의 여러 출력

이 기능을 사용하려면 Databricks Runtime 7.1 이상이 필요하며 을 설정하여 Databricks Runtime 7.1 - Databricks Runtime 7.3에서 사용하도록 설정할 수 spark.databricks.workspace.multipleResults.enabled true 있습니다. Databricks Runtime 7.4 이상에서 기본적으로 사용하도록 설정됩니다.

Python 및 Scala 오류 강조 표시

Python 및 Scala Notebook은 오류 강조 표시를 지원합니다. 즉, 오류를 throw하는 코드 줄이 셀에 강조 표시됩니다. 또한 오류 출력이 stacktrace인 경우 오류가 throw되는 셀이 스택 추적에 셀에 대한 링크로 표시됩니다. 이 링크를 클릭하여 잘못된 코드로 이동할 수 있습니다.

Python 오류 강조 표시

Scala 오류 강조 표시

알림

알림은 모든 셀 실행 중에 현재 실행 중인 명령 및 오류 상태의 명령과 같은 특정 이벤트에 대해 경고합니다. Notebook에 여러 오류 알림이 표시되면 첫 번째 알림에는 모든 알림을 지울 수 있는 링크가 있습니다.

Notebook 알림

Notebook 알림은 기본적으로 사용하도록 설정됩니다. 사용자 설정 아이콘 사용자 설정 NotebookUser Settings Icon 설정사용하지 않도록 설정할 수 있습니다.

Databricks Advisor

Databricks Advisor는 명령을 실행할 때마다 자동으로 분석하고 Notebook에 적절한 조언을 표시합니다. 조언 알림은 워크로드의 성능을 개선하고, 비용을 절감하고, 일반적인 실수를 방지하는 데 도움이 될 수 있는 정보를 제공합니다.

조언 보기

전구 아이콘이 있는 파란색 상자는 명령에 대한 조언을 사용할 수 있음을 알 수 있습니다. 상자에는 고유한 조언 수가 표시됩니다.

Databricks 조언

전구를 클릭하여 상자를 확장하고 조언을 확인합니다. 하나 이상의 조언이 표시됩니다.

조언 보기

자세한 정보 링크를 클릭하여 조언과 관련된 자세한 정보를 제공하는 설명서를 봅니다.

다시 표시 안 하세요 링크를 클릭하여 조언을 숨깁니다. 이 형식의 조언은 더 이상 표시되지 않습니다. 이 작업은 Notebook 설정 되돌릴수 있습니다.

전구를 다시 클릭하여 조언 상자를 축소합니다.

조언 설정

사용자 설정 아이콘 사용자 설정 Notebook 설정 선택하거나 확장된 조언 상자에서 기어 아이콘을 클릭하여 NotebookUser Settings Icon 설정 페이지에 액세스합니다.

Notebook 설정

Databricks Advisor 켜기 옵션을 설정/해제하여 조언을 사용하거나 사용하지 않도록 설정합니다.

하나 이상의 유형의 조언이 현재 숨겨져 있는 경우 숨겨진 조언 다시 설정 링크가 표시됩니다. 링크를 클릭하여 해당 조언 유형을 다시 표시합니다.

다른 Notebook에서 Notebook 실행

매직 명령을 사용하여 다른 Notebook에서 Notebook을 실행할 수 %run <notebook> 있습니다. 이는 :load 로컬 컴퓨터의 Scala REPL 명령 또는 import Python의 문과 거의 동일합니다. 에 정의된 모든 변수는 <notebook> 현재 Notebook에서 사용할 수 있습니다.

%run 는 전체 Notebook을 인라인으로 실행하므로 %run있어야 합니다.

참고

사용하여 Python 파일과 해당 파일에 import 정의된 엔터티를 Notebook으로 실행할 수 없습니다. Python 파일에서 가져오려면 파일을 Python 라이브러리로 패키지하고, 해당 Python 라이브러리에서 Azure Databricks 라이브러리를 만들고, Notebook을 실행하는 데 사용하는 클러스터에 라이브러리를 설치해야 합니다.

예제

및 가 있다고 notebookAnotebookB 가정합니다. notebookA 에는 다음 Python 코드가 있는 셀이 포함되어 있습니다.

x = 5

에서 를 정의하지 않은 경우에도 xnotebookB 를 실행한 후 에서 액세스할 수 xnotebookB%run notebookA 있습니다.

%run /Users/path/to/notebookA

print(x) # => 5

상대 경로를 지정하려면 또는 로 접두사로 을 ./../ 지정합니다. 예를 들어 notebookA 및 가 동일한 디렉터리에 있는 경우 notebookB 상대 경로에서 실행할 수 있습니다.

%run ./notebookA

print(x) # => 5
%run ../someDirectory/notebookA # up a directory and into another

print(x) # => 5

Notebook 간의 더 복잡한 상호 작용은 Notebook 워크플로를 참조하세요.

Notebook 상태 및 결과 관리

Notebook을 클러스터에 연결하고하나 이상의 셀을 실행하면Notebook의 상태가 표시되고 결과가 표시됩니다. 이 섹션에서는 Notebook 상태 및 결과를 관리하는 방법을 설명합니다.

이 섹션에서는 다음 작업을 수행합니다.

Notebook 상태 및 결과 지우기

Notebook 상태 및 결과를 지우려면 Notebook 도구 모음에서 지우기를 클릭하고 작업을 선택합니다.

상태 및 결과 지우기

결과 다운로드

기본적으로 결과를 다운로드 하는 것이 가능 합니다. 이 설정을 전환 하려면 전자 필기장에서 결과를 다운로드 하는 기능 관리를 참조 하세요. 다운로드 결과 단추가 사용 하지 않도록 설정 된 경우 다운로드 결과 단추가 표시 되지 않습니다.

셀 결과 다운로드

테이블 형식 출력을 포함 하는 셀 결과를 로컬 컴퓨터에 다운로드할 수 있습니다. 셀 아래쪽에서 다운로드 결과 단추를 클릭 합니다.

셀 결과 다운로드

이라는 CSV 파일이 export.csv 기본 다운로드 디렉터리에 다운로드 됩니다.

전체 결과 다운로드

기본적으로 Azure Databricks는 데이터 프레임의 1000 행을 반환 합니다. 행이 1000 개를 초과 하는 경우 쿼리를 다시 실행 하 고 최대 1만 개의 행을 표시 하는 옵션이 표시 됩니다.

다시 실행 옵션

쿼리가 1000 개 보다 많은 행을 반환 하는 경우 아래쪽 화살표 단추 를 누르면 다운로드 결과 단추에 추가 됩니다. 쿼리 결과를 모두 다운로드 하려면 다음을 수행 합니다.

  1. 다운로드 결과 옆에 있는 아래쪽 화살표를 클릭 하 고 전체 결과 다운로드를 선택 합니다.

    전체 결과 다운로드

  2. 다시 실행 및 다운로드를선택 합니다.

    결과 다시 실행 및 다운로드

    전체 결과를 다운로드 한 후 이라는 CSV 파일이 export.csv 로컬 컴퓨터에 다운로드 되 고 /databricks-results 폴더에 쿼리 결과가 전체 포함 된 생성 된 폴더가 있습니다.

    다운로드 한 결과

셀 내용 숨기기 및 표시

셀 콘텐츠는 셀 코드와 셀 실행 결과로 구성 됩니다. 셀의 오른쪽 위에 있는 셀 작업 메뉴 셀 작업 을 사용 하 여 셀 코드와 결과를 숨기고 표시할 수 있습니다.

셀 코드를 숨기려면:

  • 아래로 커서 를 클릭 하 고 코드 숨기기 를 선택 합니다.

셀 결과를 숨기고 표시 하려면 다음 중 하나를 수행 합니다.

  • 아래로 커서 를 클릭 하 고 결과 숨기기 를 선택 합니다.
  • 셀 최소화 선택
  • Esc Shift + o 를 입력 합니다.

숨겨진 셀 코드 또는 결과를 표시 하려면 링크 표시 를 클릭 합니다.

숨겨진 코드 및 결과 표시

축소 가능한 제목도 참조 하세요.

노트북 격리

노트북 격리는 전자 필기장 간의 변수와 클래스의 표시 여부를 나타냅니다. Azure Databricks는 두 가지 유형의 격리를 지원 합니다.

  • 변수 및 클래스 격리
  • Spark 세션 격리

참고

동일한 클러스터에 연결 된 모든 노트북이 동일한 클러스터 Vm에서 실행 되므로 Spark 세션 격리를 사용 하는 경우에도 클러스터 내에서 사용자 격리가 보장 되지 않습니다.

변수 및 클래스 격리

변수 및 클래스는 현재 노트북 에서만 사용할 수 있습니다. 예를 들어 동일한 클러스터에 연결 된 두 개의 노트북이 동일한 이름의 변수와 클래스를 정의할 수 있지만 이러한 개체는 고유 합니다.

동일한 클러스터에 연결 된 모든 전자 필기장에 표시 되는 클래스를 정의 하려면 패키지 셀에 클래스를 정의 합니다. 그런 다음 연결 된 Scala 또는 Java 라이브러리의 클래스에 액세스 하는 것과 동일한 정규화 된 이름을 사용 하 여 클래스에 액세스할 수 있습니다.

Spark 세션 격리

Apache Spark 2.0.0 이상을 실행 하는 클러스터에 연결 된 모든 노트북에는를 나타내는 라는 미리 정의 된 변수가SparkSession 있습니다. SparkSession 는 Spark Api를 사용 하는 진입점 이며 런타임 구성을 설정 합니다.

Spark 세션 격리는 기본적으로 사용 하도록 설정 되어 있습니다. 전역 임시 뷰를 사용 하 여 전자 필기장에서 임시 뷰를 공유할 수도 있습니다. Create view 또는 create view를 참조 하세요. Spark 세션 격리를 사용 하지 않도록 설정 하려면 spark.databricks.session.sharetruespark.databricks.session.share에서를로 설정 합니다.

중요

spark.databricks.session.shareTrue로 설정 하면 스트리밍 노트북 셀과 스트리밍 작업에서 사용 하는 모니터링이 중단 됩니다. 구체적으로는 다음과 같습니다.

  • 셀 스트리밍의 그래프가 표시 되지 않습니다.
  • 스트림이 실행 되는 동안에는 작업이 차단 되지 않습니다. 즉, "성공적으로" 종료 되 고 스트림이 중지 됩니다.
  • 작업의 스트림는 종료를 모니터링 하지 않습니다. 대신를 수동으로 호출 해야 합니다 awaitTermination() .
  • Streaming 데이터 프레임에서 표시 함수 를 호출 하는 것은 작동 하지 않습니다.

다른 언어의 명령, 즉,, 및를 사용 하는 셀을 트리거하는 셀과 다른 전자 필기장 (즉,를 사용 하는 셀 %scala%python )이 %r%sql 포함 된 셀 %run 은 현재 전자 필기장의 일부입니다. 따라서 이러한 셀은 다른 노트북 셀과 동일한 세션에 있습니다. 이와 대조적으로 노트북 워크플로 는 격리 된 노트북을 실행 합니다. 즉, 이러한 노트북에 정의 된 임시 보기가 다른 노트북에 표시 되지 않습니다 .

버전 제어

Azure Databricks에는 전자 필기장에 대 한 기본 버전 제어가 있습니다. 수정 버전에 대해 주석 추가, 수정 내용 복원 및 삭제, 수정 기록 지우기 작업을 수행할 수 있습니다.

노트북 수정 버전에 액세스 하려면 노트북 도구 모음의 오른쪽 위에서 수정 기록 을 클릭 합니다.

수정 기록

이 섹션에서는 다음 작업을 수행합니다.

댓글 추가

최신 수정 버전에 주석을 추가 하려면 다음을 수행 합니다.

  1. 수정 버전을 클릭 합니다.

  2. 지금 저장 링크를 클릭 합니다.

    주석 저장

  3. 전자 필기장 수정 버전 저장 대화 상자에서 주석을 입력 합니다.

  4. 저장을 클릭합니다. 노트북 수정 버전은 입력 된 주석과 함께 저장 됩니다.

수정 버전 복원

수정 버전을 복원 하려면:

  1. 수정 버전을 클릭 합니다.

  2. 이 수정 버전 복원을 클릭 합니다.

    복원 수정 버전

  3. 확인을 클릭합니다. 선택한 수정 버전이 노트북의 최신 수정 버전으로 바뀝니다.

수정 버전 삭제

노트북의 수정 항목을 삭제 하려면 다음을 수행 합니다.

  1. 수정 버전을 클릭 합니다.

  2. 휴지통 아이콘 휴지통을 클릭 합니다.

    수정 버전 삭제

  3. 예, 지우기를클릭 합니다. 선택한 수정 버전이 노트북의 수정 기록에서 삭제 됩니다.

수정 기록 지우기

노트북의 수정 기록을 지우려면:

  1. 파일 수정 기록 지우기를 선택 합니다.

  2. 예, 선택 취소를클릭 합니다. 노트북 수정 기록을 지웁니다.

    경고

    이 확인란의 선택을 취소 하면 수정 기록을 복구할 수 없습니다.

Git 버전 제어

참고

Azure Databricks의 작업을 원격 Git 리포지토리와 동기화하기 위해 Databricks는 Git 통합용 리포지토리를 사용할 것을 권장합니다.

Azure Databricks는 다음 Git 기반 버전 제어 도구와도 통합 됩니다.