C# 및 Visual Studio Code 시작Get started with C# and Visual Studio Code

.NET Core는 Windows, Linux 및 macOS에서 실행되는 애플리케이션을 만들기 위한 빠른 모듈식 플랫폼을 제공합니다..NET Core gives you a fast and modular platform for creating applications that run on Windows, Linux, and macOS. C# 확장이 있는 Visual Studio Code를 사용하면 C# IntelliSense(스마트 코드 완성) 및 디버깅을 완벽하게 지원하는 강력한 편집 환경이 구현됩니다.Use Visual Studio Code with the C# extension to get a powerful editing experience with full support for C# IntelliSense (smart code completion) and debugging.

전제 조건Prerequisites

  1. Visual Studio Code를 설치합니다.Install Visual Studio Code.
  2. .NET Core SDK를 설치합니다.Install the .NET Core SDK.
  3. Visual Studio Code의 C# 확장을 설치합니다.Install the C# extension for Visual Studio Code. Visual Studio Code의 확장을 설치하는 방법에 대한 자세한 내용은 VS Code Extension Marketplace(VS Code 확장 마켓플레이스)를 참조하세요.For more information about how to install extensions on Visual Studio Code, see VS Code Extension Marketplace.

Hello WorldHello World

.NET Core에서 간단한 "Hello World" 프로그램으로 시작해 보겠습니다.Let's get started with a simple "Hello World" program on .NET Core:

  1. 프로젝트 열기Open a project:

    • Visual Studio Code를 엽니다.Open Visual Studio Code.

    • 왼쪽 메뉴에 있는 탐색기 아이콘을 클릭한 다음 폴더 열기를 클릭합니다.Click on the Explorer icon on the left menu and then click Open Folder.

    • 주 메뉴에서 파일 > 폴더 열기를 선택하여 C# 프로젝트를 저장하려는 폴더를 열고 폴더 선택을 클릭합니다.Select File > Open Folder from the main menu to open the folder you want your C# project to be in and click Select Folder. 이 예제에서는 HelloWorld라는 프로젝트에 대한 폴더를 만들어 봅니다.For our example, we're creating a folder for our project named HelloWorld.

      Visual Studio Code 폴더 열기

  2. C# 프로젝트 초기화Initialize a C# project:

    • 주 메뉴에서 보기 > 통합 터미널을 선택하여 Visual Studio Code에서 통합 터미널을 엽니다.Open the Integrated Terminal from Visual Studio Code by selecting View > Integrated Terminal from the main menu.

    • 터미널 창에서 dotnet new console을 입력합니다.In the terminal window, type dotnet new console.

    • 이 명령은 폴더에 이미 작성된 간단한 "Hello World" 프로그램이 있는 Program.cs 파일을 만들고 HelloWorld.csproj라는 C# 프로젝트 파일을 만듭니다.This command creates a Program.cs file in your folder with a simple "Hello World" program already written, along with a C# project file named HelloWorld.csproj.

      dotnet new 명령

  3. 빌드 자산 확인Resolve the build assets:

    • .NET Core 1.x의 경우 dotnet restore를 입력합니다.For .NET Core 1.x, type dotnet restore. dotnet restore를 실행하면 프로젝트를 빌드하는 데 필요한 필수 .NET Core 패키지에 액세스할 수 있습니다.Running dotnet restore gives you access to the required .NET Core packages that are needed to build your project.

      dotnet restore 명령

      참고

      .NET Core 2.0 SDK부터 복원을 수행해야 하는 모든 명령(예: dotnet new, dotnet builddotnet run)에서 암시적으로 실행되므로 dotnet restore를 실행할 필요가 없습니다.Starting with .NET Core 2.0 SDK, you don't have to run dotnet restore because it's run implicitly by all commands that require a restore to occur, such as dotnet new, dotnet build and dotnet run. Azure DevOps Services의 연속 통합 빌드와 같이 명시적 복원을 수행하는 것이 올바른 특정 시나리오 또는 복원이 발생하는 시간을 명시적으로 제어해야 하는 빌드 시스템에서는 여전히 유효한 명령입니다.It's still a valid command in certain scenarios where doing an explicit restore makes sense, such as continuous integration builds in Azure DevOps Services or in build systems that need to explicitly control the time at which the restore occurs.

  4. "Hello World" 프로그램 실행Run the "Hello World" program:

    • dotnet run을 입력합니다.Type dotnet run.

      dotnet run 명령

Windows, macOS 또는 Linux에 대한 추가 설치 도움말이 제공되는 짧은 비디오 자습서를 볼 수도 있습니다.You can also watch a short video tutorial for further setup help on Windows, macOS, or Linux.

디버그Debug

  1. Program.cs를 클릭하여 엽니다.Open Program.cs by clicking on it. Visual Studio Code에서 C# 파일을 처음 열면 OmniSharp에서 편집기가 로드됩니다.The first time you open a C# file in Visual Studio Code, OmniSharp loads in the editor.

    Program.cs 파일 열기

  2. Visual Studio Code에 앱을 빌드하고 디버그하기 위해 누락된 자산을 추가하라는 메시지가 표시됩니다.Visual Studio Code should prompt you to add the missing assets to build and debug your app. 를 선택합니다.Select Yes.

    누락된 자산에 대한 프롬프트

  3. 디버그 보기를 열려면 왼쪽 메뉴에서 디버깅 아이콘을 클릭합니다.To open the Debug view, click on the Debugging icon on the left side menu.

    Visual Studio Code에서 [디버그] 탭 열기

  4. 창 위쪽에서 녹색 화살표를 찾습니다.Locate the green arrow at the top of the pane. 옆에 있는 드롭다운 목록에서 .NET Core Launch (console)가 선택되어 있는지 확인합니다.Make sure the drop-down next to it has .NET Core Launch (console) selected.

    Visual Studio Code에서.NET Core 선택

  5. 9번째 줄 옆에 있는 편집기 여백(편집기에서 줄 번호 왼쪽에 있는 공간)을 클릭하거나 편집기에서 9번째 줄로 이동하여 F9를 눌러서 프로젝트에 중단점을 추가합니다.Add a breakpoint to your project by clicking on the editor margin, which is the space on the left of the line numbers in the editor, next to line 9, or move the text cursor onto line 9 in the editor and press F9.

    중단점 설정

  6. 디버깅을 시작하려면 F5 또는 녹색 화살표를 선택합니다.To start debugging, select F5 or the green arrow. 이전 단계에서 설정한 중단점에 도달하면 디버거에서 프로그램 실행을 중지합니다.The debugger stops execution of your program when it reaches the breakpoint you set in the previous step.

    • 디버깅 동안 왼쪽 위에 있는 창에서 지역 변수를 보거나 디버그 콘솔을 사용할 수 있습니다.While debugging, you can view your local variables in the top left pane or use the debug console.
  7. 디버깅을 계속하려면 맨 위에 있는 파란색 화살표를 선택하고, 중지하려면 맨 위에 있는 빨간색 사각형을 선택합니다.Select the blue arrow at the top to continue debugging, or select the red square at the top to stop.

    Visual Studio Code에서 실행 및 디버그

Visual Studio Code에서 OmniSharp를 사용한 .NET Core 디버깅에 대한 자세한 내용과 문제 해결 정보는 Instructions for setting up the .NET Core debugger(.NET Core 디버거 설정 지침)를 참조하세요.For more information and troubleshooting tips on .NET Core debugging with OmniSharp in Visual Studio Code, see Instructions for setting up the .NET Core debugger.

클래스 추가Add a class

  1. 새 클래스를 추가하려면 VSCode 탐색기에서 마우스 오른쪽 단추를 클릭하고 새 파일을 선택합니다.To add a new class right-click in the VSCode Explorer and select New File. VSCode에서 열어 놓은 폴더에 새 파일이 추가됩니다.This adds a new file to the folder you have open in VSCode.

  2. 파일 이름을 MyClass.cs로 지정합니다.Name your file MyClass.cs. csharp 파일로 인식되도록 끝에 .cs 확장명을 추가해서 저장해야 합니다.You must save it with a .cs extension at the end for it to be recognized as a csharp file.

  3. 아래 코드를 추가하여 첫 번째 클래스를 만듭니다.Add the code below to create your first class. Program.cs 파일에서 참조할 수 있도록 올바른 네임스페이스를 포함해야 합니다.Make sure to include the correct namespace so you can reference it from your Program.cs file.

    using System;
    
    namespace HelloWorld
    {
        public class MyClass
        {
            public string ReturnMessage()
            {
                return "Happy coding!";
            }
        }
    }
    
  4. 아래 코드를 추가하여 Program.cs의 main 메서드에서 새 클래스를 호출합니다.Call your new class from your main method in Program.cs by adding the code below.

    using System;
    
    namespace HelloWorld
    {
        class Program
        {
            static void Main(string[] args)
            {
                MyClass c1 = new MyClass();
                Console.WriteLine($"Hello World! {c1.ReturnMessage()}");
            }
        }
    }
    
  5. 변경 내용을 저장하고 프로그램을 다시 실행합니다.Save your changes and run your program again. 추가된 문자열을 포함하는 새 메시지가 표시됩니다.The new message should appear with the appended string.

    > dotnet run
    Hello World! Happy coding!
    

FAQFAQ

Visual Studio Code에서 C#을 빌드하고 디버그하는 데 필요한 자산이 누락되었습니다.I'm missing required assets to build and debug C# in Visual Studio Code. 내 디버거에서 "구성 없음"이라고 표시됩니다.My debugger says "No Configuration."

Visual Studio Code C# 확장에서 빌드 및 디버그할 자산을 생성할 수 있습니다.The Visual Studio Code C# extension can generate assets to build and debug for you. C# 프로젝트를 처음 열면 Visual Studio Code에 이러한 자산을 생성하라는 메시지가 표시됩니다.Visual Studio Code prompts you to generate these assets when you first open a C# project. 자산을 생성하지 않은 경우 명령 팔레트(보기 > 명령 팔레트)를 열고 ">.NET: Generate Assets Build and Debug"를 입력하여 이 명령을 실행할 수 있습니다.If you didn't generate assets then, you can still run this command by opening the Command Palette (View > Command Palette) and typing ">.NET: Generate Assets for Build and Debug". 이를 선택하면 필요한 .vscode, launch.json 및 tasks.json 구성 파일이 생성됩니다.Selecting this generates the .vscode, launch.json, and tasks.json configuration files that you need.

참고 항목See also