방법: DBML 및 외부 매핑 파일 유효성 검사

수정한 외부 매핑 파일 및 .dbml 파일은 해당 스키마 정의에 대해 유효성이 검사되어야 합니다. 이 항목에서는 유효성 검사 프로세스를 구현 하는 단계를 사용자 Visual Studio 제공 합니다.

참고

일부 Visual Studio 사용자 인터페이스 요소의 경우 다음 지침에 설명된 것과 다른 이름 또는 위치가 시스템에 표시될 수 있습니다. 이러한 요소는 사용하는 Visual Studio 버전 및 설정에 따라 결정됩니다. 자세한 내용은 IDE 개인 설정을 참조하세요.

.dbml 또는 XML 파일의 유효성을 검사하려면

  1. Visual Studio 파일 메뉴에서 열기 를 가리킨 다음 파일 을 클릭 합니다.

  2. 파일 열기 대화 상자에서 유효성 검사를 수행 하려는 .DBML 또는 XML 매핑 파일을 클릭 합니다.

    파일이 XML 편집기 에서 열립니다.

  3. 창을 마우스 오른쪽 단추로 클릭 한 다음 속성 을 클릭 합니다.

  4. 속성 창에서 스키마 속성에 대 한 줄임표를 클릭 합니다.

    XML 스키마 대화 상자가 열립니다.

  5. 원하는 목적에 맞는 적절한 스키마 정의를 확인합니다.

    • DbmlSchema.xsd는 .dbml 파일의 유효성 검사를 위한 스키마 정의입니다. 자세한 내용은 LINQ to SQL에서 코드 생성을 참조 하세요.

    • LinqToSqlMapping.xsd는 외부 XML 매핑 파일의 유효성 검사를 위한 스키마 정의입니다. 자세한 내용은 외부 매핑을 참조 하세요.

  6. 원하는 스키마 정의 행의 사용 열에서 드롭다운 상자를 클릭 하 여 연 다음 이 스키마 사용 을 클릭 합니다.

    이제 스키마 정의 파일이 DBML 또는 XML 매핑 파일과 연관됩니다.

    다른 스키마 정의가 선택되지 않았는지 확인합니다.

  7. 보기 메뉴에서 오류 목록 을 클릭합니다.

    오류, 경고 또는 메시지가 생성되었는지 여부를 확인합니다. 생성된 것이 없는 경우 스키마 정의에 대해 XML 파일이 유효합니다.

스키마 정의 제공을 위한 대체 방법

어떤 이유로 든 적절 한 .xsd 파일이 XML 스키마 대화 상자에 표시 되지 않으면 도움말 항목에서 .xsd 파일을 다운로드할 수 있습니다. 다음 단계를 통해 Visual Studio XML 편집기에 필요한 유니코드 형식으로 다운로드 한 파일을 저장할 수 있습니다.

도움말 항목에서 스키마 정의 파일을 복사하려면

  1. 이 항목의 앞부분에서 설명한 대로 스키마 정의가 포함된 도움말 항목을 찾습니다.

  2. 코드 복사 를 클릭 하 여 코드 파일을 클립보드에 복사 합니다.

  3. 메모장을 시작하여 새 파일을 만듭니다.

  4. 클립보드에서 메모장 파일로 코드를 붙여넣습니다.

  5. 메모장 파일 메뉴에서 다른 이름으로 저장 을 클릭 합니다.

  6. 인코딩 상자에서 유니코드 를 선택 합니다.

    중요

    이렇게 하면 유니코드 16바이트 순서 마커(FFFE)가 텍스트 파일 앞에 추가됩니다.

  7. 파일 이름 상자에서 확장명이 .xsd 인 파일 이름을 만듭니다.

참고 항목