공유 사서함에서 보낸 Email 메시지는 Mac용 Outlook의 보낸 편지함 폴더에 저장되지 않습니다.

원본 KB 번호: 2928846

증상

다음과 같은 경우를 생각해볼 수 있습니다.

  • 공유 사서함에 대한 모든 권한 및 다른 이름으로 보내기 권한이 있는 기본 사서함이 있습니다.

  • Microsoft Exchange Server 2013, Exchange Server 2010 또는 Exchange Server 2007에서 호스트되는 기본 사서함을 열도록 Microsoft Mac용 Outlook 2016 또는 Mac용 Outlook 2011을 구성합니다.

  • 동일한 Outlook 프로필 또는 ID에서 Exchange Server 2013, Exchange Server 2010 또는 Exchange Server 2007에서 호스트되는 보조 공유 사서함을 엽니다.

  • 기본 사서함의 자격 증명을 사용하여 공유 사서함에 액세스합니다.

  • 공유 사서함에서 전자 메일 메시지를 보냅니다.

이 시나리오에서는 공유 사서함에서 보낸 전자 메일 메시지가 공유 사서함의 보낸 편지함 폴더에 저장되지 않습니다. 대신 메시지는 Exchange Server 기본 사서함의 Drafts 폴더에 저장됩니다. 또한 기본 사서함의 Drafts 폴더에 있는 메시지는 Mac용 Outlook 클라이언트와 동기화되지 않으며 Outlook Web Access 또는 Windows Outlook 클라이언트를 사용하는 경우에만 표시됩니다.

원인

이 문제는 Exchange Web Services 함수가 메서드를 GetMessageParentFolderIdAndSession 잘못 사용하기 SendAndSaveCopy 때문에 발생합니다.

해결 방법

이 문제는 2013년 Exchange Server 대한 누적 업데이트 5에서 해결되었습니다.

이 누적 업데이트를 설치하면 메시지가 공유 사서함의 보낸 편지함 폴더에 저장됩니다.

Exchange Server 2010 및 2007에 대한 해결 방법

Exchange Server 2010 또는 Exchange Server 2007을 실행하는 경우 다음 해결 방법이 적용됩니다.

해결 방법 1

  1. Mac용 Outlook에서 도구>계정을 클릭합니다.

    참고

    여기에 공유 계정이 추가된 경우 해당 계정을 선택한 다음 빼기 기호(-)를 클릭하여 제거합니다. 삭제를 클릭하여 확인합니다.

  2. 고급을 클릭한 다음 대리자를 클릭합니다.

  3. 이러한 추가 사서함 열기 섹션에서 더하기 기호(+)를 클릭합니다.

    참고

    공유 계정을 여기에 추가하기 위해 공유 계정의 대리자일 필요는 없으며 이 사서함에 액세스할 수 있는 권한만 있으면 됩니다.

  4. 공유 계정의 별칭을 입력한 다음 찾기를 클릭합니다. 올바른 계정을 선택한 다음 확인을 클릭합니다.

  5. 확인을 클릭한 다음 계정 창을 닫습니다.

  6. 공유 계정이 Mac용 Outlook 2011의 폴더 목록에 표시되도록 허용합니다. 이제 공유 사서함에서 전자 메일을 보내면 기본 사서함의 보낸 편지함 폴더에 메시지가 저장됩니다.

기본 및 공유 사서함 보낸 편지함 폴더에 메시지를 저장하고 Exchange Server 2010 SP2(서비스 팩 2) RU4 이상 버전을 실행 중인 경우 다른 이름으로 보내기 또는 대신 보내기 권한을 사용하는지에 따라 다음 Windows PowerShell 명령 중 하나를 실행할 수 있습니다.

  • 다른 사람 이름으로 보내기

    Set-MailboxSentItemsConfiguration <SharedAccountAlias> -SendAsItemsCopiedTo SenderAndFrom
    
  • 대신 보내기

    Set-MailboxSentItemsConfiguration <SharedAccountAlias> -SendOnBehalfOfItemsCopiedTo SenderAndFrom
    

해결 방법 2

  1. Mac용 Outlook에서 도구>계정을 클릭합니다.
  2. 공유 계정을 선택한 다음 빼기 기호 (-) 를 클릭하여 제거합니다. 삭제를 클릭하여 확인합니다.
  3. 계정 창을 닫습니다.
  4. 파일을 클릭하고 열기를 클릭한 다음 다른 사용자의 폴더를 클릭합니다.
  5. 공유 사서함의 이름을 입력하고 받은 편지함을 폴더 유형으로 선택한 다음 확인을 클릭합니다.

참고

이 방법을 사용하면 공유 사서함의 받은 편지함 폴더만 사용할 수 있습니다. 다른 폴더에 액세스할 수 있어야 하는 경우 해결 방법 1을 사용합니다.