사용자는 POP3 또는 IMAP4에 연결할 수 없습니다.

원래 KB 번호: 3025138

증상 1

Exchange Server 2016 또는 Exchange Server 2013에 사서함이 있는 사용자는 POP3 또는 IMAP4에 대한 연결이 작동하지 않을 수 있습니다. 또한 다음과 같은 오류 메시지가 표시될 수 있습니다.

Microsoft.Exchange.Monitoring.ProtocolException: 인증에 실패했습니다.
연결이 닫혀 있습니다. 전송 연결에서 데이터를 읽을 수 없음:
기존 연결은 원격 호스트에 의해 강제로 닫혔습니다. 만드는 동안 서버 응답
connection:[]. >--- System.IO.IOException: 전송에서 데이터를 읽을 수 없음
연결: 기존 연결이 원격 호스트에 의해 강제로 닫혔습니다. --->
System.Net.Sockets.SocketException: 기존 연결이 에 의해 강제로 닫혔습니다.
원격 호스트 관련 서비스가 시작되고 시스템 또는 에서 오류/경고 이벤트가 없습니다.
애플리케이션 로그.

증상 2

사용자는 서버 FQDN을 사용하여 POP3 또는 IMAP 포트로 텔넷할 수 있습니다. 그러나 배너가 표시되지 않습니다. 대신 빈 화면만 표시됩니다.

원인

이 문제는 PopProxy 및 ImapProxy 구성 요소가 비활성 상태이기 때문에 발생합니다.

명령을 사용하여 구성 요소의 Get-ServerComponentState <ServerName> 상태 검사 수 있습니다.

해결 방법

이 문제를 resolve PopProxy 및 ImapProxy 구성 요소를 활성화합니다. 이렇게 하려면 다음과 같이 하십시오.

  1. 다음 명령을 사용하여 PopProxy를 비활성 상태로 만든 요청자를 확인합니다.

    Get-ServerComponentState -Identity <ServerName> -Component PopProxy). LocalStates

    다음 예제 HealthAPI 에서는 PopProxy의 상태를 비활성으로 변경한 요청자로 표시됩니다.

    Get-ServerComponentState cmdlet의 스크린샷

  2. PopProxy를 활성화하려면 다음 명령을 사용합니다.

    Set-ServerComponentState -Identity <ServerName> -component PopProxy -state Active -requester HealthAPI

    예를 들면 다음과 같습니다.

    Set-ServerComponentState cmdlet의 스크린샷