Outlook은 공용 네트워크와 프라이빗 네트워크 간에 NAT(네트워크 주소 변환)를 수행하는 방화벽 또는 프록시 서버를 통해 연결할 수 없습니다.

원본 KB 번호: 291615

증상

Outlook 클라이언트는 공용 네트워크와 프라이빗 네트워크 간에 NAT를 수행하는 방화벽 또는 프록시 서버를 통해 연결할 수 없습니다.

원인

RPC(원격 프로시저 호출) 정보가 포함된 IP 패킷이 번역 중에 편집되면 IP 패킷은 RPC 연결 정보를 잃게 됩니다. 이렇게 하면 클라이언트가 서버에 연결되지 않습니다. 또한 Outlook에서 방화벽 또는 프록시 서버 뒤의 Microsoft Exchange Server 컴퓨터 이름을 확인하는 데 문제가 있을 수 있습니다.

해결 방법

Microsoft Windows NT 기반으로 하지 않는 방화벽 또는 프록시 서버에 대한 해결 방법은 두 네트워크 간에 일대일 변환을 수행하는 것입니다. 이를 공용 네트워크와 프라이빗 네트워크 간의 파이프 또는 터널 열기 라고도 합니다. 이렇게 하면 공용 네트워크의 특정 주소에 대한 모든 요청을 가져와서 프라이빗 네트워크에 직접 전달합니다. 일대일 번역을 구성하는 방법에 대한 자세한 내용은 제조업체의 설명서를 참조하세요.

Outlook 클라이언트가 방화벽의 EPM(엔드포인트 매퍼 포트) 포트 135에 바인딩하려고 하기 때문에 Windows NT 기반 방화벽 및 프록시 서버에서는 일대일 변환 또는 파이프가 작동하지 않습니다. 이 서버는 Outlook 클라이언트에 올바른 Exchange Server 연결 정보를 반환하지 않습니다.

또 다른 가능한 해결 방법은 Outlook Web App 사용하는 것입니다. 이렇게 하려면 방화벽 또는 프록시 서버를 통해서만 HTTP 트래픽을 허용해야 합니다.

추가 정보

자세한 내용은 다음 RFC(주석 요청)를 참조하세요.

  • RFC 1631 - NAT(IP 네트워크 주소 번역기)
  • RFC 1918 - 개인 인터넷에 대한 주소 할당

이러한 RFC는 여기에서 찾을 수 있습니다.