유지하려는 항목은 Exchange Server MRM 2.0에서 제거됩니다.

원래 KB 번호: 3036736

증상

최근에 적용된 MRM 2.0 정책은 Exchange Server 제거하지 않으려는 항목을 제거합니다. 이 문제가 발생한 후 사용자에게 최소한의 영향을 주는 메서드를 사용하여 누락된 항목을 최대한 빨리 복원하려고 합니다.

원인

이 문제는 잘못된 RPT(보존 정책 태그)가 정책에 적용되었기 때문에 발생합니다. 이 잘못된 태그는 제거하지 않으려는 항목을 제거합니다.

해결 방법 - 방법 1: 백업에서 복원

백업에서 데이터베이스를 복원한 다음 저장된 데이터를 현재 데이터와 병합합니다. 저장된 모든 메시지는 백업된 위치로 복원됩니다. 이 프로세스에 대한 자세한 내용은 백업, 복원 및 재해 복구의 복구 데이터베이스 섹션을 참조하세요.

해결 방법 - 방법 2: 사용자의 쓰레기통에서 내보내기 요청 실행

사용자의 쓰레기통에서 내보내기 요청을 실행하여 문제를 일으키는 RPT의 항목만 복구합니다. 이를 위해 다음 작업을 수행하십시오.

중요

이 메서드는 보존 작업의 값이 영구적으로 삭제되지 않은 경우에만 작동합니다. 값이 영구 삭제로 설정된 경우 메서드 1을 사용해야 합니다.

  1. 사서함 내보내기 요청 만들기 문서의 필수 구성 요소를 따릅니다.

    참고

    RBAC(역할 기반 액세스 제어) 권한에 사서함 가져오기 내보내기 역할 그룹이 추가된 사용자로 로그인해야 합니다.

  2. 사서함에 적용되는 보존 정책을 찾습니다.

  3. 사서함에서 메시지를 제거한 태그를 결정합니다. 이를 위해 다음 작업을 수행하십시오.

    참고

    이 문제는 기본 폴더에 할당된 여러 RRPT 또는 DPT(기본 정책 태그)로 인해 발생할 수 있습니다. 이 정책에서 예상대로 작동하지 않는 항목을 결정해야 합니다.

    1. 영향을 받는 사서함에 적용되는 RPT를 선택합니다. 이렇게 하려면 다음 명령을 실행합니다.

      Get-Mailbox <Alias> | Select RetentionPolicy
      

      참고

      이 명령 <에서 별칭은> 실제 사서함 별칭을 나타냅니다.

    2. RPT에 대한 태그를 가져옵니다. 이렇게 하려면 다음 명령을 실행합니다.

      Get-RetentionPolicy <Retention Policy Name> | Select RetentionPolicyTagLinks
      

      참고

      이 명령 <에서 보존 정책 이름은> 실제 이름 보존 정책 이름을 나타냅니다.

    3. 올바른 태그를 확인한 다음 RetentionID를 가져옵니다. 이렇게 하려면 다음 명령을 실행합니다.

      Get-RetentionPolicyTag "Retention Tag Name" | Select RetentionId
      

      참고

      이 명령 <에서 보존 태그 이름은> 실제 이름 태그 이름을 나타냅니다.

  4. 3단계에서 결정된 조건과 일치하는 항목을 내보냅니다. 이렇게 하려면 단일 태그 또는 여러 태그가 있는지 여부에 따라 다음 cmdlet을 실행합니다.

    • 단일 보존 태그

      New-MailboxExportRequest -Mailbox "Alias" -IncludeFolders:Dumpster -ContentFilter {(policytag -eq "RetentionID" ) -and (messagekind -eq 'email')} -FilePath \\Server\Recovery\Alias.pst
      
    • 여러 보존 태그

      New-MailboxExportRequest -Mailbox "Alias" -IncludeFolders:Dumpster -ContentFilter {((policytag -eq "RetentionID") -or (policytag -eq "RetentionID")) -and (messagekind -eq 'email')} -FilePath \\Server\Recovery\Alias.pst
      
  5. 제거된 사용자 데이터를 복원하려면 사용자가 개인 항목 폴더(.pst)를 사서함에 수동으로 추가하도록 하거나 다음 가져오기 요청 명령을 실행하여 항목을 가져옵니다.

    New-MailboxImportRequest -Mailbox "Alias" -FilePath \\Server\Recovery\Alias.pst -TargetRootFolder "Recovery"
    

    중요

    • 항목을 가져오기 전에 정책을 변경하거나 제거해야 합니다. 이는 데이터를 복원하려는 사서함에 동일한 RT가 적용된 경우 Exchange Mailbox Assistants 서비스가 사서함을 다시 처리한 후 MRM 2.0에서 메시지가 다시 제거되기 때문입니다.
    • 대상 루트 폴더 값을 제공해야 합니다. 그렇지 않으면 항목이 다시 쓰레기통으로 복원됩니다. 받은 편지함 폴더를 사용할 수 있지만, 그러면 항목이 받은 편지함 아래의 복구 가능한 항목\삭제 하위 폴더로 복원됩니다.