Office 365, Azure 또는 Intune의 페더레이션 사용자에 대 한 계정 문제 해결

참고

Office 365 ProPlus엔터프라이즈용 Microsoft 365 앱으로 이름이 바뀌고 있습니다. 이 변경에 대한 자세한 내용은 이 블로그 게시물을 참조하세요.

문제

페더레이션 계정을 사용 하 여 Office 365, Microsoft Azure 또는 Microsoft Intune과 같은 Microsoft 클라우드 서비스에 인증을 시도 하면 인증이 실패 하 고 다음 문제 중 하나 이상이 발생할 수 있습니다.

  • 로그인 프롬프트에서 페더레이션 사용자 이름을 사용 하 여 Usernamefield를 업데이트 하려고 하면 브라우저 주소 표시줄에 "로그인 at" 링크를 포함 하는 웹 페이지 대신 다음 예제와 비슷한 URL이 포함 됩니다. <AD FS endpoint name> https://login.microsoftonline.com/login.srf?..

  • 페더레이션 계정을 사용 하 여 로그인 하 고 Office 365, Outlook Web App, SharePoint Online 또는 비즈니스용 Skype Online (이전의 Lync Online)과 같은 클라우드 서비스 리소스에 액세스 하려고 하면 다음과 같은 오류 메시지가 표시 됩니다.

    액세스 거부

원인

이러한 문제가 일부 사용자 계정에만 발생 하는 경우이는 해당 사용자 계정이 온-프레미스 Active Directory 환경에서 잘못 설정 된 것일 수 있음을 나타냅니다. 이 시나리오에서는 다음 항목 중 하나 이상이 잘못 설정 되었을 수 있습니다.

  • 잘못 된 UPN (사용자 계정 이름) 및 암호를 사용 하 고 있습니다.

  • UPN은 사용자 계정에 대해 업데이트 되지 않습니다.

    이 경우 각 id 페더레이션 계정에 대 한 UPN 접미사를 업데이트 하 여 페더레이션 도메인 이름을 반영 해야 합니다. 사용자 계정 UPN을 확인 하려면 다음 단계를 수행 합니다.

    1. 로컬 Active Directory 도메인 컨트롤러에서 시작을 클릭 하 고 모든 프로그램, 관리 도구를 차례로 가리킨 다음 Active Directory 사용자 및 컴퓨터를 클릭 합니다.
    2. 변경할 사용자 계정을 마우스 오른쪽 단추로 클릭 한 다음 속성을 클릭 합니다.
    3. 계정 탭의 왼쪽 위 모서리에 있는 목록에 페더레이션 네임 스페이스의 UPN 접미사가 나열 되어 있는지 확인 하 고 확인을 클릭 합니다.
  • Office 365 사용자 계정에 Office 365 리소스가 사용 되지 않음

    라이선스가 없는 사용자 계정을 사용 하는 Office 365 리소스에 대 한 액세스를 제한 합니다. 사용자 계정에 대 한 라이선스 상태를 확인 하려면 다음 단계를 수행 합니다.

    1. https://portal.office.comOffice 365 관리 사용자 계정을 사용 하 여 office 365 portal ()에 로그인 합니다. 필요한 경우 관리 되는 계정을 사용할 수 있습니다.

    2.  관리, Office 365을 차례로 클릭 한 다음 왼쪽 탐색 창에서 사용자 및 그룹을 클릭 합니다.

    3. 사용자 목록에서 테스트할 사용자 계정을 찾은 다음 표시 이름을선택 합니다. 각 사용자 계정에 Office 365 리소스에 필요한 라이선스가 있는지 확인 합니다.

    4. 모든 항목 선택   확인란을 선택 합니다.

      테스트 하려는 사용자 계정이 나열 되어 있지 않으면 Active Directory 동기화에서 계정을 Azure Active Directory (Azure AD)로 동기화 할 수 있습니다.

      참고 사용자 계정에 온-프레미스 사서함이 있는 경우에는 Office 365 사서함을 만들지 않습니다. 사용자 계정에 Exchange Online에 대 한 라이선스가 있는 경우에도이 특정 리소스는 계속 사용할 수 없습니다.

  • 하위 도메인이 상위 도메인의 페더레이션 설정을 상속 하지 않음

    Subdomain.contoso.com와 같은 하위 도메인이 상위 도메인 앞에 추가 되는 경우 (예: contoso.com) 부모 도메인의 페더레이션 상태를 자동으로 상속 합니다. 상속 상태를 확인 하려면 다음 단계를 수행 합니다.

    1. https://portal.office.comOffice 365 관리 사용자 계정을 사용 하 여 office 365 ()에 로그인 합니다. 필요한 경우 관리 되는 계정을 사용할 수 있습니다.
    2. 관리를 클릭 한 다음 왼쪽 탐색 창에서 도메인을 클릭 합니다.
    3. 도메인 목록에서 페더레이션 하위 도메인 이름을 찾은 다음 도메인 유형 설정이 Single sign-on으로 설정 되어 있는지 확인 합니다.
    4. 부모 도메인에 대해 1 단계를 3 단계 반복 합니다. 도메인 유형 설정이 하위 도메인 설정과 다를 경우 상위 도메인이 고아입니다.
  • 디렉터리 동기화 문제로 인해 온-프레미스의 적절 한 사용자 계정 구성이 Azure AD로 동기화 되지 않습니다.

    SSO (Single sign-on)는 온-프레미스 Active Directory와 Azure AD 둘 다에 표시 되는 동일한 사용자 계정에 의존 합니다. 디렉터리 동기화는 각 온-프레미스 사용자 계정에 대해 동일한 Office 365 사용자 계정이 만들어졌는지 확인 합니다. 디렉터리 동기화가 온-프레미스 Active Directory에서 Azure AD로 올바른 계정 설정을 동기화 하지 않으면 로그인이 실패할 수 있습니다.

해결 방법

이 문제를 해결 하려면 다음 방법 중 하나 이상을 사용 하십시오.

  • 로그인에 올바른 UPN 및 암호가 사용 되었는지 확인 합니다.

  • 페더레이션 계정에 대해서는 UPN이 업데이트 되지 않습니다.

    이 문제를 해결 하는 방법에 대 한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조 하십시오.

    2392130   Office 365, Azure 또는 Intune에 로그인 하는 경우 페더레이션 사용자에 대해 발생 하는 사용자 이름 문제 해결 

  • Office 365 사용자 계정에 Office 365 리소스에 대 한 라이선스가 없습니다.

    이 문제를 해결 하려면 Office 365 포털을 사용 하 여 라이선스가 필요한 사용자 계정에 적절 한 라이선스를 할당 합니다.

  • Office 365 하위 도메인은 상위 domain의 페더레이션 설정을 상속 하지 않습니다.

    이 문제를 해결 하려면 Office 365 포털에서 하위 도메인을 제거 합니다. 도메인을 제거 하는 방법에 대 한 자세한 내용은 다음 Microsoft 웹 사이트로 이동 합니다.

    도메인 제거

    도메인을 제거한 후에는 도메인을 다시 만들어야 합니다.

    도메인을 다시 만들면 하위 도메인이 상위 도메인의 도메인 유형 설정을 상속 합니다.

    참고 사항 하위 도메인이 이미 확인 된 부모 도메인의 일부로 인식 되므로 하위 도메인을 다시 만들 때 DNS TXT 레코드 또는 MX 레코드를 사용 하 여 도메인 확인을 수행 하지 않아도 됩니다.

  • 디렉터리 동기화 문제로 인해 온-프레미스 사용자 계정 구성이 Windows Azure AD와 제대로 동기화 되지 않습니다.

    계정 불일치가 발생 했는지 확인 하려면 다음 단계를 수행 합니다.

    1. 온-프레미스 Active Directory 사용자 계정에 대 한 사소한 (임의) 변경을 수행 합니다.

    2. 디렉터리 동기화를 강제로 수행 합니다. 동기화를 강제로 수행 하는 방법에 대 한 자세한 내용은 다음 Microsoft 웹 사이트로 이동 합니다.

      디렉터리 동기화 강제 적용

      동기화에 성공 했는지 여부를 확인 하는 방법에 대 한 자세한 내용은 다음 Microsoft 웹 사이트로 이동 합니다.

      디렉터리 동기화 확인

      사소한 변경 내용이 Office 365 사용자 계정에 동기화 되지 않으면 디렉터리 동기화 문제로 인해이 문제가 발생할 수 있습니다.

      참고 사항 사용자 계정이 이미 사용이 허가 된 경우 디렉터리 동기화는 사용자의 UPN을 적절 한 값으로 업데이트 하지 않고 정상적으로 동기화 될 수 있습니다.

      이 경우 UPN을 업데이트 하는 방법에 대 한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조 하십시오.

      2523192   Office 365, Azure 또는 Intune의 사용자 이름이 온-프레미스 UPN 또는 대체 로그인 ID와 일치 하지 않습니다. 

추가 정보

아직 해결되지 않았습니까? Microsoft 커뮤니티 또는 Azure Active Directory 포럼 웹 사이트로 이동 합니다.