Microsoft 365 서비스에 연결하려고 할 때 Office 응용 프로그램 인증 문제 해결

증상

일부 Microsoft Office 애플리케이션에서는 인증이 자동으로 실패하고 Outlook은 상호 작용 없이 "암호 필요" 상태가 될 수 있습니다. 또한 FindAllAccountsAsync에 대한 웹 계정 관리자 API 호출을 수행할 때 Microsoft Entra 로그 또는 Office 클라이언트 로그에 "-2147024809" 오류 코드가 표시될 수 있습니다.

중요

이 문제는 Windows 10, 버전 1703 이상 및 Microsoft 365 버전 1807 이상을 실행하는 컴퓨터에서만 발생합니다.

원인

ADAL(Active Directory 인증 라이브러리) 또는 라이브 ID에 대한 패키지 정보가 누락되어 인증 문제가 발생합니다.

해결 방법

몇 가지 일반적인 Office 로그인 문제를 진단하고 자동으로 해결하려면 Microsoft 지원 및 Recovery Assistant를 다운로드하여 실행할 수 있습니다.

이 문제를 해결하려면 PowerShell을 사용하여 Microsoft Entra WAM 플러그 인(조직 또는 회사 계정의 경우) 및 라이브 ID(, 등과 같은 @outlook.com@hotmail.com개인 계정의 경우)에 대한 패키지를 다시 설치합니다. 이렇게 하려면 다음과 같이 하십시오.

  1. 작업 표시줄에서 Windows 아이콘을 마우스 오른쪽 단추로 클릭한 다음 Windows PowerShell(관리)를 선택합니다.

  2. 사용자 계정 컨트롤(UAC) 창에서 메시지가 표시되면 를 선택하여 PowerShell을 시작합니다.

  3. 회사 계정에 문제가 있는 경우 Microsoft Entra WAM 플러그 인 패키지를 수정해야 합니다. 명령 콘솔에서 다음 명령을 실행합니다.

    if (-not (Get-AppxPackage Microsoft.AAD.BrokerPlugin)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.AAD.BrokerPlugin
    
  4. 문제가 개인 계정에 관한 것이라면 Live ID 패키지를 수정해야 합니다. 명령 콘솔에서 다음 명령을 실행합니다.

    if (-not (Get-AppxPackage Microsoft.Windows.CloudExperienceHost)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.Windows.CloudExperienceHost
    

명령을 실행한 후 오류 없이 완료되면 빠른 진행 표시기 또는 패키지 설치에 대한 정보가 포함된 상태 결과가 표시될 수 있습니다.