레지스트리의 \App Paths 키 아래에 Outlook.exe 제대로 등록되지 않았으므로 MAPI 솔루션이 작동하지 않습니다.

원본 KB 번호: 2698523

증상

사용자 지정 MAPI 솔루션(예: Outlook 추가 기능)을 사용하는 경우 Outlook.exe Windows 레지스트리에 제대로 등록되지 않았기 때문에 솔루션이 작동하지 않을 수 있습니다.

참고

사용자 지정 솔루션에서 발생하는 실제 문제는 Outlook.exe 등록 정보를 사용하는 방법에 따라 달라집니다.

원인

이 문제는 Windows 레지스트리의 다음 키 아래에 Outlook.exe 올바르게 등록되지 않은 경우에 발생할 수 있습니다.

  • 32비트 버전의 Windows

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths

  • 64비트 버전의 Windows

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths

Outlook.exe 올바르게 등록된 경우 위의 키 아래에 \Outlook.exe 하위 키가 있으며, \Outlook.exe 하위 키 아래에서 데이터가 컴퓨터에서 Outlook.exe 올바른 경로를 참조하는 Path라는 문자열 값을 찾습니다. 다음 그림에서는 32비트 버전의 Windows에서 올바른 Outlook.exe 등록을 보여줍니다.

Outlook.exe 등록 스크린샷

참고

기본이 아닌 위치에 Office를 설치한 경우 컴퓨터에서 Outlook.exe 경로는 위의 그림과 다를 수 있습니다.

해결 방법

이 문제를 resolve Office 설치를 복구합니다.