Power BI Desktop을 사용한 쿼리 개요Query overview in Power BI Desktop

Power BI Desktop을 사용하면 데이터 세계에 연결하여 강력하고 근본적인 보고서를 만들고, 다른 사용자와 작업을 공유할 수 있습니다. 이러한 사용자는 해당 작업을 기반으로 하여 비즈니스 인텔리전스 작업을 확장할 수 있습니다.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop에는 세 가지 보기가 있습니다.Power BI Desktop has three views:

  • 보고서 보기 – 표시하고자 하는 대로 정렬되고 복수의 페이지를 가진 뛰어난 시각화를 작성하기 위해 생성한 쿼리를 사용하고 타인과 공유할 수 있습니다.Report view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • 데이터 보기 – 측정값을 추가하고 새 열을 생성하며 관계를 관리할 수 있는 데이터 모델 형식의 보고서의 데이터를 볼 수 있습니다.Data view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • 관계 보기 – 사용자의 데이터 모델에 설정되고 필요에 따라 관리 또는 수정하는 관계의 그래픽 표현을 가져옵니다.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

이 보기들은 Power BI Desktop의 왼쪽에 있는 세 개의 아이콘 중 하나를 선택하여 액세스할 수 있습니다.These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. 다음 그림에서는 아이콘 옆에 노란색 줄로 표시된 보고서 보기가 선택되었습니다.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Power BI Desktop은 하나 이상의 데이터 소스, 모양 및 필요에 맞는 데이터 변환에 연결하고 해당 모델을 Power BI Desktop에 로드할 수 있는 쿼리 편집기도 함께 제공합니다.Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

이 문서에서는 쿼리 편집기의 데이터를 사용하는 작업의 개요를 설명합니다.This document provides an overview of the work with data in the Query Editor. 물론 더 많은 내용이 있으므로, 이 문서의 끝에는 지원하는 데이터 형식, 데이터에 연결, 데이터 모양 지정, 관계 생성 및 시작 방법에 대한 자세한 지침을 제공하는 링크가 있습니다.There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

그러나 우선은 쿼리 편집기를 살펴보겠습니다.But first, let’s see get acquainted with Query Editor.

쿼리 편집기The Query Editor

쿼리 편집기를 사용하려면 Power BI Desktop의 탭에서 쿼리 편집을 선택합니다.To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

데이터 연결이 없는 경우, 쿼리 편집기는 데이터를 받을 준비가 된 빈 창으로 나타납니다.With no data connections, Query Editor appears as a blank pane, ready for data.

쿼리가 로드되면 쿼리 편집기는 더 흥미로워집니다.Once a query is loaded, Query Editor view becomes more interesting. 다음 웹 데이터 소스에 연결한 경우, 파워 쿼리 편집기는 데이터에 대한 정보를 로드하며, 그 후에는 모양을 지정할 수 있습니다.If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

데이터 연결이 설정되면 쿼리 편집기는 다음과 같이 표시됩니다.Here’s how Query Editor appears once a data connection is established:

  1. 리본 메뉴에서 이제 많은 단추가 활성화되어 쿼리의 데이터를 조작할 수 있습니다.In the ribbon, many buttons are now active to interact with the data in the query

  2. 왼쪽 창에 쿼리가 나열되며 선택, 보기 및 모양 지정에 사용할 수 있습니다.In the left pane, queries are listed and available for selection, viewing, and shaping

  3. 가운데 창에 선택한 쿼리의 데이터가 표시되고 모양 지정에 사용할 수 있습니다.In the center pane, data from the selected query is displayed and available for shaping

  4. 쿼리 설정 창이 나타나고, 쿼리의 속성과 적용된 단계를 나열합니다.The Query Settings window appears, listing the query’s properties and applied steps

다음 섹션에서 리본 메뉴, 쿼리 창, 데이터 뷰 및 쿼리 설정 창의 4가지 각 영역을 살펴보겠습니다.We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

쿼리 리본The query ribbon

쿼리 편집기의 리본 메뉴는 , 변환, 열 추가보기의 4개 탭으로 구성되어 있습니다.The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

탭에는 모든 쿼리의 첫 단계인 데이터 가져오기를 포함한 일반적인 쿼리 작업이 포함됩니다.The Home tab contains the common query tasks, including the first step in any query, which is Get Data. 다음 이미지는 리본을 보여 줍니다.The following image shows the Home ribbon.

데이터에 연결하고 쿼리 작성 프로세스를 시작하려면 데이터 가져오기 버튼을 선택합니다.To connect to data and begin the query building process, select the Get Data button. 가장 일반적인 데이터 소스를 제공하는 메뉴가 나타납니다.A menu appears, providing the most common data sources.

사용 가능한 데이터 소스에 대한 자세한 내용은 데이터 소스를 참조하세요.For more information about available data sources, see Data Sources. 예제 및 단계를 포함하여 데이터에 연결하는 방법에 대한 자세한 내용은 데이터에 연결을 참조하세요.For information about connecting to data, including examples and steps, see Connect to Data.

변환 탭은 열 추가 또는 제거, 데이터 형식 변경, 열 분할 및 기타 데이터 기반 작업과 같은 일반적인 데이터 변환 작업에 대한 액세스를 제공합니다.The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. 다음 그림은 변환 탭을 보여 줍니다.The following image shows the Transform tab.

데이터를 변환하는 방법에 대한 자세한 내용은 데이터 결합 및 모양 지정을 참조하세요.For more information about transforming data, including examples, see Combine and Shape Data.

열 추가 탭에서는 열 추가, 열 데이터 형식 지정 및 사용자 지정 열 추가와 관련된 추가 작업을 제공합니다.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. 다음 그림은 열 추가 탭을 보여 줍니다.The following image shows the Add Column tab.

리본 메뉴의 보기 탭은 특정 창이 표시되는지 여부를 전환하는 데 사용됩니다.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. 또한 고급 편집기를 표시하는 데 사용됩니다.It’s also used to display the Advanced Editor. 다음 그림은 보기 탭을 보여 줍니다.The following image shows the View tab.

리본 메뉴에서 사용할 수 있는 많은 작업은 가운데 창에서 열이나 다른 데이터를 마우스 오른쪽 단추로 클릭하여 사용할 수도 있습니다.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

왼쪽 창The left pane

왼쪽 창에는 활성 쿼리 수와 쿼리 이름이 표시됩니다.The left pane displays the number of active queries, as well as the name of the query. 왼쪽 창에서 쿼리를 선택하면 해당 데이터가 가운데 창에 표시되며, 여기서 요구 사항에 맞게 데이터 모양을 지정하고 변환할 수 있습니다.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. 다음 그림은 여러 쿼리가 포함된 왼쪽 창을 보여 줍니다.The following image shows the left pane with multiple queries.

가운데(데이터) 창The center (data) pane

가운데 창 또는 데이터 창에 선택한 쿼리의 데이터가 표시됩니다.In the center pane, or Data pane, data from the selected query is displayed. 여기서 쿼리 보기의 작업이 대부분 수행됩니다.This is where much of the work of the Query view is accomplished.

다음 그림에는 이전에 설정한 웹 데이터 연결이 표시되고, Overall score 열이 선택되며, 해당 머리글을 마우스 오른쪽 단추로 클릭하여 사용 가능한 메뉴 항목을 표시합니다.In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. 이러한 오른쪽 클릭 메뉴 항목은 대부분 리본 탭의 단추와 동일합니다.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

오른쪽 클릭 메뉴 항목(또는 리본 단추)를 선택하면 쿼리가 데이터에 단계를 적용하고 쿼리 자체의 일부로 저장합니다.When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. 단계는 다음 섹션에 설명된 대로 쿼리 설정 창에 순차적으로 기록됩니다.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

쿼리 설정 창The query settings pane

쿼리 설정 창에는 쿼리와 관련된 모든 단계가 표시됩니다.The Query Settings pane is where all steps associated with a query are displayed. 예를 들어 다음 그림에서 쿼리 설정 창의 적용된 단계 섹션은 Overall score 열의 형식을 방금 변경했다는 사실을 반영합니다.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

쿼리에 모양 지정 단계를 추가로 적용하면 적용된 단계 섹션에 캡처됩니다.As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

기본 데이터는 변경되지 않는다는 것을 알아야 합니다. 대신, 쿼리에서 데이터 보기를 조정하고 모양을 지정하며, 해당 데이터의 모양이 지정되고 수정된 쿼리 보기에 따라 기본 데이터를 조작합니다.It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

쿼리 설정 창에서 단계의 이름을 바꾸거나, 단계를 삭제하거나, 단계를 적절하게 다시 정렬할 수 있습니다.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. 이렇게 하려면 적용된 단계 섹션에서 단계를 마우스 오른쪽 단추로 클릭하고 나타나는 메뉴에서 선택합니다.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. 모든 쿼리 단계는 적용된 단계 창에 나타난 순서대로 수행됩니다.All query steps are carried out in the order they appear in the Applied Steps pane.

고급 편집기The Advanced Editor

각 단계에서 쿼리가 만드는 코드를 확인하거나 사용자 고유의 모양 지정 코드를 만들려는 경우 고급 편집기를 사용할 수 있습니다.If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. 고급 편집기를 시작하려면 리본 메뉴에서 보기를 선택한 다음 고급 편집기를 선택합니다.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. 기존 쿼리 코드를 보여 주는 창이 나타납니다.A window appears, showing the existing query code.

고급 편집기 창에서 코드를 직접 편집할 수 있습니다.You can directly edit the code in the Advanced Editor window. 창을 닫으려면 완료 또는 취소 단추를 선택합니다.To close the window, select the Done or Cancel button.

작업 내용 저장Saving your work

원하는 위치에 쿼리가 있는 경우, 쿼리 편집기에서 데이터 모델에 대한 변경 사항을 Power BI Desktop에 적용하도록 설정하고 쿼리 편집기를 닫을 수 있습니다.When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. 이렇게 하려면 쿼리 편집기의 파일 메뉴에서 닫기 및 적용을 선택합니다.To do that, select Close & Apply from Query Editor's File menu.

Power BI Desktop은 진행 상태를 대화 상자로 표시합니다.As progress is made, Power BI Desktop provides a dialog to display its status.

쿼리가 원하는 위치에 배치된 후 또는 단순히 작업 내용을 저장하려는 경우 Power BI Desktop은 .pbix 파일 형식으로 작업을 저장할 수 있습니다.Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

작업을 저장하려면 다음 이미지와 같이 파일 > 저장(또는 파일 > 다른 이름으로 저장)을 선택합니다.To save your work, select File > Save (or File > Save As), as shown in the following image.

다음 단계Next steps

Power BI Desktop에서 모든 종류의 작업을 수행할 수 있습니다.There are all sorts of things you can do with Power BI Desktop. 해당 기능에 대한 자세한 내용은 다음 리소스를 확인하세요.For more information on its capabilities, check out the following resources: