쿼리 편집기에서 R 사용Using R in Query Editor

Power BI Desktop 쿼리 편집기에서 통계학자, 데이터 과학자 및 데이터 분석에 의해 널리 사용되는 프로그래밍 언어인 R을 사용할 수 있습니다.You can use R, a programming language widely used by statisticians, data scientists, and data analysts, in the Power BI Desktop Query Editor. R을 쿼리 편집기에 통합하면 R을 사용하여 데이터 정리를 수행하고 누락된 데이터, 예측, 클러스터링을 완성하는 작업을 포함하여 데이터 집합에서 고급 데이터 셰이핑 및 분석을 수행할 수 있습니다.This integration of R into Query Editor lets you perform data cleansing using R, and perform advanced data shaping and analytics in datasets, including completion of missing data, predictions, and clustering, just to name a few. R은 강력한 언어이며 쿼리 편집기에서 사용하여 데이터 모델을 준비하고 보고서를 만들 수 있습니다.R is a powerful language, and can be used in Query Editor to prepare your data model and create reports.

R 설치Installing R

Power BI Desktop의 쿼리 편집기에서 R을 사용하려면 로컬 컴퓨터에 R을 설치해야 합니다.To use R in Power BI Desktop's Query Editor, you need to install R on your local machine. 여러 위치에서 무료로 Revolution Open 다운로드 페이지CRAN 리포지토리를 포함하는 R을 다운로드 및 설치할 수 있습니다.You can download and install R for free from many locations, including the Revolution Open download page, and the CRAN Repository.

쿼리 편집기에서 R 사용Using R in Query Editor

쿼리 편집기에서 R을 사용하는 방법을 보여 주려면 여기에서 다운로드하고 따를 수 있는 .CSV 파일을 기반으로 하는 주식 시장 데이터 집합의 예르 사용합니다.To show how to use R in Query Editor, we'll use an example from a stock market dataset, based on a .CSV file that you can download from here and follow along. 이 예제에 대한 단계는 다음과 같습니다.The steps for this example are the following:

  1. 먼저 데이터를 Power BI Desktop으로 로드합니다.First, load your data into Power BI Desktop. 이 예제에서는 EuStockMarkets_NA.csv 파일을 로드합니다.In this example we'll load the EuStockMarkets_NA.csv file. Power BI Desktop 리본에서 데이터 가져오기 > CSV를 선택합니다.Select Get Data > CSV from the Home ribbon in Power BI Desktop.

  2. 파일을 선택하고 열기를 선택하면 CSV는 CSV 파일 대화 상자에 표시됩니다.Select the file and select Open, and the CSV is displayed in the CSV file dialog.

  3. 데이터가 로드되면 Power BI Desktop의 필드 창에 표시됩니다.Once the data is loaded, you'll see it in the Fields pane in Power BI Desktop.

  4. Power BI Desktop 탭에서 쿼리 편집을 선택하여 쿼리 편집기를 엽니다.Open Query Editor by selecting Edit Queries from the Home tab in Power BI Desktop.

  5. 변환 탭에서 R 스크립트 실행을 선택하면 R 스크립트 실행 편집기가 나타납니다(다음 단계에 표시됨).In the Transform tab, select Run R Script and the Run R Script editor appears (shown in the next step). 다음 이미지에서 볼 수 없는 다른 행과 마찬가지로 15, 20행은 누락된 데이터가 발생합니다.Notice that rows 15 and 20 suffer from missing data, as do other rows you can't see in the following image. 아래 단계는 R이 해당 행을 완성할 수 있(고 완성하)는 방법을 보여 줍니다.The steps below show how R can (and will) complete those rows for you.

  6. 이 예에서는 다음 스크립트 코드를 입력합니다.For this example, we'll enter the following script code:

    library(mice)
    tempData <- mice(dataset,m=1,maxit=50,meth='pmm',seed=100)
    completedData <- complete(tempData,1)
    output <- dataset
    output$completedValues <- completedData$"SMI missing values"
    

    참고

    이전의 스크립트 코드가 제대로 작동하려면 R 환경에 설치된 mice 라이브러리가 있어야 합니다.You'll need to have the mice library installed in your R environment for the previous script code to work properly. 마우스를 설치하려면 R 설치에서 다음을 실행 합니다. | > install.packages('mice')To install mice, run the following in your R installation: | > install.packages('mice')

    R 스크립트 실행 대화 상자에 삽입했을 때 코드는 다음과 같습니다.When put into the Run R Script dialog, the code looks like the following:

  7. 확인을 선택하면 쿼리 편집기에서 데이터 개인 정보 보호에 대한 경고를 표시합니다.When we select OK, Query Editor displays a warning about data privacy.

  8. R 스크립트가 Power BI 서비스에서 제대로 작동하려면 모든 데이터 원본은 공용으로 설정되어야 합니다.For the R scripts to work properly in the Power BI service, all data sources need to be set to public. 개인 정보 설정 및 해당 구현에 대한 자세한 내용은 개인 정보 수준을 참조하세요.For more information about privacy settings and their implications, see Privacy Levels.

    이렇게 하면 completedValues라는 필드에서도 새 열을 확인할 수 있습니다.Once we do so, we see a new column in the Fields well called completedValues. 행 15, 18에서와 같은 몇 가지 누락된 데이터 요소가 있습니다.Notice there are a few missing data elements, such as on row 15 and 18. 다음 섹션에서는 R이 이를 처리하는 방법을 살펴봅니다.We'll see how R handles that in the next section.

쿼리 편집기는 R 스크립트 다섯 줄을 사용하여 예측 모델을 포함한 누락된 값을 입력했습니다.With just five lines of R script, Query Editor filled in the missing values with a predictive model.

R 스크립트 데이터의 시각적 개체 만들기Creating visuals from R script data

시각적 개체를 만들어서 다음 이미지에 보이는 것처럼 R 스크립트 코드가 마우스 라이브러리를 사용하여 누락된 값을 완성화는 방법을 확인할 수 있습니다.Now we can create a visual to see how the R script code using the mice library completed the missing values, as shown in the following image.

해당 시각적 개체 또는 Power BI Desktop을 사용하여 만들려는 다른 시각적 개체가 완성되면 Power BI Desktop 파일을 저장(.pbix 파일로 저장)한 다음 Power BI 서비스에서 해당 파일의 일부인 R 스크립트를 포함하여 데이터 모델을 사용할 수 있습니다.Once that visual is complete, and any other visuals we might want to create using Power BI Desktop, we can save the Power BI Desktop file (which saves as a .pbix file) and then use the data model, including the R scripts that are part of it, in the Power BI service.

참고

이러한 단계를 완료한 .pbix 파일을 보시겠습니까?Want to see a completed .pbix file with these steps completed? 간단한 방법이 있습니다. 이 예제에서 사용한 완료된 Power BI Desktop 파일을 지금 바로 다운로드할 수 있습니다.You're in luck - you can download the completed Power BI Desktop file used in these examples right here.

.pbix 파일을 Power BI 서비스에 업로드했으므로 (서비스에서) 데이터 새로 고침을 사용하도록 설정하고 서비스에서 업데이트할 시각적 개체를 사용하도록 설정(데이터를 업데이트하려면 시각적 개체에 대한 R에 액세스해야 함)하는 데 필요한 몇 가지 추가 단계가 있습니다.Once you've uploaded the .pbix file to the Power BI service, a couple more steps are necessary to enable data refresh (in the service) and to enable visuals to be updated in the service (the data needs access to R for visuals to be updated). 추가 단계는 다음과 같습니다.The additional steps are the following:

  • 데이터 집합에 대한 예정된 새로 고침 사용하도록 설정 - R 스크립트를 사용하여 데이터 집합을 포함하는 통합 문서에 대한 예정된 새로 고침을 사용하려면 예정된 새로 고침 구성을 참조하세요. 여기에는 개인 게이트웨이에 대한 정보가 포함됩니다.Enable scheduled refresh for the dataset - to enable scheduled refresh for the workbook that contains your dataset with R scripts, see Configuring scheduled refresh, which also includes information about Personal Gateway.
  • 개인 게이트웨이 설치 - 파일이 위치하고 R이 설치되어 있는 컴퓨터에 개인 게이트웨이를 설치해야 합니다. Power BI 서비스는 해당 통합 문서에 액세스하고 업데이트된 시각적 개체를 다시 렌더링해야 합니다.Install the Personal Gateway - you need a Personal Gateway installed on the machine where the file is located, and where R is installed; the Power BI service must access that workbook and re-render any updated visuals. 개인 게이트웨이를 설치하고 구성하는 방법에 대한 자세한 정보를 얻을 수 있습니다.You can get more information on how to install and configure Personal Gateway.

제한 사항Limitations

쿼리 편집기에서 만든 R 스크립트를 포함하는 쿼리에 몇 가지 제한 사항이 있습니다.There are some limitations to queries that include R scripts created in Query Editor:

  • 모든 R 데이터 원본은 공용으로 설정되어야 하고 쿼리 편집기에서 만든 쿼리의 다른 모든 단계도 공용이어야 합니다.All R data source settings must be set to Public, and all other steps in a query created in Query Editor must also be public. 데이터 원본 설정으로 이동하려면 Power BI Desktop에서 파일 > 옵션 및 설정 > 데이터 원본 설정을 선택합니다.To get to data source settings, in Power BI Desktop select File > Options and settings > Data source settings.

    데이터 원본 설정 대화 상자에서는 데이터 원본을 선택한 다음 사용 권한 편집...을 선택하고 개인 정보 수준공용으로 설정되었는지 확인합니다.From the Data Source Settings dialog, select the the data source(s) and then select Edit Permissions... and ensure that the Privacy Level is set to Public.

  • R 시각적 개체 또는 데이터 집합의 예정된 새로 고침을 사용하도록 설정하려면 예약된 새로 고침을 확성화해야 하고 통합 문서 및 R 설치를 저장하는 컴퓨터에 개인 게이트웨이를 설치해야 합니다.To enable scheduled refresh of your R visuals or dataset, you need to enable Scheduled refresh and have a Personal Gateway installed on the computer that houses the workbook and the R installation. 둘 다에 대한 자세한 내용은 이 문서의 이전 섹션을 참조하며 여기서 각각에 대한 자세한 내용을 알아보는 링크를 제공합니다.For more information on both, see the previous section in this article, which provides links to learn more about each.

R 및 사용자 지정 쿼리를 사용하여 수행할 수 있는 모든 것이 있으므로 데이터 모양을 지정하여 데이터를 탐색하고 모양을 지정합니다.There are all sorts of things you can do with R and custom queries, so explore and shape your data just the way you want it to appear.