화면 추가 및 화면 간 탐색Add a screen and navigate between screens

여러 화면이 있는 앱을 만들고 사용자가 이들 사이를 탐색하는 방법을 추가합니다.Create an app with multiple screens, and add ways for users to navigate between them.

필수 조건Prerequisites

화면 추가 및 이름 바꾸기Add and rename a screen

  1. 탭에서 새 화면을 클릭하거나 탭합니다.On the Home tab, click or tap New screen.

    홈 탭에서 화면 옵션 추가

  2. 오른쪽 창에서 화면의 이름(속성 탭 바로 위)을 클릭하거나 탭한 후 새 이름으로 Source를 입력합니다.In the right-hand pane, click or tap the name of the screen (just above the Properties tab), and then type the new name Source.

    기본 화면 이름 바꾸기

  3. 다른 화면을 추가하고 이름을 Target으로 지정합니다.Add another screen, and name it Target.

    왼쪽 탐색 표시줄에서 두 개의 화면

탐색 추가Add navigation

  1. Source 화면을 선택한 상태에서 삽입 탭을 열고 아이콘을 클릭하거나 탭한 후 다음 화살표를 클릭하거나 탭합니다.With the Source screen selected, open the Insert tab, click or tap Icons, and then click or tap Next arrow.

    [삽입] 탭에 있는 [셰이프] 옵션

  2. (선택 사항) 화면의 오른쪽 아래 모서리에 표시되도록 화살표를 이동합니다.(optional) Move the arrow so that it appears in the lower-right corner of the screen.
  3. 화살표를 선택한 상태로 작업 탭을 클릭하거나 탭한 후 탐색을 클릭하거나 탭합니다.With the arrow still selected, click or tap the Action tab, and then click or tap Navigate.

    화살표에 대한 OnSelect 속성이 Navigate 함수로 자동으로 설정됩니다.The OnSelect property for the arrow is automatically set to a Navigate function.

    Navigate 함수로 설정된 OnSelect 속성

    사용자가 화살표를 클릭하거나 탭하면 Target 화면이 사라집니다.When a user clicks or taps the arrow, the Target screen fades in.

  4. Target 화면에서 뒤로 화살표를 추가하고 OnSelect 속성을 다음 수식으로 설정합니다.On the Target screen, add a Back arrow, and set its OnSelect property to this formula:
    Navigate(Source, ScreenTransition.Fade)Navigate(Source, ScreenTransition.Fade)
  5. 미리 보기 모드( 또는 F5 키 누르기)를 연 후 추가한 화살표를 클릭하거나 탭하여 화면 사이를 전환합니다.Open Preview mode ( or press F5), and then switch between the screens by clicking or tapping the arrows that you added.
  6. 기본 작업 영역으로 돌아가려면 Esc 키를 누릅니다.Press Esc to return to the default workspace.