Windows PowerShell 시스템 요구 사항Windows PowerShell System Requirements

이 항목에서는 Windows PowerShell 3.0, Windows PowerShell 4.0, Windows PowerShell 5.0 및 Windows PowerShell 5.1과 특수 기능(예: Windows PowerShell ISE(통합 스크립팅 환경), CIM 명령 및 워크플로)에 대한 시스템 요구 사항을 보여 줍니다.This topic lists the system requirements for Windows PowerShell 3.0, Windows PowerShell 4.0 and Windows PowerShell 5.0, and Windows PowerShell 5.1 and for special features, such as Windows PowerShell Integrated Scripting Environment (ISE), CIM commands, and workflows.

Windows® 8.1 및 Windows Server® 2012 R2에는 필요한 모든 프로그램이 포함되어 있습니다.Windows® 8.1 and Windows Server® 2012 R2 include all required programs. 이 항목은 이전 버전의 Windows 사용자를 위한 것입니다.This topic is designed for users of earlier releases of Windows.

운영 체제 요구 사항Operating System Requirements

Windows PowerShell 5.1은 다음 버전의 Windows에서 실행됩니다.Windows PowerShell 5.1 runs on the following versions of Windows.

Windows PowerShell 5.0(Windows PowerShell 5.1 이전 버전) 은 다음 버전의 Windows에서 실행됩니다.Windows PowerShell 5.0 (Superceeded by Windows PowerShell 5.1) runs on the following versions of Windows.

Windows PowerShell 4.0은 다음 버전의 Windows에서 실행됩니다.Windows PowerShell 4.0 runs on the following versions of Windows.

Windows PowerShell 3.0은 다음 버전의 Windows에서 실행됩니다.Windows PowerShell 3.0 runs on the following versions of Windows.

Microsoft .NET Framework 요구 사항Microsoft .NET Framework Requirements

Windows PowerShell 5.1을 사용하려면 Microsoft .NET Framework 4.5 전체 설치가 필요합니다.Windows PowerShell 5.1 requires the full installation of Microsoft .NET Framework 4.5. Windows 8.1 및 Windows Server 2012 R2에는 Microsoft .NET Framework 4.5가 기본적으로 포함되어 있습니다.Windows 8.1 and Windows Server 2012 R2 include Microsoft .NET Framework 4.5 by default.

Windows PowerShell 5.0을 사용하려면 Microsoft .NET Framework 4.5 전체 설치가 필요합니다.Windows PowerShell 5.0 requires the full installation of Microsoft .NET Framework 4.5. Windows 8.1 및 Windows Server 2012 R2에는 Microsoft .NET Framework 4.5가 기본적으로 포함되어 있습니다.Windows 8.1 and Windows Server 2012 R2 include Microsoft .NET Framework 4.5 by default.

Windows PowerShell 4.0을 사용하려면 Microsoft .NET Framework 4.5 전체 설치가 필요합니다.Windows PowerShell 4.0 requires the full installation of Microsoft .NET Framework 4.5. Windows 8.1 및 Windows Server 2012 R2에는 Microsoft .NET Framework 4.5가 기본적으로 포함되어 있습니다.Windows 8.1 and Windows Server 2012 R2 include Microsoft .NET Framework 4.5 by default.

Windows PowerShell 3.0을 사용하려면 Microsoft .NET Framework 4 전체 설치가 필요합니다.Windows PowerShell 3.0 requires the full installation of Microsoft .NET Framework 4. Windows 8 및 Windows Server 2012에는 이 요구 사항을 충족하는 Microsoft .NET Framework 4.5가 기본적으로 포함되어 있습니다.Windows 8 and Windows Server 2012 include Microsoft .NET Framework 4.5 by default, which fulfills this requirement.

Microsoft .NET Framework 4.5(dotNetFx45_Full_setup.exe)를 설치하려면 Microsoft 다운로드 센터에서 Microsoft .NET Framework 4.5를 참조하세요.To install Microsoft .NET Framework 4.5 (dotNetFx45_Full_setup.exe), see Microsoft .NET Framework 4.5 on the Microsoft Download Center.

Microsoft .NET Framework 4 전체 설치(dotNetFx40_Full_setup.exe)를 설치하려면 Microsoft 다운로드 센터에서 Microsoft .NET Framework 4(웹 설치 관리자)를 참조하세요.To install the full installation of Microsoft .NET Framework 4 (dotNetFx40_Full_setup.exe), see Microsoft .NET Framework 4 (Web Installer) on the Microsoft Download Center.

Windows Management Framework 4.0Windows Management Framework 4.0

Windows PowerShell 5.0을 사용하려면 Windows Server 2008 R2 SP1 및 Windows 7 SP1에 Windows Management Framework 4.0이 미리 설치되어 있어야 합니다.Windows PowerShell 5.0 requires Windows Management Framework 4.0 to be preinstalled on Windows Server 2008 R2 SP1 and Windows 7 SP1.

WS-Management 3.0WS-Management 3.0

Windows PowerShell 3.0 및 Windows PowerShell 4.0을 사용하려면 WinRM 서비스 및 WSMan 프로토콜을 지원하는 WS-Management 3.0이 필요합니다.Windows PowerShell 3.0 and Windows PowerShell 4.0 require WS-Management 3.0, which supports the WinRM service and WSMan protocol. 이 프로그램은 Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0 및 Windows Management Framework 3.0에 포함되어 있습니다.This program is included in Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0, and Windows Management Framework 3.0.

Windows Management Instrumentation 3.0Windows Management Instrumentation 3.0

Windows PowerShell 3.0 및 Windows PowerShell 4.0을 사용하려면 WMI(Windows Management Instrumentation) 3.0이 필요합니다.Windows PowerShell 3.0 and Windows PowerShell 4.0 require Windows Management Instrumentation 3.0 (WMI). 이 프로그램은 Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0 및 Windows Management Framework 3.0에 포함되어 있습니다.This program is included in Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0, and Windows Management Framework 3.0. 이 프로그램이 컴퓨터에 설치되어 있지 않으면 WMI가 필요한 기능(예: CIM 명령)이 실행되지 않습니다.If this program is not installed on the computer, features that require WMI, such as CIM commands, do not run.

공용 언어 런타임 4.0Common Language Runtime 4.0

Windows PowerShell 3.0, Windows PowerShell 4.0 및 Windows PowerShell 5.0은 CLR(공용 언어 런타임) 4.0에 대해 컴파일됩니다.Windows PowerShell 3.0, Windows PowerShell 4.0, and Windows PowerShell 5.0 are compiled against Common Language Runtime (CLR) 4.0.

그래픽 사용자 인터페이스 요구 사항Graphical User Interface Requirements

Windows PowerShell은 그래픽 사용자 인터페이스를 요구하지 않는 콘솔 기반 응용 프로그램입니다.Windows PowerShell is a console-based application that does not require a graphical user interface. 따라서 Windows Server 2012 R2 또는 Windows Server 2012의 Server Core 설치 옵션과 같이 화면 또는 모니터나 사용자 인터페이스가 없는 컴퓨터에 적합합니다.As such, is it well suited to computers that do not have screens or monitors, or a user interface, such as the Server Core installation options of Windows Server 2012 R2 or Windows Server 2012.

그러나 다음과 같은 일부 항목에는 그래픽 사용자 인터페이스가 필요합니다.However, some items, such as the following, require a graphical user interface. 자세한 내용은 각 항목에 대한 도움말 항목을 참조하세요.For details, see the help topic for each item.

Windows PowerShell 엔진 요구 사항Windows PowerShell Engine Requirements

Windows PowerShell 4.0은 이전 버전인 Windows PowerShell 3.0 및 Windows PowerShell 2.0과 호환되도록 설계되었습니다.Windows PowerShell 4.0 is designed to be backwards compatible with Windows PowerShell 3.0 and Windows PowerShell 2.0. Windows PowerShell 2.0 및 Windows PowerShell 3.0용으로 작성된 cmdlet, 공급자, 스냅인, 모듈 및 스크립트는 Windows PowerShell 4.0에서 변경하지 않고 실행됩니다.Cmdlets, providers, snap-ins, modules, and scripts written for Windows PowerShell 2.0 and Windows PowerShell 3.0 run unchanged in Windows PowerShell 4.0.

그러나 Microsoft .NET Framework 4의 런타임 정품 인증 정책 변경으로 인해 Windows PowerShell 2.0용으로 작성되고 CLR(공용 언어 런타임) 2.0으로 컴파일된 Windows PowerShell 호스트 프로그램은 CLR 4.0으로 컴파일된 Windows PowerShell 3.0에서 수정 없이 실행할 수 없습니다.However, due to a change in the runtime activation policy in Microsoft .NET Framework 4, Windows PowerShell host programs that were written for Windows PowerShell 2.0 and compiled with Common Language Runtime (CLR) 2.0 cannot run without modification in Windows PowerShell 3.0, which is compiled with CLR 4.0.

Windows PowerShell 2.0 엔진에는 최소한 Microsoft .NET Framework 2.0.50727이 필요합니다.The Windows PowerShell 2.0 engine requires Microsoft .NET Framework 2.0.50727 at a minimum. 이 요구 사항은 Microsoft .NET Framework 3.5 서비스 팩 1에 의해 충족됩니다.This requirement is fulfilled by Microsoft .NET Framework 3.5 Service Pack 1. Microsoft .NET Framework 4 이상 릴리스의 Microsoft .NET Framework에서는 이 요구 사항이 충족되지 않습니다.This requirement is not fulfilled by Microsoft .NET Framework 4 and later releases of Microsoft .NET Framework.

Windows PowerShell 2.0 엔진을 추가 또는 설치하는 방법과 필수 버전의 Microsoft .NET Framework를 추가 또는 설치하는 방법에 대한 자세한 내용은 Windows PowerShell 2.0 엔진 설치를 참조하세요.For information about adding or installing the Windows PowerShell 2.0 engine, and adding or installing the required versions of the Microsoft .NET Framework, see Installing the Windows PowerShell 2.0 Engine. Windows PowerShell 2.0 엔진을 시작하는 방법에 대한 자세한 내용은 Windows PowerShell 2.0 엔진 시작을 참조하세요.For information about starting the Windows PowerShell 2.0 engine, see Starting the Windows PowerShell 2.0 Engine.

Windows 사전 설치 환경Windows Preinstallation Environment

Windows PowerShell 2.0, Windows PowerShell 3.0 및 Windows PowerShell 4.0은 Winows PE(Windows 사전 설치 환경)에서 실행됩니다.Windows PowerShell 2.0, Windows PowerShell 3.0, and Windows PowerShell 4.0 run in the Windows Preinstallation Environment (Windows PE). 그러나 다음 cmdlet은 지원되지 않습니다.However, the following cmdlets are not supported.

또한 Windows PE에는 WinRM 서비스가 없습니다.Also, the WinRM service is not present on Windows PE.

참고 항목See Also