Windows Vista 및 Visual Studio

업데이트: 2007년 11월

Visual Studio 2008은 Windows Vista에 설치하고 사용할 수 있습니다. 이전 버전 Visual Studio에 대한 Windows Vista 지원은 버전마다 다릅니다. SP1(서비스 팩 1) 업데이트가 설치된 Visual Studio 2005는 Windows Vista에서 지원됩니다. 하지만 Windows Vista에 이전 버전의 Visual Studio를 설치하고 사용할 수 없습니다. Visual Studio 2005 또는 Visual Studio .NET 2003을 사용하여 개발한 응용 프로그램은 Windows Vista에 설치하고 사용할 수 있습니다.

릴리스

Windows Vista에 설치할 수 있는지 여부

이번 버전을 사용하여 개발한 응용 프로그램을 Windows Vista에 설치할 수 있는지 여부

Visual Studio 2008

Windows Vista에 대한 Visual Studio 2005 서비스 팩 1 업데이트

Visual Studio 2005 서비스 팩 1

Visual Studio 2005

아니요

Visual Studio .NET 2003 서비스 팩 1

아니요

예(응용 프로그램이 .NET Framework 1.1 이상 버전을 대상으로 하는 경우)

Visual Studio .NET 2003

아니요

예(응용 프로그램이 .NET Framework 1.1 이상 버전을 대상으로 하는 경우)

Visual Studio .NET 2002

아니요

아니요

Windows Vista의 Visual Studio 2008

Windows Vista에 Visual Studio 2008 베타 2를 설치하고 사용할 수 있습니다. Visual Studio 2008을 관리자 권한으로 실행할 필요는 없지만 일부 기능은 관리자 권한으로 실행해야만 올바르게 작동합니다. 관리자 권한으로 실행해야 하는 기능의 경우 메시지 상자에 추가 지침이 나타납니다.

참고:

Windows XP에 Visual Studio 2008을 설치한 다음 운영 체제를 Windows Vista로 업그레이드하는 경우 .NET Framework 3.5가 올바르게 작동하도록 Visual Studio 2008 설치를 복구해야 합니다.

Windows Vista의 Visual Studio 2005

사용 가능한 서비스 팩 중 하나 이상이 설치되지 않은 Visual Studio 2005는 Windows Vista에 설치하고 사용할 수 없습니다. Visual Studio 2005 서비스 팩 1 또는 Windows Vista에 대한 Visual Studio 2005 서비스 팩 1 및 Visual Studio 2005 서비스 팩 1 업데이트를 설치하고 관리자 권한으로 Visual Studio를 실행해야 Windows Vista에서 Visual Studio 2005를 사용할 수 있습니다. 자세한 내용은 방법: 제품 업데이트 찾기를 참조하십시오.

주의:

Windows Vista에 대한 Visual Studio 2005 서비스 팩 1 업데이트를 설치하려는 경우 먼저 Visual Studio 2005 서비스 팩 1을 설치해야 합니다.

특정 버전의 Visual Studio 2005를 사용하여 개발된 응용 프로그램은 .NET Framework 1.1 이상을 대상으로 하는 경우에만 Windows Vista에서 실행됩니다.

자세한 내용은 Visual Studio on Windows Vista를 참조하십시오.

Windows Vista의 Visual Studio .NET 2003

현재로서는 Windows Vista에 Visual Studio .NET 2003 또는 Visual Studio .NET 2003 서비스 팩 1을 설치하고 사용할 수 없습니다. Windows Vista와 관련된 Visual Studio .NET 2003 업데이트는 아직 제공 계획이 없습니다.

Visual Studio .NET 2003 또는 Visual Studio .NET 2003 서비스 팩 1을 사용하여 개발된 응용 프로그램은 .NET Framework 1.1 이상을 대상으로 하는 경우에만 Windows Vista에서 실행됩니다.

Windows Vista의 Visual Studio .NET 2002

Windows Vista에 Visual Studio .NET 2002를 설치하고 사용할 수 없습니다.

Visual Studio .NET 2002를 사용하여 개발한 응용 프로그램은 .NET Framework 1.0을 대상으로 하기 때문에 Windows Vista에서 실행할 수 없습니다. .NET Framework 1.1 이상을 대상으로 하는 응용 프로그램만 Windows Vista에서 지원됩니다. 자세한 내용은 버전 호환성.NET Framework의 새로운 기능을 참조하십시오.

참고 항목

개념

Visual Studio 버전 및 하드웨어 요구 사항

사용자 권한과 Visual Studio