Visual Studio를 사용하여 JScript 디버깅

일부 JScript 프로그램은 명령줄에서 실행하도록 설계되어 있고, 일부는 ASP.NET 페이지에서 실행하도록 설계되어 있습니다. 디버깅 방법은 프로그램의 종류에 따라 결정됩니다.

절차

명령줄 프로그램에 대한 디버깅을 설정하려면

  1. /debug 플래그를 사용하여 디버깅할 프로그램을 컴파일합니다. 자세한 내용은 /debug를 참조하십시오.

  2. Microsoft Visual Studio를 시작합니다.

  3. 파일 메뉴에서 열기를 클릭한 다음 프로젝트를 클릭합니다.

  4. 프로젝트 열기 대화 상자에서 컴파일된 프로그램(확장명이 .exe인 파일)을 찾아 선택하고 열기를 클릭합니다.

  5. 파일 메뉴에서 열기를 클릭한 다음 파일을 클릭합니다.

  6. 파일 열기 대화 상자에서 소스 코드(확장명이 .js인 파일)를 찾아 선택하고 열기를 클릭합니다.

  7. 파일 메뉴에서 모두 저장을 클릭합니다.

  8. 새 프로젝트를 저장할 이름과 위치를 선택합니다.

이러한 설정을 마치고 나면 "Visual Studio를 사용하여 디버깅하려면" 섹션의 과정을 진행할 수 있습니다.

ASP.NET 프로그램에 대한 디버깅을 설정하려면

  1. Microsoft Visual Studio를 시작합니다.

  2. 디버깅할 ASP.NET 파일을 엽니다.

  3. **@page** 지시문의 디버그 플래그를 true로 설정합니다. 예를 들면 다음과 같습니다.

    <%@page Language=jscript debug=true %>
    
  4. 브라우저에서 페이지를 열어 페이지를 컴파일합니다.

  5. Visual Studio 도구 메뉴에서 프로세스 디버그를 클릭합니다.

  6. 프로세스 대화 상자에서 시스템 프로세스 표시모든 세션의 프로세스 표시 옵션을 선택합니다.

  7. 프로세스 대화 상자의 사용 가능한 프로세스 창에서 웹 응용 프로그램을 실행하는 ASP.NET 작업자 프로세스를 선택하고 연결을 클릭합니다.

    기본적으로 작업자 프로세스는 IIS 5.x의 aspnet_wp.exe(Windows 2000 및 Windows XP)와 IIS 6.0의 w3wp.exe(Windows Server 2003)입니다.

  8. 프로세스에 연결 대화 상자에서 공용 언어 런타임을 선택하고 확인을 클릭합니다.

  9. 프로세스 대화 상자에서 닫기를 클릭합니다.

이러한 설정을 마치고 나면 "Visual Studio를 사용하여 디버깅하려면" 섹션의 과정을 진행할 수 있습니다.

Visual Studio를 사용하여 디버깅하려면

  1. 위에 설명한 설정 방법대로 Visual Studio IDE에서 디버깅하려는 파일을 엽니다.

  2. 중단점을 설정할 파일의 위치로 커서를 옮긴 다음 F9 키를 누릅니다.

  3. 이전 단계를 반복하여 중단점을 더 추가합니다.

  4. 디버그 메뉴에서 시작을 클릭합니다.

    중단점에 도달하거나 런타임 오류가 발생할 때까지 프로그램이 실행됩니다.

  5. 이 시점에서 다른 디버깅 작업을 수행할 수 있는 몇 개의 창이 열립니다. 자세한 내용은 디버거 로드맵을 참조하십시오.

  6. 디버깅을 중단하되 프로그램은 계속 실행되도록 하려면 디버그 메뉴에서 모두 분리를 선택합니다.

    그렇지 않으면 디버깅을 중지할 때 프로그램이 종료됩니다.

설명

명령줄에서 컴파일된 프로그램을 디버깅할 때 Visual Studio에서는 디버깅을 시작할 때마다 컴파일된 프로그램을 다시 읽습니다. 따라서 JScript 코드를 수정하고 코드를 다시 컴파일한 후 수정한 결과를 확인할 수 있습니다.

참고 항목

작업

Visual Studio를 사용하여 JScript 코드 작성

개념

명령줄에서 빌드

명령줄에서 빌드

공용 언어 런타임 디버거를 사용하여 JScript 디버깅

기타 리소스

디버거 로드맵

웹 응용 프로그램 및 스크립트 디버깅