연습: 사용자 지정 작업 만들기

다음 연습에서는 설치의 끝 부분에서 사용자를 웹 페이지로 안내하는 DLL 사용자 지정 작업을 만드는 과정을 보여 줍니다. 설치가 완료된 후 사용자 지정 작업을 사용하여 코드를 실행할 수 있습니다.

참고

다음 지침처럼 컴퓨터에서 Visual Studio 사용자 인터페이스 요소 일부에 대한 이름이나 위치를 다르게 표시할 수 있습니다. 이러한 요소는 사용하는 Visual Studio 버전 및 설정에 따라 결정됩니다. 자세한 내용은 Visual Studio 설정을 참조하십시오.

사용자 지정 작업을 만들려면

  1. 파일 메뉴에서 새 프로젝트를 클릭합니다.

  2. 새 프로젝트 대화 상자에서 Windows를 선택한 다음 클래스 라이브러리를 클릭합니다. 이름 상자에 OpenWeb을 입력합니다.

    솔루션 탐색기에 프로젝트가 추가됩니다.

  3. 프로젝트 메뉴에서 클래스 추가를 클릭하고 새 항목 추가 대화 상자에서 설치 관리자 클래스를 선택합니다. 기본 이름인 Installer1을 그대로 사용하고 추가를 클릭합니다.

  4. 디자인 화면에서 **여기를 클릭하여 코드 뷰로 전환하십시오.**를 클릭하거나 디자인 화면을 마우스 오른쪽 단추로 클릭하고 코드 보기를 클릭하여 코드 보기로 전환합니다.

  5. 코드 편집기에서 Installer1 코드 파일의 생성자 아래에 웹 브라우저를 여는 다음 코드를 추가합니다.

    <Security.Permissions.SecurityPermission(Security.Permissions.SecurityAction.Demand)>
    Public Overrides Sub Install(ByVal stateSaver As System.Collections.IDictionary)
        MyBase.Install(stateSaver)
    End Sub
    
    <Security.Permissions.SecurityPermission(Security.Permissions.SecurityAction.Demand)>
    Public Overrides Sub Commit(
      ByVal savedState As System.Collections.IDictionary)
    
        MyBase.Commit(savedState)
        System.Diagnostics.Process.Start("http://www.microsoft.com")
    End Sub
    
    <Security.Permissions.SecurityPermission(Security.Permissions.SecurityAction.Demand)>
    Public Overrides Sub Rollback(ByVal savedState As System.Collections.IDictionary)
        MyBase.Rollback(savedState)
    End Sub
    
    <Security.Permissions.SecurityPermission(Security.Permissions.SecurityAction.Demand)>
    Public Overrides Sub Uninstall(ByVal savedState As System.Collections.IDictionary)
        MyBase.Uninstall(savedState)
    End Sub
    
    [System.Security.Permissions.SecurityPermission(System.Security.Permissions.SecurityAction.Demand)]
    public override void Install(IDictionary stateSaver)
    {
        base.Install(stateSaver);
    }
    
    [System.Security.Permissions.SecurityPermission(System.Security.Permissions.SecurityAction.Demand)]
    public override void Commit(IDictionary savedState)
    {
        base.Commit(savedState);
        System.Diagnostics.Process.Start("http://www.microsoft.com");
    }
    
    [System.Security.Permissions.SecurityPermission(System.Security.Permissions.SecurityAction.Demand)]
    public override void Rollback(IDictionary savedState)
    {
        base.Rollback(savedState);
    }
    
    [System.Security.Permissions.SecurityPermission(System.Security.Permissions.SecurityAction.Demand)]
    public override void Uninstall(IDictionary savedState)
    {
        base.Uninstall(savedState);
    }
    

    참고

    Public Overrides를 입력하고 공백을 입력하면 Intellisense에서 메서드 및 속성 목록을 보여 줍니다. 목록에서 Commit을 선택하면 전체 선언이 만들어집니다. Install, Rollback 및 Uninstall 메서드에 대해서도 이 과정을 반복합니다.

  6. 솔루션 탐색기에서 필요 없는 Class1 코드 파일을 마우스 오른쪽 단추로 클릭하고 삭제를 클릭합니다.

배포 프로젝트를 추가하려면

  1. 파일 메뉴에서 추가를 가리킨 다음 새 프로젝트를 클릭합니다.

  2. 새 프로젝트 추가 대화 상자에서 기타 프로젝트 형식 노드와 설치 및 배포 프로젝트를 차례로 확장하고 Visual Studio 설치 관리자를 클릭한 다음 설치 프로젝트를 클릭합니다. 이름 상자에 사용자 지정 작업 설치 관리자를 입력합니다.

    프로젝트가 솔루션 탐색기에 추가되고 파일 시스템 편집기가 표시됩니다.

  3. 파일 시스템 편집기의 왼쪽 창에서 응용 프로그램 폴더를 선택합니다. 작업 메뉴에서 추가를 가리킨 다음 프로젝트 출력을 클릭합니다.

  4. 프로젝트 출력 그룹 추가 대화 상자의 프로젝트 목록에 OpenWeb이 표시됩니다. 기본 출력을 선택합니다.

    **OpenWeb의 기본 출력(활성)**이 응용 프로그램 폴더에 나타납니다.

사용자 지정 작업을 추가하려면

  1. 솔루션 탐색기에서 사용자 지정 작업 설치 관리자 프로젝트를 선택합니다. 보기 메뉴에서 편집기를 가리킨 다음 사용자 지정 작업을 클릭합니다.

    사용자 지정 작업 편집기가 표시됩니다.

  2. 사용자 지정 작업 편집기에서 커밋 노드를 선택합니다. 작업 메뉴에서 사용자 지정 작업 추가를 클릭합니다.

  3. 프로젝트에서 항목 선택 대화 상자에서 응용 프로그램 폴더를 두 번 클릭합니다. OpenWeb의 기본 출력을 선택합니다.

    사용자 지정 작업 편집기커밋 노드 아래에 OpenWeb의 기본 출력이 나타납니다.

  4. 속성 창에서 InstallerClass 속성이 True로 설정되어 있는지 확인합니다. 이 값이 기본값입니다.

  5. 사용자 지정 작업 편집기에서 설치 노드를 선택하고 커밋 노드에서처럼 이 노드에 OpenWeb의 기본 출력을 추가합니다.

  6. 빌드 메뉴에서 사용자 지정 작업 설치 관리자 빌드를 클릭합니다.

개발 컴퓨터에 설치하려면

  • 솔루션 탐색기에서 사용자 지정 작업 설치 관리자 프로젝트를 선택합니다. 프로젝트 메뉴에서 설치를 클릭합니다.

    설치 관리자가 실행되고 개발 컴퓨터에 사용자 지정 작업 설치 관리자가 설치됩니다. 설치가 끝나면 Internet Explorer가 시작되고 Microsoft.com 웹 사이트가 열립니다.

    참고

    설치 관리자를 실행하려면 해당 컴퓨터에 대한 설치 권한이 있어야 합니다.

다른 컴퓨터에 배포하려면

  1. 솔루션 탐색기에서 설치 프로젝트를 마우스 오른쪽 단추로 클릭하고 Windows 탐색기에서 폴더 열기를 클릭합니다.

  2. 프로젝트 출력으로 이동하고 디렉터리에 있는 Custom Action Installer.msi, Setup.exe 및 다른 모든 파일과 하위 디렉터리를 다른 컴퓨터로 복사합니다.

    참고

    네트워크에 연결되어 있지 않은 컴퓨터에 설치하려면 CD-ROM 등의 미디어에 파일을 복사하십시오.

  3. 대상 컴퓨터에서 Setup.exe 파일을 두 번 클릭하여 설치 관리자를 실행합니다.

    설치가 끝나면 Internet Explorer가 시작되고 Microsoft.com 웹 사이트가 열립니다.

    참고

    설치 관리자를 실행하려면 해당 컴퓨터에 대한 설치 권한이 있어야 합니다.

    참고

    .NET Framework가 대상 컴퓨터에 아직 설치되어 있지 않으면 이 배포에서 설치됩니다. 이 설치 작업은 몇 분 정도 걸릴 수 있습니다.

응용 프로그램을 제거하려면

  1. 제어판에서 프로그램 추가/제거를 두 번 클릭합니다.

  2. 프로그램 추가/제거 대화 상자에서 사용자 지정 작업 설치 관리자를 선택하고 제거를 클릭합니다.

    개발 컴퓨터에서 제거하려면 사용자 지정 작업 설치 관리자 프로젝트를 열고 솔루션 탐색기에서 선택한 상태로 프로젝트 메뉴에서 설치 제거를 클릭합니다.

참고 항목

기타 리소스

배포 시 사용자 지정 작업 관리