방법: 사용자 지정 작업 편집기에서 사용자 지정 작업 추가 및 제거

사용자 지정 작업 편집기는 설치 중에 대상 컴퓨터에서 실행할 사용자 지정 작업을 지정하는 데 사용됩니다. .dll 파일, .exe 파일, Microsoft .NET Framework 설치 구성 요소 등 솔루션에 있는 프로젝트 출력에 포함된 사용자 지정 작업을 추가하거나 컴파일된 사용자 지정 작업을 파일 또는 구성 요소로 추가할 수 있습니다.

사용자 지정 작업의 실행 순서를 제어할 수도 있습니다.

참고

표시되는 대화 상자와 메뉴 명령은 활성 설정이나 버전에 따라 도움말에서 설명하는 것과 다를 수 있습니다. 설정을 변경하려면 도구 메뉴에서 설정 가져오기 및 내보내기를 선택합니다. 자세한 내용은 설정에 대한 작업을 참조하십시오.

사용자 지정 작업을 추가하려면

  1. 사용자 지정 작업 편집기에서 폴더를 선택합니다.

  2. 작업 메뉴에서 사용자 지정 작업 추가를 선택합니다.

  3. 프로젝트에서 항목 선택 대화 상자에서 폴더를 선택한 다음 .dll 파일, .exe 파일 또는 사용자 지정 작업을 포함하는 프로젝트 출력을 선택합니다.

    이전에 배포 프로젝트에 항목을 추가하지 않았다면 파일 추가, 출력 추가 또는 어셈블리 추가 단추를 클릭하여 항목을 사용자 지정 작업으로 추가합니다. 이렇게 하면 항목이 프로젝트에도 추가됩니다.

    경고

    파일 추가, 출력 추가 또는 어셈블리 추가 단추를 사용하여 프로젝트에서 항목 선택 대화 상자에 항목을 추가한 다음 대화 상자를 취소해도 배포 프로젝트에 해당 항목이 추가됩니다. 배포 프로젝트에 있는 항목을 삭제하려면 솔루션 탐색기를 통해 제거하면 됩니다.

    사용자 지정 작업을 네 개의 폴더에 모두 추가하려면 편집기에서 사용자 지정 작업 노드를 선택한 다음 사용자 지정 작업 추가를 선택합니다.

실행 순서를 변경하려면

  1. 사용자 지정 작업 편집기에서 사용자 지정 작업을 선택합니다.

  2. 작업 메뉴에서 위로 이동 또는 아래로 이동을 클릭합니다.

    참고

    마우스를 사용하여 끌거나 편집 메뉴의 잘라내기붙여넣기 명령을 통해 사용자 지정 작업의 순서를 변경할 수 있습니다.

사용자 지정 작업을 제거하려면

  • 사용자 지정 작업 편집기에서 사용자 지정 작업을 선택한 다음 편집 메뉴에서 삭제를 선택합니다.

참고 항목

작업

방법: 사용자 지정 작업 편집기에서 미리 정의된 사용자 지정 작업 추가

연습: 사용자 지정 작업 만들기

참조

사용자 지정 작업 편집기의 속성

기타 리소스

배포 시 사용자 지정 작업 관리