.NET Framework 4.6이 설치 된 경우 설치 오류

증상

Microsoft .NET Framework 4.6, 4.6.1 또는 4.6.2가 설치 된 컴퓨터에서 Microsoft SharePoint Foundation 2013 서비스 팩 1 설치 프로그램을 실행 하거나 SharePoint Server 2013 서비스 팩 1 설치 또는 Project Server 2013 서비스 팩 1을 설치 하면 다음 오류 메시지가 표시 됩니다.

다음 오류로 인해 설치를 계속할 수 없습니다 .이 제품에는 Microsoft .Net Framework 4.5이 필요 합니다.

원인

이 문제는 SharePoint 설치 및 Project Server 설치 프로그램에서 .NET Framework 4.6, 4.6.1 또는 4.6.2을 지원 되는 버전의 .NET Framework로 인식 하지 않기 때문에 발생 합니다.

해결 방법

이 문제를 해결 하려면 다음 단계를 수행 합니다.

  1. 쓰기 가능한 위치에 설치 미디어를 추출 합니다.

    • 설치 미디어가 실행 파일 (.exe) 이면 명령 프롬프트에서 다음 명령을 실행 하 여 실행 파일의 파일 및 폴더를 쓰기 가능한 위치로 추출 합니다.

      <executable file name> /extract:<path to writable location>
      

      예를 들어 다음 명령을 실행 합니다.

      sharepoint.exe /extract:C:\SharePointInstaller
      
    • 설치 미디어가 ISO 또는 IMG 디스크 이미지 (.iso 또는 img) 이면 디스크 이미지를 탑재 하 고 디스크 이미지에서 쓰기 가능한 위치에 파일 및 폴더를 복사 합니다.

  2. 설치 하려는 제품과 일치 하는 수정 프로그램이 포함 된 압축 파일 (.zip)을 다운로드 합니다.

  3. .Zip 파일을 엽니다.

  4. 다음 설치 지원 파일을 적절 하 게 복사 하 여 .zip 파일의 쓰기 가능한 위치에 있는 "updates" 폴더에 넣습니다.

    • SharePoint Foundation 2013 서비스 팩 1: wsssetup.dll
    • SharePoint Server 2013 서비스 팩 1: svrsetup.dll
    • Project Server 2013 서비스 팩 1: svrsetup.dll
  5. 쓰기 가능한 위치에서 Setup.exe를 실행 하 여 SharePoint 설치 또는 Project Server 설치 프로그램을 시작 합니다. 설치 프로그램에서 "updates" 폴더에 복사한 수정 내용이 포함 된 지원 파일을 사용 합니다.

해결 방법

"해결 방법" 섹션에 제공 된 fix 메서드를 사용할 수 없는 경우에는 대체 해결 방법을 사용할 수 있습니다.

이 문제를 해결 하려면 SharePoint 설치 프로그램을 실행할 때 .NET Framework 4.6, 4.6.1 또는 4.6.2가 설치 되어 있지 않은지 확인 합니다.

Microsoft .NET Framework 4.6, 4.6.1 또는 4.6.2이 이미 설치 되어 있는 경우 다음 단계를 수행 합니다.

  1. .NET Framework 4.6, 4.6.1 또는 4.6.2을 제거 합니다. 이렇게 하려면 Microsoft 기술 자료의 다음 문서에 나와 있는 것 처럼 운영 체제에 대 한 특정 위치로 이동 합니다.

    • 3151800 Windows 용 .net Framework 4.6.2 오프 라인 설치 관리자
    • 3102436 Windows 용 .net Framework 4.6.1 오프 라인 설치 관리자
    • 3045557 Windows 용 Microsoft .net Framework 4.6 (오프 라인 설치 관리자)

    참고 사항 Windows Server 2012 또는 Windows Server 2012 R2에서 .NET Framework는 운영 체제 구성 요소 이며 독립적으로 제거할 수 없습니다. .NET Framework에 대 한 업데이트는 제어판 프로그램 및 기능 앱의 설치 된 업데이트 탭에 표시 됩니다. .NET Framework가 사전 설치 되지 않은 운영 체제의 경우 .NET Framework는 제어판에서 프로그램 및 기능 앱의 프로그램 제거 또는 변경 (프로그램 추가/제거) 탭에 나타납니다. 자세한 내용은 차단 된 .Net Framework 설치 및 설치 취소 및 이전에 나열 된 Microsoft 기술 자료 문서 문제 해결을 참조 하세요.

  2. 컴퓨터를 다시 시작합니다.

  3. .NET Framework 4.5.2 용 웹 설치 관리자 를 설치 합니다.

  4. Sharepoint 설치 프로그램을 실행 하 여 SharePoint를 설치 합니다.
    SharePoint를 성공적으로 설치한 후에 .net Framework 4.5.2에서 .NET Framework 4.6, 4.6.1 또는 4.6.2로 업그레이드할 수 있습니다.

추가 정보

설치 중에 오류 메시지가 표시 되기는 하지만 .NET Framework 4.6, .NET Framework 4.6.1 또는 .NET Framework 4.6.2으로 업그레이드 한 후에는 SharePoint Foundation 2013 및 SharePoint Server 2013가 계속 지원 됩니다.

참고 사항 .NET Framework 4.5.1, 4.5 및 4.0에 대 한 공식적인 지원은 2016 년 1 월에 종료 되었습니다.

상태

Microsoft는 "적용 대상" 섹션에 나와 있는 Microsoft 제품에서이 문제를 확인 했습니다.

아직 해결되지 않았습니까? SharePoint 커뮤니티로 이동 합니다.