SharePoint Online 및 OneDrive에서 "액세스 거부" 또는 "권한이 필요합니다" 오류

증상

사용자가 SharePoint Online 또는 비즈니스용 OneDrive 사이트에 액세스하려고 하면 다음 오류 메시지 중 하나가 나타납니다.

  • 액세스 거부
  • 이 사이트에 액세스할 수 있는 사용 권한이 필요합니다
  • 디렉터리에서 사용자를 찾을 수 없습니다

사용자가 SharePoint Online 또는 OneDrive 사이트에서 다른 사용자가 공유하는 파일 또는 폴더의 링크에 액세스하려고 하면 다음과 같은 오류 메시지가 표시됩니다.

이 링크를 사용할 수 없습니다.
죄송합니다. 현재 로그인되어 있지만 해당 계정이 보안이 설정된 사용자 목록에 없습니다. 다른 이메일을 시도하려면 로그아웃하고 링크를 다시 여십시오.

원인

이러한 오류는 다음과 같은 다양한 이유로 발생할 수 있습니다.

  • 영향을 받는 사용자에 권한이 올바르게 구성되지 않았습니다.
  • 공유 링크에 액세스하는 데 사용되는 계정은 공유 초대를 보낸 계정과 다릅니다.
  • 사이트 사용자 ID가 일치하지 않습니다. ID 불일치는 일반적으로 사용자 계정이 Microsoft 365 관리 센터에서 삭제된 후 삭제된 계정에서 사용한 UPN(사용자 계정 이름)을 사용하여 새 계정을 만드는 경우에 발생합니다. UPN이 동일하더라도 새 계정에 새 ID 값이 할당됩니다. 사용자가 이미 SharePoint에 로그인되어 있고 후 나중에 다른 OU(조직 구성 단위)로 이동한 경우, Active Directory OU와 SharePoint 간의 디렉터리 동기화 중에도 불일치가 발생할 수 있습니다.

해결 옵션 1: 사용자 액세스 진단 확인 실행

참고

이 진단은 GCC High 또는 DoD 환경 또는 21Vianet에서 운영하는 Microsoft 365에서 사용할 수 없습니다.

Microsoft 365 관리자는 테넌트 내에서 진단을 실행하여 사용자 액세스에 영향을 줄 수 있는 문제를 파악할 수 있습니다.

다음 테스트 실행 단추를 선택하여 Microsoft 365 관리 센터에서 진단을 채웁니다.

진단은 SharePoint 및 OneDrive 사이트에 액세스하려는 내부 사용자 및 게스트에 대해 광범위한 검증을 수행합니다.

해결 방법 2: 수동 수정

액세스 문제를 수동으로 해결하려면 관련 시나리오의 단계를 수행합니다.

사용자가 SharePoint 사이트 또는 다른 사용자의 OneDrive 사이트에 액세스할 수 없습니다.

  1. 사이트에 대한 사용자의 사용 권한 수준을 결정합니다.

  2. 사용 권한 확인 기능을 사용하여 사용 권한을 확인합니다.

    1. SharePoint 사이트의 경우 설정>사이트 사용 권한을 선택합니다. OneDrive 사이트의 경우 설정>사이트 설정>사이트 사용 권한을 선택합니다.
    2. 리본에서 사용 권한 확인을 선택합니다.
    3. 사용자/그룹 필드에서 사용자 이름을 입력한 다음 지금 확인을 선택합니다.
    4. 사용자가 사이트에 대해 가지고 있는 권한을 확인하고 관련 보안 그룹도 확인합니다(해당하는 경우).
  3. 사용자에게 적절한 사용 권한이 없는 경우 파일 또는 사이트에 대한 사용 권한을 사용자에게 부여합니다.

  4. 사용자가 계속 오류 메시지를 받으면 사이트에서 사용자를 제거합니다. 그런 다음 사용자에게 파일 또는 사이트에 대한 사용 권한을 부여합니다.

    참고: 오류가 게스트 계정에 계속 영향을 주는 경우 Microsoft 365 관리 센터에서 게스트 계정을 완전히 제거하는 것이 좋습니다. 사용자가 사이트 모음에서 제거되어 있는지 확인합니다. 그런 다음 사용자에게 파일 또는 사이트에 대한 사용 권한을 부여합니다.

사용자가 자신의 OneDrive 사이트에 액세스할 수 없습니다.

이 문제는 일반적으로 사이트 사용자 ID 불일치로 인해 발생합니다.

이 문제를 해결하려면 새 UPN이 있는지 확인합니다. 있다면 새 UPN을 삭제하고원래 UPN을 복원합니다.

이 절차를 사용하는 데 익숙하지 않은 경우 SharePoint 또는 OneDrive에서 사이트 사용자 ID 불일치 해결에서 문제를 해결하는 자동화된 솔루션을 참조합니다.

영향을 받는 사용자를 사이트에서 제거하고 파일 또는 폴더를 다시 공유합니다.