SQL Server Management Studio의 Analysis Services 스크립트 프로젝트Analysis Services Scripts Project in SQL Server Management Studio

Analysis ServicesAnalysis Services에서 SQL Server Management StudioSQL Server Management Studio 에 분석 서버 스크립트 프로젝트를 만들어 개발, 관리 및 원본 제어를 위해 관련 스크립트를 그룹화할 수 있습니다.In Analysis ServicesAnalysis Services, you can create an Analysis Server Scripts project in SQL Server Management StudioSQL Server Management Studio to group related scripts together for development, management, and source control purposes. 현재 SQL Server Management StudioSQL Server Management Studio에 솔루션이 로드되어 있지 않은 경우 새 분석 서버 스크립트 프로젝트를 만들면 자동으로 새 솔루션이 생성됩니다.If no solution is currently loaded in SQL Server Management StudioSQL Server Management Studio, creating a new Analysis Server Scripts project automatically creates a new solution. 그렇지 않은 경우 새 분석 서버 스크립트 프로젝트를 기존 솔루션에 추가하거나 새 솔루션에 만들 수 있습니다.Otherwise, the new Analysis Server Scripts project can be added to the existing solution or created in a new solution.

다음 기본 단계를 수행하여 SQL Server Management StudioSQL Server Management Studio에서 분석 서버 스크립트 프로젝트를 만들 수 있습니다.You use the following basic steps to create an Analysis Server Scripts project in SQL Server Management StudioSQL Server Management Studio:

  1. 파일 메뉴에서 새로 만들기를 가리킨 다음 프로젝트를 클릭합니다.On the File menu, point to New, and then click Project.

    분석 서버 스크립트 프로젝트 템플릿을 선택한 다음 새 프로젝트의 이름과 위치를 지정합니다.Select Analysis Server Scripts project template and then specify a name and location for the new project.

  2. 연결 을 마우스 오른쪽 단추로 클릭하여 솔루션 탐색기에 있는 Analysis Server 스크립트 프로젝트의 연결 폴더에 새 연결을 만듭니다.Right-click Connections to create a new connection in the Connections folder of the Analysis Server Scripts project in Solution Explorer.

    이 폴더는 Analysis ServicesAnalysis Services 인스턴스에 대한 연결 문자열을 포함하며 분석 서버 스크립트 프로젝트에 포함된 스크립트를 이에 대해 실행할 수 있습니다.This folder contains connection strings to Analysis ServicesAnalysis Services instances, against which the scripts contained by the Analysis Server Scripts project can be executed. 하나의 분석 서버 스크립트 프로젝트에 대해 여러 연결을 설정할 수 있으며 이러한 연결 중 프로젝트에 포함된 스크립트를 실행할 연결을 실행 시 선택할 수 있습니다.You can have multiple connections in an Analysis Server Scripts project, and you can choose a connection against which to run a script contained by the project at the time of execution.

  3. 쿼리 를 마우스 오른쪽 단추로 클릭하여 솔루션 탐색기에 있는 Analysis Server 스크립트 프로젝트의 스크립트 폴더에 MDX(Multidimensional Expressions), DMX(Data Mining Extensions) 및 XMLA(XML for Analysis) 스크립트를 만듭니다.Right-click Queries to create Multidimensional Expressions (MDX), Data Mining Extensions (DMX), and XML for Analysis (XMLA) scripts in the Scripts folder of the Analysis Server Scripts project in Solution Explorer.

  4. 프로젝트를 마우스 오른쪽 단추로 클릭하고 추가를 가리킨 다음 기존 항목 을 선택하여 프로젝트에 대한 메모를 포함하는 텍스트 파일과 같은 기타 파일을 솔루션 탐색기에 있는 Analysis Server 스크립트 프로젝트의 기타 폴더에 추가합니다.Right-click on the project, point to Add, and then select Existing Item to add miscellaneous files, such as text files that contain notes on the project, in the Miscellaneous folder of the Analysis Server Scripts project in Solution Explorer. 이러한 파일은 SQL Server Management StudioSQL Server Management Studio에서 무시됩니다.These files are ignored by SQL Server Management StudioSQL Server Management Studio.

파일 유형File Types

SQL Server Management StudioSQL Server Management Studio 솔루션은 솔루션에 포함시킨 프로젝트에 따라 그리고 해당 솔루션의 각 프로젝트에 포함시킨 항목에 따라 여러 파일 형식을 포함할 수 있습니다.A SQL Server Management StudioSQL Server Management Studio solution can contain several file types, depending on what projects you included in the solution and what items you included in each project for that solution. SQL Server Management StudioSQL Server Management Studio의 솔루션 파일 유형에 대한 자세한 내용은 솔루션 및 프로젝트 관리 파일을 참조하세요.For more information about file types for solutions in SQL Server Management StudioSQL Server Management Studio, see Files That Manage Solutions and Projects. 일반적으로 SQL Server Management StudioSQL Server Management Studio 솔루션의 각 프로젝트에 대한 파일은 솔루션 폴더에 저장되며 각 프로젝트에 대해 별도의 폴더에 저장됩니다.Typically, the files for each project in a SQL Server Management StudioSQL Server Management Studio solution are stored in the solution folder, in a separate folder for each project.

분석 서버 스크립트 프로젝트에 대한 프로젝트 폴더는 다음 표에 나열된 파일 유형을 포함할 수 있습니다.The project folder for an Analysis Server Scripts project can contain the file types listed in the following table.

파일 유형File type DescriptionDescription
분석 서버 스크립트 프로젝트 정의 파일(.ssmsasproj)Analysis Server Scripts project definition file (.ssmsasproj) 프로젝트에 포함된 파일을 표시할 폴더를 나타내는 정보를 비롯하여 솔루션 탐색기에 표시되는 폴더에 대한 메타데이터를 포함합니다.Contains metadata about the folders shown in Solution Explorer, as well as information that indicates which folders should display files included in the project.

또한 프로젝트 정의 파일은 연결을 프로젝트에 포함된 스크립트 파일과 연결하는 메타데이터를 비롯하여 프로젝트에 포함된 Analysis ServicesAnalysis Services 연결에 대한 메타데이터를 포함합니다.The project definition file also contains the metadata for Analysis ServicesAnalysis Services connections contained in the project, as well as metadata that associates connections with script files included in the project.
DMX 스크립트 파일(.dmx)DMX script file (.dmx) 프로젝트에 포함된 DMX 스크립트를 포함합니다.Contains a DMX script included in the project.
MDX 스크립트 파일(.mdx)MDX script file (.mdx) 프로젝트에 포함된 MDX 스크립트를 포함합니다.Contains an MDX script included in the project.
XMLA 스크립트 파일(.xmla)XMLA script file (.xmla) 프로젝트에 포함된 XMLA 스크립트를 포함합니다.Contains an XMLA script included in the project.

Analysis Services 템플릿Analysis Services Templates

새 MDX, DMX 또는 XMLA 스크립트를 분석 서버 스크립트 프로젝트에 추가하는 경우 템플릿 탐색기를 사용하여 Analysis ServicesAnalysis Services 템플릿을 찾을 수 있습니다. 이러한 템플릿은 지정한 동작을 수행하는 방법을 보여 주는 미리 정의된 스크립트 또는 문의 모음입니다.When adding new MDX, DMX, or XMLA scripts to an Analysis Server Scripts project, you have the option of using Template Explorer to locate Analysis ServicesAnalysis Services templates, which are a collection of predefined scripts or statements that demonstrate how to perform a specified action. 템플릿 탐색기는 보기 메뉴에서 사용할 수 있으며 SQL ServerSQL Server, Analysis ServicesAnalysis ServicesSQL Server CompactSQL Server Compact에 대한 템플릿을 포함합니다.Template Explorer is available on the View menu and includes templates for SQL ServerSQL Server, Analysis ServicesAnalysis Services, and SQL Server CompactSQL Server Compact. 자세한 내용은 Use Analysis Services Templates in SQL Server Management Studio을 참조하세요.For more information, see Use Analysis Services Templates in SQL Server Management Studio.

관련 항목:See Also

SSDT(SQL Server Data Tools)를 사용하여 다차원 모델 만들기 Creating Multidimensional Models Using SQL Server Data Tools (SSDT)
MDX(Multidimensional Expression) 참조 Multidimensional Expressions (MDX) Reference
DMX(Data Mining Extensions) 참조 Data Mining Extensions (DMX) Reference
Analysis Services Scripting Language(XMLA용 ASSL) Analysis Services Scripting Language (ASSL for XMLA)
스크립팅 언어 ( analysis Services ASSL XMLA )Analysis Services Scripting Language (ASSL for XMLA)