단원 3-2-Customer 차원 수정Lesson 3-2 - Modifying the Customer Dimension

적용 대상:예SQL Server Analysis Services아니요Azure Analysis ServicesAPPLIES TO:yesSQL Server Analysis ServicesnoAzure Analysis Services

다양한 방법을 통해 큐브에서 차원의 유용성과 기능을 향상시킬 수 있습니다.There are many different ways that you can increase the usability and functionality of the dimensions in a cube. 이 항목의 태스크에서는 Customer 차원을 수정합니다.In the tasks in this topic, you modify the Customer dimension.

특성 이름 바꾸기Renaming Attributes

차원 디자이너의 차원 구조 탭을 사용하여 특성 이름을 바꿀 수 있습니다.You can change attribute names with the Dimension Structure tab of Dimension Designer.

특성 이름을 바꾸려면To rename an attribute

  1. 에서 Customer 차원에 대한 차원 디자이너 SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)로 전환합니다.Switch to Dimension Designer for the Customer dimension in SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT). 이렇게 하려면 솔루션 탐색기의 차원 노드에서 Customer 차원을 두 번 클릭합니다.To do this, double-click the Customer dimension in the Dimensions node of Solution Explorer.

  2. 특성 창에서 English Country Region Name을 마우스 오른쪽 단추로 클릭하고 이름 바꾸기를 클릭합니다.In the Attributes pane, right-click English Country Region Name, and then click Rename. 특성 이름을 Country-Region으로 변경합니다.Change the name of the attribute to Country-Region.

  3. 같은 방법으로 다음 특성 이름을 변경합니다.Change the names of the following attributes in the same manner:

    • English Education 특성을 EducationEnglish Education attribute — change to Education

    • English Occupation 특성을 OccupationEnglish Occupation attribute — change to Occupation

    • State Province Name 특성을 State-ProvinceState Province Name attribute — change to State-Province

  4. 파일 메뉴에서 모두 저장을 클릭합니다.On the File menu, click Save All.

계층 만들기Creating a Hierarchy

특성 창에서 계층 창으로 특성을 끌어 새 계층을 만들 수 있습니다.You can create a new hierarchy by dragging an attribute from the Attributes pane to the Hierarchies pane.

계층을 만들려면To create a hierarchy

  1. 특성 창의 Country-Region 특성을 계층 창으로 끌어옵니다.Drag the Country-Region attribute from the Attributes pane into the Hierarchies pane.

  2. 특성 창의 State-Province 특성을 계층 창의 Country-Region 수준 아래 셀에 끌어옵니다.Drag the State-Province attribute from the Attributes pane into the cell in the Hierarchies pane, underneath the Country-Region level.

  3. 특성 창의 City 특성을 계층 창의 State-Province 수준 아래 셀에 끌어옵니다.Drag the City attribute from the Attributes pane into the cell in the Hierarchies pane, underneath the State-Province level.

  4. 차원 구조 탭의 계층 창에서 Hierarchy 계층의 제목 표시줄을 마우스 오른쪽 단추로 클릭하고 이름 바꾸기를 선택한 다음 Customer Geography를 입력합니다.In the Hierarchies pane of the Dimension Structure tab, right-click the title bar of the Hierarchy hierarchy, select Rename, and then type Customer Geography.

    이제 계층 이름이 Customer Geography가 됩니다.The name of the hierarchy is now Customer Geography.

  5. 파일 메뉴에서 모두 저장을 클릭합니다.On the File menu, click Save All.

명명된 계산 추가Adding a Named Calculation

계산 열로 표시되는 SQL 식인 명명된 계산을 데이터 원본 뷰의 테이블에 추가할 수 있습니다.You can add a named calculation, which is a SQL expression that is represented as a calculated column, to a table in a data source view. 이 식은 테이블의 열로 나타나고 동작합니다.The expression appears and behaves as a column in the table. 명명된 계산을 사용하면 기본 데이터 원본의 테이블을 수정하지 않고 데이터 원본 뷰에서 기존 테이블의 관계형 스키마를 확장할 수 있습니다.Named calculations let you extend the relational schema of existing tables in a data source view without modifying the table in the underlying data source. 자세한 내용은 데이터 원본 뷰에서 명명된 계산 정의(Analysis Services)For more information, see Define Named Calculations in a Data Source View (Analysis Services)

명명된 계산을 추가하려면To add a named calculation

  1. 솔루션 탐색기의 Adventure WorksAdventure Works 데이터 원본 뷰 폴더에서 DW 2012 데이터 원본 뷰를 두 번 클릭하여 엽니다.Open the Adventure WorksAdventure Works DW 2012 data source view by double-clicking it in the Data Source Views folder in Solution Explorer.

  2. 왼쪽의 테이블 창에서 Customer를 마우스 오른쪽 단추로 클릭한 다음 새 명명된 계산을 클릭합니다.In the Tables pane on the left, right-click Customer, and then click New Named Calculation.

  3. 명명된 계산 만들기 대화 상자에서 열 이름 상자에 FullName 를 입력하고 상자에 다음 CASE 문을 입력하거나 복사하여 붙여넣습니다.In the Create Named Calculation dialog box, type FullName in the Column name box, and then type or copy and paste the following CASE statement in the Expression box:

    CASE  
       WHEN MiddleName IS NULL THEN  
       FirstName + ' ' + LastName  
       ELSE  
       FirstName + ' ' + MiddleName + ' ' + LastName  
    END  
    

    CASE 문은 FirstName, MiddleNameLastName 열을 Customer 차원에서 Customer 특성의 표시 이름으로 사용할 단일 열로 연결합니다.The CASE statement concatenates the FirstName, MiddleName, and LastName columns into a single column that you will use in the Customer dimension as the displayed name for the Customer attribute.

  4. 확인을 클릭한 다음 테이블 창에서 Customer 를 확장합니다.Click OK, and then expand Customer in the Tables pane.

    명명된 계산임을 나타내는 아이콘과 함께 FullName 명명된 계산이 Customer 테이블의 열 목록에 나타납니다.The FullName named calculation appears in the list of columns in the Customer table, with an icon that indicates that it is a named calculation.

  5. 파일 메뉴에서 모두 저장을 클릭합니다.On the File menu, click Save All.

  6. 테이블 창에서 Customer를 마우스 오른쪽 단추로 클릭하고 데이터 탐색을 클릭합니다.In the Tables pane, right-click Customer, and then click Explore Data.

  7. Customer 테이블 탐색 뷰의 마지막 열을 검토합니다.Review the last column in the Explore Customer Table view.

    원래 데이터 원본을 수정하지 않고 기본 데이터 원본에서 여러 열의 데이터를 올바르게 연결한 FullName 열이 데이터 원본 뷰에 나타납니다.Notice that the FullName column appears in the data source view, correctly concatenating data from several columns from the underlying data source and without modifying the original data source.

  8. Customer 테이블 탐색 탭을 닫습니다.Close the Explore Customer Table tab.

멤버 이름에 명명된 계산 사용Using the Named Calculation for Member Names

데이터 원본 뷰에서 명명된 계산을 만든 후에는 이 명명된 계산을 특성의 속성으로 사용할 수 있습니다.After you have created a named calculation in the data source view, you can use the named calculation as a property of an attribute.

멤버 이름에 명명된 계산을 사용하려면To use the named calculation for member names

  1. Customer 차원에 대한 차원 디자이너로 전환합니다.Switch to Dimension Designer for the Customer dimension.

  2. 차원 구조 탭의 특성 창에서 Customer Key 특성을 클릭합니다.In the Attributes pane of the Dimension Structure tab, click the Customer Key attribute.

  3. 속성 창을 열고 제목 표시줄의 자동 숨기기 단추를 클릭하여 열린 상태를 유지하도록 합니다.Open the Properties window and click the Auto Hide button on the title bar so that it stays open.

  4. Name 속성 필드에 Full Name을 입력합니다.In the Name property field, type Full Name.

  5. 아래쪽의 NameColumn 속성 필드를 클릭한 다음 찾아보기() 단추를 클릭하여 이름 열 대화 상자를 엽니다.Click in the NameColumn property field at the bottom, and then click the browse () button to open the Name Column dialog box.

  6. 원본 열 목록의 맨 아래에서 FullName 을 선택하고 확인을 클릭합니다.Select FullName at the bottom of the Source column list, and then click OK.

  7. 차원 구조 탭에서 특성 창의 Full Name 특성을 계층 창의 City 수준 아래 셀에 끌어옵니다.In the Dimensions Structure tab, drag the Full Name attribute from the Attributes pane into the cell in the Hierarchies pane, underneath the City level.

  8. 파일 메뉴에서 모두 저장을 클릭합니다.On the File menu, click Save All.

표시 폴더 정의Defining Display Folders

사용자가 좀 더 쉽게 사용할 수 있도록 표시 폴더를 사용하여 사용자와 특성 계층을 폴더 구조로 그룹화할 수 있습니다.You can use display folders to group user and attribute hierarchies into folder structures to increase usability.

표시 폴더를 정의하려면To define display folders

  1. Customer 차원에 대한 차원 구조 탭을 엽니다.Open the Dimension Structure tab for the Customer dimension.

  2. 특성 창에서 Ctrl 키를 누른 채 각 항목을 클릭하여 다음 특성을 선택합니다.In the Attributes pane, select the following attributes by holding down the CTRL key while clicking each of them:

    • 특성City

    • Country-RegionCountry-Region

    • 우편 번호Postal Code

    • State-ProvinceState-Province

  3. 속성 창의 맨 위에서 AttributeHierarchyDisplayFolder 속성 필드를 클릭하고 Location을 입력합니다. 속성 필드에 전체 이름을 표시하려면 필드를 가리켜야 할 수도 있습니다.In the Properties window, click the AttributeHierarchyDisplayFolder property field at the top (you might need to point to it to see the full name), and then type Location.

  4. 계층 창에서 Customer Geography를 클릭한 다음 오른쪽의 속성 창에서 DisplayFolder 속성 값으로 Location 을 선택합니다.In the Hierarchies pane, click Customer Geography, and then in the Properties window on the right, select Location as the value of the DisplayFolder property.

  5. 특성 창에서 Ctrl 키를 누른 채 각 항목을 클릭하여 다음 특성을 선택합니다.In the Attributes pane, select the following attributes by holding down the CTRL key while clicking each of them:

    • Commute DistanceCommute Distance

    • EducationEducation

    • GenderGender

    • House Owner FlagHouse Owner Flag

    • Marital StatusMarital Status

    • Number Cars OwnedNumber Cars Owned

    • Number Children At HomeNumber Children At Home

    • OccupationOccupation

    • Total ChildrenTotal Children

    • Yearly IncomeYearly Income

  6. 속성 창의 맨 위에서 AttributeHierarchyDisplayFolder 속성 필드를 클릭하고 Demographic을 입력합니다.In the Properties window, click the AttributeHierarchyDisplayFolder property field at the top, and then type Demographic.

  7. 특성 창에서 Ctrl 키를 누른 채 각 항목을 클릭하여 다음 특성을 선택합니다.In the Attributes pane, select the following attributes by holding down the CTRL key while clicking each of them:

    • Email AddressEmail Address

    • 전화Phone

  8. 속성 창에서 AttributeHierarchyDisplayFolder 속성 필드를 클릭하고 Contacts를 입력합니다.In the Properties window, click the AttributeHierarchyDisplayFolder property field and type Contacts.

  9. 파일 메뉴에서 모두 저장을 클릭합니다.On the File menu, click Save All.

복합 KeyColumns 정의Defining Composite KeyColumns

KeyColumns 속성에는 특성의 키를 나타내는 열이 포함됩니다.The KeyColumns property contains the column or columns that represent the key for the attribute. 이 단원에서는 CityState-Province 특성에 대한 복합 키를 만듭니다.In this lesson, you create a composite key for the City and State-Province attributes. 복합 키는 특성을 고유하게 식별해야 하는 경우 도움이 됩니다.Composite keys can be helpful when you need to uniquely identify an attribute. 예를 들어 이 자습서의 뒷부분에서 특성 관계를 정의할 때 City 특성은 State-Province 특성을 고유하게 식별해야 합니다.For example, when you define attribute relationships later in this tutorial, a City attribute must uniquely identify a State-Province attribute. 그런데 서로 다른 시/도에 같은 이름의 도시가 여러 개 있을 수 있습니다.However, there could be several cities with the same name in different states. 이러한 이유로 City 특성에 대해 StateProvinceNameCity 열로 구성된 복합 키를 만드는 것입니다.For this reason, you will create a composite key that is composed of the StateProvinceName and City columns for the City attribute. 자세한 내용은 특성의 KeyColumn 속성 수정을 참조하세요.For more information, see Modify the KeyColumn Property of an Attribute.

City 특성에 대한 복합 KeyColumns를 정의하려면To define composite KeyColumns for the City attribute

  1. Customer 차원에 대한 차원 구조 탭을 엽니다.Open the Dimension Structure tab for the Customer dimension.

  2. 특성 창에서 City 특성을 클릭합니다.In the Attributes pane, click the City attribute.

  3. 속성 창의 아래쪽에서 KeyColumns 필드를 클릭한 다음 찾아보기 단추(...)를 클릭합니다.In the Properties window, click in the KeyColumns field near the bottom, and then click the browse (...) button.

  4. 키 열 대화 상자의 사용 가능한 열 목록에서 StateProvinceName열을 선택한 후 > 단추를 클릭합니다.In the Key Columns dialog box, in the Available Columns list, select the column StateProvinceName, and then click the > button.

    이제 CityStateProvinceName 열이 키 열 목록에 표시됩니다.The City and StateProvinceName columns are now displayed in the Key Columns list.

  5. 확인을 클릭합니다.Click OK.

  6. City 특성의 NameColumn 속성을 설정하려면 속성 창에서 NameColumn 필드를 클릭한 다음 찾아보기 단추(...)를 클릭합니다.To set the NameColumn property of the City attribute, click the NameColumn field in the Properties window, and then click the browse (...) button.

  7. 이름 열 대화 상자의 원본 열 목록에서 City를 선택한 후 확인을 클릭합니다.In the Name Column dialog box, in the Source column list, select City, and then click OK.

  8. 파일 메뉴에서 모두 저장을 클릭합니다.On the File menu, click Save All.

State-Province 특성에 대한 복합 KeyColumns를 정의하려면To define composite KeyColumns for the State-Province attribute

  1. Customer 차원에 대한 차원 구조 탭을 엽니다.Make sure the Dimension Structure tab for the Customer dimension is open.

  2. 특성 창에서 State-Province 특성을 클릭합니다.In the Attributes pane, click the State-Province attribute.

  3. 속성 창에서 KeyColumns 필드를 클릭한 후 찾아보기 단추(...)를 클릭합니다.In the Properties window, click in the KeyColumns field, and then click the browse (...) button.

  4. 키 열 대화 상자의 사용 가능한 열 목록에서 EnglishCountryRegionName열을 선택한 후 > 단추를 클릭합니다.In the Key Columns dialog box, in the Available Columns list, select the column EnglishCountryRegionName, and then click the > button.

    이제 EnglishCountryRegionNameStateProvinceName 열이 키 열 목록에 표시됩니다.The EnglishCountryRegionName and StateProvinceName columns are now displayed in the Key Columns list.

  5. 확인을 클릭합니다.Click OK.

  6. State-Province 특성의 NameColumn 속성을 설정하려면 속성 창에서 NameColumn 필드를 클릭한 후 찾아보기 단추(...)를 클릭합니다.To set the NameColumn property of the State-Province attribute, click the NameColumn field in the Properties window, and then click the browse (...) button.

  7. 이름 열 대화 상자의 원본 열 목록에서 StateProvinceName을 선택한 후 확인을 클릭합니다.In the Name Column dialog box, in the Source column list, select StateProvinceName, and then click OK.

  8. 파일 메뉴에서 모두 저장을 클릭합니다.On the File menu, click Save All.

특성 관계 정의Defining Attribute Relationships

기본 데이터가 특성 관계를 지원하는 경우 특성 간의 특성 관계를 정의해야 합니다.If the underlying data supports it, you should define attribute relationships between attributes. 특성 관계를 정의하면 차원, 파티션 및 쿼리 처리가 빨라집니다.Defining attribute relationships speeds up dimension, partition, and query processing. 자세한 내용은 특성 관계 정의특성 관계를 참조하세요.For more information, see Define Attribute Relationships and Attribute Relationships.

특성 관계를 정의하려면To define attribute relationships

  1. Customer 차원의 차원 디자이너 에서 특성 관계 탭을 클릭합니다. 기다려야 할 수도 있습니다.In the Dimension Designer for the Customer dimension, click the Attribute Relationships tab. You might need to wait.

  2. 다이어그램에서 City 특성을 마우스 오른쪽 단추로 클릭한 다음 새 특성 관계를 클릭합니다.In the diagram, right-click the City attribute, and then click New Attribute Relationship.

  3. 특성 관계 만들기 대화 상자에서 원본 특성City입니다.In the Create Attribute Relationship dialog box, the Source Attribute is City. 관련 특성State-Province로 설정합니다.Set the Related Attribute to State-Province.

  4. 관계 유형 목록에서 관계 유형을 고정으로 설정합니다.In the Relationship type list, set the relationship type to Rigid.

    멤버 간의 관계는 시간이 지나도 변경되지 않으므로 관계 유형은 고정입니다.The relationship type is Rigid because relationships between the members will not change over time. 예를 들어 도시가 다른 시/도 소속으로 변경될 가능성은 거의 없습니다.For example, it would be unusual for a city to become part of a different state or province.

  5. 확인을 클릭합니다.Click OK.

  6. 다이어그램에서 State-Province 특성을 마우스 오른쪽 단추로 클릭한 다음 새 특성 관계를 선택합니다.In the diagram, right-click the State-Province attribute and then select New Attribute Relationship.

  7. 특성 관계 만들기 대화 상자에서 원본 특성State-Province입니다.In the Create Attribute Relationship dialog box, the Source Attribute is State-Province. 관련 특성Country-Region으로 설정합니다.Set the Related Attribute to Country-Region.

  8. 관계 유형 목록에서 관계 유형을 고정으로 설정합니다.In the Relationship type list, set the relationship type to Rigid.

  9. 확인을 클릭합니다.Click OK.

  10. 파일 메뉴에서 모두 저장을 클릭합니다.On the File menu, click Save All.

변경 내용 배포, 개체 처리 및 변경 내용 표시Deploying Changes, Processing the Objects, and Viewing the Changes

특성과 계층을 변경한 후에 변경 내용을 표시하려면 먼저 변경 내용을 배포하고 관련 개체를 다시 처리해야 합니다.After you have changed attributes and hierarchies, you must deploy the changes and reprocess the related objects before you can view the changes.

변경 내용을 배포하고 개체를 처리한 다음 변경 내용을 표시하려면To deploy the changes, process the objects, and view the changes

  1. 빌드 SQL Server Data ToolsSQL Server Data Tools메뉴에서 Analysis Services Tutorial 배포를 클릭합니다.On the Build menu of SQL Server Data ToolsSQL Server Data Tools, click Deploy Analysis Services Tutorial.

  2. 배포가 완료되었습니다. 메시지를 받은 후 Customer 차원에 대한 차원 디자이너의 브라우저 탭을 클릭한 다음 디자이너 도구 모음의 왼쪽에 있는 다시 연결 단추를 클릭합니다.After you receive the Deployment Completed Successfully message, click the Browser tab of Dimension Designer for the Customer dimension, and then click the Reconnect button on the left side of the toolbar of the designer.

  3. 계층 목록에 Customer Geography 가 선택되어 있는지 확인한 다음 브라우저 창에서 All, Australia, New South Wales, Coffs Harbour를 차례로 확장합니다.Verify that Customer Geography is selected in the Hierarchy list, and then in the browser pane, expand All, expand Australia, expand New South Wales, and then expand Coffs Harbour.

    브라우저에 해당 도시의 고객이 표시됩니다.The browser displays the customers in the city.

  4. Tutorial 큐브에 대한 큐브 디자이너 Analysis ServicesAnalysis Services 로 전환합니다.Switch to Cube Designer for the Analysis ServicesAnalysis Services Tutorial cube. 이렇게 하려면 솔루션 탐색기큐브 노드에서 Analysis Services Tutorial큐브를 두 번 클릭합니다.To do this, double-click the Analysis Services Tutorial cube in the Cubes node of Solution Explorer.

  5. 브라우저 탭을 클릭한 다음 디자이너 도구 모음에서 다시 연결 단추를 클릭합니다.Click the Browser tab, and then click the Reconnect button on the toolbar of the designer.

  6. 측정값 그룹 창에서 Customer를 확장합니다.In the Measure Group pane, expand Customer.

    긴 특성 목록이 아니라 표시 폴더와 표시 폴더 값이 포함되지 않은 특성만 Customer 아래에 나타납니다.Notice that instead of a long list of attributes, only the display folders and the attributes that do not have display folder values appear underneath Customer.

  7. 파일 메뉴에서 모두 저장을 클릭합니다.On the File menu, click Save All.

단원의 다음 태스크Next Task in Lesson

Product 차원 수정Modifying the Product Dimension

관련 항목:See Also

차원 특성 속성 참조Dimension Attribute Properties Reference
차원에서 특성 제거Remove an Attribute from a Dimension
특성 이름 변경Rename an Attribute
데이터 원본 뷰에서 명명된 계산 정의(Analysis Services)Define Named Calculations in a Data Source View (Analysis Services)