테이블 형식 모델 디자이너(SSAS)Tabular Model Designer (SSAS)

테이블 형식 모델 디자이너는 SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)의 일부로 Microsoft Visual StudioVisual Studio에 통합되어 있으며, 전문적인 테이블 형식의 모델 솔루션을 개발하기 위한 추가 프로젝트 형식 템플릿이 함께 제공됩니다.The tabular model designer is part of SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT), integrated with Microsoft Visual StudioVisual Studio, with additional project type templates specifically for developing professional tabular model solutions. SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT) 는 무료 웹 다운로드로 설치됩니다. is installed as a free web download. 자세한 내용은 SSDT(SQL Server Data Tools) 다운로드를 참조하세요.See Download SQL Server Data Tools (SSDT) for details.

이점 Benefits

SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)를 설치하면 테이블 형식의 모델을 만들기 위한 새 프로젝트 템플릿이 사용 가능한 프로젝트 형식에 추가됩니다.When you install SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT), new project templates for creating tabular models are added to the available project types. 이 템플릿 중 하나를 사용하여 테이블 형식의 새 모델 프로젝트를 만든 다음 테이블 형식 모델 디자이너 도구와 마법사를 사용하여 모델 제작을 시작할 수 있습니다.After creating a new tabular model project by using one of the templates, you can begin model authoring by using the tabular model designer tools and wizards.

Visual StudioVisual Studio 환경에서는 전문적인 다차원 및 테이블 형식 모델 솔루션 제작을 위한 새로운 템플릿과 도구뿐만 아니라 디버깅 및 프로젝트 수명 주기 기능을 제공하여 조직에 맞는 가장 강력한 BI 솔루션을 개발할 수 있습니다.In addition to new templates and tools for authoring professional multidimensional and tabular model solutions, the Visual StudioVisual Studio environment provides debugging and project lifecycle capabilities that ensure you create the most powerful BI solutions for your organization. Visual StudioVisual Studio에 대한 자세한 내용은 Visual Studio 시작을 참조하십시오.For more information about Visual StudioVisual Studio, see Getting Started with Visual Studio.

프로젝트 템플릿 Project templates

SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)를 설치하면 다음과 같은 테이블 형식 모델 프로젝트 템플릿이 비즈니스 인텔리전스 프로젝트 형식에 추가됩니다.When you install SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT), the following tabular model project templates are added to the Business Intelligence project types:

Analysis Services 테이블 형식 프로젝트Analysis Services Tabular Project
이 템플릿은 비어 있는 새 테이블 형식 모델 프로젝트를 만드는 데 사용할 수 있습니다.This template can be used to create a new, blank tabular model project. 호환성 수준은 프로젝트를 만들 때 지정됩니다.Compatibility levels are specified when you create the project.

서버에서 가져오기(테이블 형식)Import from Server (Tabular)
이 템플릿은 Analysis Services의 기존 테이블 형식 모델에서 메타데이터를 추출하여 새 테이블 형식 모델 프로젝트를 만드는 데 사용할 수 있습니다.This template can be used to create a new tabular model project by extracting the metadata from an existing tabular model in Analysis Services.

이전 모델에서는 오래된 호환성 수준이 사용됩니다.Older models have older compatibility levels. 모델 정의 가져온 후 호환성 수준 속성을 변경 하 여 업그레이드할 수 있습니다.You can upgrade by changing the Compatibility Level property after importing the model definition.

다음에서 가져오기 Power PivotPower PivotImport from Power PivotPower Pivot
이 템플릿은 Power Pivot for ExcelPower Pivot for Excel 파일에서 메타데이터와 데이터를 추출하여 새 테이블 형식 모델 프로젝트를 만드는 데 사용됩니다.This template is used for creating a new tabular model project by extracting the metadata and data from a Power Pivot for ExcelPower Pivot for Excel file.

창 및 메뉴 Windows and Menus

SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT) 테이블 형식 모델 제작 환경에는 다음이 포함되어 있습니다.The SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT) tabular model authoring environment includes the following:

디자이너 창Designer window

디자이너 창은 테이블 형식 모델 제작에 사용되며 모델에 대한 시각적 표현을 제공합니다.The designer window is used to author tabular models by providing a visual representation of the model. Model.bim 파일을 열면 디자이너 창에서 모델이 열립니다.When you open the Model.bim file, the model opens in the designer window. 디자이너 창에서 다음과 같은 두 가지 다른 보기 모드를 사용하여 모델을 제작할 수 있습니다.You can author a model in the designer window by using two different view modes:

데이터 뷰Data view
데이터 뷰는 테이블을 표 형식으로 표시합니다.The data view displays tables in a tabular, grid format. 데이터 뷰에서만 각 테이블에 표시할 수 있는 측정값 표를 사용하여 측정값을 정의할 수도 있습니다.You can also define measures by using the measure grid, which can be shown for each table in Data View only.

다이어그램 보기Diagram view
다이어그램 뷰는 테이블을 그래픽 형식의 관계도와 함께 표시합니다.The diagram view displays tables, with relationships between them, in a graphical format. 열, 측정값, 계층 및 KPI를 필터링할 수 있으며 정의된 큐브 뷰를 사용하여 모델을 표시하도록 선택할 수도 있습니다.Columns, measures, hierarchies, and KPIs can be filtered, and you can choose to view the model by using a defined perspective.

대부분의 모델 제작 태스크를 이 두 가지 뷰에서 수행할 수 있습니다.Most model authoring tasks can be performed in either view.

코드 창 보기View Code window

솔루션 탐색기에서 마우스 오른쪽 단추를 클릭하고 파일에 대해 코드 보기 를 선택하면 Model.bim 파일의 코드를 볼 수 있습니다.You can view the code behind a Model.bim file when you right-click select View Code on the file in Solution Explorer. 호환성 수준 1200 이상에서 테이블 형식 모델에 대 한 모델 정의 JSON으로 표현 됩니다.For Tabular models at compatibility level 1200 and later, the model definition is expressed in JSON.

이 정의를 확인하려면 JSON 편집기를 제공하는 정식 버전 Visual Studio가 필요합니다.Note that you will need a full version of Visual Studio that provides the JSON editor. 상용 버전의 추가 기능이 필요하지 않으면 무료 Visual Studio Community 버전 을 다운로드하여 설치할 수 있습니다.You can download and install the free Visual Studio Community edition if you do not require the additional features in commercial editions.

솔루션 탐색기Solution Explorer

솔루션 탐색기 창은 활성 솔루션을 테이블 형식 모델 프로젝트 및 해당 프로젝트와 관련된 항목에 대한 논리적 컨테이너로 보여줍니다.The Solution Explorer window presents the active solution as a logical container for a tabular model project and its associated items. 모델 프로젝트(.smproj)에는 참조 개체(비어 있음)와 Model.bim 파일만 포함됩니다.The model project (.smproj) contains only a References object (empty) and the Model.bim file. 이 뷰에서 프로젝트 항목을 열어 수정하고 다른 관리 태스크를 직접 수행할 수 있습니다.You can open project items for modification and perform other management tasks directly from this view.

테이블 형식 모델 솔루션에는 대개 하나의 프로젝트만 포함되지만 한 솔루션에 Integration Services 또는 Reporting Services 프로젝트 등의 다른 여러 프로젝트가 포함될 수도 있습니다.Tabular model solutions typically contain only one project; however, a solution can contain other projects too, for example, Integration Services or Reporting services project. 테이블 형식 모델 프로젝트 파일과 형식이 다르고 빌드 동작 속성이 없음으로 설정되거나 출력 디렉터리로 복사 속성이 복사 안 함으로 설정된 파일은 개수와 관계없이 무제한 추가할 수 있습니다.You can add any number of files provided they are not of the same type as tabular model project files and their Build Action property is set to None, or Copy to Output property is set to Do Not Copy.

솔루션 탐색기를 보려면 보기 메뉴를 클릭한 다음 솔루션 탐색기를 클릭합니다.To view Solution Explorer, click the View menu, and then click Solution Explorer.

테이블 형식 모델 탐색기Tabular Model Explorer

첫 번째의 2016 년 8 월 릴리스 (14.0.60812.0)에서 사용할 수 있는 SQL Server Data Tools, 테이블 형식 모델 탐색기를 사용 하면 테이블 형식 모델에서 메타 데이터 개체를 이동할 수 있습니다.First available in the August 2016 release (14.0.60812.0) of SQL Server Data Tools, Tabular Model Explorer helps you navigate metadata objects in tabular models.

테이블 형식 모델 탐색기를 표시하려면 보기 > 다른 창을 클릭한 다음 테이블 형식 모델 탐색기를 클릭합니다.To show Tabular Model Explorer, click View > Other Windows, and then click Tabular Model Explorer.

테이블 형식 모델 탐색기

테이블 형식 모델 탐색기 유사한 테이블 형식 모델의 스키마는 트리 구조로 메타 데이터 개체를 구성 합니다.Tabular Model Explorer organizes metadata objects into a tree structure that closely resembles the schema of a tabular model. 데이터 원본, 큐브 뷰, 관계, 역할, 테이블 및 변환은 최상위 스키마 개체에 해당합니다.Data Sources, Perspectives, Relationships, Roles, Tables, and Translations correspond to top-level schema objects. 특히 KPI 및 측정값과 같이 기술적으로 최상위 개체는 아니지만 모델에서 여러 테이블의 자식 개체인 예외 항목이 몇 가지 있습니다.There are some exceptions, specifically KPIs and Measures, which technically aren’t top-level objects, but child objects of the various tables in the model. 그러나 모든 KPI 및 측정값에 대한 최상위 컨테이너를 통합하면 특히 모델에 아주 많은 테이블을 포함한 경우 이러한 개체를 사용하여 쉽게 작업할 수 있습니다.However, having consolidated top-level containers for all KPIs and Measures makes it easier to work with these objects, especially if your model includes a very large number of tables. 측정값은 해당 부모 테이블에도 나열되므로 실제 부모-자식 관계에 대해 명확하게 확인할 수 있습니다.Measures are also listed under their corresponding parent tables, so you have a clear view of the actual parent-child relationships. 최상위 측정값 컨테이너에서 측정값을 선택하면 동일한 측정값이 테이블 하위의 자식 컬렉션에서도 선택됩니다. 그 반대의 경우도 마찬가지입니다.If you select a measure in the top-level Measures container, the same measure is also selected in the child collection under its table, and vice-versa.

테이블 형식 모델 탐색기에서 개체 노드는 Visual Studio의 모델, 테이블 및 열 메뉴 아래에서 숨겨져 있었던 적절한 메뉴 옵션에 연결됩니다.Object nodes in Tabular Model Explorer are linked to appropriate menu options that until now were hiding under the Model, Table, and Column menus in Visual Studio. 개체를 마우스 오른쪽 단추로 클릭하여 개체 형식에 대한 옵션을 탐색할 수 있습니다.You can right-click an object to explore options for the object type. 일부 개체 노드 형식에는 상황에 맞는 메뉴가 있지만 추가 옵션 및 향상된 기능이 후속 릴리스에서 도입될 예정입니다.Not all object node types have a context menu yet, but additional options and improvements are coming in subsequent releases.

테이블 형식 모델 탐색기는 또한 편리한 검색 기능을 제공합니다.Tabular Model Explorer also offers a convenient search feature. 검색 상자에 이름을 일부만 입력해도 테이블 형식 모델 탐색기에서 일치하는 항목을 트리 보기로 보여 줍니다.Just type in a portion of the name in the Search box and Tabular Model Explorer narrows down the tree view to the matches.

속성 창Properties window

속성 창은 선택된 개체의 속성을 나열합니다.The Properties window lists the properties of the selected object. 속성 창에서 다음과 같은 개체의 속성을 보고 편집할 수 있습니다.The following objects have properties that can be viewed and edited in the Properties window:

  • Model.bimModel.bim

  • 테이블Table

  • Column

  • 이름Measure

    프로젝트 속성은 속성 창에 프로젝트 이름과 프로젝트 폴더만 표시합니다.Project Properties display only the project name and project folder in the Properties window. 프로젝트에는 또한 모달 속성 대화 상자에서 설정할 수 있는 추가 배포 옵션 및 배포 서버 설정이 있습니다.Projects also have additional deployment Options and deployment server settings that you can set using a modal properties dialog box. 이 속성을 보려면 솔루션 탐색기에서 프로젝트를 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.To view these properties, in Solution Explorer, right click the project, and then click Properties.

    속성 창의 필드에는 클릭하면 열리는 컨트롤이 포함되어 있습니다.Fields in the Properties window have embedded controls that open when you click them. 편집 컨트롤 유형은 특정 속성에 따라 달라집니다.The type of edit control depends on the particular property. 컨트롤에는 편집 상자, 드롭다운 목록, 사용자 지정 대화 상자에 대한 링크 등이 있습니다.Controls include edit boxes, dropdown lists, and links to custom dialog boxes. 흐리게 표시되는 속성은 읽기 전용입니다.Properties that are shown as dimmed are read-only.

    속성 창을 보려면 보기 메뉴를 클릭한 다음 속성 창을 클릭합니다.To view the Properties window, click the View menu, and then click Properties Window.

오류 목록Error List

오류 목록 창에는 다음과 같은 모델 상태에 대한 메시지가 포함됩니다.The Error List window contains messages about the model state:

  • 최상의 권장 보안 방법에 대한 알림Notifications about security best practices.

  • 데이터 처리 요구 사항Requirements for data processing.

  • 계산 열, 측정값 및 역할 행 필터에 대한 의미 체계 오류 정보.Semantic error information for calculated columns, measures, and row filters for roles. 계산 열에서 오류 메시지를 두 번 클릭하면 오류의 출처가 표시됩니다.For calculated columns, you can double-click the error message to navigate to the source of the error.

  • DirectQuery 유효성 검사 오류DirectQuery validation errors.

    기본적으로 오류 목록 은 오류가 반환되어야만 표시됩니다.By default, the Error List does not appear unless an error is returned. 그러나 오류 목록 창은 언제든지 확인할 수 있습니다.You can, however, view the Error List window at any time. 오류 목록 창을 보려면 보기 메뉴를 클릭한 다음 오류 목록을 클릭합니다.To view the Error List window, click the View menu, and then click Error List.

출력Output

빌드 및 배포 정보가 출력 창 및 모달 진행률 대화 상자에 표시됩니다.Build and deployment information is displayed in the Output Window (in addition to the modal progress dialog). 출력 창을 보려면 보기 메뉴를 클릭한 다음 출력을 클릭합니다.To view the Output window, click the View menu, and then click Output.

SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)를 설치하면 테이블 형식의 모델을 제작하는 데 사용되는 추가 메뉴 항목이 Visual Studio 메뉴 모음에 추가됩니다.When you install SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT), additional menu items specifically for authoring tabular models are added to the Visual Studio menu bar. 모델 메뉴를 사용하여 데이터 가져오기 마법사를 시작하고, 기존 연결을 보고, 작업 영역 데이터를 처리하고, MicrosoftMicrosoft Excel에서 모델 작업 영역을 찾아볼 수 있습니다.The Model menu can be used to launch the Data Import Wizard, view existing connections, process workspace data, and browse the model workspace in MicrosoftMicrosoft Excel. 테이블 메뉴를 사용하여 테이블 간의 관계를 만들고 관리하고, 측정값을 만들고 관리하며, 데이터 테이블 설정을 지정하고, 계산 옵션을 지정하고, 기타 테이블 속성을 지정할 수 있습니다.The Table menu is used to create and manage relationships between tables, create and manage measures, specify data table settings, specify calculation options, and specify other table properties. 메뉴를 사용하여 테이블에서 열을 추가 및 삭제하고, 열을 숨기거나 숨기기를 취소하고, 데이터 형식 및 필터와 같은 기타 열 속성을 지정할 수 있습니다.With the Column menu, you can add and delete columns in a table, hide and unhide columns, and specify other column properties such as data types and filters. 빌드 메뉴에서 테이블 형식 모델 솔루션을 빌드하고 배포할 수 있습니다.You can build and deploy tabular model solutions on the Build menu. 복사/붙여넣기 기능은 편집 메뉴에 포함되어 있습니다.Copy/Paste functions are included on the Edit menu.

이러한 새 메뉴 항목 외에도 도구 메뉴 항목의 Analysis Services 옵션에 추가 설정이 추가되어 있습니다.In addition to these menu items, additional settings are added to the Analysis Services options on the Tools menu items.

도구 모음Toolbar

Analysis Services 도구 모음을 통해 신속하고 간편하게 자주 사용하는 모델 작성 명령에 액세스할 수 있습니다.The Analysis Services toolbar provides quick and easy access to the most frequently used model authoring commands.

Visual Studio 통합 Visual Studio integration

소스 제어Source control
Analysis Services 프로젝트는 선택한 원본 제어 플러그 인과 통합됩니다.Analysis Services projects integrate with the selected source control plug-in. 원본 제어를 사용하도록 Visual Studio를 구성하면 솔루션 탐색기에서 체크 인/체크 아웃을 사용할 수 있습니다.If you have configured Visual Studio to use source control, you can use check in/check out from Solution Explorer. Team Foundation Server를 사용하도록 구성하려면 Team Foundation 버전 제어로 Visual Studio 구성을 참조하십시오.To configure to use Team Foundation Server, see Configure Visual Studio with Team Foundation Version Control. 그 외 다양한 타사 원본 제어 플러그 인도 지원합니다.Many third-party source control plug-ins are supported as well.

글꼴Fonts
테이블 형식 모델은 Visual StudioVisual Studio 환경의 글꼴을 사용하여 표시되는 글꼴을 제어합니다.Tabular models use the Visual StudioVisual Studio environment font to control the fonts in the display. 기본 Visual StudioVisual Studio 글꼴을 사용하여 해당 언어의 유니코드 문자를 모두 표시할 수 없을 경우 이 글꼴을 변경해야 할 수 있습니다.It can be necessary to change this font if the default Visual StudioVisual Studio font does not have all of the Unicode characters you need for your language. 글꼴을 변경하려면 도구 메뉴를 클릭하고 옵션을 클릭한 다음 글꼴 및 색을 클릭합니다.To change fonts, click the Tools menu, then click Options, and then click Fonts and Colors.

바로 가기 키Keyboard shortcuts
도구->옵션->키보드 대화 상자를 통해 Analysis Services 키보드 바로 가기를 구성하거나 다시 매핑할 수 있습니다.The Analysis Services keyboard shortcuts can be configured/remapped through the Tools->Options->Keyboard dialog. 빌드, 저장, 디버그, 새 프로젝트 등과 같은 전역 Visual StudioVisual Studio 바로 가기가 테이블 형식 모델 디자이너 컨텍스트에서 지원됩니다.Some global Visual StudioVisual Studio shortcuts, such as build, save, debug, new project, etc. are supported in the tabular model designer context. 그 외 테이블 형식 모델 디자이너용 바로 가기 키는 Analysis Services 컨텍스트에서 지원됩니다.Other tabular model designer specific shortcuts are in the Analysis Services context.

참고 항목See also

테이블 형식 모델 프로젝트(SSAS 테이블 형식) Tabular Model Projects (SSAS Tabular)
속성(SSAS 테이블 형식)Properties (SSAS Tabular)